]> git.pld-linux.org Git - packages/mdds.git/blob - mdds.spec
- up to 0.5.4
[packages/mdds.git] / mdds.spec
1 Summary:        A collection of multi-dimensional data structures and indexing algorithms
2 Name:           mdds
3 Version:        0.5.4
4 Release:        1
5 License:        MIT
6 Group:          Development/Libraries
7 URL:            http://code.google.com/p/multidimalgorithm/
8 Source0:        http://multidimalgorithm.googlecode.com/files/%{name}_%{version}.tar.bz2
9 # Source0-md5:  d33e6871e05709963d7feb48f9620900
10 BuildRequires:  boost-devel
11 BuildArch:      noarch
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 A collection of multi-dimensional data structures and indexing
16 algorithms.
17
18 It implements the following data structures:
19 - segment tree
20 - flat segment tree
21 - rectangle set
22 - point quad tree
23 - mixed type matrix
24
25 %package devel
26 Summary:        Headers for %{name}
27 Group:          Development/Libraries
28 Requires:       boost-devel
29
30 %description devel
31 Headers for %{name}.
32
33 %prep
34 %setup -q -n %{name}_%{version}
35 # this is only used in tests
36 sed -i -e '/^CPPFLAGS/s/-Wall.*-std/%{rpmcflags} -std/' Makefile.in
37
38 %build
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_includedir}/mdds
45 cp -a include/mdds/* $RPM_BUILD_ROOT%{_includedir}/mdds
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files devel
51 %defattr(644,root,root,755)
52 %doc AUTHORS COPYING NEWS README
53 %{_includedir}/mdds
This page took 0.045414 seconds and 3 git commands to generate.