]> git.pld-linux.org Git - packages/mailutils.git/blob - mailutils.spec
d480717ef5f11eaa9d3bf844a7ee5d53d1753346
[packages/mailutils.git] / mailutils.spec
1 # TODO:
2 # - look at files in main package (more split?)
3 # - scripts for daemons
4 # - check optional gssapi (or maybe use gss?)
5 # - some dbm (gdbm? db as (n)dbm? db after update from db2 to db4.1 API?)
6 # - security http://security.gentoo.org/glsa/glsa-200505-20.xml
7 #
8 # Conditional build:
9 %bcond_with     gssapi  # use GSSAPI authentication (krb5 or heimdal; not ready for gss)
10 %bcond_without  sasl    # without SASL (using GNU SASL)
11 #
12 Summary:        GNU mail utilities
13 Summary(pl):    Narzêdzia pocztowe z projektu GNU
14 Name:           mailutils
15 Version:        0.6
16 Release:        0.1
17 License:        GPL
18 Group:          Applications/Mail
19 Source0:        ftp://ftp.gnu.org/gnu/mailutils/%{name}-%{version}.tar.bz2
20 # Source0-md5:  13e38442893a24f16798e4b5f634ba7d
21 Patch0:         %{name}-info.patch
22 URL:            http://www.gnu.org/software/mailutils/mailutils.html
23 BuildRequires:  gnutls-devel
24 BuildRequires:  guile-devel >= 1.4
25 %{?with_gss:BuildRequires:      heimdal-devel}
26 %{?with_sasl:BuildRequires:     gsasl-devel >= 0.0.2}
27 BuildRequires:  libltdl-devel
28 BuildRequires:  pam-devel
29 BuildRequires:  readline-devel
30 BuildRequires:  texinfo
31 Requires:       %{name}-libs = %{version}-%{release}
32 Obsoletes:      mailutils-doc
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _libexecdir     %{_sbindir}
36
37 %description
38 GNU mail utilities.
39
40 %description -l pl
41 Narzêdzia pocztowe z projektu GNU
42
43 %package libs
44 Summary:        GNU mail utilities libraries
45 Summary(pl):    Biblioteka narzêdzi pocztowych GNU
46 License:        LGPL
47 Group:          Libraries
48 Obsoletes:      libmailbox
49
50 %description libs
51 The runtime library libmailbox. This library contains various mailbox
52 access routines and support for a number of mailbox types, such as
53 mbox, mh, POP3, and IMAP4. It also support mime message handling, and
54 sending mail via SMTP and /usr/sbin/sendmail.
55
56 %description libs -l pl
57 Biblioteka libmailbox zawiera ró¿ne funkcje dostêpu do skrzynek
58 pocztowych obs³uguj±ce wiele typów skrzynek, takich jak mbox, mh, POP3
59 i IMAP4. Wspiera tak¿e obs³ugê wiadomo¶ci MIME i wysy³anie poczty
60 przez SMP oraz /usr/sbin/sendmail.
61
62 %package devel
63 Summary:        Header files for GNU mail utilities libraries
64 Summary(pl):    Pliki nag³ówkowe bibliotek narzêdzi pocztowych GNU
65 License:        LGPL
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Obsoletes:      libmailbox-dev
69
70 %description devel
71 Header files for GNU mail utilities libraries.
72
73 %description devel -l pl
74 Pliki nag³ówkowe bibliotek narzêdzi pocztowych GNU.
75
76 %package static
77 Summary:        GNU mail utilities static libraries
78 Summary(pl):    Statyczne biblioteki narzêdzi pocztowych GNU
79 License:        LGPL
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 GNU mail utilities static libraries.
85
86 %description static -l pl
87 Statyczne biblioteki narzêdzi pocztowych GNU.
88
89 %package -n gnu-mail
90 Summary:        GNU mail utilities mail(x) replacement
91 Summary(pl):    Zamiennik mail(x) z narzêdzi pocztowych GNU
92 Group:          Applications/Mail
93 Requires:       %{name} = %{version}-%{release}
94
95 %description -n gnu-mail
96 A replacement for /bin/mail(x) conforming to the UNIX98 specification
97 for mailx.
98
99 %description -n gnu-mail -l pl
100 Zamiennik /bin/mail(x) zgodny ze specyfikacj± UNIX98 dla mailx.
101
102 %package -n gnu-pop3d
103 Summary:        GNU mail utilites POP3 daemon
104 Summary(pl):    Demon POP3 z narzêdzi pocztowych GNU
105 Group:          Networking/Daemons
106 Requires:       %{name}-libs = %{version}-%{release}
107 # inetd or standalone
108
109 %description -n gnu-pop3d
110 The GNU POP3 daemon. Uses libmailbox to support different styles of
111 mailboxes.
112
113 %description -n gnu-pop3d -l pl
114 Demon GNU POP3. Wykorzystuje libmailbox do obs³ugi ró¿nych rodzajów
115 skrzynek pocztowych.
116
117 %package -n gnu-imap4d
118 Summary:        GNU mail utilities IMAP4 daemon
119 Summary(pl):    Demon IMAP4 z narzêdzi pocztowych GNU
120 Group:          Networking/Daemons
121 Requires:       %{name}-libs = %{version}-%{release}
122 # inetd or standalone
123
124 %description -n gnu-imap4d
125 The GNU IMAP4 daemon. Uses libmailbox to support different styles of
126 mailboxes.
127
128 %description -n gnu-imap4d -l pl
129 Demon GNU IMAP4. Wykorzystuje libmailbox do obs³ugi ró¿nych rodzajów
130 skrzynek pocztowych.
131
132 %prep
133 %setup -q
134 %patch0 -p1
135
136 %build
137 %configure \
138         --with-gnutls \
139         %{?with_sasl:--with-gsasl} \
140         %{?with_gssapi:--with-gssapi}
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %find_lang %{name}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
157
158 %postun
159 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %post devel
165 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
166
167 %postun devel
168 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
169
170 %files -f %{name}.lang
171 %defattr(644,root,root,755)
172 %doc AUTHORS ChangeLog NEWS README THANKS TODO
173 %attr(755,root,root) %{_bindir}/dotlock
174 %attr(755,root,root) %{_bindir}/frm
175 %attr(755,root,root) %{_bindir}/from
176 %attr(755,root,root) %{_bindir}/guimb
177 %attr(755,root,root) %{_bindir}/messages
178 %attr(755,root,root) %{_bindir}/movemail
179 %attr(755,root,root) %{_bindir}/readmsg
180 %attr(755,root,root) %{_bindir}/sieve
181 %attr(755,root,root) %{_bindir}/sieve.scm
182 %attr(755,root,root) %{_sbindir}/comsatd
183 %attr(755,root,root) %{_libexecdir}/mail.local
184 %attr(755,root,root) %{_libexecdir}/mail.remote
185 %dir %{_libdir}/mailutils
186 %{_datadir}/mailutils
187 %{_infodir}/mailutils.info*
188
189 %files libs
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
192
193 %files devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_bindir}/mailutils-config
196 %attr(755,root,root) %{_libdir}/lib*.so
197 %{_libdir}/lib*.la
198 %{_includedir}/mailutils
199 %{_infodir}/muint.info*
200
201 %files static
202 %defattr(644,root,root,755)
203 %{_libdir}/lib*.a
204
205 %files -n gnu-mail
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_bindir}/mail
208 %{_mandir}/man1/mail.1*
209
210 %files -n gnu-pop3d
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_sbindir}/pop3d
213 %{_mandir}/man1/pop3d.1*
214 %{_mandir}/man1/popauth.1*
215
216 %files -n gnu-imap4d
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_sbindir}/imap4d
219 %{_mandir}/man1/imap4d.1*
This page took 0.087891 seconds and 3 git commands to generate.