]> git.pld-linux.org Git - packages/mailutils.git/blob - mailutils.spec
178d8ab0b1d5da34d01b3f07ddc2327e1c6aaff1
[packages/mailutils.git] / mailutils.spec
1 # TODO:
2 # - look at files in main package (more split?)
3 # - scripts for daemons
4 # - check optional gssapi (or maybe use gss?)
5 # - some dbm (gdbm? db as (n)dbm? db after update from db2 to db4.1 API?)
6 #
7 # Conditional build:
8 %bcond_without  gssapi  # GSSAPI authentication (krb5 or heimdal; not ready for gss)
9 %bcond_without  sasl    # without SASL (using GNU SASL)
10 #
11 Summary:        GNU mail utilities
12 Summary(pl.UTF-8):      Narzędzia pocztowe z projektu GNU
13 Name:           mailutils
14 Version:        1.2
15 Release:        1
16 License:        GPL v3+
17 Group:          Applications/Mail
18 Source0:        ftp://ftp.gnu.org/gnu/mailutils/%{name}-%{version}.tar.bz2
19 # Source0-md5:  0a5bf84e908f15343414c6a95118a373
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-pl.po-update.patch
22 Patch2:         %{name}-tinfo.patch
23 URL:            http://www.gnu.org/software/mailutils/mailutils.html
24 BuildRequires:  autoconf >= 2.60
25 BuildRequires:  automake >= 1:1.8.5
26 BuildRequires:  fribidi-devel
27 BuildRequires:  gnu-radius-devel
28 BuildRequires:  gnutls-devel >= 1.2.5
29 %{?with_sasl:BuildRequires:     gsasl-devel >= 0.2.3}
30 BuildRequires:  guile-devel >= 1.4
31 %{?with_gssapi:BuildRequires:   krb5-devel}
32 BuildRequires:  libltdl-devel
33 BuildRequires:  mysql-devel
34 BuildRequires:  ncurses-devel
35 BuildRequires:  pam-devel
36 BuildRequires:  postgresql-devel
37 BuildRequires:  readline-devel
38 BuildRequires:  texinfo
39 BuildRequires:  unixODBC-devel
40 Requires:       %{name}-libs = %{version}-%{release}
41 Obsoletes:      mailutils-doc
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _libexecdir     %{_sbindir}
45
46 %description
47 GNU mail utilities.
48
49 %description -l pl.UTF-8
50 Narzędzia pocztowe z projektu GNU.
51
52 %package libs
53 Summary:        GNU mail utilities libraries
54 Summary(pl.UTF-8):      Biblioteka narzędzi pocztowych GNU
55 License:        LGPL
56 Group:          Libraries
57 Obsoletes:      libmailbox
58
59 %description libs
60 The runtime library libmailbox. This library contains various mailbox
61 access routines and support for a number of mailbox types, such as
62 mbox, mh, POP3, and IMAP4. It also support mime message handling, and
63 sending mail via SMTP and /usr/sbin/sendmail.
64
65 %description libs -l pl.UTF-8
66 Biblioteka libmailbox zawiera różne funkcje dostępu do skrzynek
67 pocztowych obsługujące wiele typów skrzynek, takich jak mbox, mh, POP3
68 i IMAP4. Wspiera także obsługę wiadomości MIME i wysyłanie poczty
69 przez SMP oraz /usr/sbin/sendmail.
70
71 %package devel
72 Summary:        Header files for GNU mail utilities libraries
73 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek narzędzi pocztowych GNU
74 License:        LGPL
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77 Obsoletes:      libmailbox-dev
78
79 %description devel
80 Header files for GNU mail utilities libraries.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe bibliotek narzędzi pocztowych GNU.
84
85 %package static
86 Summary:        GNU mail utilities static libraries
87 Summary(pl.UTF-8):      Statyczne biblioteki narzędzi pocztowych GNU
88 License:        LGPL
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 GNU mail utilities static libraries.
94
95 %description static -l pl.UTF-8
96 Statyczne biblioteki narzędzi pocztowych GNU.
97
98 %package -n gnu-mail
99 Summary:        GNU mail utilities mail(x) replacement
100 Summary(pl.UTF-8):      Zamiennik mail(x) z narzędzi pocztowych GNU
101 Group:          Applications/Mail
102 Requires:       %{name} = %{version}-%{release}
103
104 %description -n gnu-mail
105 A replacement for /bin/mail(x) conforming to the UNIX98 specification
106 for mailx.
107
108 %description -n gnu-mail -l pl.UTF-8
109 Zamiennik /bin/mail(x) zgodny ze specyfikacją UNIX98 dla mailx.
110
111 %package -n gnu-pop3d
112 Summary:        GNU mail utilites POP3 daemon
113 Summary(pl.UTF-8):      Demon POP3 z narzędzi pocztowych GNU
114 Group:          Networking/Daemons
115 Requires:       %{name}-libs = %{version}-%{release}
116 # inetd or standalone
117
118 %description -n gnu-pop3d
119 The GNU POP3 daemon. Uses libmailbox to support different styles of
120 mailboxes.
121
122 %description -n gnu-pop3d -l pl.UTF-8
123 Demon GNU POP3. Wykorzystuje libmailbox do obsługi różnych rodzajów
124 skrzynek pocztowych.
125
126 %package -n gnu-imap4d
127 Summary:        GNU mail utilities IMAP4 daemon
128 Summary(pl.UTF-8):      Demon IMAP4 z narzędzi pocztowych GNU
129 Group:          Networking/Daemons
130 Requires:       %{name}-libs = %{version}-%{release}
131 # inetd or standalone
132
133 %description -n gnu-imap4d
134 The GNU IMAP4 daemon. Uses libmailbox to support different styles of
135 mailboxes.
136
137 %description -n gnu-imap4d -l pl.UTF-8
138 Demon GNU IMAP4. Wykorzystuje libmailbox do obsługi różnych rodzajów
139 skrzynek pocztowych.
140
141 %prep
142 %setup -q
143 %patch0 -p1
144 %patch1 -p1
145 %patch2 -p0
146
147 %build
148 %{__libtoolize}
149 %{__aclocal} -I m4
150 %{__autoconf}
151 %{__autoheader}
152 %{__automake}
153 %configure \
154         --with-gnutls \
155         --with-mysql \
156         --with-postgres \
157         --with-odbc=odbc \
158         %{?with_sasl:--with-gsasl} \
159         %{?with_gssapi:--with-gssapi}
160
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 %find_lang %{name}
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post
175 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
176
177 %postun
178 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
179
180 %post   libs -p /sbin/ldconfig
181 %postun libs -p /sbin/ldconfig
182
183 %post devel
184 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
185
186 %postun devel
187 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
188
189 %files -f %{name}.lang
190 %defattr(644,root,root,755)
191 %doc AUTHORS ChangeLog NEWS README THANKS TODO
192 %attr(755,root,root) %{_bindir}/dotlock
193 %attr(755,root,root) %{_bindir}/frm
194 %attr(755,root,root) %{_bindir}/from
195 %attr(755,root,root) %{_bindir}/guimb
196 %attr(755,root,root) %{_bindir}/messages
197 %attr(755,root,root) %{_bindir}/mimeview
198 %attr(755,root,root) %{_bindir}/movemail
199 %attr(755,root,root) %{_bindir}/readmsg
200 %attr(755,root,root) %{_bindir}/sieve
201 %attr(755,root,root) %{_bindir}/sieve.scm
202 %attr(755,root,root) %{_sbindir}/comsatd
203 %attr(755,root,root) %{_libexecdir}/mail.local
204 %attr(755,root,root) %{_libexecdir}/mail.remote
205 %dir %{_libdir}/mailutils
206 %attr(755,root,root) %{_libdir}/mailutils/*.so
207 %{_datadir}/mailutils
208 %{_infodir}/mailutils.info*
209
210 %files libs
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
213
214 %files devel
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/mailutils-config
217 %attr(755,root,root) %{_libdir}/lib*.so
218 %{_libdir}/lib*.la
219 %{_includedir}/mailutils
220
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/lib*.a
224
225 %files -n gnu-mail
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_bindir}/mail
228 %{_mandir}/man1/mail.1*
229
230 %files -n gnu-pop3d
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_sbindir}/pop3d
233 %{_mandir}/man1/pop3d.1*
234 %{_mandir}/man1/popauth.1*
235
236 %files -n gnu-imap4d
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_sbindir}/imap4d
239 %{_mandir}/man1/imap4d.1*
This page took 0.217796 seconds and 3 git commands to generate.