]> git.pld-linux.org Git - packages/mailutils.git/blob - mailutils.spec
- typo
[packages/mailutils.git] / mailutils.spec
1 # TODO:
2 # - look at files in main package (more split?)
3 # - scripts for daemons
4 # - check optional gssapi (or maybe use gss?)
5 # - some dbm (gdbm? db as (n)dbm? db after update from db2 to db4.1 API?)
6 # - security http://security.gentoo.org/glsa/glsa-200505-20.xml
7 # - security http://security.gentoo.org/glsa/glsa-200506-02.xml
8 #
9 # Conditional build:
10 %bcond_with     gssapi  # use GSSAPI authentication (krb5 or heimdal; not ready for gss)
11 %bcond_without  sasl    # without SASL (using GNU SASL)
12 #
13 Summary:        GNU mail utilities
14 Summary(pl.UTF-8):      Narzędzia pocztowe z projektu GNU
15 Name:           mailutils
16 Version:        0.6.90
17 Release:        3
18 License:        GPL
19 Group:          Applications/Mail
20 #Source0:       ftp://ftp.gnu.org/gnu/mailutils/%{name}-%{version}.tar.bz2
21 Source0:        ftp://alpha.gnu.org/gnu/mailutils/%{name}-%{version}.tar.bz2
22 # Source0-md5:  682099acd143479aff2ed9e80f214ad6
23 Patch0:         %{name}-info.patch
24 URL:            http://www.gnu.org/software/mailutils/mailutils.html
25 BuildRequires:  gnutls-devel >= 1.2.5
26 BuildRequires:  guile-devel >= 1.4
27 %{?with_gssapi:BuildRequires:   krb5-devel}
28 %{?with_sasl:BuildRequires:     gsasl-devel >= 0.0.2}
29 BuildRequires:  libltdl-devel
30 BuildRequires:  pam-devel
31 BuildRequires:  readline-devel
32 BuildRequires:  texinfo
33 Requires:       %{name}-libs = %{version}-%{release}
34 Obsoletes:      mailutils-doc
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _libexecdir     %{_sbindir}
38
39 %description
40 GNU mail utilities.
41
42 %description -l pl.UTF-8
43 Narzędzia pocztowe z projektu GNU
44
45 %package libs
46 Summary:        GNU mail utilities libraries
47 Summary(pl.UTF-8):      Biblioteka narzędzi pocztowych GNU
48 License:        LGPL
49 Group:          Libraries
50 Obsoletes:      libmailbox
51
52 %description libs
53 The runtime library libmailbox. This library contains various mailbox
54 access routines and support for a number of mailbox types, such as
55 mbox, mh, POP3, and IMAP4. It also support mime message handling, and
56 sending mail via SMTP and /usr/sbin/sendmail.
57
58 %description libs -l pl.UTF-8
59 Biblioteka libmailbox zawiera różne funkcje dostępu do skrzynek
60 pocztowych obsługujące wiele typów skrzynek, takich jak mbox, mh, POP3
61 i IMAP4. Wspiera także obsługę wiadomości MIME i wysyłanie poczty
62 przez SMP oraz /usr/sbin/sendmail.
63
64 %package devel
65 Summary:        Header files for GNU mail utilities libraries
66 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek narzędzi pocztowych GNU
67 License:        LGPL
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Obsoletes:      libmailbox-dev
71
72 %description devel
73 Header files for GNU mail utilities libraries.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe bibliotek narzędzi pocztowych GNU.
77
78 %package static
79 Summary:        GNU mail utilities static libraries
80 Summary(pl.UTF-8):      Statyczne biblioteki narzędzi pocztowych GNU
81 License:        LGPL
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 GNU mail utilities static libraries.
87
88 %description static -l pl.UTF-8
89 Statyczne biblioteki narzędzi pocztowych GNU.
90
91 %package -n gnu-mail
92 Summary:        GNU mail utilities mail(x) replacement
93 Summary(pl.UTF-8):      Zamiennik mail(x) z narzędzi pocztowych GNU
94 Group:          Applications/Mail
95 Requires:       %{name} = %{version}-%{release}
96
97 %description -n gnu-mail
98 A replacement for /bin/mail(x) conforming to the UNIX98 specification
99 for mailx.
100
101 %description -n gnu-mail -l pl.UTF-8
102 Zamiennik /bin/mail(x) zgodny ze specyfikacją UNIX98 dla mailx.
103
104 %package -n gnu-pop3d
105 Summary:        GNU mail utilites POP3 daemon
106 Summary(pl.UTF-8):      Demon POP3 z narzędzi pocztowych GNU
107 Group:          Networking/Daemons
108 Requires:       %{name}-libs = %{version}-%{release}
109 # inetd or standalone
110
111 %description -n gnu-pop3d
112 The GNU POP3 daemon. Uses libmailbox to support different styles of
113 mailboxes.
114
115 %description -n gnu-pop3d -l pl.UTF-8
116 Demon GNU POP3. Wykorzystuje libmailbox do obsługi różnych rodzajów
117 skrzynek pocztowych.
118
119 %package -n gnu-imap4d
120 Summary:        GNU mail utilities IMAP4 daemon
121 Summary(pl.UTF-8):      Demon IMAP4 z narzędzi pocztowych GNU
122 Group:          Networking/Daemons
123 Requires:       %{name}-libs = %{version}-%{release}
124 # inetd or standalone
125
126 %description -n gnu-imap4d
127 The GNU IMAP4 daemon. Uses libmailbox to support different styles of
128 mailboxes.
129
130 %description -n gnu-imap4d -l pl.UTF-8
131 Demon GNU IMAP4. Wykorzystuje libmailbox do obsługi różnych rodzajów
132 skrzynek pocztowych.
133
134 %prep
135 %setup -q
136 %patch0 -p1
137
138 %build
139 %configure \
140         --with-gnutls \
141         %{?with_sasl:--with-gsasl} \
142         %{?with_gssapi:--with-gssapi}
143
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 %find_lang %{name}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
159
160 %postun
161 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
162
163 %post   libs -p /sbin/ldconfig
164 %postun libs -p /sbin/ldconfig
165
166 %post devel
167 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
168
169 %postun devel
170 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
171
172 %files -f %{name}.lang
173 %defattr(644,root,root,755)
174 %doc AUTHORS ChangeLog NEWS README THANKS TODO
175 %attr(755,root,root) %{_bindir}/dotlock
176 %attr(755,root,root) %{_bindir}/frm
177 %attr(755,root,root) %{_bindir}/from
178 %attr(755,root,root) %{_bindir}/guimb
179 %attr(755,root,root) %{_bindir}/messages
180 %attr(755,root,root) %{_bindir}/movemail
181 %attr(755,root,root) %{_bindir}/readmsg
182 %attr(755,root,root) %{_bindir}/sieve
183 %attr(755,root,root) %{_bindir}/sieve.scm
184 %attr(755,root,root) %{_sbindir}/comsatd
185 %attr(755,root,root) %{_libexecdir}/mail.local
186 %attr(755,root,root) %{_libexecdir}/mail.remote
187 %dir %{_libdir}/mailutils
188 %{_datadir}/mailutils
189 %{_infodir}/mailutils.info*
190
191 %files libs
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
194
195 %files devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/mailutils-config
198 %attr(755,root,root) %{_libdir}/lib*.so
199 %{_libdir}/lib*.la
200 %{_includedir}/mailutils
201 %{_infodir}/muint.info*
202
203 %files static
204 %defattr(644,root,root,755)
205 %{_libdir}/lib*.a
206
207 %files -n gnu-mail
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/mail
210 %{_mandir}/man1/mail.1*
211
212 %files -n gnu-pop3d
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_sbindir}/pop3d
215 %{_mandir}/man1/pop3d.1*
216 %{_mandir}/man1/popauth.1*
217
218 %files -n gnu-imap4d
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_sbindir}/imap4d
221 %{_mandir}/man1/imap4d.1*
This page took 0.064231 seconds and 3 git commands to generate.