]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
lxc-clone, lxc-create, lxc-destroy, lxc-shutdown use which
[packages/lxc.git] / lxc.spec
1 #
2 # Conditional build:
3 %bcond_without  seccomp # SecComp syscall filter
4 %bcond_without  apparmor        # apparmor
5 %bcond_without  lua     # Lua binding
6 %bcond_without  python  # Python binding
7
8 Summary:        Linux Container Tools
9 Summary(pl.UTF-8):      Narzędzia do kontenerów linuksowych (LXC)
10 Name:           lxc
11 Version:        0.9.0
12 Release:        5
13 License:        LGPL v2.1+
14 Group:          Applications/System
15 Source0:        http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
16 # Source0-md5:  8552a4479090616f4bc04d8473765fc9
17 Source1:        %{name}-pld.in.sh
18 Patch0:         %{name}-devpts.patch
19 Patch1:         %{name}-pld.patch
20 Patch2:         am-1.14.patch
21 Patch3:         checkconfig-module.patch
22 Patch4:         checkconfig-vserver-config.patch
23 Patch5:         fedora-template.patch
24 URL:            http://lxc.sourceforge.net/
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake
27 BuildRequires:  docbook-dtd30-sgml
28 BuildRequires:  docbook-utils
29 BuildRequires:  docbook2X
30 %{?with_apparmor:BuildRequires: libapparmor-devel}
31 BuildRequires:  libcap-devel
32 %{?with_seccomp:BuildRequires:  libseccomp-devel}
33 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
34 BuildRequires:  pkgconfig
35 %{?with_python:BuildRequires:   python3-devel >= 3.2}
36 BuildRequires:  rpmbuild(macros) >= 1.612
37 BuildRequires:  sed >= 4.0
38 Requires:       rc-scripts >= 0.4.6
39 Requires:       which
40 Suggests:       net-tools
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         configpath      /var/lib/lxc
44
45 %description
46 Tools to create and manage containers. It contains a full featured
47 container with the isolation / virtualization of the pids, the ipc,
48 the utsname, the mount points, /proc, /sys, the network and it takes
49 into account the control groups. It is very light, flexible, and
50 provides a set of tools around the container like the monitoring with
51 asynchronous events notification, or the freeze of the container. This
52 package is useful to create Virtual Private Server, or to run isolated
53 applications like bash or sshd.
54
55 %description -l pl.UTF-8
56 Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
57 w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
58 utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
59 grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
60 do czynności związanych z kontenerami, takich jak monitorowanie z
61 asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
62 pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
63 oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
64
65 %package devel
66 Summary:        Header files for lxc library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxc
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description devel
72 Header files for lxc library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki lxc.
76
77 %package -n lua-lxc
78 Summary:        Lua binding for LXC
79 Summary(pl.UTF-8):      Wiązanie Lua do LXC
80 Group:          Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       lua51-libs >= 5.1
83
84 %description -n lua-lxc
85 Lua binding for LXC.
86
87 %description -n lua-lxc -l pl.UTF-8
88 Wiązanie Lua do LXC.
89
90 %package -n python3-lxc
91 Summary:        Python (3.x) binding for LXC
92 Summary(pl.UTF-8):      Wiązanie Pythona (3.x) do LXC
93 Group:          Libraries
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       python3-libs >= 3.2
96
97 %description -n python3-lxc
98 Python (3.x) binding for LXC.
99
100 %description -n python3-lxc -l pl.UTF-8
101 Wiązanie Pythona (3.x) do LXC.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109 %patch4 -p1
110 %patch5 -p1
111
112 cp -p %{SOURCE1} templates/lxc-pld.in
113
114 %build
115 %{__aclocal} -I config
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         db2xman=docbook2X2man \
121         --disable-rpath \
122         --enable-doc \
123         %{__enable_disable apparmor} \
124         %{__enable_disable lua} \
125         %{__enable_disable python} \
126         %{__enable_disable seccomp} \
127         --with-config-path=%{configpath} \
128         --with-distro=pld
129
130 %{__make}
131 %{__make} -C doc
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT{%{configpath},/var/{cache,log}/lxc}
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT \
138         pcdatadir=%{_pkgconfigdir}
139
140 %{__make} -C doc install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
144
145 %if %{with python}
146 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
147 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
148 %endif
149 %if %{with lua}
150 %{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
151 %endif
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
162 %attr(755,root,root) %{_bindir}/lxc-attach
163 %attr(755,root,root) %{_bindir}/lxc-cgroup
164 %attr(755,root,root) %{_bindir}/lxc-checkconfig
165 %attr(755,root,root) %{_bindir}/lxc-checkpoint
166 %attr(755,root,root) %{_bindir}/lxc-clone
167 %attr(755,root,root) %{_bindir}/lxc-console
168 %attr(755,root,root) %{_bindir}/lxc-create
169 %attr(755,root,root) %{_bindir}/lxc-destroy
170 %attr(755,root,root) %{_bindir}/lxc-execute
171 %attr(755,root,root) %{_bindir}/lxc-freeze
172 %attr(755,root,root) %{_bindir}/lxc-info
173 %attr(755,root,root) %{_bindir}/lxc-kill
174 %attr(755,root,root) %{_bindir}/lxc-monitor
175 %attr(755,root,root) %{_bindir}/lxc-netstat
176 %attr(755,root,root) %{_bindir}/lxc-ps
177 %attr(755,root,root) %{_bindir}/lxc-restart
178 %attr(755,root,root) %{_bindir}/lxc-shutdown
179 %attr(755,root,root) %{_bindir}/lxc-start
180 %attr(755,root,root) %{_bindir}/lxc-stop
181 %attr(755,root,root) %{_bindir}/lxc-unfreeze
182 %attr(755,root,root) %{_bindir}/lxc-unshare
183 %attr(755,root,root) %{_bindir}/lxc-version
184 %attr(755,root,root) %{_bindir}/lxc-wait
185 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
187 %dir %{_libdir}/lxc
188 %dir %{_libdir}/lxc/rootfs
189 %{_libdir}/lxc/rootfs/README
190 %attr(755,root,root) %{_libdir}/lxc/lxc-init
191 %dir %{_sysconfdir}/lxc
192 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
193 %dir %{_datadir}/lxc
194 %{_datadir}/%{name}/lxc.functions
195 %dir %{_datadir}/%{name}/hooks
196 %dir %{_datadir}/%{name}/templates
197 %attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
198 %attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
199 %{_mandir}/man1/lxc-attach.1*
200 %{_mandir}/man1/lxc-cgroup.1*
201 %{_mandir}/man1/lxc-checkconfig.1*
202 %{_mandir}/man1/lxc-checkpoint.1*
203 %{_mandir}/man1/lxc-clone.1*
204 %{_mandir}/man1/lxc-console.1*
205 %{_mandir}/man1/lxc-create.1*
206 %{_mandir}/man1/lxc-destroy.1*
207 %{_mandir}/man1/lxc-execute.1*
208 %{_mandir}/man1/lxc-freeze.1*
209 %{_mandir}/man1/lxc-info.1*
210 %{_mandir}/man1/lxc-kill.1*
211 %{_mandir}/man1/lxc-monitor.1*
212 %{_mandir}/man1/lxc-netstat.1*
213 %{_mandir}/man1/lxc-ps.1*
214 %{_mandir}/man1/lxc-restart.1*
215 %{_mandir}/man1/lxc-shutdown.1*
216 %{_mandir}/man1/lxc-start.1*
217 %{_mandir}/man1/lxc-stop.1*
218 %{_mandir}/man1/lxc-unfreeze.1*
219 %{_mandir}/man1/lxc-unshare.1*
220 %{_mandir}/man1/lxc-version.1*
221 %{_mandir}/man1/lxc-wait.1*
222 %{_mandir}/man5/lxc.conf.5*
223 %{_mandir}/man7/lxc.7*
224 %if %{without python}
225 # legacy version
226 %attr(755,root,root) %{_bindir}/lxc-ls
227 %{_mandir}/man1/lxc-ls.1*
228 %endif
229
230 %dir %{configpath}
231 %dir %attr(750,root,root) /var/log/lxc
232 %dir %attr(750,root,root) /var/cache/lxc
233
234 %files devel
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/liblxc.so
237 %{_includedir}/lxc
238 %{_pkgconfigdir}/lxc.pc
239
240 %if %{with lua}
241 %files -n lua-lxc
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_bindir}/lxc-top
244 %dir %{_libdir}/lua/5.1/lxc
245 %attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
246 %{_datadir}/lua/5.1/lxc.lua
247 %{_mandir}/man1/lxc-top.1*
248 %endif
249
250 %if %{with python}
251 %files -n python3-lxc
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/lxc-device
254 %attr(755,root,root) %{_bindir}/lxc-ls
255 %attr(755,root,root) %{_bindir}/lxc-start-ephemeral
256 %{py3_sitedir}/lxc
257 %attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
258 %{py3_sitedir}/_lxc-0.1-py*.egg-info
259 %{_mandir}/man1/lxc-device.1*
260 %{_mandir}/man1/lxc-ls.1*
261 %{_mandir}/man1/lxc-start-ephemeral.1*
262 %endif
This page took 0.078438 seconds and 4 git commands to generate.