]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
rc-scripts 0.4.6 has lxc support in guest
[packages/lxc.git] / lxc.spec
1 #
2 # Conditional build:
3 %bcond_without  seccomp # SecComp syscall filter
4 %bcond_without  lua     # Lua binding
5 %bcond_without  python  # Python binding
6
7 Summary:        Linux Container Tools
8 Summary(pl.UTF-8):      Narzędzia do kontenerów linuksowych (LXC)
9 Name:           lxc
10 Version:        0.9.0
11 Release:        5
12 License:        LGPL v2.1+
13 Group:          Applications/System
14 Source0:        http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
15 # Source0-md5:  8552a4479090616f4bc04d8473765fc9
16 Patch0:         %{name}-devpts.patch
17 Patch1:         %{name}-pld.patch
18 Patch2:         am-1.14.patch
19 Patch3:         checkconfig-module.patch
20 Patch4:         checkconfig-vserver-config.patch
21 Patch5:         fedora-template.patch
22 URL:            http://lxc.sourceforge.net/
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  docbook-dtd30-sgml
26 BuildRequires:  docbook-utils
27 BuildRequires:  docbook2X
28 BuildRequires:  libapparmor-devel
29 BuildRequires:  libcap-devel
30 %{?with_seccomp:BuildRequires:  libseccomp-devel}
31 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
32 BuildRequires:  pkgconfig
33 %{?with_python:BuildRequires:   python3-devel >= 3.2}
34 BuildRequires:  rpmbuild(macros) >= 1.612
35 BuildRequires:  sed >= 4.0
36 Requires:       rc-scripts >= 0.4.6
37 Suggests:       net-tools
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         configpath      /var/lib/lxc
41
42 %description
43 Tools to create and manage containers. It contains a full featured
44 container with the isolation / virtualization of the pids, the ipc,
45 the utsname, the mount points, /proc, /sys, the network and it takes
46 into account the control groups. It is very light, flexible, and
47 provides a set of tools around the container like the monitoring with
48 asynchronous events notification, or the freeze of the container. This
49 package is useful to create Virtual Private Server, or to run isolated
50 applications like bash or sshd.
51
52 %description -l pl.UTF-8
53 Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
54 w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
55 utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
56 grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
57 do czynności związanych z kontenerami, takich jak monitorowanie z
58 asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
59 pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
60 oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
61
62 %package devel
63 Summary:        Header files for lxc library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxc
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description devel
69 Header files for lxc library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki lxc.
73
74 %package -n lua-lxc
75 Summary:        Lua binding for LXC
76 Summary(pl.UTF-8):      Wiązanie Lua do LXC
77 Group:          Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       lua51-libs >= 5.1
80
81 %description -n lua-lxc
82 Lua binding for LXC.
83
84 %description -n lua-lxc -l pl.UTF-8
85 Wiązanie Lua do LXC.
86
87 %package -n python3-lxc
88 Summary:        Python (3.x) binding for LXC
89 Summary(pl.UTF-8):      Wiązanie Pythona (3.x) do LXC
90 Group:          Libraries
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       python3-libs >= 3.2
93
94 %description -n python3-lxc
95 Python (3.x) binding for LXC.
96
97 %description -n python3-lxc -l pl.UTF-8
98 Wiązanie Pythona (3.x) do LXC.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105 %patch3 -p1
106 %patch4 -p1
107 %patch5 -p1
108
109 %build
110 %{__aclocal} -I config
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         db2xman=docbook2X2man \
116         --disable-rpath \
117         --enable-doc \
118         %{?with_lua:--enable-lua} \
119         %{?with_python:--enable-python} \
120         %{?with_seccomp:--enable-seccomp} \
121         --with-config-path=%{configpath} \
122         --with-distro=pld
123
124 %{__make}
125 %{__make} -C doc
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{configpath},/var/cache/lxc}
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         pcdatadir=%{_pkgconfigdir}
133
134 %{__make} -C doc install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
138
139 %if %{with python}
140 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
141 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
142 %endif
143 %if %{with lua}
144 %{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
145 %endif
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
156 %attr(755,root,root) %{_bindir}/lxc-attach
157 %attr(755,root,root) %{_bindir}/lxc-cgroup
158 %attr(755,root,root) %{_bindir}/lxc-checkconfig
159 %attr(755,root,root) %{_bindir}/lxc-checkpoint
160 %attr(755,root,root) %{_bindir}/lxc-clone
161 %attr(755,root,root) %{_bindir}/lxc-console
162 %attr(755,root,root) %{_bindir}/lxc-create
163 %attr(755,root,root) %{_bindir}/lxc-destroy
164 %attr(755,root,root) %{_bindir}/lxc-execute
165 %attr(755,root,root) %{_bindir}/lxc-freeze
166 %attr(755,root,root) %{_bindir}/lxc-info
167 %attr(755,root,root) %{_bindir}/lxc-kill
168 %attr(755,root,root) %{_bindir}/lxc-monitor
169 %attr(755,root,root) %{_bindir}/lxc-netstat
170 %attr(755,root,root) %{_bindir}/lxc-ps
171 %attr(755,root,root) %{_bindir}/lxc-restart
172 %attr(755,root,root) %{_bindir}/lxc-shutdown
173 %attr(755,root,root) %{_bindir}/lxc-start
174 %attr(755,root,root) %{_bindir}/lxc-stop
175 %attr(755,root,root) %{_bindir}/lxc-unfreeze
176 %attr(755,root,root) %{_bindir}/lxc-unshare
177 %attr(755,root,root) %{_bindir}/lxc-version
178 %attr(755,root,root) %{_bindir}/lxc-wait
179 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
181 %dir %{_libdir}/lxc
182 %dir %{_libdir}/lxc/rootfs
183 %{_libdir}/lxc/rootfs/README
184 %attr(755,root,root) %{_libdir}/lxc/lxc-init
185 %dir %{_sysconfdir}/lxc
186 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
187 %dir %{_datadir}/lxc
188 %{_datadir}/%{name}/lxc.functions
189 %dir %{_datadir}/%{name}/hooks
190 %dir %{_datadir}/%{name}/templates
191 %attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
192 %attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
193 %{_mandir}/man1/lxc-attach.1*
194 %{_mandir}/man1/lxc-cgroup.1*
195 %{_mandir}/man1/lxc-checkconfig.1*
196 %{_mandir}/man1/lxc-checkpoint.1*
197 %{_mandir}/man1/lxc-clone.1*
198 %{_mandir}/man1/lxc-console.1*
199 %{_mandir}/man1/lxc-create.1*
200 %{_mandir}/man1/lxc-destroy.1*
201 %{_mandir}/man1/lxc-execute.1*
202 %{_mandir}/man1/lxc-freeze.1*
203 %{_mandir}/man1/lxc-info.1*
204 %{_mandir}/man1/lxc-kill.1*
205 %{_mandir}/man1/lxc-monitor.1*
206 %{_mandir}/man1/lxc-netstat.1*
207 %{_mandir}/man1/lxc-ps.1*
208 %{_mandir}/man1/lxc-restart.1*
209 %{_mandir}/man1/lxc-shutdown.1*
210 %{_mandir}/man1/lxc-start.1*
211 %{_mandir}/man1/lxc-stop.1*
212 %{_mandir}/man1/lxc-unfreeze.1*
213 %{_mandir}/man1/lxc-unshare.1*
214 %{_mandir}/man1/lxc-version.1*
215 %{_mandir}/man1/lxc-wait.1*
216 %{_mandir}/man5/lxc.conf.5*
217 %{_mandir}/man7/lxc.7*
218 %if %{without python}
219 # legacy version
220 %attr(755,root,root) %{_bindir}/lxc-ls
221 %{_mandir}/man1/lxc-ls.1*
222 %endif
223
224 %dir %{configpath}
225 %dir /var/cache/lxc
226
227 %files devel
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/liblxc.so
230 %{_includedir}/lxc
231 %{_pkgconfigdir}/lxc.pc
232
233 %if %{with lua}
234 %files -n lua-lxc
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_bindir}/lxc-top
237 %dir %{_libdir}/lua/5.1/lxc
238 %attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
239 %{_datadir}/lua/5.1/lxc.lua
240 %{_mandir}/man1/lxc-top.1*
241 %endif
242
243 %if %{with python}
244 %files -n python3-lxc
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/lxc-device
247 %attr(755,root,root) %{_bindir}/lxc-ls
248 %attr(755,root,root) %{_bindir}/lxc-start-ephemeral
249 %{py3_sitedir}/lxc
250 %attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
251 %{py3_sitedir}/_lxc-0.1-py*.egg-info
252 %{_mandir}/man1/lxc-device.1*
253 %{_mandir}/man1/lxc-ls.1*
254 %{_mandir}/man1/lxc-start-ephemeral.1*
255 %endif
This page took 0.104201 seconds and 4 git commands to generate.