]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
up to 2.03.17
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - internal vs shared for snapshots,mirrors,thin,cache ?
4 #   note: dmeventd requires mirrors=internal)
5 #
6 # Conditional build:
7 # - initrd stuff
8 %bcond_with     initrd          # build initrd version
9 # - functionality
10 %bcond_without  cluster         # disable all cluster support (cmirrord, dlm support in lvmlockd)
11 %bcond_without  lvmdbusd        # lvmdbusd
12 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17
18 # lvmlockd requires lvmpolld
19 %if %{without lvmpolld}
20 %undefine       with_lvmpolld
21 %endif
22
23 %if %{without cluster} && %{without sanlock}
24 %undefine       with_lvmlockd
25 %endif
26
27 Summary:        The new version of Logical Volume Manager for Linux
28 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
29 Name:           lvm2
30 Version:        2.03.17
31 Release:        1
32 License:        GPL v2 and LGPL v2.1
33 Group:          Applications/System
34 Source0:        ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
35 # Source0-md5:  cf6927fcf772b15d5b00f4db938f496a
36 Patch0:         device-mapper-dmsetup-export.patch
37 Patch1:         %{name}-pld_init.patch
38 Patch2:         device-mapper-dmsetup-deps-export.patch
39 Patch3:         %{name}-thin.patch
40 URL:            http://www.sourceware.org/lvm2/
41 BuildRequires:  autoconf >= 2.69
42 BuildRequires:  autoconf-archive
43 BuildRequires:  automake
44 # for /run detection
45 BuildRequires:  filesystem >= 3.0-43
46 BuildRequires:  libaio-devel
47 BuildRequires:  libblkid-devel >= 2.24
48 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
49 %{?with_selinux:BuildRequires:  libsepol-devel}
50 BuildRequires:  ncurses-devel
51 BuildRequires:  pkgconfig
52 %if %{with lvmdbusd}
53 BuildRequires:  python3-dbus
54 BuildRequires:  python3-devel >= 1:3.2
55 BuildRequires:  python3-pyudev
56 %endif
57 BuildRequires:  readline-devel
58 BuildRequires:  rpmbuild(macros) >= 1.647
59 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
60 BuildRequires:  systemd-devel >= 1:221
61 BuildRequires:  udev-devel >= 1:176
62 %if %{with initrd}
63 %{?with_selinux:BuildRequires:  libselinux-static}
64 %{?with_selinux:BuildRequires:  libsepol-static}
65 BuildRequires:  glibc-static
66 BuildRequires:  libaio-static
67 %{?with_selinux:BuildRequires:  pcre-static}
68 %else
69 Obsoletes:      lvm2-initrd < %{version}-%{release}
70 %endif
71 %if %{with cluster}
72 # for cmirrord
73 BuildRequires:  corosync-devel
74 # for dlm support in lvmlockd
75 BuildRequires:  dlm-devel >= 3.99.5
76 %endif
77 Requires(post,preun,postun):    systemd-units >= 38
78 Requires(post,postun):  /sbin/chkconfig
79 Requires:       device-mapper >= %{version}-%{release}
80 %{?with_selinux:Requires:       libselinux >= 1.10}
81 Requires:       systemd-units >= 38
82 # doesn't work with 2.4 kernels
83 Requires:       uname(release) >= 2.6
84 Suggests:       thin-provisioning-tools >= 0.7.0
85 Obsoletes:      lvm < 2
86 Obsoletes:      lvm2-clvmd < 2.03
87 Obsoletes:      lvm2-systemd < 2.02.94
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _sbindir        /sbin
91 %define         _usrsbindir     /usr/sbin
92
93 # changing CFLAGS in the middle confuses confcache
94 %undefine       configure_cache
95
96 # causes: undefined reference to `__stack_chk_fail_local'
97 %define         filterout_c     -fstack-protector
98
99 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*' 'liblvm2cmd.so.*'
100
101 %description
102 This package includes a number of utilities for creating, checking,
103 and repairing logical volumes.
104
105 %description -l pl.UTF-8
106 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
107 logicznych wolumenów dyskowych (LVM2).
108
109 %package initrd
110 Summary:        The new version of Logical Volume Manager for Linux - initrd version
111 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
112 Group:          Base
113 Conflicts:      geninitrd < 10000.18
114
115 %description initrd
116 This package includes a number of utilities for creating, checking,
117 and repairing logical volumes - staticaly linked for initrd.
118
119 %description initrd -l pl.UTF-8
120 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
121 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
122 potrzeby initrd.
123
124 %package cmirrord
125 Summary:        Cluster mirror log daemon
126 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
127 Group:          Applications/System
128 Requires:       %{name} = %{version}-%{release}
129
130 %description cmirrord
131 cmirrord is the daemon that tracks mirror log information in a
132 cluster. It is specific to device-mapper based mirrors (and by
133 extension, LVM cluster mirrors). Cluster mirrors are not possible
134 without this daemon running.
135
136 This daemon relies on the cluster infrastructure provided by the
137 Cluster MANager (CMAN), which must be set up and running in order for
138 cmirrord to function.
139
140 %description cmirrord
141 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
142 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
143 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
144 lustrzanych ten demon jest niezbędny.
145
146 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
147 (Cluster MANager), który musi być skonfigurowany i działający, aby
148 działał cmirrord.
149
150 %package dbusd
151 Summary:        LVM2 D-Bus daemon
152 Summary(pl.UTF-8):      Demon LVM2 D-Bus
153 Group:          Daemons
154 Requires(post,preun,postun):    systemd-units >= 38
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       python3-dbus
157 Requires:       python3-pygobject3 >= 3
158 Requires:       python3-pyudev
159
160 %description dbusd
161 Daemon for access to LVM2 functionality through a D-Bus interface.
162
163 %description dbusd -l pl.UTF-8
164 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
165 D-Bus.
166
167 %package lockd
168 Summary:        LVM2 locking daemon
169 Summary(pl.UTF-8):      Demon blokad LVM2
170 Group:          Daemons
171 Requires(post,preun,postun):    systemd-units >= 38
172 Requires:       %{name} = %{version}-%{release}
173 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
174 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
175
176 %description lockd
177 LVM commands use lvmlockd to coordinate access to shared storage.
178
179 %description lockd -l pl.UTF-8
180 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
181 współdzielonej pamięci masowej.
182
183 %package resource-agents
184 Summary:        OCF Resource Agents for LVM2 processes
185 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
186 Group:          Applications/System
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       resource-agents
189
190 %description resource-agents
191 OCF Resource Agents for LVM2 processes.
192
193 %description resource-agents -l pl.UTF-8
194 Agenci OCF do monitorowania procesów LVM2.
195
196 %package -n device-mapper
197 Summary:        Userspace support for the device-mapper
198 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
199 Group:          Base
200 Requires(post,postun):  /sbin/ldconfig
201 Requires(post,preun,postun):    systemd-units >= 38
202 Requires:       device-mapper-libs = %{version}-%{release}
203 Requires:       systemd-units >= 38
204
205 %description -n device-mapper
206 The goal of this driver is to support volume management. The driver
207 enables the definition of new block devices composed of ranges of
208 sectors of existing devices. This can be used to define disk
209 partitions - or logical volumes. This light-weight kernel component
210 can support user-space tools for logical volume management.
211
212 %description -n device-mapper -l pl.UTF-8
213 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
214 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
215 sektorów na istniejących urządzeniach. Może to być wykorzystane do
216 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
217 składnik jądra może wspierać działające w przestrzeni użytkownika
218 narzędzia do zarządzania logicznymi wolumenami.
219
220 %package -n device-mapper-libs
221 Summary:        Device-mapper shared libraries
222 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
223 Group:          Libraries
224 Requires:       libblkid >= 2.24
225 Requires:       udev-libs >= 1:176
226 Obsoletes:      python-lvm < 2.03
227 Obsoletes:      python3-lvm < 2.03
228 Conflicts:      device-mapper < 2.02.119-1
229
230 %description -n device-mapper-libs
231 Device-mapper shared libraries.
232
233 %description -n device-mapper-libs -l pl.UTF-8
234 Biblioteki współdzielone device-mappera.
235
236 %package -n device-mapper-devel
237 Summary:        Header files for device-mapper libraries
238 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
239 Group:          Development/Libraries
240 Requires:       device-mapper-libs = %{version}-%{release}
241 Requires:       libblkid-devel >= 2.24
242 %if %{with selinux}
243 Requires:       libselinux-devel
244 Requires:       libsepol-devel
245 %endif
246 Requires:       udev-devel >= 1:176
247 Obsoletes:      device-mapper-dietlibc < 2.03
248
249 %description -n device-mapper-devel
250 Header files for device-mapper libraries.
251
252 %description -n device-mapper-devel -l pl.UTF-8
253 Pliki nagłówkowe bibliotek device-mappera.
254
255 %package -n device-mapper-static
256 Summary:        Static devmapper library
257 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
258 License:        LGPL v2.1
259 Group:          Development/Libraries
260 Requires:       device-mapper-devel = %{version}-%{release}
261
262 %description -n device-mapper-static
263 Static devmapper library.
264
265 %description -n device-mapper-static -l pl.UTF-8
266 Statyczna biblioteka devmapper.
267
268 %package -n device-mapper-initrd
269 Summary:        Userspace support for the device-mapper - initrd version
270 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
271 Group:          Base
272 Obsoletes:      device-mapper-initrd-devel < 2
273 Conflicts:      geninitrd < 10000.10
274
275 %description -n device-mapper-initrd
276 The goal of this driver is to support volume management. The driver
277 enables the definition of new block devices composed of ranges of
278 sectors of existing devices. This can be used to define disk
279 partitions - or logical volumes. This light-weight kernel component
280 can support user-space tools for logical volume management.
281
282 This package contains dmsetup program linked staticaly for use in
283 initrd.
284
285 %description -n device-mapper-initrd -l pl.UTF-8
286 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
287 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
288 sektorów na istniejących urządzeniach. Może to być wykorzystane do
289 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
290 składnik jądra może wspierać działające w przestrzeni użytkownika
291 narzędzia do zarządzania logicznymi wolumenami.
292
293 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
294 potrzeby initrd.
295
296 %prep
297 %setup -q -n LVM2.%{version}
298 %patch0 -p1
299 %patch1 -p1
300 %patch2 -p1
301 %patch3 -p1
302
303 %build
304 %{__aclocal}
305 %{__autoconf}
306
307 %if %{with initrd}
308 %configure \
309         %{?debug:--enable-debug} \
310         --disable-blkid_wiping \
311         --disable-nls \
312         --disable-readline \
313         %{!?with_selinux:--disable-selinux} \
314         --disable-silent-rules \
315         --enable-static_link \
316         --with-optimisation="%{rpmcflags} -Os"
317
318 echo 'STATIC_LIBS += %{?with_selinux:-lpcre} -lpthread -lm' >> libdm/make.tmpl
319
320 %{__make} -j1 -C lib liblvm-internal.a
321
322 %{__make} -j1 -C libdm ioctl/libdevmapper.a \
323         V=1
324
325 %{__make} -j1 -C libdaemon/client libdaemonclient.a
326
327 %{__make} -j1 -C libdm/dm-tools dmsetup.static \
328         V=1
329
330 %{__make} -j1 base/libbase.a device_mapper/libdevice-mapper.a
331
332 %{__make} -j1 -C tools lvm.static \
333         LIBS="%{?with_selinux:-lpcre} -lpthread -lm" \
334         SHELL=/bin/bash \
335         interfacebuilddir=../libdm/ioctl
336
337 %{__mv} tools/lvm.static initrd-lvm
338 %{__mv} libdm/dm-tools/dmsetup.static initrd-dmsetup
339
340 # check if tools works
341 for tool in initrd-lvm initrd-dmsetup; do
342         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
343         if [ $rc -gt 127 ]; then
344                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
345                 exit 1
346         fi
347 done
348
349 %{__make} clean
350
351 unset CC
352 %endif
353
354 %configure \
355         --enable-cache_check_needs_check \
356         --enable-cmdlib \
357         %{?with_lvmdbusd:--enable-dbus-service --enable-notify-dbus} \
358         %{?debug:--enable-debug} \
359         --enable-dmeventd \
360         --enable-dmfilemapd \
361         --enable-fsadm \
362 %if %{with lvmlockd}
363         %{?with_cluster:--enable-lvmlockd-dlm} \
364         %{?with_sanlock:--enable-lvmlockd-sanlock} \
365 %endif
366         --enable-lvmpolld \
367         --enable-ocf \
368         --enable-pkgconfig \
369         --enable-readline \
370         %{!?with_selinux:--disable-selinux} \
371         --disable-silent-rules \
372         --enable-thin_check_needs_check \
373         --enable-udev_sync \
374         --enable-udev_rules \
375         --with-cache=internal \
376         --with-cache-check=/usr/sbin/cache_check \
377         --with-cache-dump=/usr/sbin/cache_dump \
378         --with-cache-repair=/usr/sbin/cache_repair \
379         --with-cache-restore=/usr/sbin/cache_restore \
380 %if %{with cluster}
381         --enable-cmirrord \
382 %endif
383         --with-default-locking-dir=/var/lock/lvm \
384         --with-dmeventd-path=%{_sbindir}/dmeventd \
385         --with-interface=ioctl \
386         --with-mirrors=internal \
387         --with-optimisation="%{rpmcflags}" \
388         --with-snapshots=internal \
389         --with-systemdsystemunitdir=%{systemdunitdir} \
390         --with-tmpfilesdir=%{systemdtmpfilesdir} \
391         --with-thin=internal \
392         --with-thin-check=/usr/sbin/thin_check \
393         --with-thin-dump=/usr/sbin/thin_dump \
394         --with-thin-repair=/usr/sbin/thin_repair \
395         --with-thin-restore=/usr/sbin/thin_restore \
396         --with-udev-prefix=/ \
397         --with-vdo=internal --with-vdo-format=%{_bindir}/vdoformat \
398         --with-writecache=internal \
399         --with-usrlibdir=%{_libdir}
400
401 # no --enable-nls: no translations exist, broken
402
403 # use bash because of "set -o pipefail"
404 # V=1 still used because of missing --disable-silent-rules support in libdm (as of 2.03.09)
405 %{__make} -j1 \
406         SHELL=/bin/bash \
407         V=1
408 %{__make} -j1 -C libdm \
409         LIB_STATIC=libdevmapper.a \
410         V=1
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/lvm/subsys}
415
416 %{__make} install install_system_dirs install_systemd_units install_systemd_generators install_initscripts install_tmpfiles_configuration \
417         DESTDIR=$RPM_BUILD_ROOT \
418         PYTHON_PREFIX=%{_prefix} \
419         OWNER="" \
420         GROUP=""
421
422 %{__make} -C scripts install_tmpfiles_configuration \
423         DESTDIR=$RPM_BUILD_ROOT
424
425 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
426 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
427         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
428         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
429         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
430 done
431
432 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
433
434 %if %{with initrd}
435 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
436 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
437 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
438 %endif
439
440 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
441
442 %clean
443 rm -rf $RPM_BUILD_ROOT
444
445 %post
446 /sbin/chkconfig --add lvm2-monitor
447 %service lvm2-monitor restart
448 %systemd_post lvm2-monitor.service
449 /sbin/chkconfig --add blk-availability
450 %if %{with lvmpolld}
451 %systemd_post lvm2-lvmpolld.socket
452 %endif
453
454 %preun
455 %systemd_preun lvm2-monitor.service
456 %if %{with lvmpolld}
457 %systemd_preun lvm2-lvmpolld.socket
458 %endif
459
460 %postun
461 if [ "$1" = "0" ]; then
462         %service lvm2-monitor stop
463         /sbin/chkconfig --del lvm2-monitor
464         #no service blk-availability stop
465         /sbin/chkconfig --del blk-availability
466 fi
467 %systemd_reload
468
469 %triggerpostun -- %{name} < 2.02.94-1
470 %systemd_trigger lvm2-monitor.service
471
472 %post -n device-mapper
473 %systemd_post dm-event.socket
474
475 %preun -n device-mapper
476 %systemd_preun dm-event.socket dm-event.service
477
478 %postun -n device-mapper
479 %systemd_reload
480
481 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
482 %systemd_trigger dm-event.socket
483
484 %post   -n device-mapper-libs -p /sbin/ldconfig
485 %postun -n device-mapper-libs -p /sbin/ldconfig
486
487 %post dbusd
488 %systemd_post lvm2-lvmdbusd.service
489
490 %preun dbusd
491 %systemd_preun lvm2-lvmdbusd.service
492
493 %postun dbusd
494 %systemd_reload
495
496 %post lockd
497 %systemd_post lvm2-lvmlockd.service lvm2-lvmlocking.service
498
499 %preun lockd
500 %systemd_preun lvm2-lvmlockd.service lvm2-lvmlocking.service
501
502 %postun lockd
503 %systemd_reload
504
505 %files
506 %defattr(644,root,root,755)
507 %doc README WHATS_NEW doc/*
508 %attr(755,root,root) %{_sbindir}/blkdeactivate
509 %attr(755,root,root) %{_sbindir}/fsadm
510 %attr(755,root,root) %{_sbindir}/lvchange
511 %attr(755,root,root) %{_sbindir}/lvconvert
512 %attr(755,root,root) %{_sbindir}/lvcreate
513 %attr(755,root,root) %{_sbindir}/lvdisplay
514 %attr(755,root,root) %{_sbindir}/lvextend
515 %attr(755,root,root) %{_sbindir}/lvm
516 %attr(755,root,root) %{_sbindir}/lvm_import_vdo
517 %attr(755,root,root) %{_sbindir}/lvmconfig
518 %attr(755,root,root) %{_sbindir}/lvmdevices
519 %attr(755,root,root) %{_sbindir}/lvmdiskscan
520 %attr(755,root,root) %{_sbindir}/lvmdump
521 %attr(755,root,root) %{_sbindir}/lvmsadc
522 %attr(755,root,root) %{_sbindir}/lvmsar
523 %attr(755,root,root) %{_sbindir}/lvreduce
524 %attr(755,root,root) %{_sbindir}/lvremove
525 %attr(755,root,root) %{_sbindir}/lvrename
526 %attr(755,root,root) %{_sbindir}/lvresize
527 %attr(755,root,root) %{_sbindir}/lvs
528 %attr(755,root,root) %{_sbindir}/lvscan
529 %attr(755,root,root) %{_sbindir}/pvchange
530 %attr(755,root,root) %{_sbindir}/pvck
531 %attr(755,root,root) %{_sbindir}/pvcreate
532 %attr(755,root,root) %{_sbindir}/pvdisplay
533 %attr(755,root,root) %{_sbindir}/pvmove
534 %attr(755,root,root) %{_sbindir}/pvremove
535 %attr(755,root,root) %{_sbindir}/pvresize
536 %attr(755,root,root) %{_sbindir}/pvs
537 %attr(755,root,root) %{_sbindir}/pvscan
538 %attr(755,root,root) %{_sbindir}/vgcfgbackup
539 %attr(755,root,root) %{_sbindir}/vgcfgrestore
540 %attr(755,root,root) %{_sbindir}/vgchange
541 %attr(755,root,root) %{_sbindir}/vgck
542 %attr(755,root,root) %{_sbindir}/vgconvert
543 %attr(755,root,root) %{_sbindir}/vgcreate
544 %attr(755,root,root) %{_sbindir}/vgdisplay
545 %attr(755,root,root) %{_sbindir}/vgexport
546 %attr(755,root,root) %{_sbindir}/vgextend
547 %attr(755,root,root) %{_sbindir}/vgimport
548 %attr(755,root,root) %{_sbindir}/vgimportclone
549 %attr(755,root,root) %{_sbindir}/vgimportdevices
550 %attr(755,root,root) %{_sbindir}/vgmerge
551 %attr(755,root,root) %{_sbindir}/vgmknodes
552 %attr(755,root,root) %{_sbindir}/vgreduce
553 %attr(755,root,root) %{_sbindir}/vgremove
554 %attr(755,root,root) %{_sbindir}/vgrename
555 %attr(755,root,root) %{_sbindir}/vgs
556 %attr(755,root,root) %{_sbindir}/vgscan
557 %attr(755,root,root) %{_sbindir}/vgsplit
558 %attr(755,root,root) %{_libexecdir}/lvresize_fs_helper
559 %{_mandir}/man5/lvm.conf.5*
560 %{_mandir}/man7/lvmautoactivation.7*
561 %{_mandir}/man7/lvmcache.7*
562 %{_mandir}/man7/lvmraid.7*
563 %{_mandir}/man7/lvmreport.7*
564 %{_mandir}/man7/lvmsystemid.7*
565 %{_mandir}/man7/lvmthin.7*
566 %{_mandir}/man7/lvmvdo.7*
567 %{_mandir}/man8/blkdeactivate.8*
568 %{_mandir}/man8/fsadm.8*
569 %{_mandir}/man8/lvchange.8*
570 %{_mandir}/man8/lvconvert.8*
571 %{_mandir}/man8/lvcreate.8*
572 %{_mandir}/man8/lvdisplay.8*
573 %{_mandir}/man8/lvextend.8*
574 %{_mandir}/man8/lvm-config.8*
575 %{_mandir}/man8/lvm-dumpconfig.8*
576 %{_mandir}/man8/lvm-fullreport.8*
577 %{_mandir}/man8/lvm-lvpoll.8*
578 %{_mandir}/man8/lvm.8*
579 %{_mandir}/man8/lvm_import_vdo.8*
580 %{_mandir}/man8/lvmconfig.8*
581 %{_mandir}/man8/lvmdevices.8*
582 %{_mandir}/man8/lvmdiskscan.8*
583 %{_mandir}/man8/lvmdump.8*
584 %{_mandir}/man8/lvmsadc.8*
585 %{_mandir}/man8/lvmsar.8*
586 %{_mandir}/man8/lvreduce.8*
587 %{_mandir}/man8/lvremove.8*
588 %{_mandir}/man8/lvrename.8*
589 %{_mandir}/man8/lvresize.8*
590 %{_mandir}/man8/lvs.8*
591 %{_mandir}/man8/lvscan.8*
592 %{_mandir}/man8/pvchange.8*
593 %{_mandir}/man8/pvck.8*
594 %{_mandir}/man8/pvcreate.8*
595 %{_mandir}/man8/pvdisplay.8*
596 %{_mandir}/man8/pvmove.8*
597 %{_mandir}/man8/pvremove.8*
598 %{_mandir}/man8/pvresize.8*
599 %{_mandir}/man8/pvs.8*
600 %{_mandir}/man8/pvscan.8*
601 %{_mandir}/man8/vgcfgbackup.8*
602 %{_mandir}/man8/vgcfgrestore.8*
603 %{_mandir}/man8/vgchange.8*
604 %{_mandir}/man8/vgck.8*
605 %{_mandir}/man8/vgconvert.8*
606 %{_mandir}/man8/vgcreate.8*
607 %{_mandir}/man8/vgdisplay.8*
608 %{_mandir}/man8/vgexport.8*
609 %{_mandir}/man8/vgextend.8*
610 %{_mandir}/man8/vgimport.8*
611 %{_mandir}/man8/vgimportclone.8*
612 %{_mandir}/man8/vgimportdevices.8*
613 %{_mandir}/man8/vgmerge.8*
614 %{_mandir}/man8/vgmknodes.8*
615 %{_mandir}/man8/vgreduce.8*
616 %{_mandir}/man8/vgremove.8*
617 %{_mandir}/man8/vgrename.8*
618 %{_mandir}/man8/vgs.8*
619 %{_mandir}/man8/vgscan.8*
620 %{_mandir}/man8/vgsplit.8*
621 %attr(750,root,root) %dir %{_sysconfdir}/lvm
622 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
623 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
624 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
626 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
627 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
628 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
629 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
630 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
631 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
632 %{systemdtmpfilesdir}/lvm2.conf
633 %{systemdunitdir}/blk-availability.service
634 %{systemdunitdir}/lvm2-monitor.service
635 %dir %{_sysconfdir}/lvm/cache
636 %ghost %{_sysconfdir}/lvm/cache/.cache
637 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
638 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
639 %attr(700,root,root) %dir /run/lvm
640 %attr(700,root,root) %dir /var/lock/lvm
641 %attr(700,root,root) %dir /var/lock/lvm/subsys
642 %if %{with lvmlockd}
643 %attr(755,root,root) %{_sbindir}/lvmlockctl
644 %attr(755,root,root) %{_sbindir}/lvmlockd
645 %{systemdunitdir}/lvmlockd.service
646 %{systemdunitdir}/lvmlocks.service
647 %{_mandir}/man8/lvmlockctl.8*
648 %{_mandir}/man8/lvmlockd.8*
649 %endif
650 %if %{with lvmpolld}
651 %attr(755,root,root) %{_sbindir}/lvmpolld
652 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
653 %{systemdunitdir}/lvm2-lvmpolld.service
654 %{systemdunitdir}/lvm2-lvmpolld.socket
655 %{_mandir}/man8/lvmpolld.8*
656 %endif
657
658 %if %{with cluster}
659 %files cmirrord
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_usrsbindir}/cmirrord
662 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
663 %{systemdunitdir}/lvm2-cmirrord.service
664 %{_mandir}/man8/cmirrord.8*
665 %endif
666
667 %if %{with lvmdbusd}
668 %files dbusd
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_sbindir}/lvmdbusd
671 %{py3_sitescriptdir}/lvmdbusd
672 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
673 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/com.redhat.lvmdbus1.conf
674 %{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
675 %{systemdunitdir}/lvm2-lvmdbusd.service
676 %{_mandir}/man8/lvmdbusd.8*
677 %endif
678
679 %files resource-agents
680 %defattr(644,root,root,755)
681 %dir %{_prefix}/lib/ocf/resource.d/lvm2
682 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
683
684 %files -n device-mapper
685 %defattr(644,root,root,755)
686 %doc *_DM
687 %{systemdunitdir}/dm-event.service
688 %{systemdunitdir}/dm-event.socket
689 /lib/udev/rules.d/10-dm.rules
690 /lib/udev/rules.d/11-dm-lvm.rules
691 /lib/udev/rules.d/13-dm-disk.rules
692 /lib/udev/rules.d/69-dm-lvm.rules
693 /lib/udev/rules.d/95-dm-notify.rules
694 %attr(755,root,root) %{_sbindir}/dmeventd
695 %attr(755,root,root) %{_sbindir}/dmfilemapd
696 %attr(755,root,root) %{_sbindir}/dmsetup
697 %attr(755,root,root) %{_sbindir}/dmstats
698 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
699 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
700 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
701 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
702 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
703 %dir %{_libdir}/device-mapper
704 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
705 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
706 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
707 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
708 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
709 %{_mandir}/man8/dmfilemapd.8*
710 %{_mandir}/man8/dmsetup.8*
711 %{_mandir}/man8/dmstats.8*
712 %{_mandir}/man8/dmeventd.8*
713
714 %files -n device-mapper-libs
715 %defattr(644,root,root,755)
716 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
717 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
718 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
719 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
720
721 %files -n device-mapper-devel
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libdevmapper.so
724 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
725 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
726 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
727 %{_includedir}/libdevmapper.h
728 %{_includedir}/libdevmapper-event.h
729 %{_includedir}/lvm2cmd.h
730 %{_pkgconfigdir}/devmapper.pc
731 %{_pkgconfigdir}/devmapper-event.pc
732
733 %files -n device-mapper-static
734 %defattr(644,root,root,755)
735 %{_libdir}/libdevmapper.a
736
737 %if %{with initrd}
738 %files -n device-mapper-initrd
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/initrd/dmsetup
741
742 %files initrd
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/initrd/lvm
745 %endif
This page took 0.126288 seconds and 4 git commands to generate.