]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
rebuild with python 3.10
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - internal vs shared for snapshots,mirrors,thin,cache ?
4 #   note: dmeventd requires mirrors=internal)
5 #
6 # Conditional build:
7 # - initrd stuff
8 %bcond_with     initrd          # build initrd version
9 # - functionality
10 %bcond_without  cluster         # disable all cluster support (cmirrord, dlm support in lvmlockd)
11 %bcond_without  lvmdbusd        # lvmdbusd
12 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17
18 # lvmlockd requires lvmpolld
19 %if %{without lvmpolld}
20 %undefine       with_lvmpolld
21 %endif
22
23 %if %{without cluster} && %{without sanlock}
24 %undefine       with_lvmlockd
25 %endif
26
27 Summary:        The new version of Logical Volume Manager for Linux
28 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
29 Name:           lvm2
30 Version:        2.03.15
31 Release:        2
32 License:        GPL v2 and LGPL v2.1
33 Group:          Applications/System
34 Source0:        ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
35 # Source0-md5:  0dbe745e945461419b56c7a21d7e47e2
36 Patch0:         device-mapper-dmsetup-export.patch
37 Patch1:         %{name}-pld_init.patch
38 Patch2:         device-mapper-dmsetup-deps-export.patch
39 Patch3:         %{name}-thin.patch
40 URL:            http://www.sourceware.org/lvm2/
41 BuildRequires:  autoconf >= 2.69
42 BuildRequires:  automake
43 # for /run detection
44 BuildRequires:  filesystem >= 3.0-43
45 BuildRequires:  libaio-devel
46 BuildRequires:  libblkid-devel >= 2.24
47 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
48 %{?with_selinux:BuildRequires:  libsepol-devel}
49 BuildRequires:  ncurses-devel
50 BuildRequires:  pkgconfig
51 %if %{with lvmdbusd}
52 BuildRequires:  python3-dbus
53 BuildRequires:  python3-devel >= 1:3.2
54 BuildRequires:  python3-pyudev
55 %endif
56 BuildRequires:  readline-devel
57 BuildRequires:  rpmbuild(macros) >= 1.647
58 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
59 BuildRequires:  systemd-devel >= 1:221
60 BuildRequires:  udev-devel >= 1:176
61 %if %{with initrd}
62 %{?with_selinux:BuildRequires:  libselinux-static}
63 %{?with_selinux:BuildRequires:  libsepol-static}
64 BuildRequires:  glibc-static
65 BuildRequires:  libaio-static
66 %{?with_selinux:BuildRequires:  pcre-static}
67 %else
68 Obsoletes:      lvm2-initrd
69 %endif
70 %if %{with cluster}
71 # for cmirrord
72 BuildRequires:  corosync-devel
73 # for dlm support in lvmlockd
74 BuildRequires:  dlm-devel >= 3.99.5
75 %endif
76 Requires(post,preun,postun):    systemd-units >= 38
77 Requires(post,postun):  /sbin/chkconfig
78 Requires:       device-mapper >= %{version}-%{release}
79 %{?with_selinux:Requires:       libselinux >= 1.10}
80 Requires:       systemd-units >= 38
81 # doesn't work with 2.4 kernels
82 Requires:       uname(release) >= 2.6
83 Suggests:       thin-provisioning-tools >= 0.7.0
84 Obsoletes:      lvm
85 Obsoletes:      lvm2-clvmd < 2.03
86 Obsoletes:      lvm2-systemd
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         _sbindir        /sbin
90 %define         _usrsbindir     /usr/sbin
91
92 # changing CFLAGS in the middle confuses confcache
93 %undefine       configure_cache
94
95 # causes: undefined reference to `__stack_chk_fail_local'
96 %define         filterout_c     -fstack-protector
97
98 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*' 'liblvm2cmd.so.*'
99
100 %description
101 This package includes a number of utilities for creating, checking,
102 and repairing logical volumes.
103
104 %description -l pl.UTF-8
105 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
106 logicznych wolumenów dyskowych (LVM2).
107
108 %package initrd
109 Summary:        The new version of Logical Volume Manager for Linux - initrd version
110 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
111 Group:          Base
112 Conflicts:      geninitrd < 10000.18
113
114 %description initrd
115 This package includes a number of utilities for creating, checking,
116 and repairing logical volumes - staticaly linked for initrd.
117
118 %description initrd -l pl.UTF-8
119 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
120 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
121 potrzeby initrd.
122
123 %package cmirrord
124 Summary:        Cluster mirror log daemon
125 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
126 Group:          Applications/System
127 Requires:       %{name} = %{version}-%{release}
128
129 %description cmirrord
130 cmirrord is the daemon that tracks mirror log information in a
131 cluster. It is specific to device-mapper based mirrors (and by
132 extension, LVM cluster mirrors). Cluster mirrors are not possible
133 without this daemon running.
134
135 This daemon relies on the cluster infrastructure provided by the
136 Cluster MANager (CMAN), which must be set up and running in order for
137 cmirrord to function.
138
139 %description cmirrord
140 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
141 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
142 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
143 lustrzanych ten demon jest niezbędny.
144
145 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
146 (Cluster MANager), który musi być skonfigurowany i działający, aby
147 działał cmirrord.
148
149 %package dbusd
150 Summary:        LVM2 D-Bus daemon
151 Summary(pl.UTF-8):      Demon LVM2 D-Bus
152 Group:          Daemons
153 Requires(post,preun,postun):    systemd-units >= 38
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       python3-dbus
156 Requires:       python3-pygobject3 >= 3
157 Requires:       python3-pyudev
158
159 %description dbusd
160 Daemon for access to LVM2 functionality through a D-Bus interface.
161
162 %description dbusd -l pl.UTF-8
163 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
164 D-Bus.
165
166 %package lockd
167 Summary:        LVM2 locking daemon
168 Summary(pl.UTF-8):      Demon blokad LVM2
169 Group:          Daemons
170 Requires(post,preun,postun):    systemd-units >= 38
171 Requires:       %{name} = %{version}-%{release}
172 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
173 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
174
175 %description lockd
176 LVM commands use lvmlockd to coordinate access to shared storage.
177
178 %description lockd -l pl.UTF-8
179 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
180 współdzielonej pamięci masowej.
181
182 %package resource-agents
183 Summary:        OCF Resource Agents for LVM2 processes
184 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
185 Group:          Applications/System
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       resource-agents
188
189 %description resource-agents
190 OCF Resource Agents for LVM2 processes.
191
192 %description resource-agents -l pl.UTF-8
193 Agenci OCF do monitorowania procesów LVM2.
194
195 %package -n device-mapper
196 Summary:        Userspace support for the device-mapper
197 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
198 Group:          Base
199 Requires(post,postun):  /sbin/ldconfig
200 Requires(post,preun,postun):    systemd-units >= 38
201 Requires:       device-mapper-libs = %{version}-%{release}
202 Requires:       systemd-units >= 38
203
204 %description -n device-mapper
205 The goal of this driver is to support volume management. The driver
206 enables the definition of new block devices composed of ranges of
207 sectors of existing devices. This can be used to define disk
208 partitions - or logical volumes. This light-weight kernel component
209 can support user-space tools for logical volume management.
210
211 %description -n device-mapper -l pl.UTF-8
212 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
213 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
214 sektorów na istniejących urządzeniach. Może to być wykorzystane do
215 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
216 składnik jądra może wspierać działające w przestrzeni użytkownika
217 narzędzia do zarządzania logicznymi wolumenami.
218
219 %package -n device-mapper-libs
220 Summary:        Device-mapper shared libraries
221 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
222 Group:          Libraries
223 Requires:       libblkid >= 2.24
224 Requires:       udev-libs >= 1:176
225 Obsoletes:      python-lvm < 2.03
226 Obsoletes:      python3-lvm < 2.03
227 Conflicts:      device-mapper < 2.02.119-1
228
229 %description -n device-mapper-libs
230 Device-mapper shared libraries.
231
232 %description -n device-mapper-libs -l pl.UTF-8
233 Biblioteki współdzielone device-mappera.
234
235 %package -n device-mapper-devel
236 Summary:        Header files for device-mapper libraries
237 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
238 Group:          Development/Libraries
239 Requires:       device-mapper-libs = %{version}-%{release}
240 Requires:       libblkid-devel >= 2.24
241 %if %{with selinux}
242 Requires:       libselinux-devel
243 Requires:       libsepol-devel
244 %endif
245 Requires:       udev-devel >= 1:176
246 Obsoletes:      device-mapper-dietlibc < 2.03
247
248 %description -n device-mapper-devel
249 Header files for device-mapper libraries.
250
251 %description -n device-mapper-devel -l pl.UTF-8
252 Pliki nagłówkowe bibliotek device-mappera.
253
254 %package -n device-mapper-static
255 Summary:        Static devmapper library
256 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
257 License:        LGPL v2.1
258 Group:          Development/Libraries
259 Requires:       device-mapper-devel = %{version}-%{release}
260
261 %description -n device-mapper-static
262 Static devmapper library.
263
264 %description -n device-mapper-static -l pl.UTF-8
265 Statyczna biblioteka devmapper.
266
267 %package -n device-mapper-initrd
268 Summary:        Userspace support for the device-mapper - initrd version
269 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
270 Group:          Base
271 Obsoletes:      device-mapper-initrd-devel
272 Conflicts:      geninitrd < 10000.10
273
274 %description -n device-mapper-initrd
275 The goal of this driver is to support volume management. The driver
276 enables the definition of new block devices composed of ranges of
277 sectors of existing devices. This can be used to define disk
278 partitions - or logical volumes. This light-weight kernel component
279 can support user-space tools for logical volume management.
280
281 This package contains dmsetup program linked staticaly for use in
282 initrd.
283
284 %description -n device-mapper-initrd -l pl.UTF-8
285 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
286 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
287 sektorów na istniejących urządzeniach. Może to być wykorzystane do
288 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
289 składnik jądra może wspierać działające w przestrzeni użytkownika
290 narzędzia do zarządzania logicznymi wolumenami.
291
292 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
293 potrzeby initrd.
294
295 %prep
296 %setup -q -n LVM2.%{version}
297 %patch0 -p1
298 %patch1 -p1
299 %patch2 -p1
300 %patch3 -p1
301
302 %build
303 %{__aclocal}
304 %{__autoconf}
305
306 %if %{with initrd}
307 %configure \
308         %{?debug:--enable-debug} \
309         --disable-blkid_wiping \
310         --disable-nls \
311         --disable-readline \
312         %{!?with_selinux:--disable-selinux} \
313         --disable-silent-rules \
314         --enable-static_link \
315         --with-optimisation="%{rpmcflags} -Os"
316
317 echo 'STATIC_LIBS += %{?with_selinux:-lpcre} -lpthread -lm' >> libdm/make.tmpl
318
319 %{__make} -j1 -C lib liblvm-internal.a
320
321 %{__make} -j1 -C libdm ioctl/libdevmapper.a \
322         V=1
323
324 %{__make} -j1 -C libdaemon/client libdaemonclient.a
325
326 %{__make} -j1 -C libdm/dm-tools dmsetup.static \
327         V=1
328
329 %{__make} -j1 base/libbase.a device_mapper/libdevice-mapper.a
330
331 %{__make} -j1 -C tools lvm.static \
332         LIBS="%{?with_selinux:-lpcre} -lpthread -lm" \
333         SHELL=/bin/bash \
334         interfacebuilddir=../libdm/ioctl
335
336 %{__mv} tools/lvm.static initrd-lvm
337 %{__mv} libdm/dm-tools/dmsetup.static initrd-dmsetup
338
339 # check if tools works
340 for tool in initrd-lvm initrd-dmsetup; do
341         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
342         if [ $rc -gt 127 ]; then
343                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
344                 exit 1
345         fi
346 done
347
348 %{__make} clean
349
350 unset CC
351 %endif
352
353 %configure \
354         --enable-cache_check_needs_check \
355         --enable-cmdlib \
356         %{?with_lvmdbusd:--enable-dbus-service --enable-notify-dbus} \
357         %{?debug:--enable-debug} \
358         --enable-dmeventd \
359         --enable-dmfilemapd \
360         --enable-fsadm \
361 %if %{with lvmlockd}
362         %{?with_cluster:--enable-lvmlockd-dlm} \
363         %{?with_sanlock:--enable-lvmlockd-sanlock} \
364 %endif
365         --enable-lvmpolld \
366         --enable-ocf \
367         --enable-pkgconfig \
368         --enable-readline \
369         %{!?with_selinux:--disable-selinux} \
370         --disable-silent-rules \
371         --enable-thin_check_needs_check \
372         --enable-udev_sync \
373         --enable-udev_rules \
374         --with-cache=internal \
375         --with-cache-check=/usr/sbin/cache_check \
376         --with-cache-dump=/usr/sbin/cache_dump \
377         --with-cache-repair=/usr/sbin/cache_repair \
378         --with-cache-restore=/usr/sbin/cache_restore \
379 %if %{with cluster}
380         --enable-cmirrord \
381 %endif
382         --with-default-locking-dir=/var/lock/lvm \
383         --with-dmeventd-path=%{_sbindir}/dmeventd \
384         --with-interface=ioctl \
385         --with-mirrors=internal \
386         --with-optimisation="%{rpmcflags}" \
387         --with-snapshots=internal \
388         --with-systemdsystemunitdir=%{systemdunitdir} \
389         --with-tmpfilesdir=%{systemdtmpfilesdir} \
390         --with-thin=internal \
391         --with-thin-check=/usr/sbin/thin_check \
392         --with-thin-dump=/usr/sbin/thin_dump \
393         --with-thin-repair=/usr/sbin/thin_repair \
394         --with-thin-restore=/usr/sbin/thin_restore \
395         --with-udev-prefix=/ \
396         --with-vdo=internal --with-vdo-format=%{_bindir}/vdoformat \
397         --with-writecache=internal \
398         --with-usrlibdir=%{_libdir}
399
400 # no --enable-nls: no translations exist, broken
401
402 # use bash because of "set -o pipefail"
403 # V=1 still used because of missing --disable-silent-rules support in libdm (as of 2.03.09)
404 %{__make} -j1 \
405         SHELL=/bin/bash \
406         V=1
407 %{__make} -j1 -C libdm \
408         LIB_STATIC=libdevmapper.a \
409         V=1
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/lvm/subsys}
414
415 %{__make} install install_system_dirs install_systemd_units install_systemd_generators install_initscripts install_tmpfiles_configuration \
416         DESTDIR=$RPM_BUILD_ROOT \
417         PYTHON_PREFIX=%{_prefix} \
418         OWNER="" \
419         GROUP=""
420
421 %{__make} -C scripts install_tmpfiles_configuration \
422         DESTDIR=$RPM_BUILD_ROOT
423
424 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
425 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
426         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
427         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
428         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
429 done
430
431 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
432
433 %if %{with initrd}
434 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
435 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
436 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
437 %endif
438
439 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
440
441 %clean
442 rm -rf $RPM_BUILD_ROOT
443
444 %post
445 /sbin/chkconfig --add lvm2-monitor
446 %service lvm2-monitor restart
447 %systemd_post lvm2-monitor.service
448 /sbin/chkconfig --add blk-availability
449 %if %{with lvmpolld}
450 %systemd_post lvm2-lvmpolld.socket
451 %endif
452
453 %preun
454 %systemd_preun lvm2-monitor.service
455 %if %{with lvmpolld}
456 %systemd_preun lvm2-lvmpolld.socket
457 %endif
458
459 %postun
460 if [ "$1" = "0" ]; then
461         %service lvm2-monitor stop
462         /sbin/chkconfig --del lvm2-monitor
463         #no service blk-availability stop
464         /sbin/chkconfig --del blk-availability
465 fi
466 %systemd_reload
467
468 %triggerpostun -- %{name} < 2.02.94-1
469 %systemd_trigger lvm2-monitor.service
470
471 %post -n device-mapper
472 %systemd_post dm-event.socket
473
474 %preun -n device-mapper
475 %systemd_preun dm-event.socket dm-event.service
476
477 %postun -n device-mapper
478 %systemd_reload
479
480 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
481 %systemd_trigger dm-event.socket
482
483 %post   -n device-mapper-libs -p /sbin/ldconfig
484 %postun -n device-mapper-libs -p /sbin/ldconfig
485
486 %post dbusd
487 %systemd_post lvm2-lvmdbusd.service
488
489 %preun dbusd
490 %systemd_preun lvm2-lvmdbusd.service
491
492 %postun dbusd
493 %systemd_reload
494
495 %post lockd
496 %systemd_post lvm2-lvmlockd.service lvm2-lvmlocking.service
497
498 %preun lockd
499 %systemd_preun lvm2-lvmlockd.service lvm2-lvmlocking.service
500
501 %postun lockd
502 %systemd_reload
503
504 %files
505 %defattr(644,root,root,755)
506 %doc README WHATS_NEW doc/*
507 %attr(755,root,root) %{_sbindir}/blkdeactivate
508 %attr(755,root,root) %{_sbindir}/fsadm
509 %attr(755,root,root) %{_sbindir}/lvchange
510 %attr(755,root,root) %{_sbindir}/lvconvert
511 %attr(755,root,root) %{_sbindir}/lvcreate
512 %attr(755,root,root) %{_sbindir}/lvdisplay
513 %attr(755,root,root) %{_sbindir}/lvextend
514 %attr(755,root,root) %{_sbindir}/lvm
515 %attr(755,root,root) %{_sbindir}/lvm_import_vdo
516 %attr(755,root,root) %{_sbindir}/lvmconfig
517 %attr(755,root,root) %{_sbindir}/lvmdevices
518 %attr(755,root,root) %{_sbindir}/lvmdiskscan
519 %attr(755,root,root) %{_sbindir}/lvmdump
520 %attr(755,root,root) %{_sbindir}/lvmsadc
521 %attr(755,root,root) %{_sbindir}/lvmsar
522 %attr(755,root,root) %{_sbindir}/lvreduce
523 %attr(755,root,root) %{_sbindir}/lvremove
524 %attr(755,root,root) %{_sbindir}/lvrename
525 %attr(755,root,root) %{_sbindir}/lvresize
526 %attr(755,root,root) %{_sbindir}/lvs
527 %attr(755,root,root) %{_sbindir}/lvscan
528 %attr(755,root,root) %{_sbindir}/pvchange
529 %attr(755,root,root) %{_sbindir}/pvck
530 %attr(755,root,root) %{_sbindir}/pvcreate
531 %attr(755,root,root) %{_sbindir}/pvdisplay
532 %attr(755,root,root) %{_sbindir}/pvmove
533 %attr(755,root,root) %{_sbindir}/pvremove
534 %attr(755,root,root) %{_sbindir}/pvresize
535 %attr(755,root,root) %{_sbindir}/pvs
536 %attr(755,root,root) %{_sbindir}/pvscan
537 %attr(755,root,root) %{_sbindir}/vgcfgbackup
538 %attr(755,root,root) %{_sbindir}/vgcfgrestore
539 %attr(755,root,root) %{_sbindir}/vgchange
540 %attr(755,root,root) %{_sbindir}/vgck
541 %attr(755,root,root) %{_sbindir}/vgconvert
542 %attr(755,root,root) %{_sbindir}/vgcreate
543 %attr(755,root,root) %{_sbindir}/vgdisplay
544 %attr(755,root,root) %{_sbindir}/vgexport
545 %attr(755,root,root) %{_sbindir}/vgextend
546 %attr(755,root,root) %{_sbindir}/vgimport
547 %attr(755,root,root) %{_sbindir}/vgimportclone
548 %attr(755,root,root) %{_sbindir}/vgimportdevices
549 %attr(755,root,root) %{_sbindir}/vgmerge
550 %attr(755,root,root) %{_sbindir}/vgmknodes
551 %attr(755,root,root) %{_sbindir}/vgreduce
552 %attr(755,root,root) %{_sbindir}/vgremove
553 %attr(755,root,root) %{_sbindir}/vgrename
554 %attr(755,root,root) %{_sbindir}/vgs
555 %attr(755,root,root) %{_sbindir}/vgscan
556 %attr(755,root,root) %{_sbindir}/vgsplit
557 %{_mandir}/man5/lvm.conf.5*
558 %{_mandir}/man7/lvmautoactivation.7*
559 %{_mandir}/man7/lvmcache.7*
560 %{_mandir}/man7/lvmraid.7*
561 %{_mandir}/man7/lvmreport.7*
562 %{_mandir}/man7/lvmsystemid.7*
563 %{_mandir}/man7/lvmthin.7*
564 %{_mandir}/man7/lvmvdo.7*
565 %{_mandir}/man8/blkdeactivate.8*
566 %{_mandir}/man8/fsadm.8*
567 %{_mandir}/man8/lvchange.8*
568 %{_mandir}/man8/lvconvert.8*
569 %{_mandir}/man8/lvcreate.8*
570 %{_mandir}/man8/lvdisplay.8*
571 %{_mandir}/man8/lvextend.8*
572 %{_mandir}/man8/lvm-config.8*
573 %{_mandir}/man8/lvm-dumpconfig.8*
574 %{_mandir}/man8/lvm-fullreport.8*
575 %{_mandir}/man8/lvm-lvpoll.8*
576 %{_mandir}/man8/lvm.8*
577 %{_mandir}/man8/lvm_import_vdo.8*
578 %{_mandir}/man8/lvmconfig.8*
579 %{_mandir}/man8/lvmdevices.8*
580 %{_mandir}/man8/lvmdiskscan.8*
581 %{_mandir}/man8/lvmdump.8*
582 %{_mandir}/man8/lvmsadc.8*
583 %{_mandir}/man8/lvmsar.8*
584 %{_mandir}/man8/lvreduce.8*
585 %{_mandir}/man8/lvremove.8*
586 %{_mandir}/man8/lvrename.8*
587 %{_mandir}/man8/lvresize.8*
588 %{_mandir}/man8/lvs.8*
589 %{_mandir}/man8/lvscan.8*
590 %{_mandir}/man8/pvchange.8*
591 %{_mandir}/man8/pvck.8*
592 %{_mandir}/man8/pvcreate.8*
593 %{_mandir}/man8/pvdisplay.8*
594 %{_mandir}/man8/pvmove.8*
595 %{_mandir}/man8/pvremove.8*
596 %{_mandir}/man8/pvresize.8*
597 %{_mandir}/man8/pvs.8*
598 %{_mandir}/man8/pvscan.8*
599 %{_mandir}/man8/vgcfgbackup.8*
600 %{_mandir}/man8/vgcfgrestore.8*
601 %{_mandir}/man8/vgchange.8*
602 %{_mandir}/man8/vgck.8*
603 %{_mandir}/man8/vgconvert.8*
604 %{_mandir}/man8/vgcreate.8*
605 %{_mandir}/man8/vgdisplay.8*
606 %{_mandir}/man8/vgexport.8*
607 %{_mandir}/man8/vgextend.8*
608 %{_mandir}/man8/vgimport.8*
609 %{_mandir}/man8/vgimportclone.8*
610 %{_mandir}/man8/vgimportdevices.8*
611 %{_mandir}/man8/vgmerge.8*
612 %{_mandir}/man8/vgmknodes.8*
613 %{_mandir}/man8/vgreduce.8*
614 %{_mandir}/man8/vgremove.8*
615 %{_mandir}/man8/vgrename.8*
616 %{_mandir}/man8/vgs.8*
617 %{_mandir}/man8/vgscan.8*
618 %{_mandir}/man8/vgsplit.8*
619 %attr(750,root,root) %dir %{_sysconfdir}/lvm
620 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
621 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
622 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
623 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
624 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
626 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
627 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
628 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
629 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
630 %{systemdtmpfilesdir}/lvm2.conf
631 %{systemdunitdir}/blk-availability.service
632 %{systemdunitdir}/lvm2-monitor.service
633 %dir %{_sysconfdir}/lvm/cache
634 %ghost %{_sysconfdir}/lvm/cache/.cache
635 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
636 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
637 %attr(700,root,root) %dir /run/lvm
638 %attr(700,root,root) %dir /var/lock/lvm
639 %attr(700,root,root) %dir /var/lock/lvm/subsys
640 %if %{with lvmlockd}
641 %attr(755,root,root) %{_sbindir}/lvmlockctl
642 %attr(755,root,root) %{_sbindir}/lvmlockd
643 %{systemdunitdir}/lvmlockd.service
644 %{systemdunitdir}/lvmlocks.service
645 %{_mandir}/man8/lvmlockctl.8*
646 %{_mandir}/man8/lvmlockd.8*
647 %endif
648 %if %{with lvmpolld}
649 %attr(755,root,root) %{_sbindir}/lvmpolld
650 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
651 %{systemdunitdir}/lvm2-lvmpolld.service
652 %{systemdunitdir}/lvm2-lvmpolld.socket
653 %{_mandir}/man8/lvmpolld.8*
654 %endif
655
656 %if %{with cluster}
657 %files cmirrord
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_usrsbindir}/cmirrord
660 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
661 %{systemdunitdir}/lvm2-cmirrord.service
662 %{_mandir}/man8/cmirrord.8*
663 %endif
664
665 %if %{with lvmdbusd}
666 %files dbusd
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_sbindir}/lvmdbusd
669 %{py3_sitescriptdir}/lvmdbusd
670 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
671 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/com.redhat.lvmdbus1.conf
672 %{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
673 %{systemdunitdir}/lvm2-lvmdbusd.service
674 %{_mandir}/man8/lvmdbusd.8*
675 %endif
676
677 %files resource-agents
678 %defattr(644,root,root,755)
679 %dir %{_prefix}/lib/ocf/resource.d/lvm2
680 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
681
682 %files -n device-mapper
683 %defattr(644,root,root,755)
684 %doc *_DM
685 %{systemdunitdir}/dm-event.service
686 %{systemdunitdir}/dm-event.socket
687 /lib/udev/rules.d/10-dm.rules
688 /lib/udev/rules.d/11-dm-lvm.rules
689 /lib/udev/rules.d/13-dm-disk.rules
690 /lib/udev/rules.d/69-dm-lvm.rules
691 /lib/udev/rules.d/95-dm-notify.rules
692 %attr(755,root,root) %{_sbindir}/dmeventd
693 %attr(755,root,root) %{_sbindir}/dmfilemapd
694 %attr(755,root,root) %{_sbindir}/dmsetup
695 %attr(755,root,root) %{_sbindir}/dmstats
696 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
697 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
698 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
699 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
700 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
701 %dir %{_libdir}/device-mapper
702 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
703 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
704 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
705 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
706 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
707 %{_mandir}/man8/dmfilemapd.8*
708 %{_mandir}/man8/dmsetup.8*
709 %{_mandir}/man8/dmstats.8*
710 %{_mandir}/man8/dmeventd.8*
711
712 %files -n device-mapper-libs
713 %defattr(644,root,root,755)
714 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
715 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
716 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
717 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
718
719 %files -n device-mapper-devel
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/libdevmapper.so
722 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
723 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
724 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
725 %{_includedir}/libdevmapper.h
726 %{_includedir}/libdevmapper-event.h
727 %{_includedir}/lvm2cmd.h
728 %{_pkgconfigdir}/devmapper.pc
729 %{_pkgconfigdir}/devmapper-event.pc
730
731 %files -n device-mapper-static
732 %defattr(644,root,root,755)
733 %{_libdir}/libdevmapper.a
734
735 %if %{with initrd}
736 %files -n device-mapper-initrd
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/initrd/dmsetup
739
740 %files initrd
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/initrd/lvm
743 %endif
This page took 0.09912 seconds and 4 git commands to generate.