]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
- updated to 2.02.119
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 #
5 # Conditional build:
6 %bcond_with     initrd          # don't build initrd version
7 %bcond_without  uClibc          # link initrd version with uClibc
8 %bcond_with     dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static GLIBC
10 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
11 %bcond_without  lvmetad         # disable lvmetad
12 %bcond_without  selinux         # disable SELinux
13 %bcond_without  python          # Python binding
14
15 %ifarch sparc64 sparc
16 %define         with_glibc 1
17 %endif
18
19 # if one of the *libc is enabled disable default dietlibc
20 %if %{with dietlibc} && %{with uClibc}
21 %undefine       with_dietlibc
22 %endif
23
24 # with glibc disables default dietlibc
25 %if %{with glibc} && %{with dietlibc}
26 %undefine       with_dietlibc
27 %endif
28
29 # fallback is glibc if neither alternatives are enabled
30 %if %{without dietlibc} && %{without uClibc}
31 %define         with_glibc      1
32 %endif
33
34 Summary:        The new version of Logical Volume Manager for Linux
35 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
36 Name:           lvm2
37 Version:        2.02.119
38 Release:        1
39 License:        GPL v2 and LGPL v2.1
40 Group:          Applications/System
41 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
42 # Source0-md5:  93d15d76ab78fbcec4721c4b44284bbb
43 Source2:        clvmd.service
44 Source3:        clvmd.sysconfig
45 Patch0:         %{name}-selinux.patch
46 Patch1:         %{name}-diet.patch
47 Patch2:         device-mapper-dmsetup-export.patch
48 Patch3:         %{name}-pld_init.patch
49 Patch4:         dl-dlsym.patch
50 Patch6:         %{name}-lvm_path.patch
51 Patch7:         %{name}-sd_notify.patch
52 Patch8:         %{name}-clvmd_cmd_timeout.patch
53 Patch9:         device-mapper-dmsetup-deps-export.patch
54 URL:            http://www.sourceware.org/lvm2/
55 BuildRequires:  autoconf >= 2.61
56 BuildRequires:  automake
57 BuildRequires:  libblkid-devel >= 2.24
58 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
59 %{?with_selinux:BuildRequires:  libsepol-devel}
60 BuildRequires:  ncurses-devel
61 BuildRequires:  pkgconfig
62 %{?with_python:BuildRequires:   python-devel >= 2}
63 BuildRequires:  readline-devel
64 BuildRequires:  rpmbuild(macros) >= 1.647
65 BuildRequires:  systemd-devel >= 1:205
66 BuildRequires:  udev-devel >= 1:176
67 %if %{with initrd}
68 %if %{with dietlibc}
69 BuildRequires:  dietlibc-static >= 2:0.32-7
70 BuildConflicts: device-mapper-dietlibc
71 %endif
72 %if %{with glibc}
73 %{?with_selinux:BuildRequires:  libselinux-static}
74 %{?with_selinux:BuildRequires:  libsepol-static}
75 %endif
76 %{?with_glibc:BuildRequires:    glibc-static}
77 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
78 %endif
79 %if %{with cluster}
80 BuildRequires:  corosync-devel
81 BuildRequires:  dlm-devel >= 3.99.5
82 %endif
83 Requires(post,preun,postun):    systemd-units >= 38
84 Requires(post,postun):  /sbin/chkconfig
85 Requires:       device-mapper >= %{version}-%{release}
86 %{?with_selinux:Requires:       libselinux >= 1.10}
87 Requires:       systemd-units >= 38
88 # doesn't work with 2.4 kernels
89 Requires:       uname(release) >= 2.6
90 Obsoletes:      lvm
91 Obsoletes:      lvm2-systemd
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _sbindir        /sbin
95 %define         _usrsbindir     /usr/sbin
96
97 # changing CFLAGS in the middle confuses confcache
98 %undefine       configure_cache
99
100 # borken on AC
101 %define         filterout_ld    -Wl,--as-needed
102
103 # causes: undefined reference to `__stack_chk_fail_local'
104 %define         filterout_c     -fstack-protector
105
106 # for some reason known only to rpm there must be "\\|" not "\|" here
107 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
108 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
109
110 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
111
112 %description
113 This package includes a number of utilities for creating, checking,
114 and repairing logical volumes.
115
116 %description -l pl.UTF-8
117 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
118 logicznych wolumenów dyskowych (LVM2).
119
120 %package initrd
121 Summary:        The new version of Logical Volume Manager for Linux - initrd version
122 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
123 Group:          Base
124 Conflicts:      geninitrd < 10000.18
125
126 %description initrd
127 This package includes a number of utilities for creating, checking,
128 and repairing logical volumes - staticaly linked for initrd.
129
130 %description initrd -l pl.UTF-8
131 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
132 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
133 potrzeby initrd.
134
135 %package clvmd
136 Summary:        Cluster LVM daemon
137 Summary(pl.UTF-8):      Demon clustra LVM
138 Group:          Applications/System
139 Requires:       %{name} = %{version}-%{release}
140
141 %description clvmd
142 clvmd is the daemon that distributes LVM metadata updates around a
143 cluster. It must be running on all nodes in the cluster and will give
144 an error if a node in the cluster does not have this daemon running.
145
146 %description clvmd -l pl.UTF-8
147 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
148 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
149 węzeł w klastrze nie ma tego demona uruchomionego.
150
151 %package cmirrord
152 Summary:        Cluster mirror log daemon
153 Summary(pl.UTF-*):      Demon śledzący log lustrzany w klastrze
154 Group:          Applications/System
155 Requires:       %{name} = %{version}-%{release}
156
157 %description cmirrord
158 cmirrord is the daemon that tracks mirror log information in a
159 cluster. It is specific to device-mapper based mirrors (and by
160 extension, LVM cluster mirrors). Cluster mirrors are not possible
161 without this daemon running.
162
163 This daemon relies on the cluster infrastructure provided by the
164 Cluster MANager (CMAN), which must be set up and running in order for
165 cmirrord to function.
166
167 %description cmirrord
168 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
169 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
170 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
171 lustrzanych ten demon jest niezbędny.
172
173 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
174 (Cluster MANager), który musi być skonfigurowany i działający, aby
175 działał cmirrord.
176
177 %package resource-agents
178 Summary:        OCF Resource Agents for LVM2 processes
179 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
180 Group:          Applications/System
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       resource-agents
183
184 %description resource-agents
185 OCF Resource Agents for LVM2 processes.
186
187 %description resource-agents -l pl.UTF-8
188 Agenci OCF do monitorowania procesów LVM2.
189
190 %package -n python-lvm
191 Summary:        Python interface to LVM2
192 Summary(pl.UTF-8):      Interfejs Pythona do LVM2
193 Group:          Libraries/Python
194 Requires:       device-mapper-libs = %{version}-%{release}
195
196 %description -n python-lvm
197 Python interface to LVM2.
198
199 %description -n python-lvm -l pl.UTF-8
200 Interfejs Pythona do LVM2.
201
202 %package -n device-mapper
203 Summary:        Userspace support for the device-mapper
204 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
205 Group:          Base
206 Requires(post,postun):  /sbin/ldconfig
207 Requires(post,preun,postun):    systemd-units >= 38
208 Requires:       device-mapper-libs = %{version}-%{release}
209 Requires:       systemd-units >= 38
210
211 %description -n device-mapper
212 The goal of this driver is to support volume management. The driver
213 enables the definition of new block devices composed of ranges of
214 sectors of existing devices. This can be used to define disk
215 partitions - or logical volumes. This light-weight kernel component
216 can support user-space tools for logical volume management.
217
218 %description -n device-mapper -l pl.UTF-8
219 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
220 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
221 sektorów na istniejących urządzeniach. Może to być wykorzystane do
222 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
223 składnik jądra może wspierać działające w przestrzeni użytkownika
224 narzędzia do zarządzania logicznymi wolumenami.
225
226 %package -n device-mapper-libs
227 Summary:        Device-mapper shared libraries
228 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
229 Group:          Libraries
230 Conflicts:      device-mapper < 2.02.119-1
231 Requires:       libblkid >= 2.24
232 Requires:       udev-libs >= 1:176
233
234 %description -n device-mapper-libs
235 Device-mapper shared libraries.
236
237 %description -n device-mapper-libs -l pl.UTF-8
238 Biblioteki współdzielone device-mappera.
239
240 %package -n device-mapper-devel
241 Summary:        Header files for device-mapper libraries
242 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
243 Group:          Development/Libraries
244 Requires:       device-mapper-libs = %{version}-%{release}
245 Requires:       libblkid-devel >= 2.24
246 %if %{with selinux}
247 Requires:       libselinux-devel
248 Requires:       libsepol-devel
249 %endif
250 Requires:       udev-devel >= 1:176
251
252 %description -n device-mapper-devel
253 Header files for device-mapper libraries.
254
255 %description -n device-mapper-devel -l pl.UTF-8
256 Pliki nagłówkowe bibliotek device-mappera.
257
258 %package -n device-mapper-static
259 Summary:        Static devmapper library
260 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
261 License:        LGPL v2.1
262 Group:          Development/Libraries
263 Requires:       device-mapper-devel = %{version}-%{release}
264
265 %description -n device-mapper-static
266 Static devmapper library.
267
268 %description -n device-mapper-static -l pl.UTF-8
269 Statyczna biblioteka devmapper.
270
271 %package -n device-mapper-dietlibc
272 Summary:        Static devmapper library built with dietlibc
273 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
274 License:        LGPL v2.1
275 Group:          Development/Libraries
276 Requires:       device-mapper-devel = %{version}-%{release}
277
278 %description -n device-mapper-dietlibc
279 Static devmapper library built with dietlibc.
280
281 %description -n device-mapper-dietlibc -l pl.UTF-8
282 Statyczna biblioteka devmapper zbudowana z dietlibc.
283
284 %package -n device-mapper-initrd
285 Summary:        Userspace support for the device-mapper - initrd version
286 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
287 Group:          Base
288 Obsoletes:      device-mapper-initrd-devel
289 Conflicts:      geninitrd < 10000.10
290
291 %description -n device-mapper-initrd
292 The goal of this driver is to support volume management. The driver
293 enables the definition of new block devices composed of ranges of
294 sectors of existing devices. This can be used to define disk
295 partitions - or logical volumes. This light-weight kernel component
296 can support user-space tools for logical volume management.
297
298 This package contains dmsetup program linked staticaly for use in
299 initrd.
300
301 %description -n device-mapper-initrd -l pl.UTF-8
302 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
303 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
304 sektorów na istniejących urządzeniach. Może to być wykorzystane do
305 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
306 składnik jądra może wspierać działające w przestrzeni użytkownika
307 narzędzia do zarządzania logicznymi wolumenami.
308
309 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
310 potrzeby initrd.
311
312 %prep
313 %setup -q -n LVM2.%{version}
314 %{?with_selinux:%patch0 -p1}
315 %patch1 -p1
316 %patch2 -p1
317 %patch3 -p1
318 %patch4 -p1
319 %patch6 -p1
320 %patch7 -p1
321 %patch8 -p1
322 %patch9 -p1
323
324 # do not force --export-symbol linker option for e.g. statically linked executables
325 # -rdynamic compiler option drives linker in the right way.
326 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
327
328 %build
329 %if %{with initrd}
330 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
331 %endif
332 cp -f /usr/share/automake/config.sub autoconf
333 %{__aclocal}
334 %{__autoconf}
335
336 %if %{with initrd}
337 %{?with_glibc:export CC="%{__cc}"}
338 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
339 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
340
341 %configure \
342         ac_cv_lib_dl_dlopen=no \
343         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
344         %{?debug:--enable-debug} \
345         --disable-nls \
346         --disable-readline \
347         --enable-selinux%{!?with_glibc:=no} \
348         --enable-static_link \
349         --with-lvm1=internal \
350         --with-optimisation="%{rpmcflags} -Os"
351 # glibc version links with normal static libdevicemapper which has selinux enabled
352 # and we need to keep these in sync between device-mapper and lvm2
353
354 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
355 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
356
357 %{__make} -j1 -C include
358 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
359 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
360 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
361 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
362 mv -f tools/lvm.static initrd-lvm
363 mv -f tools/dmsetup.static initrd-dmsetup
364
365 # check if tools works
366 for tool in initrd-lvm initrd-dmsetup; do
367         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
368         if [ $rc -gt 127 ]; then
369                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
370                 exit 1
371         fi
372 done
373
374 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
375 %{__make} clean
376
377 unset CC
378 %endif
379
380 %configure \
381         --enable-applib \
382         --enable-cmdlib \
383         %{?debug:--enable-debug} \
384         --enable-dmeventd \
385         --enable-fsadm \
386         %{?with_lvmetad:--enable-lvmetad} \
387         --enable-ocf \
388         %{?with_python:--enable-python_bindings} \
389         --enable-readline \
390         %{!?with_selinux:--disable-selinux} \
391         --enable-pkgconfig \
392         --enable-udev_sync \
393         --enable-udev_rules \
394         --with-cache=internal \
395         --with-cluster=internal \
396 %if %{with cluster}
397         --with-clvmd=corosync \
398         --enable-cmirrord \
399 %endif
400         --with-dmeventd-path=%{_sbindir}/dmeventd \
401         --with-interface=ioctl \
402         --with-lvm1=internal \
403         --with-mirrors=internal \
404         --with-optimisation="%{rpmcflags}" \
405         --with-pool=internal \
406         --with-snapshots=internal \
407         --with-systemdsystemunitdir=%{systemdunitdir} \
408         --with-tmpfilesdir=%{systemdtmpfilesdir} \
409         --with-thin=internal \
410         --with-thin-check=%{_sbindir}/thin_check \
411         --with-thin-dump=%{_sbindir}/thin_dump \
412         --with-thin-repair=%{_sbindir}/thin_repair \
413         --with-udev-prefix=/ \
414         --with-usrlibdir=%{_libdir}
415
416 %{__make} -j1
417 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
418
419 %install
420 rm -rf $RPM_BUILD_ROOT
421 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
422 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
423
424 %{__make} install install_system_dirs install_systemd_units install_initscripts install_tmpfiles_configuration \
425         DESTDIR=$RPM_BUILD_ROOT \
426         OWNER="" \
427         GROUP=""
428
429 %{__make} -C scripts install_tmpfiles_configuration \
430         DESTDIR=$RPM_BUILD_ROOT \
431
432 %if %{with cluster}
433 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
434 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
435 %endif
436
437 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
438 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
439         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
440         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
441         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
442 done
443
444 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
445
446 %if %{with initrd}
447 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
448 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
449 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
450
451 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
452 %endif
453
454 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %post
460 /sbin/chkconfig --add lvm2-monitor
461 %service lvm2-monitor restart
462 %systemd_post lvm2-monitor.service
463 /sbin/chkconfig --add blk-availability
464 # no service blk-availability restart
465 %systemd_post blk-availability.service
466
467 %preun
468 %systemd_preun lvm2-monitor.service
469 %systemd_preun blk-availability.service
470
471 %postun
472 if [ "$1" = "0" ]; then
473         %service lvm2-monitor stop
474         /sbin/chkconfig --del lvm2-monitor
475         #no service blk-availability stop
476         /sbin/chkconfig --del blk-availability
477 fi
478 %systemd_reload
479
480 %triggerpostun -- %{name} < 2.02.94-1
481 %systemd_trigger lvm2-monitor.service
482
483 %post -n device-mapper
484 %systemd_post dm-event.socket
485
486 %preun -n device-mapper
487 %systemd_preun dm-event.socket dm-event.service
488
489 %postun -n device-mapper
490 %systemd_reload
491
492 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
493 %systemd_trigger dm-event.socket
494
495 %post   -n device-mapper-libs -p /sbin/ldconfig
496 %postun -n device-mapper-libs -p /sbin/ldconfig
497
498 %post clvmd
499 /sbin/chkconfig --add clvmd
500 # no service restart - it breaks current locks!
501 export NORESTART=1
502 %systemd_post clvmd.service
503 # re-exec instead
504 /usr/sbin/clvmd -S 2>/dev/null || :
505
506 %preun clvmd
507 %systemd_preun clvmd.service
508
509 %postun clvmd
510 if [ "$1" = "0" ]; then
511         %service clvmd stop
512         /sbin/chkconfig --del clvmd
513 fi
514 %systemd_reload
515
516 %files
517 %defattr(644,root,root,755)
518 %doc README WHATS_NEW doc/*
519 %attr(755,root,root) %{_sbindir}/blkdeactivate
520 %attr(755,root,root) %{_sbindir}/fsadm
521 %attr(755,root,root) %{_sbindir}/lv*
522 %attr(755,root,root) %{_sbindir}/pv*
523 %attr(755,root,root) %{_sbindir}/vg*
524 %{_mandir}/man5/lvm.conf.5*
525 %{_mandir}/man7/lvmcache.7*
526 %{_mandir}/man7/lvmsystemid.7*
527 %{_mandir}/man7/lvmthin.7*
528 %{_mandir}/man8/blkdeactivate.8*
529 %{_mandir}/man8/fsadm.8*
530 %{_mandir}/man8/lv*.8*
531 %{_mandir}/man8/pv*.8*
532 %{_mandir}/man8/vg*.8*
533 %attr(750,root,root) %dir %{_sysconfdir}/lvm
534 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
535 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
536 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
537 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
538 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
539 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
540 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
541 %if %{with lvmetad}
542 /lib/udev/rules.d/69-dm-lvm-metad.rules
543 %endif
544 %{systemdtmpfilesdir}/lvm2.conf
545 %{systemdunitdir}/blk-availability.service
546 %if %{with lvmetad}
547 %{systemdunitdir}/lvm2-lvmetad.service
548 %{systemdunitdir}/lvm2-lvmetad.socket
549 %endif
550 %{systemdunitdir}/lvm2-monitor.service
551 %{systemdunitdir}/lvm2-pvscan@.service
552 %dir %{_sysconfdir}/lvm/cache
553 %ghost %{_sysconfdir}/lvm/cache/.cache
554 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
555 %if %{with lvmetad}
556 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
557 %endif
558 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
559 %dir %attr(700,root,root) /var/run/lvm
560
561 %if %{with cluster}
562 %files clvmd
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_usrsbindir}/clvmd
565 %attr(754,root,root) /etc/rc.d/init.d/clvmd
566 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
567 %attr(755,root,root) /lib/systemd/lvm2-cluster-activation
568 %{systemdunitdir}/clvmd.service
569 %{systemdunitdir}/lvm2-cluster-activation.service
570 %{systemdunitdir}/lvm2-clvmd.service
571 %{_mandir}/man8/clvmd.8*
572
573 %files cmirrord
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_usrsbindir}/cmirrord
576 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
577 %{systemdunitdir}/lvm2-cmirrord.service
578 %{_mandir}/man8/cmirrord.8*
579 %endif
580
581 %files resource-agents
582 %defattr(644,root,root,755)
583 %dir %{_prefix}/lib/ocf/resource.d/lvm2
584 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
585
586 %if %{with python}
587 %files -n python-lvm
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{py_sitedir}/lvm.so
590 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
591 %endif
592
593 %files -n device-mapper
594 %defattr(644,root,root,755)
595 %doc *_DM
596 %{systemdunitdir}/dm-event.service
597 %{systemdunitdir}/dm-event.socket
598 /lib/udev/rules.d/10-dm.rules
599 /lib/udev/rules.d/11-dm-lvm.rules
600 /lib/udev/rules.d/13-dm-disk.rules
601 /lib/udev/rules.d/95-dm-notify.rules
602 %attr(755,root,root) %{_sbindir}/dmeventd
603 %attr(755,root,root) %{_sbindir}/dmsetup
604 %dir %{_libdir}/device-mapper
605 %attr(755,root,root) %{_libdir}/device-mapper/*.so
606 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
607 %{_mandir}/man8/dmsetup.8*
608 %{_mandir}/man8/dmeventd.8*
609
610 %files -n device-mapper-libs
611 %defattr(644,root,root,755)
612 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
613 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
614 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
615 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
616 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
617
618 %files -n device-mapper-devel
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/libdevmapper.so
621 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
622 %attr(755,root,root) %{_libdir}/liblvm2app.so
623 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
624 %{_includedir}/libdevmapper.h
625 %{_includedir}/libdevmapper-event.h
626 %{_includedir}/lvm2app.h
627 %{_includedir}/lvm2cmd.h
628 %{_pkgconfigdir}/devmapper.pc
629 %{_pkgconfigdir}/devmapper-event.pc
630 %{_pkgconfigdir}/lvm2app.pc
631
632 %files -n device-mapper-static
633 %defattr(644,root,root,755)
634 %{_libdir}/libdevmapper.a
635
636 %if %{with initrd}
637 %if %{with dietlibc}
638 %files -n device-mapper-dietlibc
639 %defattr(644,root,root,755)
640 %{dietlibdir}/libdevmapper.a
641 %endif
642
643 %files -n device-mapper-initrd
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/initrd/dmsetup
646
647 %files initrd
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/initrd/lvm
650 %endif
This page took 0.230123 seconds and 4 git commands to generate.