]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
- up to 2.02.64 but no initrd for now
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - kill -lreadline from libs (using -as-needed or moving from LIBS to binaries linking)
3 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
4 #
5 # Conditional build:
6 %bcond_without  initrd          # don't build initrd version
7 %bcond_with     uClibc          # link initrd version with uClibc
8 %bcond_without  dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static glibc
10 %bcond_without  clvmd           # don't build clvmd
11 %bcond_without  selinux         # disable SELinux
12
13 %ifarch sparc64 sparc
14 %define         with_glibc 1
15 %endif
16
17 # if one of the *libc is enabled disable default dietlibc
18 %if %{with dietlibc} && %{with uClibc}
19 %undefine       with_dietlibc
20 %endif
21
22 %if %{with glibc} && %{with dietlibc}
23 %undefine       with_dietlibc
24 %endif
25
26 Summary:        The new version of Logical Volume Manager for Linux
27 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
28 Name:           lvm2
29 Version:        2.02.65
30 Release:        1
31 License:        GPL v2
32 Group:          Applications/System
33 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
34 # Source0-md5:  1ce72f18492ffaa92e2a20b54c0b7cc6
35 Source1:        %{name}-initramfs-hook
36 Source2:        %{name}-initramfs-local-top
37 Patch0:         %{name}-selinux.patch
38 Patch1:         %{name}-diet.patch
39 Patch2:         device-mapper-dmsetup-export.patch
40 URL:            http://sources.redhat.com/lvm2/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
44 %{?with_selinux:BuildRequires:  libsepol-devel}
45 BuildRequires:  rpmbuild(macros) >= 1.213
46 %if %{with initrd}
47 %if %{with dietlibc}
48 BuildRequires:  dietlibc-static >= 2:0.31-5
49 BuildConflicts: device-mapper-dietlibc
50 %endif
51 %{?with_glibc:BuildRequires:    glibc-static}
52 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
53 %endif
54 %if %{with clvmd}
55 BuildRequires:  cman-devel >= 1.0
56 BuildRequires:  dlm-devel >= 1.0-0.pre21.2
57 %endif
58 BuildRequires:  ncurses-devel
59 BuildRequires:  readline-devel
60 Requires:       device-mapper >= %{version}-%{release}
61 %if %{with clvmd}
62 Requires:       cman-libs >= 1.0
63 Requires:       dlm >= 1.0-0.pre21.2
64 %endif
65 %{?with_selinux:Requires:       libselinux >= 1.10}
66 # doesn't work with 2.4 kernels
67 Requires:       uname(release) >= 2.6
68 Obsoletes:      lvm
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sbindir        /sbin
72 %define         _usrsbindir     /usr/sbin
73
74 # changing CFLAGS in the middle confuses confcache
75 %undefine       configure_cache
76 # can't work with diet
77 %undefine       with_ccache
78
79 # for some reason known only to rpm there must be "\\|" not "\|" here
80 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
81 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
82
83 %description
84 This package includes a number of utilities for creating, checking,
85 and repairing logical volumes.
86
87 %description -l pl.UTF-8
88 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
89 logicznych wolumenów dyskowych (LVM2).
90
91 %package initrd
92 Summary:        The new version of Logical Volume Manager for Linux - initrd version
93 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
94 Group:          Base
95 Conflicts:      geninitrd < 10000.18
96
97 %description initrd
98 This package includes a number of utilities for creating, checking,
99 and repairing logical volumes - staticaly linked for initrd.
100
101 %description initrd -l pl.UTF-8
102 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
103 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
104 potrzeby initrd.
105
106 %package -n device-mapper
107 Summary:        Userspace support for the device-mapper
108 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
109 Group:          Base
110
111 %description -n device-mapper
112 The goal of this driver is to support volume management. The driver
113 enables the definition of new block devices composed of ranges of
114 sectors of existing devices. This can be used to define disk
115 partitions - or logical volumes. This light-weight kernel component
116 can support user-space tools for logical volume management.
117
118 %description -n device-mapper -l pl.UTF-8
119 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
120 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
121 sektorów na istniejących urządzeniach. Może to być wykorzystane do
122 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
123 składnik jądra może wspierać działające w przestrzeni użytkownika
124 narzędzia do zarządzania logicznymi wolumenami.
125
126 %package -n device-mapper-devel
127 Summary:        Header files and development documentation for %{name}
128 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do %{name}
129 Group:          Development/Libraries
130 Requires:       device-mapper = %{version}-%{release}
131 %if %{with selinux}
132 Requires:       libselinux-devel
133 Requires:       libsepol-devel
134 %endif
135
136 %description -n device-mapper-devel
137 Header files and development documentation for %{name}.
138
139 %description -n device-mapper-devel -l pl.UTF-8
140 Pliki nagłówkowe i dokumentacja do %{name}.
141
142 %package -n device-mapper-static
143 Summary:        Static devmapper library
144 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
145 License:        LGPL v2.1
146 Group:          Development/Libraries
147 Requires:       device-mapper-devel = %{version}-%{release}
148
149 %description -n device-mapper-static
150 Static devmapper library.
151
152 %description -n device-mapper-static -l pl.UTF-8
153 Statyczna biblioteka devmapper.
154
155 %package -n device-mapper-dietlibc
156 Summary:        Static devmapper library built with dietlibc
157 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
158 License:        LGPL v2.1
159 Group:          Development/Libraries
160 Requires:       device-mapper-devel = %{version}-%{release}
161
162 %description -n device-mapper-dietlibc
163 Static devmapper library built with dietlibc.
164
165 %description -n device-mapper-dietlibc -l pl.UTF-8
166 Statyczna biblioteka devmapper zbudowana z dietlibc.
167
168 %package -n device-mapper-initrd
169 Summary:        Userspace support for the device-mapper - initrd version
170 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
171 Group:          Base
172 Obsoletes:      device-mapper-initrd-devel
173 Conflicts:      geninitrd < 10000.10
174
175 %description -n device-mapper-initrd
176 The goal of this driver is to support volume management. The driver
177 enables the definition of new block devices composed of ranges of
178 sectors of existing devices. This can be used to define disk
179 partitions - or logical volumes. This light-weight kernel component
180 can support user-space tools for logical volume management.
181
182 This package contains dmsetup program linked staticaly for use in
183 initrd.
184
185 %description -n device-mapper-initrd -l pl.UTF-8
186 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
187 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
188 sektorów na istniejących urządzeniach. Może to być wykorzystane do
189 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
190 składnik jądra może wspierać działające w przestrzeni użytkownika
191 narzędzia do zarządzania logicznymi wolumenami.
192
193 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
194 potrzeby initrd.
195
196 %package initramfs
197 Summary:        The new version of Logical Volume Manager for Linux - support scripts for initramfs-tools
198 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - skrypty dla initramfs-tools
199 Group:          Base
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       initramfs-tools
202
203 %description initramfs
204 The new version of Logical Volume Manager for Linux - support
205 scripts for initramfs-tools.
206
207 %description initramfs -l pl.UTF-8
208 Nowa wersja Logical Volume Managera dla Linuksa - skrypty dla
209 initramfs-tools.
210
211 %prep
212 %setup -q -n LVM2.%{version}
213 %{?with_selinux:%patch0 -p1}
214 %patch1 -p1
215 %patch2 -p1
216
217 %build
218 cp -f /usr/share/automake/config.sub autoconf
219 %{__aclocal}
220 %{__autoconf}
221
222 %if %{with initrd}
223 %configure \
224         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"} \
225         %{?with_dietlibc:CC="diet %{__cc}"} \
226         ac_cv_lib_dl_dlopen=no \
227         %{?debug:--enable-debug} \
228         --with-optimisation="%{rpmcflags} -Os" \
229         --enable-static_link \
230         --with-lvm1=internal \
231         --%{?with_glibc:en}%{!?with_glibc:dis}able-selinux \
232         --disable-readline \
233         --disable-nls
234 # glibc version links with normal static libdevicemapper which has selinux enabled
235 # and we need to keep these in sync between device-mapper and lvm2
236
237 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
238
239 %{__make} -j1 -C include
240 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
241 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
242 %{__make} -j1 -C tools dmsetup.static lvm.static
243 mv -f tools/lvm.static initrd-lvm
244 mv -f tools/dmsetup.static initrd-dmsetup
245 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
246 %{__make} clean
247 %endif
248
249 %configure \
250         --with-usrlibdir=%{_libdir} \
251         %{?debug:--enable-debug} \
252         --with-optimisation="%{rpmcflags}" \
253         --enable-readline \
254         --enable-fsadm \
255         --enable-cmdlib \
256         --enable-dmeventd \
257         --enable-pkgconfig \
258         %{?with_clvmd:--with-clvmd=cman} \
259         --with-lvm1=internal \
260         --with-pool=internal \
261         --with-cluster=internal \
262         --with-snapshots=internal \
263         --with-mirrors=internal \
264         --with-interface=ioctl \
265         %{!?with_selinux:--disable-selinux}
266 %{__make} -j1
267 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm} \
272         $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/{hooks,scripts/local-top}
273 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
274
275 %{__make} install \
276         DESTDIR=$RPM_BUILD_ROOT \
277         OWNER="" \
278         GROUP=""
279
280 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
281 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
282         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
283         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
284         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
285 done
286
287 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
288
289 %if %{with initrd}
290 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
291 install initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
292 install initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
293
294 %{?with_dietlibc:install diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
295 %endif
296
297 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/hooks/lvm2
298 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/scripts/local-top/lvm2
299
300 install libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
301
302 %clean
303 rm -rf $RPM_BUILD_ROOT
304
305 %post   -n device-mapper -p /sbin/ldconfig
306 %postun -n device-mapper -p /sbin/ldconfig
307
308 %files
309 %defattr(644,root,root,755)
310 %doc README WHATS_NEW doc/*
311 %attr(755,root,root) %{_sbindir}/*
312 %exclude %{_sbindir}/dmeventd
313 %exclude %{_sbindir}/dmsetup
314 %{?with_clvmd:%attr(755,root,root) %{_usrsbindir}/clvmd}
315 %{_mandir}/man?/*
316 %exclude %{_mandir}/man8/dmsetup.8*
317 %attr(750,root,root) %dir %{_sysconfdir}/lvm
318 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
319
320 %files -n device-mapper
321 %defattr(644,root,root,755)
322 %doc *_DM
323 %attr(755,root,root) %{_sbindir}/dmeventd
324 %attr(755,root,root) %{_sbindir}/dmsetup
325 %attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
326 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
327 %dir %{_libdir}/device-mapper
328 %attr(755,root,root) %{_libdir}/device-mapper/*.so
329 %{_mandir}/man8/dmsetup.8*
330
331 %files -n device-mapper-devel
332 %defattr(644,root,root,755)
333 %attr(755,root,root) %{_libdir}/libdevmapper*.so
334 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
335 %{_includedir}/libdevmapper*.h
336 %{_includedir}/lvm2cmd.h
337 %{_pkgconfigdir}/devmapper*.pc
338
339 %files -n device-mapper-static
340 %defattr(644,root,root,755)
341 %{_libdir}/libdevmapper*.a
342
343 %if %{with initrd}
344 %if %{with dietlibc}
345 %files -n device-mapper-dietlibc
346 %defattr(644,root,root,755)
347 %{dietlibdir}/libdevmapper.a
348 %endif
349
350 %files -n device-mapper-initrd
351 %defattr(644,root,root,755)
352 %attr(755,root,root) %{_libdir}/initrd/dmsetup
353
354 %files initrd
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_libdir}/initrd/lvm
357 %endif
358
359 %files initramfs
360 %defattr(644,root,root,755)
361 %attr(755,root,root) %{_datadir}/initramfs-tools/hooks/lvm2
362 %attr(755,root,root) %{_datadir}/initramfs-tools/scripts/local-top/lvm2
This page took 0.187532 seconds and 4 git commands to generate.