]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
08aad6641afd53995b6a46c4bfcc43edaf21c931
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 #
5 # Conditional build:
6 %bcond_without  initrd          # don't build initrd version
7 %bcond_without  uClibc          # link initrd version with uClibc
8 %bcond_with     dietlibc        # link initrd version with dietlibc
9 %bcond_with     glibc           # link initrd version with static GLIBC
10 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
11 %bcond_with     lvmetad         # enable lvmetad
12 %bcond_without  selinux         # disable SELinux
13
14 %ifarch sparc64 sparc
15 %define         with_glibc 1
16 %endif
17
18 # if one of the *libc is enabled disable default dietlibc
19 %if %{with dietlibc} && %{with uClibc}
20 %undefine       with_dietlibc
21 %endif
22
23 # with glibc disables default dietlibc
24 %if %{with glibc} && %{with dietlibc}
25 %undefine       with_dietlibc
26 %endif
27
28 # fallback is glibc if neither alternatives are enabled
29 %if %{without dietlibc} && %{without uClibc}
30 %define         with_glibc      1
31 %endif
32
33 Summary:        The new version of Logical Volume Manager for Linux
34 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
35 Name:           lvm2
36 Version:        2.02.103
37 Release:        1
38 License:        GPL v2 and LGPL v2.1
39 Group:          Applications/System
40 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
41 # Source0-md5:  e427e3494aaf86da2d363f344deb3837
42 Source1:        %{name}-tmpfiles.conf
43 Source2:        clvmd.service
44 Source3:        clvmd.sysconfig
45 Patch0:         %{name}-selinux.patch
46 Patch1:         %{name}-diet.patch
47 Patch2:         device-mapper-dmsetup-export.patch
48 Patch3:         %{name}-pld_init.patch
49 Patch4:         dl-dlsym.patch
50 Patch5:         %{name}-wrapper.patch
51 Patch6:         %{name}-lvm_path.patch
52 Patch7:         %{name}-sd_notify.patch
53 Patch8:         %{name}-clvmd_cmd_timeout.patch
54 Patch9:         device-mapper-dmsetup-deps-export.patch
55 URL:            http://sources.redhat.com/lvm2/
56 BuildRequires:  autoconf >= 2.61
57 BuildRequires:  automake
58 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
59 %{?with_selinux:BuildRequires:  libsepol-devel}
60 BuildRequires:  ncurses-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  readline-devel
63 BuildRequires:  rpmbuild(macros) >= 1.647
64 BuildRequires:  udev-devel >= 1:143
65 %if %{with initrd}
66 %if %{with dietlibc}
67 BuildRequires:  dietlibc-static >= 2:0.32-7
68 BuildConflicts: device-mapper-dietlibc
69 %endif
70 %if %{with glibc}
71 %{?with_selinux:BuildRequires:  libselinux-static}
72 %{?with_selinux:BuildRequires:  libsepol-static}
73 %endif
74 %{?with_glibc:BuildRequires:    glibc-static}
75 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
76 %endif
77 %if %{with cluster}
78 BuildRequires:  corosync-devel
79 BuildRequires:  dlm-devel >= 3.99.5
80 BuildRequires:  systemd-devel
81 %endif
82 Requires(post,preun,postun):    systemd-units >= 38
83 Requires(post,postun):  /sbin/chkconfig
84 Requires:       device-mapper >= %{version}-%{release}
85 %{?with_selinux:Requires:       libselinux >= 1.10}
86 Requires:       systemd-units >= 38
87 # doesn't work with 2.4 kernels
88 Requires:       uname(release) >= 2.6
89 Obsoletes:      lvm
90 Obsoletes:      lvm2-systemd
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _sbindir        /sbin
94 %define         _usrsbindir     /usr/sbin
95
96 # changing CFLAGS in the middle confuses confcache
97 %undefine       configure_cache
98
99 # borken on AC
100 %define         filterout_ld    -Wl,--as-needed
101
102 # causes: undefined reference to `__stack_chk_fail_local'
103 %define         filterout_c     -fstack-protector
104
105 # for some reason known only to rpm there must be "\\|" not "\|" here
106 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
107 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
108
109 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
110
111 %description
112 This package includes a number of utilities for creating, checking,
113 and repairing logical volumes.
114
115 %description -l pl.UTF-8
116 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
117 logicznych wolumenów dyskowych (LVM2).
118
119 %package initrd
120 Summary:        The new version of Logical Volume Manager for Linux - initrd version
121 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
122 Group:          Base
123 Conflicts:      geninitrd < 10000.18
124
125 %description initrd
126 This package includes a number of utilities for creating, checking,
127 and repairing logical volumes - staticaly linked for initrd.
128
129 %description initrd -l pl.UTF-8
130 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
131 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
132 potrzeby initrd.
133
134 %package clvmd
135 Summary:        Cluster LVM daemon
136 Summary(pl.UTF-8):      Demon clustra LVM
137 Group:          Applications/System
138 Requires:       %{name} = %{version}-%{release}
139
140 %description clvmd
141 clvmd is the daemon that distributes LVM metadata updates around a
142 cluster. It must be running on all nodes in the cluster and will give
143 an error if a node in the cluster does not have this daemon running.
144
145 %description clvmd -l pl.UTF-8
146 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
147 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
148 węzeł w klastrze nie ma tego demona uruchomionego.
149
150 %package cmirrord
151 Summary:        Cluster mirror log daemon
152 Group:          Applications/System
153 Requires:       %{name} = %{version}-%{release}
154
155 %description cmirrord
156 cmirrord is the daemon that tracks mirror log information in a
157 cluster. It is specific to device-mapper based mirrors (and by
158 extension, LVM cluster mirrors). Cluster mirrors are not possible
159 without this daemon running.
160
161 This daemon relies on the cluster infrastructure provided by the
162 Cluster MANager (CMAN), which must be set up and running in order for
163 cmirrord to function.
164
165 %package resource-agents
166 Summary:        OCF Resource Agents for LVM2 processes
167 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
168 Group:          Applications/System
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       resource-agents
171
172 %description resource-agents
173 OCF Resource Agents for LVM2 processes.
174
175 %description resource-agents -l pl.UTF-8
176 Agenci OCF do monitorowania procesów LVM2.
177
178 %package -n device-mapper
179 Summary:        Userspace support for the device-mapper
180 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
181 Group:          Base
182 Requires(post,preun,postun):    systemd-units >= 38
183 Requires:       systemd-units >= 38
184
185 %description -n device-mapper
186 The goal of this driver is to support volume management. The driver
187 enables the definition of new block devices composed of ranges of
188 sectors of existing devices. This can be used to define disk
189 partitions - or logical volumes. This light-weight kernel component
190 can support user-space tools for logical volume management.
191
192 %description -n device-mapper -l pl.UTF-8
193 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
194 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
195 sektorów na istniejących urządzeniach. Może to być wykorzystane do
196 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
197 składnik jądra może wspierać działające w przestrzeni użytkownika
198 narzędzia do zarządzania logicznymi wolumenami.
199
200 %package -n device-mapper-devel
201 Summary:        Header files and development documentation for %{name}
202 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do %{name}
203 Group:          Development/Libraries
204 Requires:       device-mapper = %{version}-%{release}
205 %if %{with selinux}
206 Requires:       libselinux-devel
207 Requires:       libsepol-devel
208 %endif
209
210 %description -n device-mapper-devel
211 Header files and development documentation for %{name}.
212
213 %description -n device-mapper-devel -l pl.UTF-8
214 Pliki nagłówkowe i dokumentacja do %{name}.
215
216 %package -n device-mapper-static
217 Summary:        Static devmapper library
218 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
219 License:        LGPL v2.1
220 Group:          Development/Libraries
221 Requires:       device-mapper-devel = %{version}-%{release}
222
223 %description -n device-mapper-static
224 Static devmapper library.
225
226 %description -n device-mapper-static -l pl.UTF-8
227 Statyczna biblioteka devmapper.
228
229 %package -n device-mapper-dietlibc
230 Summary:        Static devmapper library built with dietlibc
231 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
232 License:        LGPL v2.1
233 Group:          Development/Libraries
234 Requires:       device-mapper-devel = %{version}-%{release}
235
236 %description -n device-mapper-dietlibc
237 Static devmapper library built with dietlibc.
238
239 %description -n device-mapper-dietlibc -l pl.UTF-8
240 Statyczna biblioteka devmapper zbudowana z dietlibc.
241
242 %package -n device-mapper-initrd
243 Summary:        Userspace support for the device-mapper - initrd version
244 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
245 Group:          Base
246 Obsoletes:      device-mapper-initrd-devel
247 Conflicts:      geninitrd < 10000.10
248
249 %description -n device-mapper-initrd
250 The goal of this driver is to support volume management. The driver
251 enables the definition of new block devices composed of ranges of
252 sectors of existing devices. This can be used to define disk
253 partitions - or logical volumes. This light-weight kernel component
254 can support user-space tools for logical volume management.
255
256 This package contains dmsetup program linked staticaly for use in
257 initrd.
258
259 %description -n device-mapper-initrd -l pl.UTF-8
260 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
261 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
262 sektorów na istniejących urządzeniach. Może to być wykorzystane do
263 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
264 składnik jądra może wspierać działające w przestrzeni użytkownika
265 narzędzia do zarządzania logicznymi wolumenami.
266
267 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
268 potrzeby initrd.
269
270 %prep
271 %setup -q -n LVM2.%{version}
272 %{?with_selinux:%patch0 -p1}
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch5 -p1
278 %patch6 -p1
279 %patch7 -p1
280 %patch8 -p1
281 %patch9 -p1
282
283 # do not force --export-symbol linker option for e.g. statically linked executables
284 # -rdynamic compiler option drives linker in the right way.
285 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
286
287 %build
288 %if %{with initrd}
289 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
290 %endif
291 cp -f /usr/share/automake/config.sub autoconf
292 %{__aclocal}
293 %{__autoconf}
294
295 %if %{with initrd}
296 %{?with_glibc:export CC="%{__cc}"}
297 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
298 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
299
300 %configure \
301         ac_cv_lib_dl_dlopen=no \
302         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
303         %{?debug:--enable-debug} \
304         --with-optimisation="%{rpmcflags} -Os" \
305         --enable-static_link \
306         --with-lvm1=internal \
307         --disable-selinux \
308         --%{?with_glibc:en}%{!?with_glibc:dis}able-selinux \
309         --disable-readline \
310         --disable-nls
311 # glibc version links with normal static libdevicemapper which has selinux enabled
312 # and we need to keep these in sync between device-mapper and lvm2
313
314 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
315 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
316
317 %{__make} -j1 -C include
318 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
319 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
320 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
321 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
322 mv -f tools/lvm.static initrd-lvm
323 mv -f tools/dmsetup.static initrd-dmsetup
324
325 # check if tools works
326 for tool in initrd-lvm initrd-dmsetup; do
327         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
328         if [ $rc -gt 127 ]; then
329                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
330                 exit 1
331         fi
332 done
333
334
335 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
336 %{__make} clean
337
338 unset CC
339 %endif
340
341 %configure \
342         --with-usrlibdir=%{_libdir} \
343         %{?debug:--enable-debug} \
344         --with-optimisation="%{rpmcflags}" \
345         --enable-readline \
346         --enable-fsadm \
347         --enable-applib \
348         --enable-cmdlib \
349         %{?with_lvmetad:--enable-lvmetad} \
350         --enable-dmeventd \
351         --with-dmeventd-path=%{_sbindir}/dmeventd \
352         --enable-ocf \
353         --enable-pkgconfig \
354         --enable-udev_sync \
355         --enable-udev_rules \
356 %if %{with cluster}
357         --with-clvmd=corosync \
358         --enable-cmirrord \
359 %endif
360         --with-lvm1=internal \
361         --with-pool=internal \
362         --with-cluster=internal \
363         --with-snapshots=internal \
364         --with-mirrors=internal \
365         --with-thin=internal \
366         --with-thin-check=%{_sbindir}/thin_check \
367         --with-thin-dump=%{_sbindir}/thin_dump \
368         --with-thin-repair=%{_sbindir}/thin_repair \
369         --with-interface=ioctl \
370         --with-udev-prefix=/ \
371         --with-systemd_dir=%{systemdunitdir} \
372         %{!?with_selinux:--disable-selinux}
373
374 %{__make} -j1
375 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
376
377 %install
378 rm -rf $RPM_BUILD_ROOT
379 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
380 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
381
382 %{__make} install install_system_dirs install_systemd_units install_initscripts \
383         DESTDIR=$RPM_BUILD_ROOT \
384         OWNER="" \
385         GROUP=""
386
387 install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
388 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
389
390 %if %{with cluster}
391 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
392 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
393 %endif
394
395 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
396 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
397         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
398         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
399         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
400 done
401
402 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
403
404 %if %{with initrd}
405 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
406 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
407 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
408
409 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
410 %endif
411
412 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
413
414 %clean
415 rm -rf $RPM_BUILD_ROOT
416
417 %post
418 /sbin/chkconfig --add lvm2-monitor
419 %service lvm2-monitor restart
420 %systemd_post lvm2-monitor.service
421 /sbin/chkconfig --add blk-availability
422 # no service blk-availability restart
423 %systemd_post blk-availability.service
424
425 %preun
426 %systemd_preun lvm2-monitor.service
427 %systemd_preun blk-availability.service
428
429 %postun
430 if [ "$1" = "0" ]; then
431         %service lvm2-monitor stop
432         /sbin/chkconfig --del lvm2-monitor
433         #no service blk-availability stop
434         /sbin/chkconfig --del blk-availability
435 fi
436 %systemd_reload
437
438 %triggerpostun -- %{name} < 2.02.94-1
439 %systemd_trigger lvm2-monitor.service
440
441 %post -n device-mapper
442 /sbin/ldconfig
443 %systemd_post dm-event.socket
444
445 %preun -n device-mapper
446 %systemd_preun dm-event.socket dm-event.service
447
448 %postun -n device-mapper
449 /sbin/ldconfig
450 %systemd_reload
451
452 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
453 %systemd_trigger dm-event.socket
454
455 %post clvmd
456 /sbin/chkconfig --add clvmd
457 # no service restart - it breaks current locks!
458 export NORESTART=1
459 %systemd_post clvmd.service
460 # re-exec instead
461 /usr/sbin/clvmd -S 2>/dev/null || :
462
463 %preun clvmd
464 %systemd_preun clvmd.service
465
466 %postun clvmd
467 if [ "$1" = "0" ]; then
468         %service clvmd stop
469         /sbin/chkconfig --del clvmd
470 fi
471 %systemd_reload
472
473 %files
474 %defattr(644,root,root,755)
475 %doc README WHATS_NEW doc/*
476 %attr(755,root,root) %{_sbindir}/blkdeactivate
477 %attr(755,root,root) %{_sbindir}/fsadm
478 %attr(755,root,root) %{_sbindir}/lv*
479 %attr(755,root,root) %{_sbindir}/pv*
480 %attr(755,root,root) %{_sbindir}/vg*
481 %{_mandir}/man5/lvm.conf.5*
482 %{_mandir}/man8/blkdeactivate.8*
483 %{_mandir}/man8/fsadm.8*
484 %{_mandir}/man8/lv*.8*
485 %{_mandir}/man8/pv*.8*
486 %{_mandir}/man8/vg*.8*
487 %attr(750,root,root) %dir %{_sysconfdir}/lvm
488 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
489 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
490 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/default.profile
491 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
492 %{_sysconfdir}/tmpfiles.d/lvm2.conf
493 %{systemdunitdir}/lvm2-monitor.service
494 %{systemdunitdir}/blk-availability.service
495 %dir %{_sysconfdir}/lvm/cache
496 %ghost %{_sysconfdir}/lvm/cache/.cache
497 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
498 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
499 %dir %attr(700,root,root) /var/run/lvm
500
501 %if %{with cluster}
502 %files clvmd
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_usrsbindir}/clvmd
505 %attr(754,root,root) /etc/rc.d/init.d/clvmd
506 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
507 %{systemdunitdir}/clvmd.service
508 %{_mandir}/man8/clvmd.8*
509
510 %files cmirrord
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_usrsbindir}/cmirrord
513 %{_mandir}/man8/cmirrord.8*
514 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
515 %endif
516
517 %files resource-agents
518 %defattr(644,root,root,755)
519 %dir %{_prefix}/lib/ocf/resource.d/lvm2
520 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
521
522 %files -n device-mapper
523 %defattr(644,root,root,755)
524 %doc *_DM
525 %{systemdunitdir}/dm-event.service
526 %{systemdunitdir}/dm-event.socket
527 /lib/udev/rules.d/10-dm.rules
528 /lib/udev/rules.d/11-dm-lvm.rules
529 /lib/udev/rules.d/13-dm-disk.rules
530 /lib/udev/rules.d/95-dm-notify.rules
531 %attr(755,root,root) %{_sbindir}/dmeventd
532 %attr(755,root,root) %{_sbindir}/dmsetup
533 %attr(755,root,root) /%{_lib}/libdevmapper*.so.*.*
534 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
535 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
536 %dir %{_libdir}/device-mapper
537 %attr(755,root,root) %{_libdir}/device-mapper/*.so
538 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
539 %{_mandir}/man8/dmsetup.8*
540 %{_mandir}/man8/dmeventd.8*
541
542 %files -n device-mapper-devel
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/libdevmapper.so
545 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
546 %attr(755,root,root) %{_libdir}/liblvm2app.so
547 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
548 %{_includedir}/libdevmapper*.h
549 %{_includedir}/lvm2app.h
550 %{_includedir}/lvm2cmd.h
551 %{_pkgconfigdir}/devmapper*.pc
552 %{_pkgconfigdir}/lvm2app.pc
553
554 %files -n device-mapper-static
555 %defattr(644,root,root,755)
556 %{_libdir}/libdevmapper*.a
557
558 %if %{with initrd}
559 %if %{with dietlibc}
560 %files -n device-mapper-dietlibc
561 %defattr(644,root,root,755)
562 %{dietlibdir}/libdevmapper.a
563 %endif
564
565 %files -n device-mapper-initrd
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_libdir}/initrd/dmsetup
568
569 %files initrd
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_libdir}/initrd/lvm
572 %endif
This page took 0.067717 seconds and 2 git commands to generate.