]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
03f66e750d582994e16449be1baae2add24d9dd9
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - spec default value for --with-replicators (=internal/shared/none, configure default is none)?
4 #   (also internal vs shared for lvm1,pool,cluster,snapshots,mirrors,raid,replicators,thin,cache;
5 #    note: dmeventd requires mirrors=internal)
6 #
7 # Conditional build:
8 # - initrd stuff
9 %bcond_with     initrd          # build initrd version
10 %bcond_without  uClibc          # link initrd version with uClibc
11 %bcond_with     dietlibc        # link initrd version with dietlibc
12 %bcond_with     glibc           # link initrd version with static GLIBC
13 # - functionality
14 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
15 %bcond_without  lvmetad         # lvmetad (and lvmlockd)
16 %bcond_without  lvmdbusd        # lvmdbusd
17 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
18 %bcond_without  lvmlockd        # lvmlockd
19 %bcond_with     sanlock         # sanlock support in lvmlockd
20 %bcond_with     replicator      # internal replicator support
21 # - additional features
22 %bcond_without  selinux         # SELinux support
23 # - bindings
24 %bcond_without  python          # Python bindings
25 %bcond_without  python2         # Python 2 binding
26 %bcond_without  python3         # Python 3 binding and lvmdbusd
27
28 # lvmlockd requires lvmetad and lvmpolld
29 %if %{without lvmetad} || %{without lvmpolld}
30 %undefine       with_lvmpolld
31 %endif
32
33 # only glibc possible on SPARC
34 %ifarch sparc sparcv9 sparc64
35 %define         with_glibc 1
36 %endif
37 # if one of the *libc is enabled disable default dietlibc
38 %if %{with dietlibc} && %{with uClibc}
39 %undefine       with_dietlibc
40 %endif
41 # with glibc disables default dietlibc
42 %if %{with glibc} && %{with dietlibc}
43 %undefine       with_dietlibc
44 %endif
45 # fallback is glibc if neither alternatives are enabled
46 %if %{without dietlibc} && %{without uClibc}
47 %define         with_glibc      1
48 %endif
49 # for convenience
50 %if %{without python}
51 %undefine       with_python2
52 %undefine       with_python3
53 %endif
54 %if %{without python3}
55 %undefine       with_lvmdbusd
56 %endif
57
58 Summary:        The new version of Logical Volume Manager for Linux
59 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
60 Name:           lvm2
61 Version:        2.02.173
62 Release:        1
63 License:        GPL v2 and LGPL v2.1
64 Group:          Applications/System
65 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
66 # Source0-md5:  61cba056ac552f2d362600d494b1b8d9
67 Source2:        clvmd.service
68 Source3:        clvmd.sysconfig
69 Patch0:         %{name}-selinux.patch
70 Patch1:         %{name}-diet.patch
71 Patch2:         device-mapper-dmsetup-export.patch
72 Patch3:         %{name}-pld_init.patch
73 Patch4:         dl-dlsym.patch
74 Patch6:         %{name}-lvm_path.patch
75 Patch7:         %{name}-sd_notify.patch
76 Patch8:         %{name}-clvmd_cmd_timeout.patch
77 Patch9:         device-mapper-dmsetup-deps-export.patch
78 Patch10:        %{name}-replicator.patch
79 Patch11:        %{name}-thin.patch
80 URL:            http://www.sourceware.org/lvm2/
81 BuildRequires:  autoconf >= 2.69
82 BuildRequires:  automake
83 # for /run detection
84 BuildRequires:  filesystem >= 3.0-43
85 BuildRequires:  libblkid-devel >= 2.24
86 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
87 %{?with_selinux:BuildRequires:  libsepol-devel}
88 BuildRequires:  ncurses-devel
89 BuildRequires:  pkgconfig
90 %{?with_python2:BuildRequires:  python-devel >= 2}
91 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
92 %if %{with lvmdbusd}
93 BuildRequires:  python3-dbus
94 BuildRequires:  python3-pyudev
95 %endif
96 BuildRequires:  readline-devel
97 BuildRequires:  rpmbuild(macros) >= 1.647
98 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
99 BuildRequires:  systemd-devel >= 1:221
100 BuildRequires:  udev-devel >= 1:176
101 %if %{with initrd}
102 %if %{with dietlibc}
103 BuildRequires:  dietlibc-static >= 2:0.32-7
104 BuildConflicts: device-mapper-dietlibc
105 %endif
106 %if %{with glibc}
107 %{?with_selinux:BuildRequires:  libselinux-static}
108 %{?with_selinux:BuildRequires:  libsepol-static}
109 %endif
110 %{?with_glibc:BuildRequires:    glibc-static}
111 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
112 %endif
113 %if %{with cluster}
114 BuildRequires:  corosync-devel
115 BuildRequires:  dlm-devel >= 3.99.5
116 %endif
117 Requires(post,preun,postun):    systemd-units >= 38
118 Requires(post,postun):  /sbin/chkconfig
119 Requires:       device-mapper >= %{version}-%{release}
120 %{?with_selinux:Requires:       libselinux >= 1.10}
121 Requires:       systemd-units >= 38
122 # doesn't work with 2.4 kernels
123 Requires:       uname(release) >= 2.6
124 Suggests:       thin-provisioning-tools >= 0.5.4
125 Obsoletes:      lvm
126 Obsoletes:      lvm2-systemd
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %define         _sbindir        /sbin
130 %define         _usrsbindir     /usr/sbin
131
132 # changing CFLAGS in the middle confuses confcache
133 %undefine       configure_cache
134
135 # borken on AC
136 %define         filterout_ld    -Wl,--as-needed
137
138 # causes: undefined reference to `__stack_chk_fail_local'
139 %define         filterout_c     -fstack-protector
140
141 # for some reason known only to rpm there must be "\\|" not "\|" here
142 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
143 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
144
145 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
146
147 %description
148 This package includes a number of utilities for creating, checking,
149 and repairing logical volumes.
150
151 %description -l pl.UTF-8
152 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
153 logicznych wolumenów dyskowych (LVM2).
154
155 %package initrd
156 Summary:        The new version of Logical Volume Manager for Linux - initrd version
157 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
158 Group:          Base
159 Conflicts:      geninitrd < 10000.18
160
161 %description initrd
162 This package includes a number of utilities for creating, checking,
163 and repairing logical volumes - staticaly linked for initrd.
164
165 %description initrd -l pl.UTF-8
166 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
167 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
168 potrzeby initrd.
169
170 %package clvmd
171 Summary:        Cluster LVM daemon
172 Summary(pl.UTF-8):      Demon clustra LVM
173 Group:          Applications/System
174 Requires:       %{name} = %{version}-%{release}
175
176 %description clvmd
177 clvmd is the daemon that distributes LVM metadata updates around a
178 cluster. It must be running on all nodes in the cluster and will give
179 an error if a node in the cluster does not have this daemon running.
180
181 %description clvmd -l pl.UTF-8
182 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
183 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
184 węzeł w klastrze nie ma tego demona uruchomionego.
185
186 %package cmirrord
187 Summary:        Cluster mirror log daemon
188 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
189 Group:          Applications/System
190 Requires:       %{name} = %{version}-%{release}
191
192 %description cmirrord
193 cmirrord is the daemon that tracks mirror log information in a
194 cluster. It is specific to device-mapper based mirrors (and by
195 extension, LVM cluster mirrors). Cluster mirrors are not possible
196 without this daemon running.
197
198 This daemon relies on the cluster infrastructure provided by the
199 Cluster MANager (CMAN), which must be set up and running in order for
200 cmirrord to function.
201
202 %description cmirrord
203 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
204 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
205 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
206 lustrzanych ten demon jest niezbędny.
207
208 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
209 (Cluster MANager), który musi być skonfigurowany i działający, aby
210 działał cmirrord.
211
212 %package dbusd
213 Summary:        LVM2 D-Bus daemon
214 Summary(pl.UTF-8):      Demon LVM2 D-Bus
215 Group:          Daemons
216 Requires(post,preun,postun):    systemd-units >= 38
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       python3-dbus
219 Requires:       python3-pyudev
220 Requires:       python3-pygobject3 >= 3
221
222 %description dbusd
223 Daemon for access to LVM2 functionality through a D-Bus interface.
224
225 %description dbusd -l pl.UTF-8
226 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
227 D-Bus.
228
229 %package lockd
230 Summary:        LVM2 locking daemon
231 Summary(pl.UTF-8):      Demon blokad LVM2
232 Group:          Daemons
233 Requires(post,preun,postun):    systemd-units >= 38
234 Requires:       %{name} = %{version}-%{release}
235 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
236 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
237
238 %description lockd
239 LVM commands use lvmlockd to coordinate access to shared storage.
240
241 %description lockd -l pl.UTF-8
242 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
243 współdzielonej pamięci masowej.
244
245 %package resource-agents
246 Summary:        OCF Resource Agents for LVM2 processes
247 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
248 Group:          Applications/System
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       resource-agents
251
252 %description resource-agents
253 OCF Resource Agents for LVM2 processes.
254
255 %description resource-agents -l pl.UTF-8
256 Agenci OCF do monitorowania procesów LVM2.
257
258 %package -n python-lvm
259 Summary:        Python 2 interface to LVM2
260 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
261 Group:          Libraries/Python
262 Requires:       device-mapper-libs = %{version}-%{release}
263
264 %description -n python-lvm
265 Python 2 interface to LVM2.
266
267 %description -n python-lvm -l pl.UTF-8
268 Interfejs Pythona 2 do LVM2.
269
270 %package -n python3-lvm
271 Summary:        Python 3 interface to LVM2
272 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
273 Group:          Libraries/Python
274 Requires:       device-mapper-libs = %{version}-%{release}
275
276 %description -n python3-lvm
277 Python 3 interface to LVM2.
278
279 %description -n python3-lvm -l pl.UTF-8
280 Interfejs Pythona 3 do LVM2.
281
282 %package -n device-mapper
283 Summary:        Userspace support for the device-mapper
284 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
285 Group:          Base
286 Requires(post,postun):  /sbin/ldconfig
287 Requires(post,preun,postun):    systemd-units >= 38
288 Requires:       device-mapper-libs = %{version}-%{release}
289 Requires:       systemd-units >= 38
290
291 %description -n device-mapper
292 The goal of this driver is to support volume management. The driver
293 enables the definition of new block devices composed of ranges of
294 sectors of existing devices. This can be used to define disk
295 partitions - or logical volumes. This light-weight kernel component
296 can support user-space tools for logical volume management.
297
298 %description -n device-mapper -l pl.UTF-8
299 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
300 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
301 sektorów na istniejących urządzeniach. Może to być wykorzystane do
302 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
303 składnik jądra może wspierać działające w przestrzeni użytkownika
304 narzędzia do zarządzania logicznymi wolumenami.
305
306 %package -n device-mapper-libs
307 Summary:        Device-mapper shared libraries
308 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
309 Group:          Libraries
310 Conflicts:      device-mapper < 2.02.119-1
311 Requires:       libblkid >= 2.24
312 Requires:       udev-libs >= 1:176
313
314 %description -n device-mapper-libs
315 Device-mapper shared libraries.
316
317 %description -n device-mapper-libs -l pl.UTF-8
318 Biblioteki współdzielone device-mappera.
319
320 %package -n device-mapper-devel
321 Summary:        Header files for device-mapper libraries
322 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
323 Group:          Development/Libraries
324 Requires:       device-mapper-libs = %{version}-%{release}
325 Requires:       libblkid-devel >= 2.24
326 %if %{with selinux}
327 Requires:       libselinux-devel
328 Requires:       libsepol-devel
329 %endif
330 Requires:       udev-devel >= 1:176
331
332 %description -n device-mapper-devel
333 Header files for device-mapper libraries.
334
335 %description -n device-mapper-devel -l pl.UTF-8
336 Pliki nagłówkowe bibliotek device-mappera.
337
338 %package -n device-mapper-static
339 Summary:        Static devmapper library
340 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
341 License:        LGPL v2.1
342 Group:          Development/Libraries
343 Requires:       device-mapper-devel = %{version}-%{release}
344
345 %description -n device-mapper-static
346 Static devmapper library.
347
348 %description -n device-mapper-static -l pl.UTF-8
349 Statyczna biblioteka devmapper.
350
351 %package -n device-mapper-dietlibc
352 Summary:        Static devmapper library built with dietlibc
353 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
354 License:        LGPL v2.1
355 Group:          Development/Libraries
356 Requires:       device-mapper-devel = %{version}-%{release}
357
358 %description -n device-mapper-dietlibc
359 Static devmapper library built with dietlibc.
360
361 %description -n device-mapper-dietlibc -l pl.UTF-8
362 Statyczna biblioteka devmapper zbudowana z dietlibc.
363
364 %package -n device-mapper-initrd
365 Summary:        Userspace support for the device-mapper - initrd version
366 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
367 Group:          Base
368 Obsoletes:      device-mapper-initrd-devel
369 Conflicts:      geninitrd < 10000.10
370
371 %description -n device-mapper-initrd
372 The goal of this driver is to support volume management. The driver
373 enables the definition of new block devices composed of ranges of
374 sectors of existing devices. This can be used to define disk
375 partitions - or logical volumes. This light-weight kernel component
376 can support user-space tools for logical volume management.
377
378 This package contains dmsetup program linked staticaly for use in
379 initrd.
380
381 %description -n device-mapper-initrd -l pl.UTF-8
382 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
383 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
384 sektorów na istniejących urządzeniach. Może to być wykorzystane do
385 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
386 składnik jądra może wspierać działające w przestrzeni użytkownika
387 narzędzia do zarządzania logicznymi wolumenami.
388
389 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
390 potrzeby initrd.
391
392 %prep
393 %setup -q -n LVM2.%{version}
394 %{?with_selinux:%patch0 -p1}
395 %patch1 -p1
396 %patch2 -p1
397 %patch3 -p1
398 %patch4 -p1
399 %patch6 -p1
400 %patch7 -p1
401 %patch8 -p1
402 %patch9 -p1
403 %patch10 -p1
404 %patch11 -p1
405
406 # do not force --export-symbol linker option for e.g. statically linked executables
407 # -rdynamic compiler option drives linker in the right way.
408 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
409
410 %build
411 %if %{with initrd}
412 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
413 %endif
414 cp -f /usr/share/automake/config.sub autoconf
415 %{__aclocal}
416 %{__autoconf}
417
418 %if %{with initrd}
419 %{?with_glibc:export CC="%{__cc}"}
420 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
421 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
422
423 %configure \
424         ac_cv_lib_dl_dlopen=no \
425         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
426         %{?debug:--enable-debug} \
427         --disable-nls \
428         --disable-readline \
429         --enable-selinux%{!?with_glibc:=no} \
430         --enable-static_link \
431         --with-lvm1=internal \
432         --with-optimisation="%{rpmcflags} -Os"
433 # glibc version links with normal static libdevicemapper which has selinux enabled
434 # and we need to keep these in sync between device-mapper and lvm2
435
436 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
437 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
438
439 %{__make} -j1 -C include
440 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
441 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
442 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
443 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
444 %{__mv} tools/lvm.static initrd-lvm
445 %{__mv} tools/dmsetup.static initrd-dmsetup
446
447 # check if tools works
448 for tool in initrd-lvm initrd-dmsetup; do
449         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
450         if [ $rc -gt 127 ]; then
451                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
452                 exit 1
453         fi
454 done
455
456 %{?with_dietlibc:%{__mv} libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
457 %{__make} clean
458
459 unset CC
460 %endif
461
462 %configure \
463         --enable-applib \
464         --enable-cache_check_needs_check \
465         --enable-cmdlib \
466         %{?with_lvmdbusd:--enable-dbus-service} \
467         %{?debug:--enable-debug} \
468         --enable-dmeventd \
469         --enable-fsadm \
470         --with-default-locking-dir=/var/lock/lvm \
471 %if %{with lvmlockd}
472         %{?with_cluster:--enable-lvmlockd-dlm} \
473         %{?with_sanlock:--enable-lvmlockd-sanlock} \
474 %endif
475         %{?with_lvmetad:--enable-lvmetad} \
476         --enable-lvmpolld \
477         --enable-ocf \
478         %{?with_python2:--enable-python2_bindings} \
479         %{?with_python3:--enable-python3_bindings} \
480         --enable-readline \
481         %{!?with_selinux:--disable-selinux} \
482         --enable-pkgconfig \
483         --enable-thin_check_needs_check \
484         --enable-udev_sync \
485         --enable-udev_rules \
486         --with-cache=internal \
487         --with-cache-check=/usr/sbin/cache_check \
488         --with-cache-dump=/usr/sbin/cache_dump \
489         --with-cache-repair=/usr/sbin/cache_repair \
490         --with-cache-restore=/usr/sbin/cache_restore \
491         --with-cluster=internal \
492 %if %{with cluster}
493         --with-clvmd=corosync \
494         --enable-cmirrord \
495 %endif
496         --with-dmeventd-path=%{_sbindir}/dmeventd \
497         --with-interface=ioctl \
498         --with-lvm1=internal \
499         --with-mirrors=internal \
500         --with-optimisation="%{rpmcflags}" \
501         --with-pool=internal \
502         %{?with_replicator:--with-replicators=internal} \
503         --with-snapshots=internal \
504         --with-systemdsystemunitdir=%{systemdunitdir} \
505         --with-tmpfilesdir=%{systemdtmpfilesdir} \
506         --with-thin=internal \
507         --with-thin-check=/usr/sbin/thin_check \
508         --with-thin-dump=/usr/sbin/thin_dump \
509         --with-thin-repair=/usr/sbin/thin_repair \
510         --with-thin-restore=/usr/sbin/thin_restore \
511         --with-udev-prefix=/ \
512         --with-usrlibdir=%{_libdir}
513
514 # use bash because of "set -o pipefail"
515 %{__make} -j1 \
516         SHELL=/bin/bash
517 %{__make} -j1 -C libdm \
518         LIB_STATIC=libdevmapper.a
519
520 %install
521 rm -rf $RPM_BUILD_ROOT
522 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
523 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
524
525 %{__make} install install_system_dirs install_systemd_units install_initscripts install_tmpfiles_configuration \
526         DESTDIR=$RPM_BUILD_ROOT \
527         OWNER="" \
528         GROUP="" \
529         python3dir=%{py3_sitescriptdir}
530
531 %{__make} -C scripts install_tmpfiles_configuration \
532         DESTDIR=$RPM_BUILD_ROOT \
533
534 %if %{with cluster}
535 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
536 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
537 %endif
538
539 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
540 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
541         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
542         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
543         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
544 done
545
546 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
547
548 %if %{with initrd}
549 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
550 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
551 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
552
553 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
554 %endif
555
556 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %post
562 /sbin/chkconfig --add lvm2-monitor
563 %service lvm2-monitor restart
564 %systemd_post lvm2-monitor.service
565 /sbin/chkconfig --add blk-availability
566 # no service blk-availability restart
567 %systemd_post blk-availability.service
568 %if %{with lvmetad}
569 %systemd_post lvm2-lvmetad.socket
570 %endif
571 %if %{with lvmpolld}
572 %systemd_post lvm2-lvmpolld.socket
573 %endif
574
575 %preun
576 %systemd_preun lvm2-monitor.service
577 %systemd_preun blk-availability.service
578 %if %{with lvmetad}
579 %systemd_preun lvm2-lvmetad.socket
580 %endif
581 %if %{with lvmpolld}
582 %systemd_preun lvm2-lvmpolld.socket
583 %endif
584
585 %postun
586 if [ "$1" = "0" ]; then
587         %service lvm2-monitor stop
588         /sbin/chkconfig --del lvm2-monitor
589         #no service blk-availability stop
590         /sbin/chkconfig --del blk-availability
591 fi
592 %systemd_reload
593
594 %triggerpostun -- %{name} < 2.02.94-1
595 %systemd_trigger lvm2-monitor.service
596
597 %post -n device-mapper
598 %systemd_post dm-event.socket
599
600 %preun -n device-mapper
601 %systemd_preun dm-event.socket dm-event.service
602
603 %postun -n device-mapper
604 %systemd_reload
605
606 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
607 %systemd_trigger dm-event.socket
608
609 %post   -n device-mapper-libs -p /sbin/ldconfig
610 %postun -n device-mapper-libs -p /sbin/ldconfig
611
612 %post clvmd
613 /sbin/chkconfig --add clvmd
614 # no service restart - it breaks current locks!
615 export NORESTART=1
616 %systemd_post clvmd.service
617 # re-exec instead
618 /usr/sbin/clvmd -S 2>/dev/null || :
619
620 %preun clvmd
621 %systemd_preun clvmd.service
622 if [ "$1" = "0" ]; then
623         %service clvmd stop
624         /sbin/chkconfig --del clvmd
625 fi
626
627 %postun clvmd
628 %systemd_reload
629
630 %post dbusd
631 %systemd_post lvm2-lvmdbusd.service
632
633 %preun dbusd
634 %systemd_preun lvm2-lvmdbusd.service
635
636 %postun dbusd
637 %systemd_reload
638
639 %post lockd
640 %systemd_post lvm2-lvmlockd.service lvm2-lvmlocking.service
641
642 %preun lockd
643 %systemd_preun lvm2-lvmlockd.service lvm2-lvmlocking.service
644
645 %postun lockd
646 %systemd_reload
647
648 %files
649 %defattr(644,root,root,755)
650 %doc README WHATS_NEW doc/*
651 %attr(755,root,root) %{_sbindir}/blkdeactivate
652 %attr(755,root,root) %{_sbindir}/fsadm
653 %attr(755,root,root) %{_sbindir}/lvchange
654 %attr(755,root,root) %{_sbindir}/lvconvert
655 %attr(755,root,root) %{_sbindir}/lvcreate
656 %attr(755,root,root) %{_sbindir}/lvdisplay
657 %attr(755,root,root) %{_sbindir}/lvextend
658 %attr(755,root,root) %{_sbindir}/lvm
659 %attr(755,root,root) %{_sbindir}/lvmconf
660 %attr(755,root,root) %{_sbindir}/lvmconfig
661 %attr(755,root,root) %{_sbindir}/lvmdiskscan
662 %attr(755,root,root) %{_sbindir}/lvmdump
663 %attr(755,root,root) %{_sbindir}/lvmsadc
664 %attr(755,root,root) %{_sbindir}/lvmsar
665 %attr(755,root,root) %{_sbindir}/lvreduce
666 %attr(755,root,root) %{_sbindir}/lvremove
667 %attr(755,root,root) %{_sbindir}/lvrename
668 %attr(755,root,root) %{_sbindir}/lvresize
669 %attr(755,root,root) %{_sbindir}/lvs
670 %attr(755,root,root) %{_sbindir}/lvscan
671 %attr(755,root,root) %{_sbindir}/pvchange
672 %attr(755,root,root) %{_sbindir}/pvck
673 %attr(755,root,root) %{_sbindir}/pvcreate
674 %attr(755,root,root) %{_sbindir}/pvdisplay
675 %attr(755,root,root) %{_sbindir}/pvmove
676 %attr(755,root,root) %{_sbindir}/pvremove
677 %attr(755,root,root) %{_sbindir}/pvresize
678 %attr(755,root,root) %{_sbindir}/pvs
679 %attr(755,root,root) %{_sbindir}/pvscan
680 %attr(755,root,root) %{_sbindir}/vgcfgbackup
681 %attr(755,root,root) %{_sbindir}/vgcfgrestore
682 %attr(755,root,root) %{_sbindir}/vgchange
683 %attr(755,root,root) %{_sbindir}/vgck
684 %attr(755,root,root) %{_sbindir}/vgconvert
685 %attr(755,root,root) %{_sbindir}/vgcreate
686 %attr(755,root,root) %{_sbindir}/vgdisplay
687 %attr(755,root,root) %{_sbindir}/vgexport
688 %attr(755,root,root) %{_sbindir}/vgextend
689 %attr(755,root,root) %{_sbindir}/vgimport
690 %attr(755,root,root) %{_sbindir}/vgimportclone
691 %attr(755,root,root) %{_sbindir}/vgmerge
692 %attr(755,root,root) %{_sbindir}/vgmknodes
693 %attr(755,root,root) %{_sbindir}/vgreduce
694 %attr(755,root,root) %{_sbindir}/vgremove
695 %attr(755,root,root) %{_sbindir}/vgrename
696 %attr(755,root,root) %{_sbindir}/vgs
697 %attr(755,root,root) %{_sbindir}/vgscan
698 %attr(755,root,root) %{_sbindir}/vgsplit
699 %{_mandir}/man5/lvm.conf.5*
700 %{_mandir}/man7/lvmcache.7*
701 %{_mandir}/man7/lvmraid.7*
702 %{_mandir}/man7/lvmreport.7*
703 %{_mandir}/man7/lvmsystemid.7*
704 %{_mandir}/man7/lvmthin.7*
705 %{_mandir}/man8/blkdeactivate.8*
706 %{_mandir}/man8/fsadm.8*
707 %{_mandir}/man8/lvchange.8*
708 %{_mandir}/man8/lvconvert.8*
709 %{_mandir}/man8/lvcreate.8*
710 %{_mandir}/man8/lvdisplay.8*
711 %{_mandir}/man8/lvextend.8*
712 %{_mandir}/man8/lvm-config.8*
713 %{_mandir}/man8/lvm-dumpconfig.8*
714 %{_mandir}/man8/lvm-fullreport.8*
715 %{_mandir}/man8/lvm-lvpoll.8*
716 %{_mandir}/man8/lvm.8*
717 %{_mandir}/man8/lvmconf.8*
718 %{_mandir}/man8/lvmconfig.8*
719 %{_mandir}/man8/lvmdiskscan.8*
720 %{_mandir}/man8/lvmdump.8*
721 %{_mandir}/man8/lvmsadc.8*
722 %{_mandir}/man8/lvmsar.8*
723 %{_mandir}/man8/lvreduce.8*
724 %{_mandir}/man8/lvremove.8*
725 %{_mandir}/man8/lvrename.8*
726 %{_mandir}/man8/lvresize.8*
727 %{_mandir}/man8/lvs.8*
728 %{_mandir}/man8/lvscan.8*
729 %{_mandir}/man8/pvchange.8*
730 %{_mandir}/man8/pvck.8*
731 %{_mandir}/man8/pvcreate.8*
732 %{_mandir}/man8/pvdisplay.8*
733 %{_mandir}/man8/pvmove.8*
734 %{_mandir}/man8/pvremove.8*
735 %{_mandir}/man8/pvresize.8*
736 %{_mandir}/man8/pvs.8*
737 %{_mandir}/man8/pvscan.8*
738 %{_mandir}/man8/vgcfgbackup.8*
739 %{_mandir}/man8/vgcfgrestore.8*
740 %{_mandir}/man8/vgchange.8*
741 %{_mandir}/man8/vgck.8*
742 %{_mandir}/man8/vgconvert.8*
743 %{_mandir}/man8/vgcreate.8*
744 %{_mandir}/man8/vgdisplay.8*
745 %{_mandir}/man8/vgexport.8*
746 %{_mandir}/man8/vgextend.8*
747 %{_mandir}/man8/vgimport.8*
748 %{_mandir}/man8/vgimportclone.8*
749 %{_mandir}/man8/vgmerge.8*
750 %{_mandir}/man8/vgmknodes.8*
751 %{_mandir}/man8/vgreduce.8*
752 %{_mandir}/man8/vgremove.8*
753 %{_mandir}/man8/vgrename.8*
754 %{_mandir}/man8/vgs.8*
755 %{_mandir}/man8/vgscan.8*
756 %{_mandir}/man8/vgsplit.8*
757 %attr(750,root,root) %dir %{_sysconfdir}/lvm
758 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
759 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
760 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
761 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
762 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
763 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
764 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
765 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
766 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
767 %{systemdtmpfilesdir}/lvm2.conf
768 %{systemdunitdir}/blk-availability.service
769 %{systemdunitdir}/lvm2-monitor.service
770 %{systemdunitdir}/lvm2-pvscan@.service
771 %dir %{_sysconfdir}/lvm/cache
772 %ghost %{_sysconfdir}/lvm/cache/.cache
773 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
774 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
775 %attr(700,root,root) %dir /run/lvm
776 %attr(700,root,root) %dir /var/lock/lvm
777 %if %{with lvmetad}
778 %attr(755,root,root) %{_sbindir}/lvmetad
779 /lib/udev/rules.d/69-dm-lvm-metad.rules
780 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
781 %{systemdunitdir}/lvm2-lvmetad.service
782 %{systemdunitdir}/lvm2-lvmetad.socket
783 %{_mandir}/man8/lvmetad.8*
784 %endif
785 %if %{with lvmlockd}
786 %attr(755,root,root) %{_sbindir}/lvmlockctl
787 %attr(755,root,root) %{_sbindir}/lvmlockd
788 %{systemdunitdir}/lvm2-lvmlockd.service
789 %{systemdunitdir}/lvm2-lvmlocking.service
790 %{_mandir}/man8/lvmlockctl.8*
791 %{_mandir}/man8/lvmlockd.8*
792 %endif
793 %if %{with lvmpolld}
794 %attr(755,root,root) %{_sbindir}/lvmpolld
795 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
796 %{systemdunitdir}/lvm2-lvmpolld.service
797 %{systemdunitdir}/lvm2-lvmpolld.socket
798 %{_mandir}/man8/lvmpolld.8*
799 %endif
800
801 %if %{with cluster}
802 %files clvmd
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_usrsbindir}/clvmd
805 %attr(754,root,root) /etc/rc.d/init.d/clvmd
806 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
807 %attr(755,root,root) /lib/systemd/lvm2-cluster-activation
808 %{systemdunitdir}/clvmd.service
809 %{systemdunitdir}/lvm2-cluster-activation.service
810 %{systemdunitdir}/lvm2-clvmd.service
811 %{_mandir}/man8/clvmd.8*
812
813 %files cmirrord
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_usrsbindir}/cmirrord
816 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
817 %{systemdunitdir}/lvm2-cmirrord.service
818 %{_mandir}/man8/cmirrord.8*
819 %endif
820
821 %if %{with lvmdbusd}
822 %files dbusd
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_sbindir}/lvmdbusd
825 %{py3_sitescriptdir}/lvmdbusd
826 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
827 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/com.redhat.lvmdbus1.conf
828 %{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
829 %{systemdunitdir}/lvm2-lvmdbusd.service
830 %{_mandir}/man8/lvmdbusd.8*
831 %endif
832
833 %files resource-agents
834 %defattr(644,root,root,755)
835 %dir %{_prefix}/lib/ocf/resource.d/lvm2
836 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
837
838 %if %{with python2}
839 %files -n python-lvm
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{py_sitedir}/lvm.so
842 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
843 %endif
844
845 %if %{with python3}
846 %files -n python3-lvm
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
849 %{py3_sitedir}/lvm-%{version}_*-py*.egg-info
850 %endif
851
852 %files -n device-mapper
853 %defattr(644,root,root,755)
854 %doc *_DM
855 %{systemdunitdir}/dm-event.service
856 %{systemdunitdir}/dm-event.socket
857 /lib/udev/rules.d/10-dm.rules
858 /lib/udev/rules.d/11-dm-lvm.rules
859 /lib/udev/rules.d/13-dm-disk.rules
860 /lib/udev/rules.d/95-dm-notify.rules
861 %attr(755,root,root) %{_sbindir}/dmeventd
862 %attr(755,root,root) %{_sbindir}/dmsetup
863 %attr(755,root,root) %{_sbindir}/dmstats
864 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
865 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
866 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
867 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
868 %dir %{_libdir}/device-mapper
869 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
870 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
871 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
872 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
873 %{_mandir}/man8/dmsetup.8*
874 %{_mandir}/man8/dmstats.8*
875 %{_mandir}/man8/dmeventd.8*
876
877 %files -n device-mapper-libs
878 %defattr(644,root,root,755)
879 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
880 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
881 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
882 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
883 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
884
885 %files -n device-mapper-devel
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/libdevmapper.so
888 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
889 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
890 %attr(755,root,root) %{_libdir}/liblvm2app.so
891 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
892 %{_includedir}/libdevmapper.h
893 %{_includedir}/libdevmapper-event.h
894 %{_includedir}/lvm2app.h
895 %{_includedir}/lvm2cmd.h
896 %{_pkgconfigdir}/devmapper.pc
897 %{_pkgconfigdir}/devmapper-event.pc
898 %{_pkgconfigdir}/lvm2app.pc
899
900 %files -n device-mapper-static
901 %defattr(644,root,root,755)
902 %{_libdir}/libdevmapper.a
903
904 %if %{with initrd}
905 %if %{with dietlibc}
906 %files -n device-mapper-dietlibc
907 %defattr(644,root,root,755)
908 %{dietlibdir}/libdevmapper.a
909 %endif
910
911 %files -n device-mapper-initrd
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/initrd/dmsetup
914
915 %files initrd
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/initrd/lvm
918 %endif
This page took 0.108521 seconds and 2 git commands to generate.