]> git.pld-linux.org Git - packages/lttng-ust.git/blob - lttng-ust.spec
- updated to 2.8.1
[packages/lttng-ust.git] / lttng-ust.spec
1 #
2 # Conditional build:
3 %bcond_without  java            # JNI interface [builds with java-sun 1.6, but not gcj 4.9]
4 %bcond_without  python          # Python agent
5 %bcond_without  systemtap       # SystemTap integration
6 #
7 Summary:        LTTng Userspace Tracer
8 Summary(pl.UTF-8):      LTTng Userspace Tracer - narzędzia LTTng do śledzenia przestrzeni użytkownika
9 Name:           lttng-ust
10 Version:        2.8.1
11 Release:        1
12 License:        LGPL v2.1 (library), MIT (headers), GPL v2 (programs)
13 Group:          Libraries
14 Source0:        http://lttng.org/files/lttng-ust/%{name}-%{version}.tar.bz2
15 # Source0-md5:  be505077245dc05f93370a565eec15f4
16 Patch0:         %{name}-link.patch
17 Patch1:         %{name}-java.patch
18 Patch2:         %{name}-python.patch
19 URL:            http://lttng.org/ust
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  rpmbuild(macros) >= 1.294
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:2
25 %{?with_python:BuildRequires:   python >= 1:2.7}
26 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
27 BuildRequires:  userspace-rcu-devel >= 0.7.2
28 %if %{with java}
29 BuildRequires:  java-log4j
30 BuildRequires:  jdk
31 BuildRequires:  jpackage-utils
32 %endif
33 Requires:       userspace-rcu >= 0.7.2
34 ExclusiveArch:  %{ix86} %{x8664} x32 arm aarch64 mips ppc ppc64 s390 s390x tile
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # non-function rcu_reader_bp symbol
38 %define         skip_post_check_so_1    liblttng-ust\.so.* liblttng-ust-cyg-profile\.so.* liblttng-ust-cyg-profile-fast\.so.* liblttng-ust-dl\.so.* liblttng-ust-tracepoint\.so.*
39 # non-function lttng_ust_context_info_tls symbol
40 %define         skip_post_check_so_2    liblttng-ust-jul-jni\.so.* liblttng-ust-log4j-jni\.so.*
41
42 %define         skip_post_check_so      %{skip_post_check_so_1} %{skip_post_check_so_2}
43
44 %description
45 The LTTng Userspace Tracer (UST) is a library accompanied by a set of
46 tools to trace userspace code. 
47
48 %description -l pl.UTF-8
49 LTTng Userspace Tracer (UST) to biblioteka, której towarzyszą
50 narzędzia do śledzenia kodu w przestrzeni użytkownika.
51
52 %package devel
53 Summary:        Header files for LTTNG-UST libraries
54 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek LTTNG-UST
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       userspace-rcu-devel >= 0.7.2
58 %{?with_systemtap:Requires:     systemtap-sdt-devel}
59
60 %description devel
61 Header files for LTTNG-UST libraries.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe bibliotek LTTNG-UST.
65
66 %package static
67 Summary:        Static LTTNG-UST libraries
68 Summary(pl.UTF-8):      Statyczne biblioteki LTTNG-UST
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static LTTNG-UST libraries.
74
75 %description static -l pl.UTF-8
76 Statyczne biblioteki LTTNG-UST.
77
78 %package -n java-lttng-ust
79 Summary:        JNI interface for LTTng Userspace Tracer library
80 Summary(pl.UTF-8):      Interfejs JNI do biblioteki LTTng Userspace Tracer
81 Group:          Libraries/Java
82 Requires:       %{name} = %{version}-%{release}
83
84 %description -n java-lttng-ust
85 JNI interface for LTTng Userspace Tracer library.
86
87 %description -n java-lttng-ust -l pl.UTF-8
88 Interfejs JNI do biblioteki LTTng Userspace Tracer.
89
90 %package -n python-lttng-ust
91 Summary:        Python agent for LTTng Userspace Tracer library
92 Summary(pl.UTF-8):      Agent Pythona do biblioteki LTTng Userspace Tracer
93 Group:          Libraries/Python
94 Requires:       %{name} = %{version}-%{release}
95
96 %description -n python-lttng-ust
97 Python agent for LTTng Userspace Tracer library.
98
99 %description -n python-lttng-ust -l pl.UTF-8
100 Agent Pythona do biblioteki LTTng Userspace Tracer.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107
108 %build
109 %{__libtoolize}
110 %{__aclocal} -I config
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 export CLASSPATH=.:%{_javadir}/log4j.jar
115 %configure \
116         %{?with_java:JAVA_HOME="%{java_home}" JAVAC=javac} \
117         --disable-silent-rules \
118         %{?with_java:--enable-jni-interface --enable-java-agent-all} \
119         %{?with_python:--enable-python-agent} \
120         %{?with_systemtap:--with-sdt}
121
122 %{__make} -j1
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         lttnglibjavadir=%{_javadir}
130
131 # *.la kept - no .pc files for individual libraries
132
133 install -d $RPM_BUILD_ROOT%{_examplesdir}
134 %{__mv} $RPM_BUILD_ROOT%{_docdir}/lttng-ust/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
135 # packaged as %doc
136 %{__rm} $RPM_BUILD_ROOT%{_docdir}/lttng-ust/{ChangeLog,README.md,java-agent.txt}
137
138 %if %{with java}
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblttng-ust-{context-jni,java,jul-jni,log4j-jni}.{la,a}
140 %endif
141 %if %{with python}
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblttng-ust-python-agent.{la,a}
143 %py_postclean
144 %endif
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %post   -n java-lttng-ust -p /sbin/ldconfig
153 %postun -n java-lttng-ust -p /sbin/ldconfig
154
155 %post   -n python-lttng-ust -p /sbin/ldconfig
156 %postun -n python-lttng-ust -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc COPYING ChangeLog README.md
161 %attr(755,root,root) %{_libdir}/liblttng-ust.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust.so.0
163 %attr(755,root,root) %{_libdir}/liblttng-ust-ctl.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-ctl.so.2
165 %attr(755,root,root) %{_libdir}/liblttng-ust-cyg-profile.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-cyg-profile.so.0
167 %attr(755,root,root) %{_libdir}/liblttng-ust-cyg-profile-fast.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-cyg-profile-fast.so.0
169 %attr(755,root,root) %{_libdir}/liblttng-ust-dl.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-dl.so.0
171 %attr(755,root,root) %{_libdir}/liblttng-ust-fork.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-fork.so.0
173 %attr(755,root,root) %{_libdir}/liblttng-ust-libc-wrapper.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-libc-wrapper.so.0
175 %attr(755,root,root) %{_libdir}/liblttng-ust-pthread-wrapper.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-pthread-wrapper.so.0
177 %attr(755,root,root) %{_libdir}/liblttng-ust-tracepoint.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-tracepoint.so.0
179
180 %files devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/lttng-gen-tp
183 %attr(755,root,root) %{_libdir}/liblttng-ust.so
184 %attr(755,root,root) %{_libdir}/liblttng-ust-ctl.so
185 %attr(755,root,root) %{_libdir}/liblttng-ust-cyg-profile.so
186 %attr(755,root,root) %{_libdir}/liblttng-ust-cyg-profile-fast.so
187 %attr(755,root,root) %{_libdir}/liblttng-ust-dl.so
188 %attr(755,root,root) %{_libdir}/liblttng-ust-fork.so
189 %attr(755,root,root) %{_libdir}/liblttng-ust-libc-wrapper.so
190 %attr(755,root,root) %{_libdir}/liblttng-ust-pthread-wrapper.so
191 %attr(755,root,root) %{_libdir}/liblttng-ust-tracepoint.so
192 %{_libdir}/liblttng-ust.la
193 %{_libdir}/liblttng-ust-ctl.la
194 %{_libdir}/liblttng-ust-cyg-profile.la
195 %{_libdir}/liblttng-ust-cyg-profile-fast.la
196 %{_libdir}/liblttng-ust-dl.la
197 %{_libdir}/liblttng-ust-fork.la
198 %{_libdir}/liblttng-ust-libc-wrapper.la
199 %{_libdir}/liblttng-ust-pthread-wrapper.la
200 %{_libdir}/liblttng-ust-tracepoint.la
201 %{_includedir}/lttng
202 %{_pkgconfigdir}/lttng-ust.pc
203 %{_mandir}/man1/lttng-gen-tp.1*
204 %{_mandir}/man3/do_tracepoint.3*
205 %{_mandir}/man3/lttng-ust.3*
206 %{_mandir}/man3/lttng-ust-cyg-profile.3*
207 %{_mandir}/man3/lttng-ust-dl.3*
208 %{_mandir}/man3/tracef.3*
209 %{_mandir}/man3/tracelog.3*
210 %{_mandir}/man3/tracepoint.3*
211 %{_mandir}/man3/tracepoint_enabled.3*
212 %{_examplesdir}/%{name}-%{version}
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/liblttng-ust.a
217 %{_libdir}/liblttng-ust-ctl.a
218 %{_libdir}/liblttng-ust-cyg-profile.a
219 %{_libdir}/liblttng-ust-cyg-profile-fast.a
220 %{_libdir}/liblttng-ust-dl.a
221 %{_libdir}/liblttng-ust-fork.a
222 %{_libdir}/liblttng-ust-libc-wrapper.a
223 %{_libdir}/liblttng-ust-pthread-wrapper.a
224 %{_libdir}/liblttng-ust-tracepoint.a
225
226 %if %{with java}
227 %files -n java-lttng-ust
228 %defattr(644,root,root,755)
229 %doc doc/java-agent.txt
230 %attr(755,root,root) %{_libdir}/liblttng-ust-context-jni.so.*.*.*
231 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-context-jni.so.0
232 %attr(755,root,root) %{_libdir}/liblttng-ust-context-jni.so
233 %attr(755,root,root) %{_libdir}/liblttng-ust-java.so.*.*.*
234 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-java.so.0
235 %attr(755,root,root) %{_libdir}/liblttng-ust-java.so
236 %attr(755,root,root) %{_libdir}/liblttng-ust-jul-jni.so.*.*.*
237 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-jul-jni.so.0
238 %attr(755,root,root) %{_libdir}/liblttng-ust-jul-jni.so
239 %attr(755,root,root) %{_libdir}/liblttng-ust-log4j-jni.so.*.*.*
240 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-log4j-jni.so.0
241 %attr(755,root,root) %{_libdir}/liblttng-ust-log4j-jni.so
242 %{_javadir}/liblttng-ust-agent.jar
243 %{_javadir}/liblttng-ust-java.jar
244 %{_javadir}/lttng-ust-agent-all-1.0.0.jar
245 %{_javadir}/lttng-ust-agent-all.jar
246 %{_javadir}/lttng-ust-agent-common-1.0.0.jar
247 %{_javadir}/lttng-ust-agent-common.jar
248 %{_javadir}/lttng-ust-agent-jul-1.0.0.jar
249 %{_javadir}/lttng-ust-agent-jul.jar
250 %{_javadir}/lttng-ust-agent-log4j-1.0.0.jar
251 %{_javadir}/lttng-ust-agent-log4j.jar
252 %endif
253
254 %if %{with python}
255 %files -n python-lttng-ust
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/liblttng-ust-python-agent.so.*.*.*
258 %attr(755,root,root) %ghost %{_libdir}/liblttng-ust-python-agent.so.0
259 %attr(755,root,root) %{_libdir}/liblttng-ust-python-agent.so
260 %{py_sitescriptdir}/lttngust
261 %{py_sitescriptdir}/lttngust-%{version}-py*.egg-info
262 %endif
This page took 0.064192 seconds and 4 git commands to generate.