]> git.pld-linux.org Git - packages/logtool.git/blob - logtool.spec
raw version from homepage
[packages/logtool.git] / logtool.spec
1 # This file is automagically generated by ./configure.  Don't mess with it
2 # by hand unless you know what you're doing.  --A.L.Lambert
3
4 Summary: A handy syslog file(s) manipulation/monitoring/parsing tool
5 Vendor: A.L.Lambert
6 Name: logtool
7 Version: 1.0.5
8 Release: 1
9 Copyright: GPL
10 Group: Applications/Text
11 Source: %{name}-%{version}.tar.gz
12 Buildroot: /var/tmp/logtool
13
14 %description
15         Logtool is a handy little tool for manipulation/monitoring/parsing
16 of syslog (and syslog-like) files.  It produces output in ANSI, ASCII, CSV,
17 HTML format, and is easily configured to your needs via the /etc/logtool/* 
18 files.  It is suitable for use in generating easy to read logfile reports, 
19 webpages, and online monitoring of logfiles.
20
21         Please see the included documentation files (which are located in 
22 /usr/doc/%{name}-%{version}) for more details. 
23
24 %prep
25 %setup  
26 %build
27 # Make sure we clean up anything I might have fscked up and left laying around
28 # in the source tree.
29 make clean
30 # configure for a default install 
31 ./configure 
32 # build the binaries
33 make
34
35 %install
36 # Until I get the hang of autoconf and friends, the stuff below is the same 
37 # thing as "make install" taking into account $RPM_BUILD_ROOT
38 rm -Rf $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT/etc/logtool
39 mkdir -p $RPM_BUILD_ROOT/usr/bin
40 mkdir -p $RPM_BUILD_ROOT/etc/logtool
41
42 install -c -m 0644 conf/* $RPM_BUILD_ROOT/etc/logtool
43 install -c -m 0755 logtool/logtool logtail/logtail $RPM_BUILD_ROOT/usr/bin
44
45 cd $RPM_BUILD_ROOT/usr/bin
46 ln -s ../../usr/bin/logtool ../../usr/bin/lt
47
48
49 %clean
50 # blow away the build dir structure
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 if [ ! -f /usr/bin/lt ] ; then
55 ln -s /usr/bin/logtool /usr/bin/lt
56 fi
57
58 %postun
59 if [ -f /usr/bin/lt ] ; then
60 rm -f /usr/bin/lt
61 fi
62
63
64 %files
65 %defattr(-,root,root)
66 %doc README COPYING TODO INSTALL CHANGES USAGE CREDITS logtool.spec doc/*
67 %config(noreplace) /etc/logtool/*
68 /usr/bin/logtool
69 /usr/bin/logtail
70
71
72 %changelog
73 * Thu Feb 01 2001 A.L.Lambert <al at 9b.com>
74 - Tweaked the 1.0.5 release as follows:
75 -
76 - Added configure.in statements to make ./configure point to the propper
77 - paths in the documentation (config file stuff).
78
79 * Mon Jan 29 2001 A.L.Lambert <al at 9b.com>
80 - 1.0.5 release.  Not much new except the following:
81 -
82 -       Now uses GNU autoconf and friends to configure for build
83 -       Fixes a small compile time bug for ScoUnixware induced in 1.0.4
84 -       Not much else. :)
85
86 * Sat Jan 27 2001 A.L.Lambert <al at 9b.com>
87 - 1.0.4 release.  Only chage is a modification to the format check to allow
88 - for broken-ness in PAM syslog messages on RedHat 7.0
89
90 * Wed Jan 16 2001 A.L.Lambert <al at 9b.com>
91 - I think I have the configure stuff all tweaked out like it should be.
92 - No doubt I'm wrong on that count, but it's getting closer to release grade
93 - stuff.
94 -
95 - Wrote a manpage for logtool.  manpages are annoying to write/deal with.
96
97 * Sun Jan 14 2001 A.L.Lambert <al at 9b.com>
98 - Commenced converting to a GNU autoconf/configure build process for easier
99 - cross-platform portability.  Hopefully this will make our lives nicer in the
100 - long run.
101 -
102 - This spec file is even built using configure.  Isn't that neat. :)
103
104 * Thu Jan 11 2001 A.L.Lambert <al at 9b.com>
105 - 1.0.4 pre-release started.  Hopefully nothing major in this release.
106 -
107 - First change, modification of the lt_fmtcheck() function to fix some 
108 - format mismatch problems on RedHat 7.0.  See logtool/regex.c for the 
109 - specifics. (thanks to Laurent Jacquot for pointing this out)
110 -
111 - Fixed two minor compilation problems on AIX.  
112 -       1.  Getopt returns int, and I was reading it as a char: fixed
113 -       2.  AIX defines 'regex', which clashed with the struct I will be 
114 -           using to hold regex strings: fixed
115 - (thanks to Thanh Ma for pointing these two things out to me)
116
117 * Wed Jan 11 2001 A.L.Lambert <al at 9b.com>
118 - 1.0.3 release 'officially' declared ready to go.  No new changes since
119 - the comments below, just some e-mail feedback from the folks testing the
120 - changes indicating that everything seems to be working fine. 
121 -
122
123 * Tue Jan 10 2001 A.L.Lambert <al at 9b.com>
124 - Updated version to 1.0.3 to reflect changes below.  Still waiting to hear
125 - back from the folks that are testing these changes.  They should work, 
126 - but until I know for sure, the 1.0.3 release should be considered BETA, and
127 - subject to change without version number incrementation prior to public 
128 - release.
129 -
130 - Wrote a really ugly configure script to handle the SCO vs everything else
131 - differences. (at this point, it just copies the appropo logtail.*.c file to
132 - logtail.c, and initializes the main Makefile)
133 -
134 - Made some changes to the logtool/Makefile to build only the objects/binaries
135 - by default (reported problems with OpenBSD 2.8's 'make' not building library
136 - correctly).  Also added a "make lib" option so that anyone wishing to have
137 - the library can build it. (really, who needs the library for this?)
138 -
139 - Later that night:
140
141 - Ying-Chieh Liao pointed out some "features" in the logtool/Makefile, which 
142 - I have now fixed. (see, I told you I might change it before the official
143 - release) ;)
144 -
145 - Report from Andreas Ã–stling on the OpenBSD changes looks good.  
146 -
147 - Sanitized e-mail addresses in this file, since it gets displayed on the 
148 - website (I'd hate to think some spammer snagged the e-mail addresses of
149 - the nice folks who've helped me out from my website).
150
151 * Fri Jan 05 2001 A.L.Lambert <al at 9b.com>
152 - Updated to fix the missing symlink to /usr/bin/lt.
153 - Included the changes suggested from Thomas Hagar listed below
154
155 * Fri Jan 05 2001 Thomas Hager <thomas at 1012surf.net>
156 - replaced cp with install in %install
157
158 * Thu Jan 04 2001 A.L.Lambert <al at 9b.com>
159 - Various fixes so's it will compile under the original cc-compiler from 
160 - SUN (Solaris 2.6).  Thanks to Christoph Krempe <ck at ub.fu-berlin.de>
161 - for pointing out the problems, and working with me on fixes.  Christoph
162 - should also get credit for pointing out the bug in the includefile 
163 - functionality that was fixed below.
164 -
165 - It compiled
166 - It worked for me
167 - I shipped it. :P
168
169 * Fri Dec 29 2000 A.L.Lambert <al at 9b.com>
170 - Working on fixes for Solaris (why did I expect this?) for version 1.0.2
171 -
172 - So far, I've done the following:
173 -       Tested with removing the strncasecmp() decl - seems to work fine
174 -       Removed the getopt_long() and related stuff, and use only getopt()
175 -
176 -       Waiting on report back from Christoph Krempe on the success/failure
177 -       of these steps.
178
179 * Thu Dec 28 2000 A.L.Lambert <al at 9b.com>
180 - Big OOPS! The includefile functionality was broken!  I have no idea how I
181 - missed this the first time around, but it's fixed now. Updated version to 
182 - 1.0.1
183
184 * Tue Dec 26 2000 A.L.Lambert <al at 9b.com>
185 - Woohoo!  1.0 release is good to go (as far as I can tell)!
186 -
187 - Documentation is still a bit shabby, but it's better than some I've seen.
188 - Still some things in the TODO list that I'd like to get done Real Soon Now.
189
190 - But all in all, all the features are in place, they all work flawlessly as
191 - far as I can tell (famous last words of a programmer :), and as they say in
192 - GNU land; "It works for me."
193 -
194 - Later that day:
195 -
196 - Modified the getopt.c stuff to allow for specification of an alternate 
197 - config file instead of being stuck with the system defaults.
198
199 - Fixed a minor bug in the ansi.c module (color display thing)
200 -
201 - Updated CREDITS and a few things in doc/logtool.txt
202
203 * Mon Dec 25 2000 A.L.Lambert <al at 9b.com>
204 - Now have a working program!  WooHoo!!
205 -
206 - I lied about not messing with it till the 27'th.
207 -
208 - I think most all of the back-end code is done (cfg file reader, getopt, etc)
209 - ANSI, ASCII, RAW, and CSV output modules are completed (more/less), and
210 - everything test's OK, even with bizare/broken input.  Probably some buffer
211 - overlows in here somewhere, but this program is not/will not be SUID, so I
212 - don't think that's too big a deal (and will never happen unless users muss 
213 - up the config file really badly or overdo the REGEX string files).
214 -
215 - Still TODO
216 -       Write the HTML <PRE>, and HTML <TABLE> output modules
217 -       Change the way we do REGEX's (need to compile the paterns once, not 
218 -               every time).
219 -       Documentation, Documentation, Documentation.  :(
220 -       Clean up the code some more so I won't be quite so embarrassed when I 
221 -       release this thing.  :)
222
223 * Sun Dec 24 2000 A.L.Lambert <al at 9b.com>
224 - Came up with idea, and commenced work on getting this thing ready for 
225 - distribution
226 -       Code is about half written at this point, but should progress
227 -       relatively quickly (I type way too fast).
228 -
229 -       Anciliary stuff (Makefile's, .spec file, etc.) is pretty much done.
230 -       
231 -       Documentation is basically un-started (although this program ain't
232 -       likely to need a rocket scientist to run it).
233 -
234 -       I have to go to bed so's I can be fresh for Christmas, so no more work
235 -       will likely be getting done until around the 27'th.
This page took 0.044004 seconds and 4 git commands to generate.