]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
- %doc updated
[packages/lms.git] / lms.spec
1 Summary:        LAN Managment System
2 Summary(pl):    System Zarz±dzania Siec± Lokaln±
3 Name:           lms
4 Version:        1.0pre10
5 Release:        0.1
6 License:        GPL
7 Vendor:         LMS Developers
8 Group:          Networking/Utilities
9 Source0:        http://lms.rulez.pl/download/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-PLD.patch
11 URL:            http://lms.rulez.pl/
12 Requires:       php
13 Requires:       php-posix
14 Requires:       php-pcre
15 Requires:       webserver
16 Requires:       Smarty >= 2.5.0
17 Requires:       adodb >= 2.90
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _lmsdir         /home/services/httpd/html/%{name}
22 %define         _sharedstatedir /var/lib
23 # when spec'll be finished, this sould go to RA-branch
24 # because sharedstatedir is already defined at rpm macros from HEAD
25
26 %description
27 This is a package of applications in PHP and Perl for managing LANs.
28 It's using MySQL (for now) but PostgreSQL will be supported in near
29 future. The main goal is to get the best service of users at
30 provider's level.
31 The main features in LMS are:
32 - database of users (name, surname, address, telefon number, 
33   commentary);
34 - database of computers (IP, MAC);
35 - easy-ridden financial system and funds of network;
36 - different subscriptions;
37 - sending warnings to users;
38 - autogenerating dhcpd.conf;
39 - autogenerating firewall rules (ipchains/iptables);
40 - autogenerating idents for ident daemon;
41 - many levels of access for LMS administrators;
42 - integration with LinuxStat package;
43 - autogenerating ARP rules (ether auth);
44 - autogenerating DNS files.
45
46 %description -l pl
47 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
48 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
49 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
50 opartych o bazê danych MySQL (docelowo, do wyboru, MySQL lub
51 PostgreSQL). G³ówne za³o¿enia to uzyskanie jako¶ci us³ug oraz obs³ugi
52 u¿ytkowników na poziomie providera z prawdziwego zdarzenia.
53 Najbardziej podstawowe cechy LMS to:
54 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
55   uwagi);
56 - baza danych komputerów (adres IP, adres MAC);
57 - prowadzenie prostego rachunku operacji finansowych oraz stanu
58   funduszów sieci;
59 - ró¿ne taryfy abonamentowe;
60 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
61 - automatyczne naliczanie op³at miesiêcznych;
62 - generowanie dhcpd.conf;
63 - generowanie regu³ firewalla (ipchains/iptables);
64 - generowanie identów dla demona oidentd;
65 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
66 - integracja z pakietem LinuxStat;
67 - generowanie wpisów ARP (blokada adresów IP po ARP);
68 - generowanie wpisów do DNS.
69
70 %package scripts
71 Summary:        LAN Managment System - scripts
72 Summary(pl):    LAN Managment System - skrypty
73 Requires:       perl-Net-SMTP-Server
74 Requires:       perl-Config-IniFiles
75 Requires:       perl-DBI
76 BuildArch:      noarch
77 Group:          Networking/Utilities
78
79 %description scripts
80 This package contains scripts to integrate LMS with your system,
81 monthly billing, notify users about their debts and cutting off
82 customers. Also you can build propably any kind of config file using
83 lms-mgc.
84
85 %description scripts -l pl
86 Ten pakiet zawiera skrypty do zintegrowania LMS z systemem, naliczania
87 comiesiêcznych op³at, powiadamiania u¿ytkowników o ich zad³u¿eniu oraz
88 ich automagicznego od³±czania. Mo¿esz tak¿e zbudowaæ prawdopodobnie
89 ka¿dy typ pliku konfiguracyjnego przy u¿yciu lms-mgc.
90
91 %prep
92 %setup -q -n %{name}
93 %patch0 -p1
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_lmsdir}/img
98 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
99 install -d $RPM_BUILD_ROOT%{_bindir}
100 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
101 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/{backups,templates_c}
102 install -d $RPM_BUILD_ROOT%{_libexecdir}/%{name}/{lib,modules,templates}
103
104 install *.php $RPM_BUILD_ROOT%{_lmsdir}
105 install bin/* $RPM_BUILD_ROOT%{_bindir}
106 install lib/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/lib
107 install img/* $RPM_BUILD_ROOT%{_lmsdir}/img
108 install modules/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/modules
109 install templates/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/templates
110 install sample/%{name}.ini $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc doc/* sample/*.ini sample/*txt sample/rc.reminder_1st sample/crontab-entry
118 %dir %{_lmsdir}
119 %dir %{_libexecdir}/%{name}
120 %dir %{_sharedstatedir}/%{name}
121 %attr(770,root,http) %{_sharedstatedir}/%{name}/templates_c
122 %attr(770,root,http) %{_sharedstatedir}/%{name}/backups
123 %{_lmsdir}/*.php
124 %{_lmsdir}/img
125 %{_libexecdir}/%{name}/lib
126 %{_libexecdir}/%{name}/modules
127 %{_libexecdir}/%{name}/templates
128 %dir %{_sysconfdir}/%{name}
129 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/*.ini
130
131 %files scripts
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/lms-*
134 %doc sample/*.ini
This page took 0.069848 seconds and 4 git commands to generate.