]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
- moved perl scripts into separated package
[packages/lms.git] / lms.spec
1 Summary:        LAN Managment System
2 Summary(pl):    System Zarz±dzania Siec± Lokaln±
3 Name:           lms
4 Version:        1.0pre10
5 Release:        0.1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://lms.rulez.pl/download/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-PLD.patch
10 Vendor:         LMS Developers
11 URL:            http://lms.rulez.pl
12 Requires:       php
13 Requires:       php-posix
14 Requires:       webserver
15 Requires:       Smarty >= 2.5.0
16 Requires:       adodb >= 2.90
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _lmsdir         /home/services/httpd/html/%{name}
21 %define         _sharedstatedir /var/lib
22
23 %description
24 This is a package of applications in PHP and Perl for managing LANs.
25 It's using MySQL (for now) but PostgreSQL will be supported in near
26 future. The main goal is to get the best service of users at
27 provider's level.
28 The main features in LMS are:
29 - database of users (name, surname, address, telefon number, 
30   commentary);
31 - database of computers (IP, MAC);
32 - easy-ridden financial system and funds of network;
33 - different subscriptions;
34 - sending warnings to users;
35 - autogenerating dhcpd.conf;
36 - autogenerating firewall rules (ipchains/iptables);
37 - autogenerating idents for ident daemon;
38 - many levels of access for LMS administrators;
39 - integration with LinuxStat package;
40 - autogenerating ARP rules (ether auth);
41 - autogenerating DNS files.
42
43 %description -l pl
44 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
45 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
46 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
47 opartych o bazê danych MySQL (docelowo, do wyboru, MySQL lub
48 PostgreSQL). G³ówne za³o¿enia to uzyskanie jako¶ci us³ug oraz obs³ugi
49 u¿ytkowników na poziomie providera z prawdziwego zdarzenia.
50 Najbardziej podstawowe cechy LMS to:
51 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
52   uwagi);
53 - baza danych komputerów (adres IP, adres MAC);
54 - prowadzenie prostego rachunku operacji finansowych oraz stanu
55   funduszów sieci;
56 - ró¿ne taryfy abonamentowe;
57 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
58 - automatyczne naliczanie op³at miesiêcznych;
59 - generowanie dhcpd.conf;
60 - generowanie regu³ firewalla (ipchains/iptables);
61 - generowanie identów dla demona oidentd;
62 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
63 - integracja z pakietem LinuxStat;
64 - generowanie wpisów ARP (blokada adresów IP po ARP);
65 - generowanie wpisów do DNS.
66
67 %package scripts
68 Summary:        LAN Managment System - scripts
69 Summary(pl):    LAN Managment System - skrypty
70 Requires:       perl-Net-SMTP-Server
71 Requires:       perl-Config-IniFiles
72 Requires:       perl-DBI
73 BuildArch:      noarch
74 Group:          Networking/Utilities
75
76 %description scripts
77 This package contains scripts to integrate LMS with your system, monthly
78 billing, notify users about their debts and cutting off customers. Also
79 you can build propably any kind of config file using lms-mgc.
80
81 %description scripts -l pl
82 Ten pakiet zawiera skrypty do zintegrowania LMS z twoim systemem,
83 naliczania comiesiêcznych op³at, powiadamiania u¿ytkowników o ich
84 zad³u¿eniu oraz ich automagicznego od³±czania. Mo¿esz tak¿e zbudowaæ
85 prawdopodobnie ka¿dy typ pliku konfiguracyjnego przy u¿yciu lms-mgc.
86
87 %prep
88 %setup -q -n lms
89 %patch0 -p1
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_lmsdir}/img
94 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
95 install -d $RPM_BUILD_ROOT%{_bindir}
96 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
97 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/{backups,templates_c}
98 install -d $RPM_BUILD_ROOT%{_libexecdir}/%{name}/{lib,modules,templates}
99
100 install *.php $RPM_BUILD_ROOT%{_lmsdir}
101 install bin/* $RPM_BUILD_ROOT%{_bindir}
102 install lib/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/lib
103 install img/* $RPM_BUILD_ROOT%{_lmsdir}/img
104 install modules/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/modules
105 install templates/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/templates
106 install sample/%{name}.ini $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc doc sample/*.ini sample/*txt sample/rc.reminder_1st sample/crontab-entry
114 %dir %{_lmsdir}
115 %dir %{_libexecdir}/%{name}
116 %dir %{_sharedstatedir}/%{name}
117 %attr(770,root,http) %{_sharedstatedir}/%{name}/templates_c
118 %attr(770,root,http) %{_sharedstatedir}/%{name}/backups
119 %{_lmsdir}/*.php
120 %{_lmsdir}/img
121 %{_libexecdir}/%{name}/lib
122 %{_libexecdir}/%{name}/modules
123 %{_libexecdir}/%{name}/templates
124 %dir %{_sysconfdir}/%{name}
125 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/*.ini
126
127 %files scripts
128 %attr(755,root,root) %{_bindir}/lms-*
129 %doc sample/*.ini
This page took 0.043729 seconds and 4 git commands to generate.