]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
- massive attack: source-md5
[packages/lms.git] / lms.spec
1 Summary:        LAN Managment System
2 Summary(pl):    System Zarz±dzania Siec± Lokaln±
3 Name:           lms
4 Version:        1.0pre10
5 Release:        0.1
6 License:        GPL
7 Vendor:         LMS Developers
8 Group:          Networking/Utilities
9 Source0:        http://lms.rulez.pl/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  976fe1c627369c01e9868e326c11de09
11 Patch0:         %{name}-PLD.patch
12 URL:            http://lms.rulez.pl/
13 Requires:       php
14 Requires:       php-posix
15 Requires:       php-pcre
16 Requires:       webserver
17 Requires:       Smarty >= 2.5.0
18 Requires:       adodb >= 2.90
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _lmsdir         /home/services/httpd/html/%{name}
23 %define         _sharedstatedir /var/lib
24 # when spec'll be finished, this sould go to RA-branch
25 # because sharedstatedir is already defined at rpm macros from HEAD
26
27 %description
28 This is a package of applications in PHP and Perl for managing LANs.
29 It's using MySQL (for now) but PostgreSQL will be supported in near
30 future. The main goal is to get the best service of users at
31 provider's level.
32 The main features in LMS are:
33 - database of users (name, surname, address, telefon number, 
34   commentary);
35 - database of computers (IP, MAC);
36 - easy-ridden financial system and funds of network;
37 - different subscriptions;
38 - sending warnings to users;
39 - autogenerating dhcpd.conf;
40 - autogenerating firewall rules (ipchains/iptables);
41 - autogenerating idents for ident daemon;
42 - many levels of access for LMS administrators;
43 - integration with LinuxStat package;
44 - autogenerating ARP rules (ether auth);
45 - autogenerating DNS files.
46
47 %description -l pl
48 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
49 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
50 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
51 opartych o bazê danych MySQL (docelowo, do wyboru, MySQL lub
52 PostgreSQL). G³ówne za³o¿enia to uzyskanie jako¶ci us³ug oraz obs³ugi
53 u¿ytkowników na poziomie providera z prawdziwego zdarzenia.
54 Najbardziej podstawowe cechy LMS to:
55 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
56   uwagi);
57 - baza danych komputerów (adres IP, adres MAC);
58 - prowadzenie prostego rachunku operacji finansowych oraz stanu
59   funduszów sieci;
60 - ró¿ne taryfy abonamentowe;
61 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
62 - automatyczne naliczanie op³at miesiêcznych;
63 - generowanie dhcpd.conf;
64 - generowanie regu³ firewalla (ipchains/iptables);
65 - generowanie identów dla demona oidentd;
66 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
67 - integracja z pakietem LinuxStat;
68 - generowanie wpisów ARP (blokada adresów IP po ARP);
69 - generowanie wpisów do DNS.
70
71 %package scripts
72 Summary:        LAN Managment System - scripts
73 Summary(pl):    LAN Managment System - skrypty
74 Requires:       perl-Net-SMTP-Server
75 Requires:       perl-Config-IniFiles
76 Requires:       perl-DBI
77 BuildArch:      noarch
78 Group:          Networking/Utilities
79
80 %description scripts
81 This package contains scripts to integrate LMS with your system,
82 monthly billing, notify users about their debts and cutting off
83 customers. Also you can build propably any kind of config file using
84 lms-mgc.
85
86 %description scripts -l pl
87 Ten pakiet zawiera skrypty do zintegrowania LMS z systemem, naliczania
88 comiesiêcznych op³at, powiadamiania u¿ytkowników o ich zad³u¿eniu oraz
89 ich automagicznego od³±czania. Mo¿esz tak¿e zbudowaæ prawdopodobnie
90 ka¿dy typ pliku konfiguracyjnego przy u¿yciu lms-mgc.
91
92 %prep
93 %setup -q -n %{name}
94 %patch0 -p1
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_lmsdir}/img
99 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
100 install -d $RPM_BUILD_ROOT%{_bindir}
101 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
102 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/{backups,templates_c}
103 install -d $RPM_BUILD_ROOT%{_libexecdir}/%{name}/{lib,modules,templates}
104
105 install *.php $RPM_BUILD_ROOT%{_lmsdir}
106 install bin/* $RPM_BUILD_ROOT%{_bindir}
107 install lib/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/lib
108 install img/* $RPM_BUILD_ROOT%{_lmsdir}/img
109 install modules/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/modules
110 install templates/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/templates
111 install sample/%{name}.ini $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc doc/* sample/*.ini sample/*txt sample/rc.reminder_1st sample/crontab-entry
119 %dir %{_lmsdir}
120 %dir %{_libexecdir}/%{name}
121 %dir %{_sharedstatedir}/%{name}
122 %attr(770,root,http) %{_sharedstatedir}/%{name}/templates_c
123 %attr(770,root,http) %{_sharedstatedir}/%{name}/backups
124 %{_lmsdir}/*.php
125 %{_lmsdir}/img
126 %{_libexecdir}/%{name}/lib
127 %{_libexecdir}/%{name}/modules
128 %{_libexecdir}/%{name}/templates
129 %dir %{_sysconfdir}/%{name}
130 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/*.ini
131
132 %files scripts
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/lms-*
135 %doc sample/*.ini
This page took 0.044577 seconds and 4 git commands to generate.