]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
- en fixes, removed second Log
[packages/lms.git] / lms.spec
1 %define         _add pre5
2 Summary:        LAN Managment System
3 Summary(pl):    System Zarz±dzania Siec± Lokaln±
4 Name:           lms
5 Version:        1.0
6 Release:        0.2.%{_add}
7 License:        GPL
8 Group:          Networking/Utilities
9 Source0:        http://lms.rulez.pl/download/%{name}-%{version}%{_add}.tar.gz
10 Vendor:         Rulez.PL
11 Requires:       php
12 Requires:       php-posix
13 Requires:       webserver
14 Requires:       mysql
15 #Requires:      perl-Getopt-Long
16 # for now i'm not sure is it required ...
17 Requires:       perl-Net-SMTP-Server
18 Requires:       perl-Config-IniFiles
19 Requires:       perl-DBI
20 Requires:       perl-DBD-mysql
21 Requires:       perl-DBD-Pg
22 Requires:       Smarty
23 Requires:       ADOdb
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _lmsdir         /home/services/httpd/html/%{name}
28 %define         _localstatedir  /var/lib/lms
29
30 %description
31 This is a package of applications in PHP and Perl for managing LANs.
32 It's using MySQL (for now) but PostgreSQL will be supported in near
33 future. The main goal is to get the best service of users at
34 provider's level.
35 The main features in LMS are:
36 - database of users (name, surname, address, telefon number, 
37   commentary);
38 - database of computers (IP, MAC);
39 - easy-ridden financial system and funds of network;
40 - different subscriptions;
41 - sending warnings to users;
42 - autogenerating dhcpd.conf;
43 - autogenerating firewall rules (ipchains/iptables);
44 - autogenerating idents for ident daemon;
45 - many levels of access for LMS administrators;
46 - integration with LinuxStat package;
47 - autogenerating ARP rules (ether auth);
48 - autogenerating DNS files.
49
50 %description -l pl
51 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
52 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
53 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
54 opartych o bazê danych MySQL (docelowo, do wyboru, MySQL lub
55 PostgreSQL). G³ówne za³o¿enia to uzyskanie jako¶ci us³ug oraz obs³ugi
56 u¿ytkowników na poziomie providera z prawdziwego zdarzenia.
57 Najbardziej podstawowe cechy LMS to:
58 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
59   uwagi);
60 - baza danych komputerów (adres IP, adres MAC);
61 - prowadzenie prostego rachunku operacji finansowych oraz stanu
62   funduszów sieci;
63 - ró¿ne taryfy abonamentowe;
64 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
65 - automatyczne naliczanie op³at miesiêcznych;
66 - generowanie dhcpd.conf;
67 - generowanie regu³ firewalla (ipchains/iptables);
68 - generowanie identów dla demona oidentd;
69 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
70 - integracja z pakietem LinuxStat;
71 - generowanie wpisów ARP (blokada adresów IP po ARP);
72 - generowanie wpisów do DNS.
73
74 %prep
75 %setup -q -n lms
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_lmsdir}/{img,lib,modules,templates,templates_c}
80 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
81 install -d $RPM_BUILD_ROOT%{_bindir}
82
83 install *.php $RPM_BUILD_ROOT%{_lmsdir}
84 install -d {img,lib,modules,templates,templates_c} $RPM_BUILD_ROOT%{_lmsdir}
85 install -d backup $RPM_BUILD_ROOT%{_localstatedir}
86 install bin/* $RPM_BUILD_ROOT%{_bindir}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc doc
94 %attr(755,root,root) %{_bindir}/lms-*
95 %dir %{_lmsdir}
96 %attr(770,root,http) %{_lmsdir}/templates_c
97 %{_lmsdir}/*.php
98 %{_lmsdir}/img
99 %{_lmsdir}/lib
100 %{_lmsdir}/modules
101 %{_lmsdir}/templates
102 %{_localstatedir}
This page took 0.094128 seconds and 4 git commands to generate.