]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
- formatting
[packages/lms.git] / lms.spec
1 Summary:        LAN Managment System
2 Summary(pl):    System Zarz±dzania Sieci± Lokaln±
3 Name:           lms
4 Version:        1.0.4
5 Release:        2
6 License:        GPL
7 Vendor:         LMS Developers
8 Group:          Networking/Utilities
9 Source0:        http://lms.rulez.pl/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  1481b7b7b8c14a739ce38f14c1fd2aeb
11 Patch0:         %{name}-PLD.patch
12 URL:            http://lms.rulez.pl/
13 Requires:       php
14 Requires:       php-posix
15 Requires:       php-pcre
16 Requires:       webserver
17 Requires:       Smarty >= 2.5.0
18 Requires:       adodb >= 2.90
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _lmsdir         /home/services/httpd/html/%{name}
23 %define         _sharedstatedir /var/lib
24 # when spec'll be finished, this should go to RA-branch
25 # because sharedstatedir is already defined at rpm macros from HEAD
26
27 %description
28 This is a package of applications in PHP and Perl for managing LANs.
29 It's using MySQL or PostgreSQL. The main goal is to get the best 
30 service of users at provider's level. The main features in LMS are:
31 - database of users (name, surname, address, telefon number,
32   commentary);
33 - database of computers (IP, MAC);
34 - easy-ridden financial system and funds of network;
35 - different subscriptions;
36 - sending warnings to users;
37 - many levels of access for LMS administrators;
38 - autogenerating ipchains, iptables, dhcpd, ethers file, oidentd,
39   openbsd packet filter configuration files/scripts;
40 - autogenerating almost any kind of config file using templates;
41
42 %description -l pl
43 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
44 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
45 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
46 opartych o bazê danych MySQL lub PostgreSQL. G³ówne za³o¿enia to
47 uzyskanie jako¶ci us³ug oraz obs³ugi u¿ytkowników na poziomie
48 providera z prawdziwego zdarzenia. Najbardziej podstawowe cechy LMS
49 to:
50 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
51   uwagi);
52 - baza danych komputerów (adres IP, adres MAC);
53 - prowadzenie prostego rachunku operacji finansowych oraz stanu
54   funduszów sieci;
55 - ró¿ne taryfy abonamentowe;
56 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
57 - automatyczne naliczanie op³at miesiêcznych;
58 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
59 - generowanie regu³ i plików konfiguracyjnych dla ipchains, iptables,
60   dhcpd, oidentd, packet filtra openbsd, wpisów /etc/ethers
61 - generowanie praktycznie ka¿dego pliku konfiguracyjnego na podstawie
62   danych w bazie przy u¿yciu prostych szablonów;
63
64 %package scripts
65 Summary:        LAN Managment System - scripts
66 Summary(pl):    LAN Managment System - skrypty
67 Requires:       perl-Net-SMTP-Server
68 Requires:       perl-Config-IniFiles
69 Requires:       perl-DBI
70 BuildArch:      noarch
71 Group:          Networking/Utilities
72
73 %description scripts
74 This package contains scripts to integrate LMS with your system,
75 monthly billing, notify users about their debts and cutting off
76 customers. Also you can build propably any kind of config file using
77 lms-mgc.
78
79 %description scripts -l pl
80 Ten pakiet zawiera skrypty do zintegrowania LMS z systemem, naliczania
81 comiesiêcznych op³at, powiadamiania u¿ytkowników o ich zad³u¿eniu oraz
82 ich automagicznego od³±czania. Mo¿esz tak¿e zbudowaæ prawdopodobnie
83 ka¿dy typ pliku konfiguracyjnego przy u¿yciu lms-mgc;
84
85 %prep
86 %setup -q -n %{name}
87 %patch0 -p1
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_lmsdir}/img
92 install -d $RPM_BUILD_ROOT%{_bindir}
93 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
94 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/{backups,templates_c}
95 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/{lib,modules,templates}
96
97 install *.php $RPM_BUILD_ROOT%{_lmsdir}
98 install bin/* $RPM_BUILD_ROOT%{_bindir}
99 install lib/* $RPM_BUILD_ROOT%{_datadir}/%{name}/lib
100 install img/* $RPM_BUILD_ROOT%{_lmsdir}/img
101 install modules/* $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
102 install templates/* $RPM_BUILD_ROOT%{_datadir}/%{name}/templates
103 install sample/%{name}.ini $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc doc/* sample/*.ini sample/*txt sample/rc.reminder_1st sample/crontab-entry
111 %dir %{_lmsdir}
112 %dir %{_datadir}/%{name}
113 %dir %{_sharedstatedir}/%{name}
114 %attr(770,root,http) %{_sharedstatedir}/%{name}/templates_c
115 %attr(770,root,http) %{_sharedstatedir}/%{name}/backups
116 %{_lmsdir}/*.php
117 %{_lmsdir}/img
118 %{_datadir}/%{name}/lib
119 %{_datadir}/%{name}/modules
120 %{_datadir}/%{name}/templates
121 %dir %{_sysconfdir}/%{name}
122 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/*.ini
123
124 %files scripts
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/lms-*
127 %doc sample/*.ini
This page took 0.062103 seconds and 4 git commands to generate.