]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
93da9d796aa20c6e3781426c9cffd8cbe326bb02
[packages/lms.git] / lms.spec
1 Summary:        LAN Managment System
2 Summary(pl):    System Zarz±dzania Sieci± Lokaln±
3 Name:           lms
4 Version:        1.0.4
5 Release:        1
6 License:        GPL
7 Vendor:         LMS Developers
8 Group:          Networking/Utilities
9 Source0:        http://lms.rulez.pl/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  1481b7b7b8c14a739ce38f14c1fd2aeb
11 Patch0:         %{name}-PLD.patch
12 URL:            http://lms.rulez.pl/
13 Requires:       php
14 Requires:       php-posix
15 Requires:       php-pcre
16 Requires:       webserver
17 Requires:       Smarty >= 2.5.0
18 Requires:       adodb >= 2.90
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _lmsdir         /home/services/httpd/html/%{name}
23 %define         _sharedstatedir /var/lib
24 # when spec'll be finished, this sould go to RA-branch
25 # because sharedstatedir is already defined at rpm macros from HEAD
26
27 %description
28 This is a package of applications in PHP and Perl for managing LANs.
29 It's using MySQL or PostgreSQL. The main goal is to get the best 
30 service of users at provider's level.
31 The main features in LMS are:
32 - database of users (name, surname, address, telefon number,
33   commentary);
34 - database of computers (IP, MAC);
35 - easy-ridden financial system and funds of network;
36 - different subscriptions;
37 - sending warnings to users;
38 - many levels of access for LMS administrators;
39 - autogenerating ipchains, iptables, dhcpd, ethers file, oidentd,
40   openbsd packet filter configuration files/scripts;
41 - autogenerating almost any kind of config file using templates;
42
43 %description -l pl
44 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
45 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
46 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
47 opartych o bazê danych MySQL lub PostgreSQL. G³ówne za³o¿enia to 
48 uzyskanie jako¶ci us³ug oraz obs³ugi u¿ytkowników na poziomie 
49 providera z prawdziwego zdarzenia. 
50 Najbardziej podstawowe cechy LMS to:
51 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
52   uwagi);
53 - baza danych komputerów (adres IP, adres MAC);
54 - prowadzenie prostego rachunku operacji finansowych oraz stanu
55   funduszów sieci;
56 - ró¿ne taryfy abonamentowe;
57 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
58 - automatyczne naliczanie op³at miesiêcznych;
59 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
60 - generowanie regu³ i plików konfiguracyjnych dla ipchains, iptables,
61   dhcpd, oidentd, packet filtra openbsd, wpisów /etc/ethers
62 - generowanie praktycznie ka¿dego pliku konfiguracyjnego na podstawie
63   danych w bazie przy u¿yciu prostych szablonów;
64
65 %package scripts
66 Summary:        LAN Managment System - scripts
67 Summary(pl):    LAN Managment System - skrypty
68 Requires:       perl-Net-SMTP-Server
69 Requires:       perl-Config-IniFiles
70 Requires:       perl-DBI
71 BuildArch:      noarch
72 Group:          Networking/Utilities
73
74 %description scripts
75 This package contains scripts to integrate LMS with your system,
76 monthly billing, notify users about their debts and cutting off
77 customers. Also you can build propably any kind of config file using
78 lms-mgc.
79
80 %description scripts -l pl
81 Ten pakiet zawiera skrypty do zintegrowania LMS z systemem, naliczania
82 comiesiêcznych op³at, powiadamiania u¿ytkowników o ich zad³u¿eniu oraz
83 ich automagicznego od³±czania. Mo¿esz tak¿e zbudowaæ prawdopodobnie
84 ka¿dy typ pliku konfiguracyjnego przy u¿yciu lms-mgc;
85
86 %prep
87 %setup -q -n %{name}
88 %patch0 -p1
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_lmsdir}/img
93 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
94 install -d $RPM_BUILD_ROOT%{_bindir}
95 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
96 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/{backups,templates_c}
97 install -d $RPM_BUILD_ROOT%{_libexecdir}/%{name}/{lib,modules,templates}
98
99 install *.php $RPM_BUILD_ROOT%{_lmsdir}
100 install bin/* $RPM_BUILD_ROOT%{_bindir}
101 install lib/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/lib
102 install img/* $RPM_BUILD_ROOT%{_lmsdir}/img
103 install modules/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/modules
104 install templates/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/templates
105 install sample/%{name}.ini $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc doc/* sample/*.ini sample/*txt sample/rc.reminder_1st sample/crontab-entry
113 %dir %{_lmsdir}
114 %dir %{_libexecdir}/%{name}
115 %dir %{_sharedstatedir}/%{name}
116 %attr(770,root,http) %{_sharedstatedir}/%{name}/templates_c
117 %attr(770,root,http) %{_sharedstatedir}/%{name}/backups
118 %{_lmsdir}/*.php
119 %{_lmsdir}/img
120 %{_libexecdir}/%{name}/lib
121 %{_libexecdir}/%{name}/modules
122 %{_libexecdir}/%{name}/templates
123 %dir %{_sysconfdir}/%{name}
124 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/*.ini
125
126 %files scripts
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/lms-*
129 %doc sample/*.ini
This page took 0.096528 seconds and 3 git commands to generate.