]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
704856641e2899e6f0f0e7102f4d2ca1a549d1b3
[packages/lms.git] / lms.spec
1 Summary:        LAN Managment System
2 Summary(pl):    System Zarz±dzania Siec± Lokaln±
3 Name:           lms
4 Version:        1.0pre10
5 Release:        0.1
6 License:        GPL
7 Group:          Networking/Utilities
8 Source0:        http://lms.rulez.pl/download/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-PLD.patch
10 Vendor:         LMS Developers
11 URL:            http://lms.rulez.pl
12 Requires:       php
13 Requires:       php-posix
14 Requires:       webserver
15 Requires:       Smarty >= 2.5.0
16 Requires:       adodb >= 2.90
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _lmsdir         /home/services/httpd/html/%{name}
21 %define         _sharedstatedir /var/lib
22 # when spec'll be finished, this sould go to RA-branch
23 # becouse sharedstatedir is already defined at rpm macros from HEAD
24
25 %description
26 This is a package of applications in PHP and Perl for managing LANs.
27 It's using MySQL (for now) but PostgreSQL will be supported in near
28 future. The main goal is to get the best service of users at
29 provider's level.
30 The main features in LMS are:
31 - database of users (name, surname, address, telefon number, 
32   commentary);
33 - database of computers (IP, MAC);
34 - easy-ridden financial system and funds of network;
35 - different subscriptions;
36 - sending warnings to users;
37 - autogenerating dhcpd.conf;
38 - autogenerating firewall rules (ipchains/iptables);
39 - autogenerating idents for ident daemon;
40 - many levels of access for LMS administrators;
41 - integration with LinuxStat package;
42 - autogenerating ARP rules (ether auth);
43 - autogenerating DNS files.
44
45 %description -l pl
46 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
47 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
48 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
49 opartych o bazê danych MySQL (docelowo, do wyboru, MySQL lub
50 PostgreSQL). G³ówne za³o¿enia to uzyskanie jako¶ci us³ug oraz obs³ugi
51 u¿ytkowników na poziomie providera z prawdziwego zdarzenia.
52 Najbardziej podstawowe cechy LMS to:
53 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
54   uwagi);
55 - baza danych komputerów (adres IP, adres MAC);
56 - prowadzenie prostego rachunku operacji finansowych oraz stanu
57   funduszów sieci;
58 - ró¿ne taryfy abonamentowe;
59 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
60 - automatyczne naliczanie op³at miesiêcznych;
61 - generowanie dhcpd.conf;
62 - generowanie regu³ firewalla (ipchains/iptables);
63 - generowanie identów dla demona oidentd;
64 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
65 - integracja z pakietem LinuxStat;
66 - generowanie wpisów ARP (blokada adresów IP po ARP);
67 - generowanie wpisów do DNS.
68
69 %package scripts
70 Summary:        LAN Managment System - scripts
71 Summary(pl):    LAN Managment System - skrypty
72 Requires:       perl-Net-SMTP-Server
73 Requires:       perl-Config-IniFiles
74 Requires:       perl-DBI
75 BuildArch:      noarch
76 Group:          Networking/Utilities
77
78 %description scripts
79 This package contains scripts to integrate LMS with your system, monthly
80 billing, notify users about their debts and cutting off customers. Also
81 you can build propably any kind of config file using lms-mgc.
82
83 %description scripts -l pl
84 Ten pakiet zawiera skrypty do zintegrowania LMS z twoim systemem,
85 naliczania comiesiêcznych op³at, powiadamiania u¿ytkowników o ich
86 zad³u¿eniu oraz ich automagicznego od³±czania. Mo¿esz tak¿e zbudowaæ
87 prawdopodobnie ka¿dy typ pliku konfiguracyjnego przy u¿yciu lms-mgc.
88
89 %prep
90 %setup -q -n lms
91 %patch0 -p1
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{_lmsdir}/img
96 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
97 install -d $RPM_BUILD_ROOT%{_bindir}
98 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
99 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/{backups,templates_c}
100 install -d $RPM_BUILD_ROOT%{_libexecdir}/%{name}/{lib,modules,templates}
101
102 install *.php $RPM_BUILD_ROOT%{_lmsdir}
103 install bin/* $RPM_BUILD_ROOT%{_bindir}
104 install lib/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/lib
105 install img/* $RPM_BUILD_ROOT%{_lmsdir}/img
106 install modules/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/modules
107 install templates/* $RPM_BUILD_ROOT%{_libexecdir}/%{name}/templates
108 install sample/%{name}.ini $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc doc sample/*.ini sample/*txt sample/rc.reminder_1st sample/crontab-entry
116 %dir %{_lmsdir}
117 %dir %{_libexecdir}/%{name}
118 %dir %{_sharedstatedir}/%{name}
119 %attr(770,root,http) %{_sharedstatedir}/%{name}/templates_c
120 %attr(770,root,http) %{_sharedstatedir}/%{name}/backups
121 %{_lmsdir}/*.php
122 %{_lmsdir}/img
123 %{_libexecdir}/%{name}/lib
124 %{_libexecdir}/%{name}/modules
125 %{_libexecdir}/%{name}/templates
126 %dir %{_sysconfdir}/%{name}
127 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/*.ini
128
129 %files scripts
130 %attr(755,root,root) %{_bindir}/lms-*
131 %doc sample/*.ini
This page took 0.040868 seconds and 3 git commands to generate.