]> git.pld-linux.org Git - packages/lm_sensors.git/blob - lm_sensors.spec
- new kernel module naming scheme
[packages/lm_sensors.git] / lm_sensors.spec
1 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
2 %define         _kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
3 %define         smpstr          %{?_with_smp:-smp}
4 %define         smp             %{?_with_smp:1}%{!?_with_smp:0}
5
6 Summary:        Hardware health monitoring
7 Summary(pl):    Monitor stanu sprzêtu
8 Name:           lm_sensors
9 Version:        2.6.1
10 Release:        1
11 License:        GPL
12 Group:          Applications/System
13 Group(de):      Applikationen/System
14 Group(pl):      Aplikacje/System
15 Source0:        http://www.netroedge.com/~lm78/archive/%{name}-%{version}.tar.gz
16 Patch0:         %{name}-make.patch
17 URL:            http://www.netroedge.com/~lm78/
18 BuildRequires:  flex >= 2.5.1
19 BuildRequires:  i2c-devel >= 2.6.0
20 Requires:       %{name}-modules = %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Tools for monitoring the hardware health of Linux systems containing
25 hardware health monitoring hardware such as the LM78 and LM75.
26
27 %description -l pl
28 Narzêdzie do monitorowania sprzêtu w systemach Linuxowych wyposa¿onych
29 w sprzêt monitoruj±cy, taki jak LM78 lub LM75.
30
31 %package devel
32 Summary:        Header files for lm_sensors
33 Summary(pl):    Pliki nag³ówkowe dla lm_sensors
34 Group:          Development/Libraries
35 Group(de):      Entwicklung/Libraries
36 Group(es):      Desarrollo/Bibliotecas
37 Group(fr):      Development/Librairies
38 Group(pl):      Programowanie/Biblioteki
39 Group(pt_BR):   Desenvolvimento/Bibliotecas
40 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
41 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
42 Requires:       %{name} = %{version}
43
44 %description devel
45 Header files for lm_sensors.
46
47 %description devel -l pl
48 Pliki nag³ówkowe dla lm_sensors.
49
50 %package static
51 Summary:        Static libraries for lm_sensors
52 Summary(pl):    Biblioteki statyczne dla lm_sensors
53 Group:          Development/Libraries
54 Group(de):      Entwicklung/Libraries
55 Group(es):      Desarrollo/Bibliotecas
56 Group(fr):      Development/Librairies
57 Group(pl):      Programowanie/Biblioteki
58 Group(pt_BR):   Desenvolvimento/Bibliotecas
59 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
60 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
61 Requires:       %{name}-devel = %{version}
62
63 %description static
64 Static libraries for lm_sensors.
65
66 %description static -l pl
67 Biblioteki statyczne dla lm_sensors.
68
69 %package -n kernel%{smpstr}-misc-lm_sensors
70 Summary:        Kernel modules for various buses and monitor chips
71 Summary(pl):    Modu³y j±dra dla ró¿nego rodzaju sensorów
72 Group:          Applications/System
73 Group(de):      Applikationen/System
74 Group(pl):      Aplikacje/System
75 Release:        %{release}@%{_kernel_ver_str}
76 Prereq:         /sbin/depmod
77 Requires:       i2c >= 2.6.0
78 Conflicts:      kernel < %{_kernel_ver}, kernel > %{_kernel_ver}
79 Conflicts:      kernel-%{?_with_smp:up}%{!?_with_smp:smp}
80 Obsoletes:      lm_sensors-modules
81
82 %description -n kernel%{smpstr}-misc-lm_sensors
83 Kernel modules for various buses and monitor chips.
84
85 %description -n kernel%{smpstr}-misc-lm_sensors -l pl
86 Modu³y j±dra dla ró¿nego rodzaju sensorów monitoruj±cych.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %if %{smp}
94 SMP="-D__KERNEL_SMP=1"
95 %endif
96 %{__make} \
97         OPTS="%{rpmcflags} $SMP" \
98         LINUX=/dev/null \
99         LINUX_HEADERS=%{_kernelsrcdir}/include \
100         I2C_HEADERS=%{_kernelsrcdir}/include \
101         SMP=%{smp}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         PREFIX=%{_prefix} \
109         ETCDIR=%{_sysconfdir} \
110         MANDIR=%{_mandir} \
111         MODDIR=/lib/modules/%{_kernel_ver}/misc
112
113 gzip -9nf BACKGROUND BUGS CHANGES README README.thinkpad TODO
114 find doc -type f ! -name \*.\* -a ! -name \*ticket | xargs gzip -9nf
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %post -n kernel%{smpstr}-misc-lm_sensors
120 /sbin/depmod -a
121
122 %postun -n kernel%{smpstr}-misc-lm_sensors
123 /sbin/depmod -a
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files 
129 %defattr(644,root,root,755)
130 %doc *.gz 
131 %doc doc/*.gz doc/*.html doc/busses doc/chips
132 %attr(755,root,root) %{_bindir}/sensors
133 %attr(755,root,root) %{_sbindir}/sensors-detect
134 %attr(755,root,root) %{_libdir}/lib*.so.*.*
135 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sensors.conf
136 %{_mandir}/man1/*
137 %{_mandir}/man5/*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %doc doc/developers doc/kernel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/lib*.so
144 %{_includedir}/sensors
145 %{_includedir}/linux/*
146 %{_mandir}/man3/*
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libsensors.a
151
152 %files -n kernel%{smpstr}-misc-lm_sensors
153 %defattr(644,root,root,755)
154 /lib/modules/*/misc/*
This page took 0.08258 seconds and 4 git commands to generate.