]> git.pld-linux.org Git - packages/lm_sensors.git/blob - lm_sensors.spec
- added URL
[packages/lm_sensors.git] / lm_sensors.spec
1 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
2 %define         smpstr          %{?_with_smp:smp}%{!?_with_smp:up}
3 %define         smp             %{?_with_smp:1}%{!?_with_smp:0}
4
5 Summary:        Hardware health monitoring
6 Summary(pl):    Monitor stanu sprzêtu
7 Name:           lm_sensors
8 Version:        2.6.1
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Group(de):      Applikationen/System
13 Group(pl):      Aplikacje/System
14 Source0:        http://www.netroedge.com/~lm78/archive/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-make.patch
16 URL:            http://www.netroedge.com/~lm78/
17 BuildRequires:  flex >= 2.5.1
18 BuildRequires:  i2c-devel >= 2.6.0
19 Requires:       %{name}-modules = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Tools for monitoring the hardware health of Linux systems containing
24 hardware health monitoring hardware such as the LM78 and LM75.
25
26 %description -l pl
27 Narzêdzie do monitorowania sprzêtu w systemach Linuxowych wyposa¿onych
28 w sprzêt monitoruj±cy, taki jak LM78 and LM75.
29
30 %package devel
31 Summary:        Header files for lm_sensors
32 Summary(pl):    Pliki nag³ówkowe dla lm_sensors
33 Group:          Development/Libraries
34 Group(de):      Entwicklung/Libraries
35 Group(es):      Desarrollo/Bibliotecas
36 Group(fr):      Development/Librairies
37 Group(pl):      Programowanie/Biblioteki
38 Group(pt_BR):   Desenvolvimento/Bibliotecas
39 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
40 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
41 Requires:       %{name} = %{version}
42
43 %description devel
44 Header files for lm_sensors.
45
46 %description devel -l pl
47 Pliki nag³ówkowe dla lm_sensors.
48
49 %package static
50 Summary:        Static libraries for lm_sensors
51 Summary(pl):    Biblioteki statyczne dla lm_sensors
52 Group:          Development/Libraries
53 Group(de):      Entwicklung/Libraries
54 Group(es):      Desarrollo/Bibliotecas
55 Group(fr):      Development/Librairies
56 Group(pl):      Programowanie/Biblioteki
57 Group(pt_BR):   Desenvolvimento/Bibliotecas
58 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
59 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
60 Requires:       %{name}-devel = %{version}
61
62 %description static
63 Static libraries for lm_sensors.
64
65 %description static -l pl
66 Biblioteki statyczne dla lm_sensors.
67
68 %package modules
69 Summary:        Kernel modules for various buses and monitor chips
70 Summary(pl):    Modu³y j±dra dla ró¿nego rodzaju sensorów
71 Group:          Applications/System
72 Group(de):      Applikationen/System
73 Group(pl):      Aplikacje/System
74 Release:        %{release}@%{_kernel_ver}%{smpstr}
75 Prereq:         /sbin/depmod
76 Requires:       i2c >= 2.6.0
77 Conflicts:      kernel < %{_kernel_ver}, kernel > %{_kernel_ver}
78 Conflicts:      kernel-%{?_with_smp:up}%{!?_with_smp:smp}
79
80 %description modules
81 Kernel modules for various buses and monitor chips.
82
83 %description -l pl
84 Modu³y j±dra dla ró¿nego rodzaju sensorów monitoruj±cych.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 %if %{smp}
92 SMP="-D__KERNEL_SMP=1"
93 %endif
94 %{__make} \
95         OPTS="%{rpmcflags} $SMP" \
96         LINUX=/dev/null \
97         LINUX_HEADERS=%{_kernelsrcdir}/include \
98         I2C_HEADERS=%{_kernelsrcdir}/include \
99         SMP=%{smp}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         PREFIX=%{_prefix} \
107         ETCDIR=%{_sysconfdir} \
108         MANDIR=%{_mandir} \
109         MODDIR=/lib/modules/%{_kernel_ver}/misc
110
111 gzip -9nf BACKGROUND BUGS CHANGES README README.thinkpad TODO
112 find doc -type f ! -name \*.\* -a ! -name \*ticket | xargs gzip -9nf
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %post modules
118 /sbin/depmod -a
119
120 %postun modules
121 /sbin/depmod -a
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files 
127 %defattr(644,root,root,755)
128 %doc *.gz 
129 %doc doc/*.gz doc/*.html doc/busses doc/chips
130 %attr(755,root,root) %{_bindir}/sensors
131 %attr(755,root,root) %{_sbindir}/sensors-detect
132 %attr(755,root,root) %{_libdir}/lib*.so.*.*
133 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sensors.conf
134 %{_mandir}/man1/*
135 %{_mandir}/man5/*
136
137 %files devel
138 %defattr(644,root,root,755)
139 %doc doc/developers doc/kernel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/lib*.so
142 %{_includedir}/sensors
143 %{_includedir}/linux/*
144 %{_mandir}/man3/*
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libsensors.a
149
150 %files modules
151 %defattr(644,root,root,755)
152 /lib/modules/*/misc/*
This page took 0.04491 seconds and 4 git commands to generate.