]> git.pld-linux.org Git - packages/lm_sensors.git/blob - lm_sensors.spec
1c7f61c2ff4f545e81bfac3513d96bd43f5b129d
[packages/lm_sensors.git] / lm_sensors.spec
1 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
2 %define         smpstr          %{?_with_smp:smp}%{!?_with_smp:up}
3 %define         smp             %{?_with_smp:1}%{!?_with_smp:0}
4
5 Summary:        Hardware health monitoring
6 Summary(pl):    Monitor stanu sprzêtu
7 Name:           lm_sensors
8 Version:        2.6.1
9 Release:        1
10 License:        GPL
11 Group:          Applications/System
12 Group(de):      Applikationen/System
13 Group(pl):      Aplikacje/System
14 Source0:        http://www.netroedge.com/~lm78/archive/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-make.patch
16 BuildRequires:  flex >= 2.5.1
17 BuildRequires:  i2c-devel >= 2.6.0
18 Requires:       %{name}-modules = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Tools for monitoring the hardware health of Linux systems containing
23 hardware health monitoring hardware such as the LM78 and LM75.
24
25 %description -l pl
26 Narzêdzie do monitorowania sprzêtu w systemach Linuxowych wyposa¿onych
27 w sprzêt monitoruj±cy, taki jak LM78 and LM75.
28
29 %package devel
30 Summary:        Header files for lm_sensors
31 Summary(pl):    Pliki nag³ówkowe dla lm_sensors
32 Group:          Development/Libraries
33 Group(de):      Entwicklung/Libraries
34 Group(es):      Desarrollo/Bibliotecas
35 Group(fr):      Development/Librairies
36 Group(pl):      Programowanie/Biblioteki
37 Group(pt_BR):   Desenvolvimento/Bibliotecas
38 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
39 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
40 Requires:       %{name} = %{version}
41
42 %description devel
43 Header files for lm_sensors.
44
45 %description devel -l pl
46 Pliki nag³ówkowe dla lm_sensors.
47
48 %package static
49 Summary:        Static libraries for lm_sensors
50 Summary(pl):    Biblioteki statyczne dla lm_sensors
51 Group:          Development/Libraries
52 Group(de):      Entwicklung/Libraries
53 Group(es):      Desarrollo/Bibliotecas
54 Group(fr):      Development/Librairies
55 Group(pl):      Programowanie/Biblioteki
56 Group(pt_BR):   Desenvolvimento/Bibliotecas
57 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
58 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
59 Requires:       %{name}-devel = %{version}
60
61 %description static
62 Static libraries for lm_sensors.
63
64 %description static -l pl
65 Biblioteki statyczne dla lm_sensors.
66
67 %package modules
68 Summary:        Kernel modules for various buses and monitor chips
69 Summary(pl):    Modu³y j±dra dla ró¿nego rodzaju sensorów
70 Group:          Applications/System
71 Group(de):      Applikationen/System
72 Group(pl):      Aplikacje/System
73 Release:        %{release}@%{_kernel_ver}%{smpstr}
74 Prereq:         /sbin/depmod
75 Requires:       i2c >= 2.6.0
76 Conflicts:      kernel < %{_kernel_ver}, kernel > %{_kernel_ver}
77 Conflicts:      kernel-%{?_with_smp:up}%{!?_with_smp:smp}
78
79 %description modules
80 Kernel modules for various buses and monitor chips.
81
82 %description -l pl
83 Modu³y j±dra dla ró¿nego rodzaju sensorów monitoruj±cych.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %if %{smp}
91 SMP="-D__KERNEL_SMP=1"
92 %endif
93 %{__make} \
94         OPTS="%{rpmcflags} $SMP" \
95         LINUX=/dev/null \
96         LINUX_HEADERS=%{_kernelsrcdir}/include \
97         I2C_HEADERS=%{_kernelsrcdir}/include \
98         SMP=%{smp}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT \
105         PREFIX=%{_prefix} \
106         ETCDIR=%{_sysconfdir} \
107         MANDIR=%{_mandir} \
108         MODDIR=/lib/modules/%{_kernel_ver}/misc
109
110 gzip -9nf BACKGROUND BUGS CHANGES README README.thinkpad TODO
111 find doc -type f ! -name \*.\* -a ! -name \*ticket | xargs gzip -9nf
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %post modules
117 /sbin/depmod -a
118
119 %postun modules
120 /sbin/depmod -a
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files 
126 %defattr(644,root,root,755)
127 %doc *.gz 
128 %doc doc/*.gz doc/*.html doc/busses doc/chips
129 %attr(755,root,root) %{_bindir}/sensors
130 %attr(755,root,root) %{_sbindir}/sensors-detect
131 %attr(755,root,root) %{_libdir}/lib*.so.*.*
132 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sensors.conf
133 %{_mandir}/man1/*
134 %{_mandir}/man5/*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc doc/developers doc/kernel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/lib*.so
141 %{_includedir}/sensors
142 %{_includedir}/linux/*
143 %{_mandir}/man3/*
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libsensors.a
148
149 %files modules
150 %defattr(644,root,root,755)
151 /lib/modules/*/misc/*
This page took 0.034595 seconds and 3 git commands to generate.