]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
- removed duplicated macro
[packages/llvm.git] / llvm.spec
1 # TODO:
2 # - move and package:
3 #       %{_datadir}/clang/clang-format-sublime.py - sublime plugin
4 #       %{_datadir}/clang/clang-format.el - emacs mode
5 #       %{_datadir}/clang/clang-format.py - vim plugin
6 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
7 #
8 # Conditional build:
9 %bcond_without  lldb    # LLDB debugger
10 %bcond_without  polly   # Polly cache-locality optimization, auto-parallelism and vectorization
11 %bcond_without  rt      # compiler-rt libraries
12 %bcond_without  ocaml   # OCaml binding
13 %bcond_without  doc     # HTML docs and man pages
14 %bcond_with     apidocs # doxygen docs (HUGE, so they are not built by default)
15 %bcond_with     tests   # run tests
16
17 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
18 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9 
19 %undefine       with_ocaml
20 %endif
21
22 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
23 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
24 Name:           llvm
25 Version:        3.7.0
26 Release:        0.1
27 License:        University of Illinois/NCSA Open Source License
28 Group:          Development/Languages
29 #Source0Download: http://llvm.org/releases/download.html
30 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
31 # Source0-md5:  b98b9495e5655a672d6cb83e1a180f8e
32 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
33 # Source1-md5:  8f9d27335e7331cf0a4711e952f21f01
34 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
35 # Source2-md5:  383c10affd513026f08936b5525523f5
36 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
37 # Source3-md5:  e5931740400d1dc3e7db4c7ba2ceff68
38 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
39 # Source4-md5:  32f93ffc9cc7e042df22089761558f8b
40 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
41 # Source5-md5:  d5a87dacb65d981a427a536f6964642e
42 Source6:        http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
43 # Source6-md5:  91bd593a67293d84dad0bf11845546c2
44 Patch0:         %{name}-lld-link.patch
45 # Data files should be installed with timestamps preserved
46 Patch1:         %{name}-2.6-timestamp.patch
47 Patch2:         %{name}-pld.patch
48 Patch3:         build-lld.patch
49 Patch4:         %{name}-lldb.patch
50 Patch5:         %{name}-lldb-atomic.patch
51 Patch6:         libdir.patch
52 Patch7:         x32-gcc-toolchain.patch
53 Patch8:         gcc5.patch
54 URL:            http://llvm.org/
55 BuildRequires:  autoconf >= 2.60
56 BuildRequires:  automake >= 1:1.9.6
57 BuildRequires:  bash
58 BuildRequires:  bison
59 BuildRequires:  flex
60 BuildRequires:  gcc >= 5:3.4
61 # gcc4 might be installed, but not current __cc
62 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
63 BuildRequires:  __cc >= 3.4
64 %endif
65 %ifarch x32
66 BuildRequires:  glibc-devel(x86_64)
67 %endif
68 BuildRequires:  groff
69 BuildRequires:  libltdl-devel
70 BuildRequires:  libtool >= 2:1.5.22
71 BuildRequires:  libstdc++-devel >= 5:3.4
72 %if %{with ocaml}
73 BuildRequires:  ocaml-ctypes-devel >= 0.4
74 BuildRequires:  ocaml-findlib
75 BuildRequires:  ocaml-ocamldoc
76 BuildRequires:  ocaml-ounit
77 %endif
78 BuildRequires:  perl-base >= 1:5.6
79 BuildRequires:  perl-tools-pod
80 BuildRequires:  rpm-pythonprov
81 %{?with_doc:BuildRequires:      sphinx-pdg}
82 BuildRequires:  tar >= 1:1.22
83 BuildRequires:  xz
84 %if %{with apidocs}
85 BuildRequires:  doxygen
86 BuildRequires:  graphviz
87 %endif
88 %if %{with tests}
89 BuildRequires:  dejagnu
90 BuildRequires:  python
91 BuildRequires:  tcl-devel
92 %endif
93 %if %{with lldb}
94 BuildRequires:  epydoc
95 %ifarch i386 i486
96 BuildRequires:  libatomic-devel
97 %endif
98 BuildRequires:  libedit-devel
99 BuildRequires:  libxml2-devel >= 2
100 BuildRequires:  ncurses-ext-devel
101 BuildRequires:  python-devel >= 2
102 BuildRequires:  swig-python
103 %endif
104 %if %{with polly}
105 BuildRequires:  cloog-isl-devel
106 # >= 0.18.2-2
107 BuildRequires:  gmp-devel
108 BuildRequires:  isl-devel >= 0.14
109 # optional
110 BuildRequires:  pluto-devel
111 BuildRequires:  scoplib-devel >= 0.2.1-2
112 #cuda-devel
113 %endif
114 Requires:       %{name}-libs = %{version}-%{release}
115 # LLVM is not supported on PPC64
116 # http://llvm.org/bugs/show_bug.cgi?id=3729
117 ExcludeArch:    ppc64
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %define         _sysconfdir     /etc/%{name}
121
122 %define         specflags_ppc   -fno-var-tracking-assignments
123
124 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
125 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
126
127 # clang doesn't know it, and leaving it here would pollute llvm-config
128 %define         filterout_c     -fvar-tracking-assignments
129 %define         filterout_cxx   -fvar-tracking-assignments
130 %define         filterout_ccpp  -fvar-tracking-assignments
131
132 # std::__once_call, std::__once_callable non-function symbols
133 %define         skip_post_check_so      liblldAArch64ELFTarget.so.* liblldARMELFTarget.so.* liblldHexagonELFTarget.so.* liblldMipsELFTarget.so.* liblldb.so.*
134
135 %description
136 LLVM is a compiler infrastructure designed for compile-time,
137 link-time, runtime, and idle-time optimization of programs from
138 arbitrary programming languages. LLVM is written in C++ and has been
139 developed since 2000 at the University of Illinois and Apple. It
140 currently supports compilation of C and C++ programs using clang
141 frontend.
142
143 %description -l pl.UTF-8
144 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
145 czasu kompilowania, linkowania, działania i bezczynności programów w
146 dowolnych językach programowania. Jest napisana w C++, rozwijana od
147 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
148 kompilację programów w C i C++ przy użyciu frontendu clang.
149
150 %package libs
151 Summary:        LLVM shared library
152 Summary(pl.UTF-8):      Biblioteka współdzielona LLVM-a
153 Group:          Libraries
154 Conflicts:      llvm < 3.2
155
156 %description libs
157 LLVM shared library.
158
159 %description libs -l pl.UTF-8
160 Biblioteka współdzielona LLVM-a.
161
162 %package devel
163 Summary:        Static libraries and header files for LLVM
164 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
165 Group:          Development/Languages
166 Requires:       %{name}-libs = %{version}-%{release}
167 Requires:       libstdc++-devel >= 6:3.4
168
169 %description devel
170 This package contains static libraries and header files needed to
171 develop new native programs that use the LLVM infrastructure.
172
173 %description devel -l pl.UTF-8
174 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
175 potrzebne do tworzenia nowych programów natywnych wykorzystujących
176 infrastrukturę LLVM.
177
178 %package doc
179 Summary:        Documentation for LLVM
180 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
181 Group:          Documentation
182 # does not require base
183
184 %description doc
185 Documentation for the LLVM compiler infrastructure.
186
187 %description doc -l pl.UTF-8
188 Dokumentacja do infrastruktury kompilatorów LLVM.
189
190 %package apidocs
191 Summary:        API documentation for LLVM
192 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
193 Group:          Development/Languages
194 Requires:       %{name}-doc = %{version}-%{release}
195
196 %description apidocs
197 API documentation for the LLVM compiler infrastructure.
198
199 %description apidocs -l pl.UTF-8
200 Dokumentacja API infrastruktury kompilatorów LLVM.
201
202 %package polly
203 Summary:        Polyhedral optimizations for LLVM
204 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
205 Group:          Development/Tools
206 URL:            http://polly.llvm.org/
207 Requires:       %{name} = %{version}-%{release}
208
209 %description polly
210 Polly is a high-level loop and data-locality optimizer and
211 optimization infrastructure for LLVM. It uses an abstract mathematical
212 representation based on integer polyhedra to analyze and optimize the
213 memory access pattern of a program.
214
215 %description polly -l pl.UTF-8
216 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
217 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
218 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
219 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
220
221 %package polly-devel
222 Summary:        Header files for LLVM Polly optimization infrastructure
223 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
224 Group:          Development/Libraries
225 URL:            http://polly.llvm.org/
226 Requires:       %{name}-devel = %{version}-%{release}
227 Requires:       %{name}-polly = %{version}-%{release}
228
229 %description polly-devel
230 Header files for LLVM Polly optimization infrastructure.
231
232 %description polly-devel -l pl.UTF-8
233 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
234
235 %package -n clang
236 Summary:        A C language family frontend for LLVM
237 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
238 License:        NCSA
239 Group:          Development/Languages
240 Requires:       %{name} = %{version}-%{release}
241
242 %description -n clang
243 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
244 of a crane or goose. 3. C-language family front-end toolkit.
245
246 The goal of the Clang project is to create a new C, C++, Objective C
247 and Objective C++ front-end for the LLVM compiler. Its tools are built
248 as libraries and designed to be loosely-coupled and extendable.
249
250 %description -n clang -l pl.UTF-8
251 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
252 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
253 z rodziny C.
254
255 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
256 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
257 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
258 i rozszerzaniu.
259
260 %package -n clang-analyzer
261 Summary:        A source code analysis framework
262 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
263 License:        NCSA
264 Group:          Development/Languages
265 Requires:       clang = %{version}-%{release}
266 # not picked up automatically since files are currently not instaled
267 # in standard Python hierarchies yet
268 Requires:       python
269
270 %description -n clang-analyzer
271 The Clang Static Analyzer consists of both a source code analysis
272 framework and a standalone tool that finds bugs in C and Objective-C
273 programs. The standalone tool is invoked from the command-line, and is
274 intended to run in tandem with a build of a project or code base.
275
276 %description -n clang-analyzer -l pl.UTF-8
277 Clang Static Analyzer składa się ze szkieletu do analizy kodu
278 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
279 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
280 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
281
282 %package -n clang-devel
283 Summary:        Header files for Clang
284 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
285 Group:          Development/Languages
286 Requires:       %{name}-devel = %{version}-%{release}
287 Requires:       clang = %{version}-%{release}
288
289 %description -n clang-devel
290 This package contains header files for the Clang compiler.
291
292 %description -n clang-devel -l pl.UTF-8
293 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
294
295 %package -n clang-doc
296 Summary:        Documentation for Clang
297 Summary(pl.UTF-8):      Dokumentacja do Clanga
298 Group:          Documentation
299 Requires:       %{name} = %{version}-%{release}
300
301 %description -n clang-doc
302 Documentation for the Clang compiler front-end.
303
304 %description -n clang-doc -l pl.UTF-8
305 Dokumentacja do frontendu kompilatora Clang.
306
307 %package -n clang-apidocs
308 Summary:        API documentation for Clang
309 Summary(pl.UTF-8):      Dokumentacja API Clanga
310 Group:          Development/Languages
311 Requires:       clang-doc = %{version}-%{release}
312
313 %description -n clang-apidocs
314 API documentation for the Clang compiler.
315
316 %description -n clang-apidocs -l pl.UTF-8
317 Dokumentacja API kompilatora Clang.
318
319 %package -n clang-tools-extra
320 Summary:        Extra tools for Clang
321 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
322 Group:          Development/Tools
323 URL:            http://clang.llvm.org/docs/ClangTools.html
324 Requires:       clang = %{version}-%{release}
325
326 %description -n clang-tools-extra
327 Extra tools for Clang.
328
329 %description -n clang-tools-extra -l pl.UTF-8
330 Dodatkowe narzędzia do kompilatora Clang.
331
332 %package -n lld
333 Summary:        The LLVM linker
334 Summary(pl.UTF-8):      Konsolidator z projektu LLVM
335 Group:          Development/Libraries
336 URL:            http://lld.llvm.org/
337 Requires:       %{name} = %{version}-%{release}
338
339 %description -n lld
340 lld is a new set of modular code for creating linker tools.
341
342 %description -n lld -l pl.UTF-8
343 lld to nowy zbiór modularnego kodu do tworzenia narzędzi
344 konsolidujących.
345
346 %package -n lld-devel
347 Summary:        Development files for LLD linker tools
348 Summary(pl.UTF-8):      Pliki programistyczne narzędzi konsolidujących LLD
349 Group:          Development/Tools
350 URL:            http://lld.llvm.org/
351 Requires:       %{name}-devel = %{version}-%{release}
352
353 %description -n lld-devel
354 Development files for LLD linker tools.
355
356 %description -n lld-devel -l pl.UTF-8
357 Pliki programistyczne narzędzi konsolidujących LLD.
358
359 %package -n lldb
360 Summary:        Next generation high-performance debugger
361 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
362 Group:          Development/Debuggers
363 URL:            http://lldb.llvm.org/
364 Requires:       %{name} = %{version}-%{release}
365
366 %description -n lldb
367 LLDB is a next generation, high-performance debugger. It is built as a
368 set of reusable components which highly leverage existing libraries in
369 the larger LLVM Project, such as the Clang expression parser and LLVM
370 disassembler.
371
372 %description -n lldb -l pl.UTF-8
373 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
374 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
375 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
376 disasembler LLVM.
377
378 %package -n lldb-devel
379 Summary:        Development files for LLDB debugger
380 Summary(pl.UTF-8):      Pliki programistyczne debuggera LLDB
381 Group:          Development/Libraries
382 URL:            http://lldb.llvm.org/
383 Requires:       %{name}-devel = %{version}-%{release}
384 Requires:       clang-devel = %{version}-%{release}
385 Requires:       lldb = %{version}-%{release}
386
387 %description -n lldb-devel
388 Development files for LLDB debugger.
389
390 %description -n lldb-devel -l pl.UTF-8
391 Pliki programistyczne debuggera LLDB.
392
393 %package ocaml
394 Summary:        OCaml binding for LLVM
395 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
396 Group:          Libraries
397 Requires:       %{name} = %{version}-%{release}
398 %requires_eq    ocaml-runtime
399
400 %description ocaml
401 OCaml binding for LLVM.
402
403 %description ocaml -l pl.UTF-8
404 Wiązanie OCamla do LLVM-a.
405
406 %package ocaml-devel
407 Summary:        Development files for LLVM OCaml binding
408 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
409 Group:          Development/Libraries
410 Requires:       %{name}-devel = %{version}-%{release}
411 Requires:       %{name}-ocaml = %{version}-%{release}
412
413 %description ocaml-devel
414 The llvm-ocaml-devel package contains libraries and signature files
415 for developing applications that use llvm-ocaml binding.
416
417 %description ocaml-devel -l pl.UTF-8
418 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
419 wykorzystujących wiązanie llvm-ocaml.
420
421 %package ocaml-doc
422 Summary:        Documentation for LLVM's OCaml binding
423 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
424 Group:          Documentation
425 Requires:       %{name}-ocaml = %{version}-%{release}
426
427 %description ocaml-doc
428 HTML documentation for LLVM's OCaml binding.
429
430 %description ocaml-doc -l pl.UTF-8
431 Dokumentacja HTML wiązania OCamla do LLVM-a.
432
433 %prep
434 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
435 mv cfe-%{version}.src tools/clang
436 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
437 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
438 %{?with_polly:mv polly-%{version}.src tools/polly}
439 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
440 mv lld-%{version}.src tools/lld
441
442 %patch0 -p1
443 %patch1 -p1
444 %patch2 -p1
445 %patch3 -p1
446 %if %{with lldb}
447 %patch4 -p1
448 %ifarch i386 i486
449 %patch5 -p1
450 %endif
451 %endif
452 %patch6 -p1
453 %patch7 -p1
454 %patch8 -p1
455
456 # configure does not properly specify libdir
457 #%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
458 # clang resources
459 #%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' \
460 #       tools/clang/lib/Headers/Makefile \
461 #       tools/clang/runtime/compiler-rt/Makefile
462 %{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
463
464 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
465         s,^#!.*bin/env python,#!%{__python},
466         s,^#!.*bin/env perl,#!%{__perl},
467 }'
468
469 %build
470 install -d build
471 #%if "%{_lib}" != "lib"
472 ## workaround for clang relative search paths building
473 #install -d build/Release
474 #ln -snf lib build/Release/%{_lib}
475 #%endif
476
477 #cd autoconf
478 #%{__aclocal} -I m4
479 #%{__autoconf} -o ../configure configure.ac
480 #cd ..
481 #%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
482 #%if %{with polly}
483 #cd tools/polly/autoconf
484 #%{__aclocal} -I m4 -I ../../../autoconf/m4
485 #%{__autoconf} -o ../configure configure.ac
486 #cd ..
487 #%{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
488 #cd ../..
489 #%endif
490
491 # Disabling assertions now, rec. by pure and needed for OpenGTL
492 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
493 cd build
494 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
495
496 %{cmake} ../ \
497 %ifarch %{x8664}
498         -DLLVM_LIBDIR_SUFFIX:STRING=64 \
499 %endif
500 %ifarch x32
501         -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
502 %endif
503 %ifarch %{ix86}
504         -DLLVM_ENABLE_PIC:BOOL=OFF \
505 %endif
506 %if %{with apidocs}
507         -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
508 %endif
509 %if %{with doc}
510         -DLLVM_ENABLE_SPHINX:BOOL=ON \
511 %endif
512         -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
513         -DLLVM_ENABLE_CXX1Y:BOOL=ON \
514         -DLLVM_BINDINGS_LIST:LIST="go%{?with_ocaml:;ocaml};python" \
515         -DBUILD_SHARED_LIBS:BOOL=ON
516
517 #bash ../%%configure \
518 #       --datadir=%{_datadir}/%{name}-%{version} \
519 #       --enable-jit \
520 #       --enable-optimized
521
522 %{__make} \
523         VERBOSE=1 \
524         REQUIRES_RTTI=1 \
525         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
526
527 %if %{with tests}
528 %{__make} check 2>&1 | tee llvm-testlog.txt
529 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
530 %endif
531
532 %if %{with doc}
533 %{__make} -C docs docs-llvm-html
534 %{__make} -C docs docs-llvm-man
535 %if %{with ocaml}
536 %{__make} -C docs ocaml_doc
537 %endif
538 %{__make} -C tools/clang/docs docs-clang-html
539 %{__make} -C tools/clang/docs docs-clang-man
540 %{__make} -C tools/lld/docs docs-lld-html
541 %{__make} -C tools/lldb/docs lldb-python-doc
542 %{__make} -C tools/lldb/docs lldb-cpp-doc
543 %{__make} -C ../tools/clang/tools/extra/docs html
544 %endif
545
546 %install
547 rm -rf $RPM_BUILD_ROOT
548 %{__make} -C build install \
549         DESTDIR=$RPM_BUILD_ROOT
550
551 # only some .pyc files are created by make install
552 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
553 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
554
555 # Static analyzer not installed by default:
556 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
557 install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
558 # create launchers
559 for f in scan-{build,view}; do
560         ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
561         cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
562 done
563 install -d $RPM_BUILD_ROOT%{_mandir}/man1
564 %{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
565 %py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
566 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
567 %py_postclean %{_libdir}/clang-analyzer/scan-view
568 # not this OS
569 %{__rm} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/*.bat
570
571 # not installed by cmake buildsystem
572 install build/bin/clang-query $RPM_BUILD_ROOT%{_bindir}
573 install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
574
575 %if %{with doc}
576 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
577 # these tools are not installed
578 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
579 # make links
580 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
581 %endif
582
583 # Move documentation back to build directory
584 %if %{with ocaml}
585 rm -rf ocamldocs
586 mv $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
587 %endif
588
589 # and separate the apidoc
590 %if %{with apidocs}
591 rm -rf clang-apidoc
592 cp -a build/tools/clang/docs/html clang-apidoc
593 %endif
594
595 # And prepare Clang documentation
596 rm -rf clang-docs
597 install -d clang-docs
598 for f in LICENSE.TXT NOTES.txt README.txt; do
599         ln tools/clang/$f clang-docs
600 done
601
602 # Get rid of erroneously installed example files.
603 %{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
604 # test?
605 %{__rm} $RPM_BUILD_ROOT%{_bindir}/llvm-c-test
606 # not this OS
607 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
608
609 %clean
610 rm -rf $RPM_BUILD_ROOT
611
612 %post   libs -p /sbin/ldconfig
613 %postun libs -p /sbin/ldconfig
614
615 %post   -n clang -p /sbin/ldconfig
616 %postun -n clang -p /sbin/ldconfig
617
618 %post   -n clang-tools-extra -p /sbin/ldconfig
619 %postun -n clang-tools-extra -p /sbin/ldconfig
620
621 %post   -n lldb -p /sbin/ldconfig
622 %postun -n lldb -p /sbin/ldconfig
623
624 %files
625 %defattr(644,root,root,755)
626 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
627 %attr(755,root,root) %{_bindir}/bugpoint
628 %attr(755,root,root) %{_bindir}/llc
629 %attr(755,root,root) %{_bindir}/lli
630 %attr(755,root,root) %{_bindir}/llvm-ar
631 %attr(755,root,root) %{_bindir}/llvm-as
632 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
633 %attr(755,root,root) %{_bindir}/llvm-cov
634 %attr(755,root,root) %{_bindir}/llvm-diff
635 %attr(755,root,root) %{_bindir}/llvm-dis
636 %attr(755,root,root) %{_bindir}/llvm-dsymutil
637 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
638 %attr(755,root,root) %{_bindir}/llvm-extract
639 %attr(755,root,root) %{_bindir}/llvm-lib
640 %attr(755,root,root) %{_bindir}/llvm-link
641 %ifarch %{x8664} x32
642 %attr(755,root,root) %{_bindir}/llvm-lto
643 %endif
644 %attr(755,root,root) %{_bindir}/llvm-mc
645 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
646 %attr(755,root,root) %{_bindir}/llvm-nm
647 %attr(755,root,root) %{_bindir}/llvm-objdump
648 %attr(755,root,root) %{_bindir}/llvm-profdata
649 %attr(755,root,root) %{_bindir}/llvm-ranlib
650 %attr(755,root,root) %{_bindir}/llvm-readobj
651 %attr(755,root,root) %{_bindir}/llvm-rtdyld
652 %attr(755,root,root) %{_bindir}/llvm-size
653 %attr(755,root,root) %{_bindir}/llvm-stress
654 %attr(755,root,root) %{_bindir}/llvm-symbolizer
655 %attr(755,root,root) %{_bindir}/llvm-tblgen
656 %attr(755,root,root) %{_bindir}/llvm-cxxdump
657 %attr(755,root,root) %{_bindir}/llvm-pdbdump
658 %attr(755,root,root) %{_bindir}/macho-dump
659 %attr(755,root,root) %{_bindir}/obj2yaml
660 %attr(755,root,root) %{_bindir}/opt
661 %attr(755,root,root) %{_bindir}/verify-uselistorder
662 %attr(755,root,root) %{_bindir}/yaml2obj
663 %if %{with doc}
664 %{_mandir}/man1/bugpoint.1*
665 %{_mandir}/man1/lit.1*
666 %{_mandir}/man1/llc.1*
667 %{_mandir}/man1/lli.1*
668 %{_mandir}/man1/llvm-ar.1*
669 %{_mandir}/man1/llvm-as.1*
670 %{_mandir}/man1/llvm-bcanalyzer.1*
671 %{_mandir}/man1/llvm-cov.1*
672 %{_mandir}/man1/llvm-diff.1*
673 %{_mandir}/man1/llvm-dis.1*
674 %{_mandir}/man1/llvm-dwarfdump.1*
675 %{_mandir}/man1/llvm-extract.1*
676 %{_mandir}/man1/llvm-link.1*
677 %{_mandir}/man1/llvm-nm.1*
678 %{_mandir}/man1/llvm-profdata.1*
679 %{_mandir}/man1/llvm-ranlib.1*
680 %{_mandir}/man1/llvm-readobj.1*
681 %{_mandir}/man1/llvm-stress.1*
682 %{_mandir}/man1/llvm-symbolizer.1*
683 %{_mandir}/man1/opt.1*
684 %{_mandir}/man1/tblgen.1*
685 %endif
686
687 %files libs
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/libLLVM*.so.%{version}
690 %attr(755,root,root) %ghost %{_libdir}/libLLVM*.so.3.7
691 %ifarch %{x8664} x32
692 %attr(755,root,root) %{_libdir}/libLTO.so.%{version}
693 %attr(755,root,root) %ghost %{_libdir}/libLTO.so.3.7
694 %endif
695
696 %files devel
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/llvm-config
699 %attr(755,root,root) %{_libdir}/libLLVM*.so
700 %attr(755,root,root) %{_libdir}/BugpointPasses.so
701 %ifarch %{x8664} x32
702 %attr(755,root,root) %{_libdir}/libLTO.so
703 %endif
704 %{_includedir}/llvm
705 %{_includedir}/llvm-c
706 %dir %{_datadir}/llvm
707 %{_datadir}/llvm/cmake
708 %if %{with doc}
709 %{_mandir}/man1/llvm-config.1*
710 %endif
711
712 #%files doc
713 #%defattr(644,root,root,755)
714
715 %if %{with apidocs}
716 %files apidocs
717 %defattr(644,root,root,755)
718 %doc apidoc/*
719 %endif
720
721 %if %{with polly}
722 %files polly
723 %defattr(644,root,root,755)
724 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
725 %attr(755,root,root) %{_libdir}/LLVMPolly.so
726 %attr(755,root,root) %{_libdir}/libPolly.so
727
728 %files polly-devel
729 %defattr(644,root,root,755)
730 %{_includedir}/polly
731 %endif
732
733 %files -n clang
734 %defattr(644,root,root,755)
735 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
736 %attr(755,root,root) %{_bindir}/clang
737 %attr(755,root,root) %{_bindir}/clang++
738 %attr(755,root,root) %{_bindir}/clang-3.7
739 %attr(755,root,root) %{_bindir}/clang-check
740 %attr(755,root,root) %{_bindir}/clang-cl
741 %attr(755,root,root) %{_bindir}/clang-format
742 %attr(755,root,root) %{_bindir}/git-clang-format
743 %attr(755,root,root) %{_libdir}/libclang*.so.%{version}
744 %attr(755,root,root) %ghost %{_libdir}/libclang*.so.3.7
745 %dir %{_libdir}/clang
746 %dir %{_libdir}/clang/%{version}
747 %{_libdir}/clang/%{version}/include
748 %if %{with rt}
749 %ifarch %{ix86} %{x8664}
750 %{_libdir}/clang/%{version}/lib
751 %{_libdir}/clang/%{version}/asan_blacklist.txt
752 %{_libdir}/clang/%{version}/dfsan_abilist.txt
753 %{_libdir}/clang/%{version}/msan_blacklist.txt
754 %endif
755 %ifarch %{x8664}
756 %{_libdir}/clang/%{version}/dfsan_abilist.txt
757 %{_libdir}/clang/%{version}/msan_blacklist.txt
758 %endif
759 %endif
760 %dir %{_datadir}/clang
761 %{_datadir}/clang/clang-format-diff.py
762
763 %files -n clang-analyzer
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_bindir}/scan-build
766 %attr(755,root,root) %{_bindir}/scan-view
767 %{_mandir}/man1/scan-build.1*
768 %dir %{_libdir}/clang-analyzer
769
770 %dir %{_libdir}/clang-analyzer/scan-build
771 %{_libdir}/clang-analyzer/scan-build/*.css
772 %{_libdir}/clang-analyzer/scan-build/*.js
773 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
774 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
775
776 %dir %{_libdir}/clang-analyzer/scan-view
777 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
778 %{_libdir}/clang-analyzer/scan-view/Resources
779 %{_libdir}/clang-analyzer/scan-view/*.py[co]
780
781 %files -n clang-devel
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libclang*.so
784 %ifarch %{ix86} # ???
785 %{_libdir}/libclang.a
786 %endif
787 %{_includedir}/clang
788 %{_includedir}/clang-c
789
790 %files -n clang-doc
791 %defattr(644,root,root,755)
792 %doc tools/clang/docs/*.{html,png,txt}
793
794 %if %{with apidocs}
795 %files -n clang-apidocs
796 %defattr(644,root,root,755)
797 %doc clang-apidoc/*
798 %endif
799
800 %files -n clang-tools-extra
801 %defattr(644,root,root,755)
802 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
803 %attr(755,root,root) %{_bindir}/clang-apply-replacements
804 %attr(755,root,root) %{_bindir}/clang-modernize
805 %attr(755,root,root) %{_bindir}/clang-query
806 %attr(755,root,root) %{_bindir}/clang-rename
807 %attr(755,root,root) %{_bindir}/clang-tidy
808 %attr(755,root,root) %{_bindir}/pp-trace
809 %attr(755,root,root) %{_libdir}/libmodernizeCore.so.%{version}
810 %attr(755,root,root) %ghost %{_libdir}/libmodernizeCore.so.3.7
811 # -devel?
812 %attr(755,root,root) %{_libdir}/libmodernizeCore.so
813
814 %files -n lld
815 %defattr(644,root,root,755)
816 %doc tools/lld/{LICENSE.TXT,README.md}
817 %attr(755,root,root) %{_bindir}/lld
818 %attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so.%{version}
819 %attr(755,root,root) %ghost %{_libdir}/liblld[ACDEHMPRXY]*.so.3.7
820
821 %files -n lld-devel
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so
824 %{_includedir}/lld
825
826 %if %{with lldb}
827 %files -n lldb
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_bindir}/argdumper
830 %attr(755,root,root) %{_bindir}/lldb
831 %attr(755,root,root) %{_bindir}/lldb-%{version}
832 %attr(755,root,root) %{_bindir}/lldb-mi
833 %attr(755,root,root) %{_bindir}/lldb-mi-%{version}
834 %attr(755,root,root) %{_bindir}/lldb-server
835 %attr(755,root,root) %{_bindir}/lldb-server-%{version}
836 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
837 %attr(755,root,root) %ghost %{_libdir}/liblldb.so.3.7
838 %dir %{py_sitedir}/lldb
839 %attr(755,root,root) %{py_sitedir}/lldb/argdumper
840 %{py_sitedir}/lldb/formatters
841 %{py_sitedir}/lldb/runtime
842 %{py_sitedir}/lldb/utils
843 %{py_sitedir}/lldb/__init__.py[co]
844 %{py_sitedir}/lldb/embedded_interpreter.py[co]
845 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
846 %attr(755,root,root) %{py_sitedir}/readline.so
847
848 %files -n lldb-devel
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/liblldb.so
851 %{_libdir}/liblldb*.a
852 %{_includedir}/lldb
853 %endif
854
855 %if %{with ocaml}
856 %files ocaml
857 %defattr(644,root,root,755)
858 %{_libdir}/ocaml/META.llvm*
859 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
860 %{_libdir}/ocaml/llvm*.cma
861 %{_libdir}/ocaml/llvm*.cmi
862
863 %files ocaml-devel
864 %defattr(644,root,root,755)
865 %{_libdir}/ocaml/libllvm*.a
866 %{_libdir}/ocaml/llvm*.a
867 %{_libdir}/ocaml/llvm*.cmx*
868
869 %files ocaml-doc
870 %defattr(644,root,root,755)
871 %doc ocamldocs/*
872 %endif
This page took 0.086022 seconds and 4 git commands to generate.