]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
4a9d58ac82e000dca2c0086907b9d31b928e8553
[packages/llvm.git] / llvm.spec
1 # TODO:
2 # - move and package:
3 #       %{_datadir}/clang/clang-format-sublime.py - sublime plugin
4 #       %{_datadir}/clang/clang-format.el - emacs mode
5 #       %{_datadir}/clang/clang-format.py - vim plugin
6 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
7 #
8 # Conditional build:
9 %bcond_without  lldb            # LLDB debugger
10 %bcond_without  polly           # Polly cache-locality optimization, auto-parallelism and vectorization
11 %bcond_without  rt              # compiler-rt libraries
12 %bcond_without  multilib        # compiler-rt multilib libraries
13 %bcond_without  ocaml           # OCaml binding
14 %bcond_without  doc             # HTML docs and man pages
15 %bcond_with     apidocs         # doxygen docs (HUGE, so they are not built by default)
16 %bcond_with     tests           # run tests
17
18 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
19 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
20 %undefine       with_ocaml
21 %endif
22
23 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
24 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
25 Name:           llvm
26 Version:        3.8.1
27 Release:        0.1
28 License:        University of Illinois/NCSA Open Source License
29 Group:          Development/Languages
30 #Source0Download: http://llvm.org/releases/download.html
31 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
32 # Source0-md5:  538467e6028bbc9259b1e6e015d25845
33 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
34 # Source1-md5:  4ff2f8844a786edb0220f490f7896080
35 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
36 # Source2-md5:  f140db073d2453f854fbe01cc46f3110
37 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
38 # Source3-md5:  9e4787b71be8e432fffd31e13ac87623
39 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
40 # Source4-md5:  8a40e697a4ba1c8b640b85d074bd6e25
41 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
42 # Source5-md5:  6e49f285d0b366cc3cab782d8c92d382
43 Source6:        http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
44 # Source6-md5:  68cd069bf99c71ebcfbe01d557c0e14d
45 Patch0:         %{name}-lld-link.patch
46 Patch1:         %{name}-pld.patch
47 Patch2:         libdir.patch
48 Patch3:         x32-gcc-toolchain.patch
49 Patch4:         cmake-buildtype.patch
50 Patch5:         %{name}-ocaml-shared.patch
51 URL:            http://llvm.org/
52 BuildRequires:  bash
53 BuildRequires:  bison
54 BuildRequires:  cmake >= 2.8.8
55 BuildRequires:  flex
56 BuildRequires:  gcc >= 5:3.4
57 # gcc4 might be installed, but not current __cc
58 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
59 BuildRequires:  __cc >= 3.4
60 %endif
61 %ifarch x32
62 BuildRequires:  glibc-devel(x86_64)
63 %endif
64 BuildRequires:  groff
65 BuildRequires:  libltdl-devel
66 BuildRequires:  libstdc++-devel >= 5:3.4
67 %if %{with ocaml}
68 BuildRequires:  ocaml-ctypes-devel >= 0.4
69 BuildRequires:  ocaml-findlib
70 BuildRequires:  ocaml-ocamldoc
71 BuildRequires:  ocaml-ounit
72 %endif
73 BuildRequires:  perl-base >= 1:5.6
74 BuildRequires:  perl-tools-pod
75 BuildRequires:  rpm-pythonprov
76 %{?with_doc:BuildRequires:      sphinx-pdg}
77 BuildRequires:  tar >= 1:1.22
78 BuildRequires:  xz
79 %if %{with apidocs}
80 BuildRequires:  doxygen
81 BuildRequires:  graphviz
82 %endif
83 %if %{with tests}
84 BuildRequires:  dejagnu
85 BuildRequires:  python
86 BuildRequires:  tcl-devel
87 %endif
88 %if %{with rt} && %{with multilib}
89 %ifarch %{x8664}
90 BuildRequires:  gcc-c++-multilib-32
91 BuildRequires:  libstdc++-multilib-32-devel
92 %endif
93 %endif
94 %if %{with lldb}
95 BuildRequires:  epydoc
96 %ifarch i386 i486
97 BuildRequires:  libatomic-devel
98 %endif
99 BuildRequires:  libedit-devel
100 BuildRequires:  libxml2-devel >= 2
101 BuildRequires:  ncurses-ext-devel
102 BuildRequires:  python-devel >= 2
103 BuildRequires:  swig-python
104 %endif
105 %if %{with polly}
106 BuildRequires:  cloog-isl-devel
107 # >= 0.18.2-2
108 BuildRequires:  gmp-devel
109 BuildRequires:  isl-devel >= 0.14
110 # optional
111 BuildRequires:  pluto-devel
112 BuildRequires:  scoplib-devel >= 0.2.1-2
113 #cuda-devel
114 %endif
115 %if %{with ocaml}
116 BuildConflicts: llvm-ocaml
117 %endif
118 Requires:       %{name}-libs = %{version}-%{release}
119 # LLVM is not supported on PPC64
120 # http://llvm.org/bugs/show_bug.cgi?id=3729
121 ExcludeArch:    ppc64
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define         abi     3.8
125 %define         _sysconfdir     /etc/%{name}
126
127 %define         specflags_ppc   -fno-var-tracking-assignments
128
129 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
130 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
131
132 # clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
133 # -Werror=format-security is for swig
134 # TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
135 %define         filterout_c     -fvar-tracking-assignments
136 %define         filterout_cxx   -fvar-tracking-assignments -Werror=format-security
137 %define         filterout_ccpp  -fvar-tracking-assignments
138
139 # std::__once_call, std::__once_callable non-function symbols
140 %define         skip_post_check_so      liblldb.so.*
141
142 %description
143 LLVM is a compiler infrastructure designed for compile-time,
144 link-time, runtime, and idle-time optimization of programs from
145 arbitrary programming languages. LLVM is written in C++ and has been
146 developed since 2000 at the University of Illinois and Apple. It
147 currently supports compilation of C and C++ programs using clang
148 frontend.
149
150 %description -l pl.UTF-8
151 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
152 czasu kompilowania, linkowania, działania i bezczynności programów w
153 dowolnych językach programowania. Jest napisana w C++, rozwijana od
154 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
155 kompilację programów w C i C++ przy użyciu frontendu clang.
156
157 %package libs
158 Summary:        LLVM shared libraries
159 Summary(pl.UTF-8):      Biblioteki współdzielone LLVM-a
160 Group:          Libraries
161 Conflicts:      llvm < 3.2
162
163 %description libs
164 LLVM shared libraries.
165
166 %description libs -l pl.UTF-8
167 Biblioteki współdzielone LLVM-a.
168
169 %package devel
170 Summary:        Static libraries and header files for LLVM
171 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
172 Group:          Development/Languages
173 Requires:       %{name}-libs = %{version}-%{release}
174 Requires:       libstdc++-devel >= 6:3.4
175
176 %description devel
177 This package contains static libraries and header files needed to
178 develop new native programs that use the LLVM infrastructure.
179
180 %description devel -l pl.UTF-8
181 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
182 potrzebne do tworzenia nowych programów natywnych wykorzystujących
183 infrastrukturę LLVM.
184
185 %package doc
186 Summary:        Documentation for LLVM
187 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
188 Group:          Documentation
189 # does not require base
190
191 %description doc
192 Documentation for the LLVM compiler infrastructure.
193
194 %description doc -l pl.UTF-8
195 Dokumentacja do infrastruktury kompilatorów LLVM.
196
197 %package apidocs
198 Summary:        API documentation for LLVM
199 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
200 Group:          Development/Languages
201 Requires:       %{name}-doc = %{version}-%{release}
202
203 %description apidocs
204 API documentation for the LLVM compiler infrastructure.
205
206 %description apidocs -l pl.UTF-8
207 Dokumentacja API infrastruktury kompilatorów LLVM.
208
209 %package polly
210 Summary:        Polyhedral optimizations for LLVM
211 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
212 Group:          Development/Tools
213 URL:            http://polly.llvm.org/
214 Requires:       %{name} = %{version}-%{release}
215
216 %description polly
217 Polly is a high-level loop and data-locality optimizer and
218 optimization infrastructure for LLVM. It uses an abstract mathematical
219 representation based on integer polyhedra to analyze and optimize the
220 memory access pattern of a program.
221
222 %description polly -l pl.UTF-8
223 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
224 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
225 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
226 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
227
228 %package polly-devel
229 Summary:        Header files for LLVM Polly optimization infrastructure
230 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
231 Group:          Development/Libraries
232 URL:            http://polly.llvm.org/
233 Requires:       %{name}-devel = %{version}-%{release}
234 Requires:       %{name}-polly = %{version}-%{release}
235
236 %description polly-devel
237 Header files for LLVM Polly optimization infrastructure.
238
239 %description polly-devel -l pl.UTF-8
240 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
241
242 %package -n clang
243 Summary:        A C language family frontend for LLVM
244 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
245 License:        NCSA
246 Group:          Development/Languages
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       clang-libs = %{version}-%{release}
249
250 %description -n clang
251 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
252 of a crane or goose. 3. C-language family front-end toolkit.
253
254 The goal of the Clang project is to create a new C, C++, Objective C
255 and Objective C++ front-end for the LLVM compiler. Its tools are built
256 as libraries and designed to be loosely-coupled and extendable.
257
258 %description -n clang -l pl.UTF-8
259 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
260 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
261 z rodziny C.
262
263 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
264 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
265 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
266 i rozszerzaniu.
267
268 %package -n clang-libs
269 Summary:        Clang shared libraries
270 Summary(pl.UTF-8):      Biblioteki współdzielone Clanga
271 Group:          Libraries
272
273 %description -n clang-libs
274 Clang shared libraries.
275
276 %description -n clang-libs -l pl.UTF-8
277 Biblioteki współdzielone Clanga.
278
279 %package -n clang-multilib
280 Summary:        A C language family frontend for LLVM - 32-bit support
281 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
282 License:        NCSA
283 Group:          Development/Languages
284 Requires:       clang = %{version}-%{release}
285
286 %description -n clang-multilib
287 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
288 of a crane or goose. 3. C-language family front-end toolkit.
289
290 The goal of the Clang project is to create a new C, C++, Objective C
291 and Objective C++ front-end for the LLVM compiler. Its tools are built
292 as libraries and designed to be loosely-coupled and extendable.
293
294 This package contains the C compiler support for producing 32-bit
295 programs on 64-bit host.
296
297 %description -n clang-multilib -l pl.UTF-8
298 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
299 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
300 z rodziny C.
301
302 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
303 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
304 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
305 i rozszerzaniu.
306
307 Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
308 programów 32-bitowych na maszynie 64-bitowej.
309
310 %package -n clang-analyzer
311 Summary:        A source code analysis framework
312 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
313 License:        NCSA
314 Group:          Development/Languages
315 Requires:       clang = %{version}-%{release}
316 # not picked up automatically since files are currently not instaled
317 # in standard Python hierarchies yet
318 Requires:       python
319
320 %description -n clang-analyzer
321 The Clang Static Analyzer consists of both a source code analysis
322 framework and a standalone tool that finds bugs in C and Objective-C
323 programs. The standalone tool is invoked from the command-line, and is
324 intended to run in tandem with a build of a project or code base.
325
326 %description -n clang-analyzer -l pl.UTF-8
327 Clang Static Analyzer składa się ze szkieletu do analizy kodu
328 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
329 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
330 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
331
332 %package -n clang-devel
333 Summary:        Header files for Clang
334 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
335 Group:          Development/Languages
336 Requires:       %{name}-devel = %{version}-%{release}
337 Requires:       clang = %{version}-%{release}
338
339 %description -n clang-devel
340 This package contains header files for the Clang compiler.
341
342 %description -n clang-devel -l pl.UTF-8
343 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
344
345 %package -n clang-doc
346 Summary:        Documentation for Clang
347 Summary(pl.UTF-8):      Dokumentacja do Clanga
348 Group:          Documentation
349 Requires:       %{name} = %{version}-%{release}
350
351 %description -n clang-doc
352 Documentation for the Clang compiler front-end.
353
354 %description -n clang-doc -l pl.UTF-8
355 Dokumentacja do frontendu kompilatora Clang.
356
357 %package -n clang-apidocs
358 Summary:        API documentation for Clang
359 Summary(pl.UTF-8):      Dokumentacja API Clanga
360 Group:          Development/Languages
361 Requires:       clang-doc = %{version}-%{release}
362
363 %description -n clang-apidocs
364 API documentation for the Clang compiler.
365
366 %description -n clang-apidocs -l pl.UTF-8
367 Dokumentacja API kompilatora Clang.
368
369 %package -n clang-tools-extra
370 Summary:        Extra tools for Clang
371 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
372 Group:          Development/Tools
373 URL:            http://clang.llvm.org/docs/ClangTools.html
374 Requires:       clang = %{version}-%{release}
375
376 %description -n clang-tools-extra
377 Extra tools for Clang.
378
379 %description -n clang-tools-extra -l pl.UTF-8
380 Dodatkowe narzędzia do kompilatora Clang.
381
382 %package -n lld
383 Summary:        The LLVM linker
384 Summary(pl.UTF-8):      Konsolidator z projektu LLVM
385 Group:          Development/Libraries
386 URL:            http://lld.llvm.org/
387 Requires:       %{name} = %{version}-%{release}
388
389 %description -n lld
390 lld is a new set of modular code for creating linker tools.
391
392 %description -n lld -l pl.UTF-8
393 lld to nowy zbiór modularnego kodu do tworzenia narzędzi
394 konsolidujących.
395
396 %package -n lld-devel
397 Summary:        Development files for LLD linker tools
398 Summary(pl.UTF-8):      Pliki programistyczne narzędzi konsolidujących LLD
399 Group:          Development/Tools
400 URL:            http://lld.llvm.org/
401 Requires:       %{name}-devel = %{version}-%{release}
402
403 %description -n lld-devel
404 Development files for LLD linker tools.
405
406 %description -n lld-devel -l pl.UTF-8
407 Pliki programistyczne narzędzi konsolidujących LLD.
408
409 %package -n lldb
410 Summary:        Next generation high-performance debugger
411 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
412 Group:          Development/Debuggers
413 URL:            http://lldb.llvm.org/
414 Requires:       %{name} = %{version}-%{release}
415 Requires:       python-six
416
417 %description -n lldb
418 LLDB is a next generation, high-performance debugger. It is built as a
419 set of reusable components which highly leverage existing libraries in
420 the larger LLVM Project, such as the Clang expression parser and LLVM
421 disassembler.
422
423 %description -n lldb -l pl.UTF-8
424 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
425 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
426 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
427 disasembler LLVM.
428
429 %package -n lldb-devel
430 Summary:        Development files for LLDB debugger
431 Summary(pl.UTF-8):      Pliki programistyczne debuggera LLDB
432 Group:          Development/Libraries
433 URL:            http://lldb.llvm.org/
434 Requires:       %{name}-devel = %{version}-%{release}
435 Requires:       clang-devel = %{version}-%{release}
436 Requires:       lldb = %{version}-%{release}
437
438 %description -n lldb-devel
439 Development files for LLDB debugger.
440
441 %description -n lldb-devel -l pl.UTF-8
442 Pliki programistyczne debuggera LLDB.
443
444 %package ocaml
445 Summary:        OCaml binding for LLVM
446 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
447 Group:          Libraries
448 Requires:       %{name} = %{version}-%{release}
449 %requires_eq    ocaml-runtime
450
451 %description ocaml
452 OCaml binding for LLVM.
453
454 %description ocaml -l pl.UTF-8
455 Wiązanie OCamla do LLVM-a.
456
457 %package ocaml-devel
458 Summary:        Development files for LLVM OCaml binding
459 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
460 Group:          Development/Libraries
461 Requires:       %{name}-devel = %{version}-%{release}
462 Requires:       %{name}-ocaml = %{version}-%{release}
463
464 %description ocaml-devel
465 The llvm-ocaml-devel package contains libraries and signature files
466 for developing applications that use llvm-ocaml binding.
467
468 %description ocaml-devel -l pl.UTF-8
469 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
470 wykorzystujących wiązanie llvm-ocaml.
471
472 %package ocaml-doc
473 Summary:        Documentation for LLVM's OCaml binding
474 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
475 Group:          Documentation
476 Requires:       %{name}-ocaml = %{version}-%{release}
477
478 %description ocaml-doc
479 HTML documentation for LLVM's OCaml binding.
480
481 %description ocaml-doc -l pl.UTF-8
482 Dokumentacja HTML wiązania OCamla do LLVM-a.
483
484 %prep
485 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
486 %{__mv} cfe-%{version}.src tools/clang
487 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
488 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
489 %{?with_polly:mv polly-%{version}.src tools/polly}
490 %{__mv} clang-tools-extra-%{version}.src tools/clang/tools/extra
491 %{__mv} lld-%{version}.src tools/lld
492
493 %patch0 -p1
494 %patch1 -p1
495 %patch2 -p1
496 %patch3 -p1
497 %patch4 -p1
498 %patch5 -p1
499
500 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
501         s,^#!.*bin/env python,#!%{__python},
502         s,^#!.*bin/env perl,#!%{__perl},
503 }'
504
505 %build
506 install -d build
507
508 # Disabling assertions now, rec. by pure and needed for OpenGTL
509 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
510 cd build
511 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
512
513 %cmake \
514 %ifarch %{x8664}
515         -DLLVM_LIBDIR_SUFFIX:STRING=64 \
516 %endif
517 %ifarch x32
518         -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
519 %endif
520 %if %{with apidocs}
521         -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
522 %endif
523 %if %{with doc}
524         -DLLVM_ENABLE_SPHINX:BOOL=ON \
525         -DSPHINX_WARNINGS_AS_ERRORS=OFF \
526 %endif
527         -DLLVM_ENABLE_PIC:BOOL=ON \
528         -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
529         -DLLVM_ENABLE_CXX1Y:BOOL=ON \
530         -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
531         -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
532         -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
533         -DBUILD_SHARED_LIBS:BOOL=OFF \
534         ../
535
536 %{__make} \
537         VERBOSE=1 \
538         REQUIRES_RTTI=1 \
539         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
540
541 %if %{with tests}
542 %{__make} check 2>&1 | tee llvm-testlog.txt
543 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
544 %endif
545
546 %if %{with doc}
547 %{__make} -C docs docs-llvm-html
548 %{__make} -C docs docs-llvm-man
549 %if %{with ocaml}
550 %{__make} -C docs ocaml_doc
551 %endif
552 %{__make} -C tools/clang/docs docs-clang-html
553 %{__make} -C tools/clang/docs docs-clang-man
554 %{__make} -C tools/lld/docs docs-lld-html
555 %{__make} -C tools/lldb/docs lldb-python-doc
556 %{__make} -C tools/lldb/docs lldb-cpp-doc
557 %{__make} -C ../tools/clang/tools/extra/docs html
558 %endif
559
560 %install
561 rm -rf $RPM_BUILD_ROOT
562 %{__make} -C build install \
563         DESTDIR=$RPM_BUILD_ROOT
564
565 # only some .pyc files are created by make install
566 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
567 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
568
569 # Adjust static analyzer installation
570 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
571 install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
572 %{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
573 %{__sed} -i -e 's,/\.\./libexec/,../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
574 %py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
575 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
576 %py_postclean %{_datadir}/scan-view
577
578 # not installed by cmake buildsystem
579 install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
580
581 %if %{with doc}
582 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
583 # these tools are not installed
584 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
585 # make links
586 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
587 %endif
588
589 # Move documentation back to build directory
590 %if %{with ocaml}
591 rm -rf ocamldocs
592 %{__mv} $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
593 %endif
594
595 # and separate the apidoc
596 %if %{with apidocs}
597 rm -rf clang-apidoc
598 cp -a build/tools/clang/docs/html clang-apidoc
599 %endif
600
601 # And prepare Clang documentation
602 rm -rf clang-docs
603 install -d clang-docs
604 for f in LICENSE.TXT NOTES.txt README.txt; do
605         ln tools/clang/$f clang-docs
606 done
607
608 # Get rid of erroneously installed example files.
609 %{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
610 # test?
611 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
612 # not this OS
613 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
614 # use system six
615 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/six.py*
616
617 %clean
618 rm -rf $RPM_BUILD_ROOT
619
620 %post   libs -p /sbin/ldconfig
621 %postun libs -p /sbin/ldconfig
622
623 %post   -n clang -p /sbin/ldconfig
624 %postun -n clang -p /sbin/ldconfig
625
626 %post   -n lldb -p /sbin/ldconfig
627 %postun -n lldb -p /sbin/ldconfig
628
629 %files
630 %defattr(644,root,root,755)
631 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
632 %attr(755,root,root) %{_bindir}/bugpoint
633 %attr(755,root,root) %{_bindir}/llc
634 %attr(755,root,root) %{_bindir}/lli
635 %attr(755,root,root) %{_bindir}/llvm-ar
636 %attr(755,root,root) %{_bindir}/llvm-as
637 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
638 %attr(755,root,root) %{_bindir}/llvm-cov
639 %attr(755,root,root) %{_bindir}/llvm-diff
640 %attr(755,root,root) %{_bindir}/llvm-dis
641 %attr(755,root,root) %{_bindir}/llvm-dsymutil
642 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
643 %attr(755,root,root) %{_bindir}/llvm-dwp
644 %attr(755,root,root) %{_bindir}/llvm-extract
645 %attr(755,root,root) %{_bindir}/llvm-lib
646 %attr(755,root,root) %{_bindir}/llvm-link
647 %attr(755,root,root) %{_bindir}/llvm-lto
648 %attr(755,root,root) %{_bindir}/llvm-mc
649 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
650 %attr(755,root,root) %{_bindir}/llvm-nm
651 %attr(755,root,root) %{_bindir}/llvm-objdump
652 %attr(755,root,root) %{_bindir}/llvm-profdata
653 %attr(755,root,root) %{_bindir}/llvm-ranlib
654 %attr(755,root,root) %{_bindir}/llvm-readobj
655 %attr(755,root,root) %{_bindir}/llvm-rtdyld
656 %attr(755,root,root) %{_bindir}/llvm-size
657 %attr(755,root,root) %{_bindir}/llvm-split
658 %attr(755,root,root) %{_bindir}/llvm-stress
659 %attr(755,root,root) %{_bindir}/llvm-symbolizer
660 %attr(755,root,root) %{_bindir}/llvm-tblgen
661 %attr(755,root,root) %{_bindir}/llvm-cxxdump
662 %attr(755,root,root) %{_bindir}/llvm-pdbdump
663 %attr(755,root,root) %{_bindir}/obj2yaml
664 %attr(755,root,root) %{_bindir}/opt
665 %attr(755,root,root) %{_bindir}/sancov
666 %attr(755,root,root) %{_bindir}/verify-uselistorder
667 %attr(755,root,root) %{_bindir}/yaml2obj
668 %if %{with doc}
669 %{_mandir}/man1/bugpoint.1*
670 %{_mandir}/man1/lit.1*
671 %{_mandir}/man1/llc.1*
672 %{_mandir}/man1/lli.1*
673 %{_mandir}/man1/llvm-ar.1*
674 %{_mandir}/man1/llvm-as.1*
675 %{_mandir}/man1/llvm-bcanalyzer.1*
676 %{_mandir}/man1/llvm-cov.1*
677 %{_mandir}/man1/llvm-diff.1*
678 %{_mandir}/man1/llvm-dis.1*
679 %{_mandir}/man1/llvm-dwarfdump.1*
680 %{_mandir}/man1/llvm-extract.1*
681 %{_mandir}/man1/llvm-lib.1*
682 %{_mandir}/man1/llvm-link.1*
683 %{_mandir}/man1/llvm-nm.1*
684 %{_mandir}/man1/llvm-profdata.1*
685 %{_mandir}/man1/llvm-ranlib.1*
686 %{_mandir}/man1/llvm-readobj.1*
687 %{_mandir}/man1/llvm-stress.1*
688 %{_mandir}/man1/llvm-symbolizer.1*
689 %{_mandir}/man1/opt.1*
690 %{_mandir}/man1/tblgen.1*
691 %endif
692
693 %files libs
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
696 # non-soname symlink
697 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
698 %attr(755,root,root) %{_libdir}/libLTO.so
699
700 %files devel
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_bindir}/llvm-config
703 %attr(755,root,root) %{_libdir}/libLLVM.so
704 %attr(755,root,root) %{_libdir}/BugpointPasses.so
705 %{_libdir}/libLLVM*.a
706 %{_includedir}/llvm
707 %{_includedir}/llvm-c
708 %dir %{_datadir}/llvm
709 %{_datadir}/llvm/cmake
710 %if %{with doc}
711 %{_mandir}/man1/llvm-config.1*
712 %endif
713
714 #%files doc
715 #%defattr(644,root,root,755)
716
717 %if %{with apidocs}
718 %files apidocs
719 %defattr(644,root,root,755)
720 %doc apidoc/*
721 %endif
722
723 %if %{with polly}
724 %files polly
725 %defattr(644,root,root,755)
726 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
727 %attr(755,root,root) %{_libdir}/LLVMPolly.so
728
729 %files polly-devel
730 %defattr(644,root,root,755)
731 %{_libdir}/libPolly.a
732 %{_libdir}/libPollyISL.a
733 %{_includedir}/polly
734 %endif
735
736 %files -n clang
737 %defattr(644,root,root,755)
738 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
739 %attr(755,root,root) %{_bindir}/clang
740 %attr(755,root,root) %{_bindir}/clang++
741 %attr(755,root,root) %{_bindir}/clang-%{abi}
742 %attr(755,root,root) %{_bindir}/clang-check
743 %attr(755,root,root) %{_bindir}/clang-cl
744 %attr(755,root,root) %{_bindir}/clang-format
745 %attr(755,root,root) %{_bindir}/git-clang-format
746 %dir %{_libdir}/clang
747 %dir %{_libdir}/clang/%{version}
748 %{_libdir}/clang/%{version}/include
749 %if %{with rt}
750 %ifarch %{ix86} %{x8664}
751 %dir %{_libdir}/clang/%{version}/lib
752 %dir %{_libdir}/clang/%{version}/lib/linux
753 %endif
754 %ifarch %{ix86}
755 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
756 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
757 %endif
758 %ifarch %{x8664}
759 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
760 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
761 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
762 %endif
763 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips mips64 ppc64
764 %{_libdir}/clang/%{version}/asan_blacklist.txt
765 %endif
766 %ifarch %{ix86} %{x8664} mips64
767 %{_libdir}/clang/%{version}/cfi_blacklist.txt
768 %endif
769 %ifarch %{x8664} aarch64 mips64
770 %{_libdir}/clang/%{version}/dfsan_abilist.txt
771 %{_libdir}/clang/%{version}/msan_blacklist.txt
772 %endif
773 %endif
774 %dir %{_datadir}/clang
775 %{_datadir}/clang/clang-format-diff.py
776
777 %files -n clang-libs
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libclang.so.%{abi}
780
781 %if %{with rt} && %{with multilib}
782 %ifarch %{x8664}
783 %files -n clang-multilib
784 %defattr(644,root,root,755)
785 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
786 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
787 %endif
788 %endif
789
790 %files -n clang-analyzer
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_bindir}/scan-build
793 %attr(755,root,root) %{_bindir}/scan-view
794 %{_datadir}/scan-build
795 %{_datadir}/scan-view
796 %{_mandir}/man1/scan-build.1*
797 %dir %{_libdir}/scan-build
798 %attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
799 %attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
800
801 %files -n clang-devel
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libclang.so
804 %{_libdir}/libclang*.a
805 %{_includedir}/clang
806 %{_includedir}/clang-c
807 %{_datadir}/clang/cmake
808
809 %files -n clang-doc
810 %defattr(644,root,root,755)
811 %doc tools/clang/docs/*.{html,png,txt}
812
813 %if %{with apidocs}
814 %files -n clang-apidocs
815 %defattr(644,root,root,755)
816 %doc clang-apidoc/*
817 %endif
818
819 %files -n clang-tools-extra
820 %defattr(644,root,root,755)
821 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
822 %attr(755,root,root) %{_bindir}/clang-apply-replacements
823 %attr(755,root,root) %{_bindir}/clang-query
824 %attr(755,root,root) %{_bindir}/clang-rename
825 %attr(755,root,root) %{_bindir}/clang-tidy
826 %attr(755,root,root) %{_bindir}/modularize
827 %attr(755,root,root) %{_bindir}/pp-trace
828 %{_datadir}/clang/clang-tidy-diff.py
829 %{_datadir}/clang/run-clang-tidy.py
830
831 %files -n lld
832 %defattr(644,root,root,755)
833 %doc tools/lld/{LICENSE.TXT,README.md}
834 %attr(755,root,root) %{_bindir}/ld.lld
835 %attr(755,root,root) %{_bindir}/lld
836 %attr(755,root,root) %{_bindir}/lld-link
837
838 %files -n lld-devel
839 %defattr(644,root,root,755)
840 %{_libdir}/liblld[ACDEHMRXY]*.a
841 %{_includedir}/lld
842
843 %if %{with lldb}
844 %files -n lldb
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_bindir}/lldb
847 %attr(755,root,root) %{_bindir}/lldb-%{version}
848 %attr(755,root,root) %{_bindir}/lldb-argdumper
849 %attr(755,root,root) %{_bindir}/lldb-mi
850 %attr(755,root,root) %{_bindir}/lldb-mi-%{version}
851 %attr(755,root,root) %{_bindir}/lldb-server
852 %attr(755,root,root) %{_bindir}/lldb-server-%{version}
853 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
854 %dir %{py_sitedir}/lldb
855 %attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
856 %{py_sitedir}/lldb/formatters
857 %{py_sitedir}/lldb/runtime
858 %{py_sitedir}/lldb/utils
859 %{py_sitedir}/lldb/__init__.py[co]
860 %{py_sitedir}/lldb/embedded_interpreter.py[co]
861 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
862 %attr(755,root,root) %{py_sitedir}/readline.so
863
864 %files -n lldb-devel
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/liblldb.so
867 %{_libdir}/liblldb*.a
868 %{_includedir}/lldb
869 %endif
870
871 %if %{with ocaml}
872 %files ocaml
873 %defattr(644,root,root,755)
874 %{_libdir}/ocaml/META.llvm*
875 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
876 %{_libdir}/ocaml/llvm*.cma
877 %{_libdir}/ocaml/llvm*.cmi
878
879 %files ocaml-devel
880 %defattr(644,root,root,755)
881 %{_libdir}/ocaml/libllvm*.a
882 %{_libdir}/ocaml/llvm*.a
883 %{_libdir}/ocaml/llvm*.cmx*
884
885 %files ocaml-doc
886 %defattr(644,root,root,755)
887 %doc ocamldocs/*
888 %endif
This page took 0.15034 seconds and 3 git commands to generate.