]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
- reworked config patch for 3.6.0
[packages/llvm.git] / llvm.spec
1 #
2 # Conditional build:
3 %bcond_without  lldb    # LLDB debugger
4 %bcond_without  polly   # Polly cache-locality optimization, auto-parallelism and vectorization
5 %bcond_without  rt      # compiler-rt libraries
6 %bcond_without  ocaml   # OCaml binding
7 %bcond_without  doc     # HTML docs and man pages
8 %bcond_with     apidocs # doxygen docs (HUGE, so they are not built by default)
9 %bcond_with     tests   # run tests
10
11 %ifarch s390 s390x sparc64 x32
12 # No ocaml on these arches or no native ocaml (required for ocaml-ctypes)
13 %undefine       with_ocaml
14 %endif
15
16 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
17 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
18 Name:           llvm
19 Version:        3.6.0
20 Release:        0.1
21 License:        University of Illinois/NCSA Open Source License
22 Group:          Development/Languages
23 #Source0Download: http://llvm.org/releases/download.html
24 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
25 # Source0-md5:  f1e14e949f8df3047c59816c55278cec
26 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
27 # Source1-md5:  e3012065543dc6ab8a9842b09616b78d
28 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
29 # Source2-md5:  cc36dbcafe43406083e98bc9e74f8054
30 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
31 # Source3-md5:  a1ea02b3126152f3dd9aeee8ebb5afa5
32 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
33 # Source4-md5:  73d3d3b024da1e542ed5ecd8c936bd08
34 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
35 # Source5-md5:  85a170713a0b15a728b0cfd7b63c546c
36 Source6:        http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
37 # Source6-md5:  482dc6f72f6e9ff80bc520987c5b4f7e
38 Patch0:         %{name}-config.patch
39 # Data files should be installed with timestamps preserved
40 Patch1:         %{name}-2.6-timestamp.patch
41 Patch2:         %{name}-pld.patch
42 Patch4:         %{name}-lldb.patch
43 Patch5:         %{name}-lldb-atomic.patch
44 Patch6:         %{name}-lld-link.patch
45 URL:            http://llvm.org/
46 BuildRequires:  autoconf >= 2.60
47 BuildRequires:  automake >= 1:1.9.6
48 BuildRequires:  bash
49 BuildRequires:  bison
50 BuildRequires:  flex
51 BuildRequires:  gcc >= 5:3.4
52 # gcc4 might be installed, but not current __cc
53 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
54 BuildRequires:  __cc >= 3.4
55 %endif
56 %ifarch x32
57 BuildRequires:  glibc-devel(x86_64)
58 %endif
59 BuildRequires:  groff
60 BuildRequires:  libltdl-devel
61 BuildRequires:  libtool >= 2:1.5.22
62 BuildRequires:  libstdc++-devel >= 5:3.4
63 %if %{with ocaml}
64 BuildRequires:  ocaml-ctypes
65 BuildRequires:  ocaml-findlib
66 BuildRequires:  ocaml-ocamldoc
67 BuildRequires:  ocaml-ounit
68 %endif
69 BuildRequires:  perl-base >= 1:5.6
70 BuildRequires:  perl-tools-pod
71 BuildRequires:  rpm-pythonprov
72 %{?with_doc:BuildRequires:      sphinx-pdg}
73 BuildRequires:  tar >= 1:1.22
74 BuildRequires:  xz
75 %if %{with apidocs}
76 BuildRequires:  doxygen
77 BuildRequires:  graphviz
78 %endif
79 %if %{with tests}
80 BuildRequires:  dejagnu
81 BuildRequires:  python
82 BuildRequires:  tcl-devel
83 %endif
84 %if %{with lldb}
85 %ifarch i386 i486
86 BuildRequires:  libatomic-devel
87 %endif
88 BuildRequires:  libedit-devel
89 BuildRequires:  libxml2-devel >= 2
90 BuildRequires:  ncurses-ext-devel
91 BuildRequires:  python-devel >= 2
92 %endif
93 %if %{with polly}
94 BuildRequires:  cloog-isl-devel
95 # >= 0.18.2-2
96 BuildRequires:  gmp-devel
97 BuildRequires:  isl-devel >= 0.14
98 # optional
99 BuildRequires:  pluto-devel
100 BuildRequires:  scoplib-devel >= 0.2.1-2
101 #cuda-devel
102 %endif
103 Requires:       %{name}-libs = %{version}-%{release}
104 # LLVM is not supported on PPC64
105 # http://llvm.org/bugs/show_bug.cgi?id=3729
106 ExcludeArch:    ppc64
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         _sysconfdir     /etc/%{name}
110
111 %define         specflags_ppc   -fno-var-tracking-assignments
112
113 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
114 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
115
116 %description
117 LLVM is a compiler infrastructure designed for compile-time,
118 link-time, runtime, and idle-time optimization of programs from
119 arbitrary programming languages. LLVM is written in C++ and has been
120 developed since 2000 at the University of Illinois and Apple. It
121 currently supports compilation of C and C++ programs using clang
122 frontend.
123
124 %description -l pl.UTF-8
125 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
126 czasu kompilowania, linkowania, działania i bezczynności programów w
127 dowolnych językach programowania. Jest napisana w C++, rozwijana od
128 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
129 kompilację programów w C i C++ przy użyciu frontendu clang.
130
131 %package libs
132 Summary:        LLVM shared library
133 Summary(pl.UTF-8):      Biblioteka współdzielona LLVM-a
134 Group:          Libraries
135 Conflicts:      llvm < 3.2
136
137 %description libs
138 LLVM shared library.
139
140 %description libs -l pl.UTF-8
141 Biblioteka współdzielona LLVM-a.
142
143 %package devel
144 Summary:        Static libraries and header files for LLVM
145 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
146 Group:          Development/Languages
147 Requires:       %{name}-libs = %{version}-%{release}
148 Requires:       libstdc++-devel >= 6:3.4
149
150 %description devel
151 This package contains static libraries and header files needed to
152 develop new native programs that use the LLVM infrastructure.
153
154 %description devel -l pl.UTF-8
155 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
156 potrzebne do tworzenia nowych programów natywnych wykorzystujących
157 infrastrukturę LLVM.
158
159 %package doc
160 Summary:        Documentation for LLVM
161 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
162 Group:          Documentation
163 # does not require base
164
165 %description doc
166 Documentation for the LLVM compiler infrastructure.
167
168 %description doc -l pl.UTF-8
169 Dokumentacja do infrastruktury kompilatorów LLVM.
170
171 %package apidocs
172 Summary:        API documentation for LLVM
173 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
174 Group:          Development/Languages
175 Requires:       %{name}-doc = %{version}-%{release}
176
177 %description apidocs
178 API documentation for the LLVM compiler infrastructure.
179
180 %description apidocs -l pl.UTF-8
181 Dokumentacja API infrastruktury kompilatorów LLVM.
182
183 %package polly
184 Summary:        Polyhedral optimizations for LLVM
185 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
186 Group:          Development/Tools
187 URL:            http://polly.llvm.org/
188 Requires:       %{name} = %{version}-%{release}
189
190 %description polly
191 Polly is a high-level loop and data-locality optimizer and
192 optimization infrastructure for LLVM. It uses an abstract mathematical
193 representation based on integer polyhedra to analyze and optimize the
194 memory access pattern of a program.
195
196 %description polly -l pl.UTF-8
197 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
198 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
199 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
200 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
201
202 %package polly-devel
203 Summary:        Header files for LLVM Polly optimization infrastructure
204 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
205 Group:          Development/Libraries
206 URL:            http://polly.llvm.org/
207 Requires:       %{name}-devel = %{version}-%{release}
208 Requires:       %{name}-polly = %{version}-%{release}
209
210 %description polly-devel
211 Header files for LLVM Polly optimization infrastructure.
212
213 %description polly-devel -l pl.UTF-8
214 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
215
216 %package -n clang
217 Summary:        A C language family frontend for LLVM
218 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
219 License:        NCSA
220 Group:          Development/Languages
221 Requires:       %{name} = %{version}-%{release}
222
223 %description -n clang
224 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
225 of a crane or goose. 3. C-language family front-end toolkit.
226
227 The goal of the Clang project is to create a new C, C++, Objective C
228 and Objective C++ front-end for the LLVM compiler. Its tools are built
229 as libraries and designed to be loosely-coupled and extendable.
230
231 %description -n clang -l pl.UTF-8
232 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
233 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
234 z rodziny C.
235
236 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
237 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
238 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
239 i rozszerzaniu.
240
241 %package -n clang-analyzer
242 Summary:        A source code analysis framework
243 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
244 License:        NCSA
245 Group:          Development/Languages
246 Requires:       clang = %{version}-%{release}
247 # not picked up automatically since files are currently not instaled
248 # in standard Python hierarchies yet
249 Requires:       python
250
251 %description -n clang-analyzer
252 The Clang Static Analyzer consists of both a source code analysis
253 framework and a standalone tool that finds bugs in C and Objective-C
254 programs. The standalone tool is invoked from the command-line, and is
255 intended to run in tandem with a build of a project or code base.
256
257 %description -n clang-analyzer -l pl.UTF-8
258 Clang Static Analyzer składa się ze szkieletu do analizy kodu
259 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
260 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
261 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
262
263 %package -n clang-devel
264 Summary:        Header files for Clang
265 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
266 Group:          Development/Languages
267 Requires:       %{name}-devel = %{version}-%{release}
268 Requires:       clang = %{version}-%{release}
269
270 %description -n clang-devel
271 This package contains header files for the Clang compiler.
272
273 %description -n clang-devel -l pl.UTF-8
274 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
275
276 %package -n clang-doc
277 Summary:        Documentation for Clang
278 Summary(pl.UTF-8):      Dokumentacja do Clanga
279 Group:          Documentation
280 Requires:       %{name} = %{version}-%{release}
281
282 %description -n clang-doc
283 Documentation for the Clang compiler front-end.
284
285 %description -n clang-doc -l pl.UTF-8
286 Dokumentacja do frontendu kompilatora Clang.
287
288 %package -n clang-apidocs
289 Summary:        API documentation for Clang
290 Summary(pl.UTF-8):      Dokumentacja API Clanga
291 Group:          Development/Languages
292 Requires:       clang-doc = %{version}-%{release}
293
294 %description -n clang-apidocs
295 API documentation for the Clang compiler.
296
297 %description -n clang-apidocs -l pl.UTF-8
298 Dokumentacja API kompilatora Clang.
299
300 %package -n clang-tools-extra
301 Summary:        Extra tools for Clang
302 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
303 Group:          Development/Tools
304 URL:            http://clang.llvm.org/docs/ClangTools.html
305 Requires:       clang = %{version}-%{release}
306
307 %description -n clang-tools-extra
308 Extra tools for Clang.
309
310 %description -n clang-tools-extra -l pl.UTF-8
311 Dodatkowe narzędzia do kompilatora Clang.
312
313 %package -n lld
314 Summary:        The LLVM linker
315 Summary(pl.UTF-8):      Konsolidator z projektu LLVM
316 Group:          Development/Libraries
317 URL:            http://lld.llvm.org/
318 Requires:       %{name} = %{version}-%{release}
319
320 %description -n lld
321 lld is a new set of modular code for creating linker tools.
322
323 %description -n lld -l pl.UTF-8
324 lld to nowy zbiór modularnego kodu do tworzenia narzędzi
325 konsolidujących.
326
327 %package -n lld-devel
328 Summary:        Development files for LLD linker tools
329 Summary(pl.UTF-8):      Pliki programistyczne narzędzi konsolidujących LLD
330 Group:          Development/Tools
331 URL:            http://lld.llvm.org/
332 Requires:       %{name}-devel = %{version}-%{release}
333
334 %description -n lld-devel
335 Development files for LLD linker tools.
336
337 %description -n lld-devel -l pl.UTF-8
338 Pliki programistyczne narzędzi konsolidujących LLD.
339
340 %package -n lldb
341 Summary:        Next generation high-performance debugger
342 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
343 Group:          Development/Debuggers
344 URL:            http://lldb.llvm.org/
345 Requires:       %{name} = %{version}-%{release}
346
347 %description -n lldb
348 LLDB is a next generation, high-performance debugger. It is built as a
349 set of reusable components which highly leverage existing libraries in
350 the larger LLVM Project, such as the Clang expression parser and LLVM
351 disassembler.
352
353 %description -n lldb -l pl.UTF-8
354 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
355 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
356 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
357 disasembler LLVM.
358
359 %package -n lldb-devel
360 Summary:        Development files for LLDB debugger
361 Summary(pl.UTF-8):      Pliki programistyczne debuggera LLDB
362 Group:          Development/Libraries
363 URL:            http://lldb.llvm.org/
364 Requires:       %{name}-devel = %{version}-%{release}
365 Requires:       clang-devel = %{version}-%{release}
366 Requires:       lldb = %{version}-%{release}
367
368 %description -n lldb-devel
369 Development files for LLDB debugger.
370
371 %description -n lldb-devel -l pl.UTF-8
372 Pliki programistyczne debuggera LLDB.
373
374 %package ocaml
375 Summary:        OCaml binding for LLVM
376 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
377 Group:          Libraries
378 Requires:       %{name} = %{version}-%{release}
379 %requires_eq    ocaml-runtime
380
381 %description ocaml
382 OCaml binding for LLVM.
383
384 %description ocaml -l pl.UTF-8
385 Wiązanie OCamla do LLVM-a.
386
387 %package ocaml-devel
388 Summary:        Development files for LLVM OCaml binding
389 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
390 Group:          Development/Libraries
391 Requires:       %{name}-devel = %{version}-%{release}
392 Requires:       %{name}-ocaml = %{version}-%{release}
393
394 %description ocaml-devel
395 The llvm-ocaml-devel package contains libraries and signature files
396 for developing applications that use llvm-ocaml binding.
397
398 %description ocaml-devel -l pl.UTF-8
399 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
400 wykorzystujących wiązanie llvm-ocaml.
401
402 %package ocaml-doc
403 Summary:        Documentation for LLVM's OCaml binding
404 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
405 Group:          Documentation
406 Requires:       %{name}-ocaml = %{version}-%{release}
407
408 %description ocaml-doc
409 HTML documentation for LLVM's OCaml binding.
410
411 %description ocaml-doc -l pl.UTF-8
412 Dokumentacja HTML wiązania OCamla do LLVM-a.
413
414 %prep
415 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
416 mv cfe-%{version}.src tools/clang
417 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
418 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
419 %{?with_polly:mv polly-%{version}.src tools/polly}
420 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
421 mv lld-%{version}.src tools/lld
422
423 %patch0 -p1
424 %patch1 -p1
425 %patch2 -p1
426 %if %{with lldb}
427 %patch4 -p1
428 %ifarch i386 i486
429 %patch5 -p1
430 %endif
431 %endif
432 %patch6 -p1
433
434 # configure does not properly specify libdir
435 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
436 # clang resources
437 %{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
438 %{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
439
440 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
441         s,^#!.*bin/env python,#!%{__python},
442         s,^#!.*bin/env perl,#!%{__perl},
443 }'
444
445 %build
446 install -d obj
447 %if "%{_lib}" != "lib"
448 # workaround for clang relative search paths building
449 install -d obj/Release
450 ln -snf lib obj/Release/%{_lib}
451 %endif
452
453 cd autoconf
454 %{__aclocal} -I m4
455 %{__autoconf} -o ../configure configure.ac
456 cd ..
457 %{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
458 %if %{with polly}
459 cd tools/polly/autoconf
460 %{__aclocal} -I m4 -I ../../../autoconf/m4
461 %{__autoconf} -o ../configure configure.ac
462 cd ..
463 %{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
464 cd ../..
465 %endif
466
467 # Disabling assertions now, rec. by pure and needed for OpenGTL
468 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
469 #
470 # bash specific 'test a < b'
471 cd obj
472 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64 \
473 %ifarch %{x8664}
474 -DLLVM_LIBDIR_SUFFIX=64"
475 %endif
476 %ifarch x32
477 -DLLVM_LIBDIR_SUFFIX=x32"
478 %endif
479
480 bash ../%configure \
481         --datadir=%{_datadir}/%{name}-%{version} \
482         --disable-assertions \
483         --enable-cxx11 \
484 %ifarch %{ix86}
485         --disable-pic \
486 %endif
487         --disable-static \
488         --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
489         --enable-debug-runtime \
490 %if %{with apidocs}
491         --enable-doxygen \
492 %endif
493         --enable-experimental-targets=R600 \
494         --enable-jit \
495         --enable-optimized \
496         --enable-shared \
497         --with-pic
498
499 %{__make} \
500         VERBOSE=1 \
501         REQUIRES_RTTI=1 \
502         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
503
504 %if %{with tests}
505 %{__make} check 2>&1 | tee llvm-testlog.txt
506 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
507 %endif
508
509 cd ..
510
511 %if %{with doc}
512 %{__make} -C docs -f Makefile.sphinx man
513 %{__make} -C tools/clang/tools/extra/docs html
514 %endif
515
516 %install
517 rm -rf $RPM_BUILD_ROOT
518 %{__make} -C obj -j1 install \
519         PROJ_docsdir=/moredocs \
520         DESTDIR=$RPM_BUILD_ROOT
521
522 # Static analyzer not installed by default:
523 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
524 install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
525 # create launchers
526 for f in scan-{build,view}; do
527         ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
528         cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
529 done
530 %{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
531 %py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
532 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
533 %py_postclean %{_libdir}/clang-analyzer/scan-view
534
535 %if %{with doc}
536 install -d $RPM_BUILD_ROOT%{_mandir}/man1
537 cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
538 # these tools are not installed
539 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
540 # make links
541 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
542 %endif
543
544 # Move documentation back to build directory
545 rm -rf moredocs
546 mv $RPM_BUILD_ROOT/moredocs .
547 %{__rm} -v moredocs/*.tar.gz
548 %if %{with ocaml}
549 %{__rm} -v moredocs/ocamldoc/html/*.tar.gz
550 %endif
551
552 # and separate the apidoc
553 %if %{with apidocs}
554 rm -rf apidoc clang-apidoc
555 mv moredocs/html/doxygen apidoc
556 cp -a tools/clang/docs/doxygen/html clang-apidoc
557 %endif
558
559 # And prepare Clang documentation
560 rm -rf clang-docs
561 install -d clang-docs
562 for f in LICENSE.TXT NOTES.txt README.txt; do
563         ln tools/clang/$f clang-docs
564 done
565
566 # Get rid of erroneously installed example files.
567 %{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
568 # parts of test suite
569 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
570 %{__rm} $RPM_BUILD_ROOT%{_bindir}/linker-script-test
571
572 # remove documentation makefiles:
573 # they require the build directory to work
574 rm -rf moredocs/examples
575 cp -a examples moredocs/examples
576 find moredocs/examples -name Makefile | xargs -0r rm -f
577
578 %clean
579 rm -rf $RPM_BUILD_ROOT
580
581 %post   libs -p /sbin/ldconfig
582 %postun libs -p /sbin/ldconfig
583
584 %post   -n clang -p /sbin/ldconfig
585 %postun -n clang -p /sbin/ldconfig
586
587 %post   -n lldb -p /sbin/ldconfig
588 %postun -n lldb -p /sbin/ldconfig
589
590 %files
591 %defattr(644,root,root,755)
592 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
593 %attr(755,root,root) %{_bindir}/bugpoint
594 %attr(755,root,root) %{_bindir}/llc
595 %attr(755,root,root) %{_bindir}/lli
596 %attr(755,root,root) %{_bindir}/lli-child-target
597 %attr(755,root,root) %{_bindir}/llvm-ar
598 %attr(755,root,root) %{_bindir}/llvm-as
599 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
600 %attr(755,root,root) %{_bindir}/llvm-cov
601 %attr(755,root,root) %{_bindir}/llvm-diff
602 %attr(755,root,root) %{_bindir}/llvm-dis
603 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
604 %attr(755,root,root) %{_bindir}/llvm-extract
605 %attr(755,root,root) %{_bindir}/llvm-link
606 %attr(755,root,root) %{_bindir}/llvm-mc
607 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
608 %attr(755,root,root) %{_bindir}/llvm-nm
609 %attr(755,root,root) %{_bindir}/llvm-objdump
610 %attr(755,root,root) %{_bindir}/llvm-profdata
611 %attr(755,root,root) %{_bindir}/llvm-ranlib
612 %attr(755,root,root) %{_bindir}/llvm-readobj
613 %attr(755,root,root) %{_bindir}/llvm-rtdyld
614 %attr(755,root,root) %{_bindir}/llvm-size
615 %attr(755,root,root) %{_bindir}/llvm-stress
616 %attr(755,root,root) %{_bindir}/llvm-symbolizer
617 %attr(755,root,root) %{_bindir}/llvm-tblgen
618 %attr(755,root,root) %{_bindir}/macho-dump
619 %attr(755,root,root) %{_bindir}/opt
620 %if %{with doc}
621 %{_mandir}/man1/bugpoint.1*
622 %{_mandir}/man1/lit.1*
623 %{_mandir}/man1/llc.1*
624 %{_mandir}/man1/lli.1*
625 %{_mandir}/man1/llvm-ar.1*
626 %{_mandir}/man1/llvm-as.1*
627 %{_mandir}/man1/llvm-bcanalyzer.1*
628 %{_mandir}/man1/llvm-cov.1*
629 %{_mandir}/man1/llvm-diff.1*
630 %{_mandir}/man1/llvm-dis.1*
631 %{_mandir}/man1/llvm-dwarfdump.1*
632 %{_mandir}/man1/llvm-extract.1*
633 %{_mandir}/man1/llvm-link.1*
634 %{_mandir}/man1/llvm-nm.1*
635 %{_mandir}/man1/llvm-profdata.1*
636 %{_mandir}/man1/llvm-ranlib.1*
637 %{_mandir}/man1/llvm-readobj.1*
638 %{_mandir}/man1/llvm-stress.1*
639 %{_mandir}/man1/llvm-symbolizer.1*
640 %{_mandir}/man1/opt.1*
641 %{_mandir}/man1/tblgen.1*
642 %endif
643
644 %files libs
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
647 %attr(755,root,root) %{_libdir}/libLLVM-3.5.so
648
649 %files devel
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_bindir}/llvm-config
652 %{_libdir}/libLLVM*.a
653 %ifarch %{x8664}
654 %attr(755,root,root) %{_libdir}/BugpointPasses.so
655 %attr(755,root,root) %{_libdir}/libLTO.so
656 %{_libdir}/libLTO.a
657 %endif
658 %{_includedir}/llvm
659 %{_includedir}/llvm-c
660 %dir %{_datadir}/llvm
661 %{_datadir}/llvm/cmake
662 %if %{with doc}
663 %{_mandir}/man1/llvm-config.1*
664 %endif
665
666 %files doc
667 %defattr(644,root,root,755)
668 %doc moredocs/examples moredocs/html
669
670 %if %{with apidocs}
671 %files apidocs
672 %defattr(644,root,root,755)
673 %doc apidoc/*
674 %endif
675
676 %if %{with polly}
677 %files polly
678 %defattr(644,root,root,755)
679 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
680 %attr(755,root,root) %{_libdir}/LLVMPolly.so
681
682 %files polly-devel
683 %defattr(644,root,root,755)
684 %{_includedir}/polly
685 %endif
686
687 %files -n clang
688 %defattr(644,root,root,755)
689 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
690 %attr(755,root,root) %{_bindir}/c-index-test
691 %attr(755,root,root) %{_bindir}/clang
692 %attr(755,root,root) %{_bindir}/clang++
693 %attr(755,root,root) %{_bindir}/clang-check
694 %attr(755,root,root) %{_bindir}/clang-format
695 %attr(755,root,root) %{_bindir}/clang-tblgen
696 %attr(755,root,root) %{_libdir}/libclang.so
697 %dir %{_libdir}/clang
698 %dir %{_libdir}/clang/%{version}
699 %{_libdir}/clang/%{version}/include
700 %if %{with rt}
701 %{_libdir}/clang/%{version}/lib
702 %endif
703 %{_mandir}/man1/clang.1*
704
705 %files -n clang-analyzer
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_bindir}/scan-build
708 %attr(755,root,root) %{_bindir}/scan-view
709 %{_mandir}/man1/scan-build.1*
710 %dir %{_libdir}/clang-analyzer
711
712 %dir %{_libdir}/clang-analyzer/scan-build
713 %{_libdir}/clang-analyzer/scan-build/*.css
714 %{_libdir}/clang-analyzer/scan-build/*.js
715 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
716 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
717
718 %dir %{_libdir}/clang-analyzer/scan-view
719 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
720 %{_libdir}/clang-analyzer/scan-view/Resources
721 %{_libdir}/clang-analyzer/scan-view/*.py[co]
722
723 %files -n clang-devel
724 %defattr(644,root,root,755)
725 %{_libdir}/libclang*.a
726 %{_includedir}/clang
727 %{_includedir}/clang-c
728
729 %files -n clang-doc
730 %defattr(644,root,root,755)
731 %doc tools/clang/docs/*.{css,html,png,txt}
732
733 %if %{with apidocs}
734 %files -n clang-apidocs
735 %defattr(644,root,root,755)
736 %doc clang-apidoc/*
737 %endif
738
739 %files -n clang-tools-extra
740 %defattr(644,root,root,755)
741 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt,docs/_build/html/{*.html,*.js,_static}}
742 %attr(755,root,root) %{_bindir}/clang-apply-replacements
743 %attr(755,root,root) %{_bindir}/clang-modernize
744 %attr(755,root,root) %{_bindir}/clang-query
745 %attr(755,root,root) %{_bindir}/clang-tidy
746 %attr(755,root,root) %{_bindir}/pp-trace
747 %{_libdir}/libmodernizeCore.a
748
749 %files -n lld
750 %defattr(644,root,root,755)
751 %doc tools/lld/{LICENSE.TXT,README.md}
752 %attr(755,root,root) %{_bindir}/lld
753
754 %files -n lld-devel
755 %defattr(644,root,root,755)
756 %{_libdir}/liblldCore.a
757 %{_libdir}/liblldDriver.a
758 %{_libdir}/liblldELF.a
759 %{_libdir}/liblldMachO.a
760 %{_libdir}/liblldNative.a
761 %{_libdir}/liblldPECOFF.a
762 %{_libdir}/liblldPasses.a
763 %{_libdir}/liblldReaderWriter.a
764 %{_libdir}/liblldYAML.a
765 %{_libdir}/liblld*ELFTarget.a
766 %{_includedir}/lld
767
768 %if %{with lldb}
769 %files -n lldb
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_bindir}/lldb
772 %attr(755,root,root) %{_bindir}/lldb-gdbserver
773 %attr(755,root,root) %{_bindir}/lldb-mi
774 %attr(755,root,root) %{_bindir}/lldb-platform
775 %attr(755,root,root) %{_libdir}/liblldb.so
776 %dir %{py_sitedir}/lldb
777 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
778 %attr(755,root,root) %{py_sitedir}/readline.so
779
780 %files -n lldb-devel
781 %defattr(644,root,root,755)
782 %{_libdir}/liblldb*.a
783 %{_includedir}/lldb
784 %endif
785
786 %if %{with ocaml}
787 %files ocaml
788 %defattr(644,root,root,755)
789 %{_libdir}/ocaml/META.llvm*
790 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
791 %{_libdir}/ocaml/llvm*.cma
792 %{_libdir}/ocaml/llvm*.cmi
793
794 %files ocaml-devel
795 %defattr(644,root,root,755)
796 %{_libdir}/libllvm*.a
797 %{_libdir}/ocaml/libLLVM*.a
798 %{_libdir}/ocaml/libllvm*.a
799 %{_libdir}/ocaml/llvm*.a
800 %{_libdir}/ocaml/llvm*.cmx*
801 %{_libdir}/ocaml/llvm*.mli
802
803 %files ocaml-doc
804 %defattr(644,root,root,755)
805 %doc moredocs/ocamldoc/html/*
806 %endif
This page took 0.112342 seconds and 3 git commands to generate.