]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- user /usr/share/texmf-dist/fonts dir for fonts
[packages/lilypond.git] / lilypond.spec
1 # TODO:
2 #       - probably gui bcond is meaningless
3 #
4 # Conditional build:
5 %bcond_with     gui     # enable experimental GUI
6 %bcond_with     docs    # build docs
7 #
8 Summary:        Music typesetter
9 Summary(pl.UTF-8):      Program do składania nut
10 Name:           lilypond
11 Version:        2.12.2
12 Release:        1
13 License:        GPL
14 Group:          Applications/Sound
15 Source0:        http://lilypond.org/download/v2.12/%{name}-%{version}.tar.gz
16 # Source0-md5:  681dfbecf8a3710d1400cf9488be716b
17 Patch0:         %{name}-info.patch
18 Patch1:         %{name}-sh.patch
19 Patch3:         %{name}-afm.patch
20 Patch4:         %{name}-aclocal.patch
21 Patch5:         %{name}-bad_cast.patch
22 URL:            http://www.lilypond.org/
23 %{?with_docs:BuildRequires:     ImageMagick}
24 %{?with_docs:BuildRequires:     ImageMagick-coder-png}
25 BuildRequires:  automake
26 BuildRequires:  bison >= 1.29
27 BuildRequires:  flex >= 2.5.4a
28 BuildRequires:  fontconfig
29 BuildRequires:  fontconfig-devel >= 1:2.2.0
30 BuildRequires:  fontforge >= 20060125
31 BuildRequires:  fonts-Type1-urw
32 BuildRequires:  gettext-devel >= 0.17
33 BuildRequires:  ghostscript >= 8.15
34 %{?with_docs:BuildRequires:     ghostscript >= 8.60}
35 BuildRequires:  ghostscript-fonts-std
36 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
37 BuildRequires:  guile-devel >= 5:1.8.2
38 BuildRequires:  kpathsea-devel
39 BuildRequires:  libltdl-devel
40 BuildRequires:  libstdc++-devel >= 5:3.4
41 BuildRequires:  mftrace >= 1.1.19
42 %{?with_docs:BuildRequires:     netpbm-progs}
43 BuildRequires:  pango-devel >= 1.12.0
44 BuildRequires:  perl-base
45 BuildRequires:  pkgconfig >= 1:0.9.0
46 BuildRequires:  python-devel >= 2.4
47 %{?with_docs:BuildRequires:     rsync}
48 BuildRequires:  texlive-dvips
49 BuildRequires:  texlive-fonts-cm
50 BuildRequires:  texlive-fonts-cmextra
51 BuildRequires:  texlive-fonts-jknappen
52 %{?with_docs:BuildRequires:     texlive-latex-bibtex}
53 BuildRequires:  texlive-metapost
54 BuildRequires:  texinfo >= 4.11
55 %{?with_docs:BuildRequires:     texinfo-texi2dvi}
56 BuildConflicts: lilypond < 1.6.0
57 Requires:       ghostscript >= 8.15
58 Requires:       guile >= 5:1.8.2
59 Requires:       python >= 2.4
60 Requires:       texlive-latex
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         texmfdir        %{_datadir}/texmf
64 %define         texmfdistdir    %{texmfdir}-dist
65 %define         texfontsdir     %{texmfdistdir}/fonts
66
67 %description
68 LilyPond is a music typesetter. It produces beautiful sheet music
69 using a high level description file as input. It excels at typesetting
70 classical music, but you can also print pop-songs. With LilyPond we
71 hope to make music publication software available to anyone on the
72 internet.
73
74 %description -l pl.UTF-8
75 LilyPond jest programem do składu muzycznego. Produkuje piękne
76 partytury używając języka wysokiego poziomu jako wejście. Służy przede
77 wszystkim do składania nut muzyki klasycznej, ale można drukować także
78 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
79 wszystkim oprogramowania do publikacji muzycznych.
80
81 %package -n emacs-lilypond-mode-pkg
82 Summary:        LilyPond mode for Emacs
83 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
84 Group:          Applications/Editors/Emacs
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       emacs
87
88 %description -n emacs-lilypond-mode-pkg
89 LilyPond mode for Emacs.
90
91 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
92 Tryb edycji plików LilyPond dla Emacsa.
93
94 %package -n vim-syntax-lilypond
95 Summary:        LilyPond files support for Vim
96 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
97 Group:          Applications/Editors/Vim
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       vim-rt >= 4:6.4.001-2
100
101 %description -n vim-syntax-lilypond
102 LilyPond files support for Vim.
103
104 %description -n vim-syntax-lilypond -l pl.UTF-8
105 Obsługa plików LilyPonda dla Vima.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111 %patch3 -p1
112 %patch4 -p1
113 %patch5 -p1
114
115 %build
116 cp -f /usr/share/automake/config.* stepmake/bin
117 %{__autoconf}
118 %configure \
119         %{?debug:--disable-optimising} \
120         %{?with_gui:--enable-gui}
121 %{__make} -j1
122 %{?with_docs:%{__make} -j1 web}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips,tex},%{texfontsdir}/{source,tfm,type1}}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130 %if %{with docs}
131 %{__make} -j1 web-install \
132         DESTDIR=$RPM_BUILD_ROOT
133 %endif
134 cp -aL out/share/lilypond/current/fonts/tfm \
135         $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
136
137 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
138
139 # ?
140 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
141         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
142 # for latex and dvips
143 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
144         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
145 # both for lilypond and dvips
146 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
147         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
148 ln -sf %{_datadir}/lilypond/%{version}/ps \
149         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
150 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips
151
152 # vim syntax/etc. files
153 install -d $RPM_BUILD_ROOT%{_datadir}/vim
154 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
155         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
156
157 # lilypond/stepmake build system - not needed at runtime
158 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
159
160 %find_lang %{name}
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %pre
166 test -h %{texmfdir}/dvips/lilypond || rm -rf %{texmfdir}/dvips/lilypond
167
168 %post
169 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
170 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
171 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
172
173 %postun
174 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
175 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
176 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
177
178 %files -f %{name}.lang
179 %defattr(644,root,root,755)
180 %doc AUTHORS.txt DEDICATION NEWS.txt README.txt THANKS
181 %attr(755,root,root) %{_bindir}/abc2ly
182 %attr(755,root,root) %{_bindir}/convert-ly
183 %attr(755,root,root) %{_bindir}/etf2ly
184 %attr(755,root,root) %{_bindir}/lilymidi
185 %attr(755,root,root) %{_bindir}/lilypond
186 %attr(755,root,root) %{_bindir}/lilypond-book
187 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
188 %attr(755,root,root) %{_bindir}/lilysong
189 %attr(755,root,root) %{_bindir}/midi2ly
190 %attr(755,root,root) %{_bindir}/musicxml2ly
191 %dir %{_libdir}/lilypond
192 %dir %{_libdir}/lilypond/%{version}
193 %dir %{_libdir}/lilypond/%{version}/python
194 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
195 %dir %{_datadir}/lilypond
196 %dir %{_datadir}/lilypond/%{version}
197 %{_datadir}/lilypond/%{version}/fonts
198 %{_datadir}/lilypond/%{version}/ly
199 %{_datadir}/lilypond/%{version}/ps
200 %dir %{_datadir}/lilypond/%{version}/python
201 %{_datadir}/lilypond/%{version}/python/*.py
202 %{_datadir}/lilypond/%{version}/python/*.pyc
203 %{_datadir}/lilypond/%{version}/scm
204 %{_infodir}/*.info*
205 %{_mandir}/man1/*
206
207 %{texfontsdir}/source/lilypond
208 %{texfontsdir}/tfm/lilypond
209 %{texfontsdir}/type1/lilypond
210 %{texmfdir}/dvips/lilypond
211 %{texmfdir}/tex/lilypond
212
213 %{_datadir}/omf/lilypond
214 %{?with_docs:/usr/share/doc/lilypond}
215
216 %files -n emacs-lilypond-mode-pkg
217 %defattr(644,root,root,755)
218 %{_datadir}/emacs/site-lisp/*.el
219
220 %files -n vim-syntax-lilypond
221 %defattr(644,root,root,755)
222 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
223 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
224 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
225 %{_datadir}/vim/vimfiles/indent/lilypond.vim
226 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.063459 seconds and 4 git commands to generate.