]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- tabs in preamble
[packages/lilypond.git] / lilypond.spec
1 #
2 # Conditional build:
3 %bcond_with     gui     # enable experimental GUI
4 #
5 Summary:        Music typesetter
6 Summary(pl.UTF-8):      Program do składania nut
7 Name:           lilypond
8 Version:        2.10.0
9 Release:        1
10 License:        GPL
11 Group:          Applications/Sound
12 Source0:        http://lilypond.org/download/v2.10/%{name}-%{version}.tar.gz
13 # Source0-md5:  82e4487c5c1fa1d2e478d5974a3630df
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-sh.patch
16 Patch2:         %{name}-po.patch
17 Patch3:         %{name}-afm.patch
18 URL:            http://www.lilypond.org/
19 BuildRequires:  automake
20 BuildRequires:  bison >= 1.29
21 BuildRequires:  flex >= 2.5.4a
22 BuildRequires:  fontconfig-devel >= 1:2.2.0
23 BuildRequires:  fontforge >= 20050624
24 BuildRequires:  gettext-devel
25 BuildRequires:  ghostscript >= 8.15
26 BuildRequires:  ghostscript-fonts-std
27 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
28 BuildRequires:  guile-devel >= 5:1.6.5
29 BuildRequires:  kpathsea-devel
30 BuildRequires:  libltdl-devel
31 BuildRequires:  libstdc++-devel >= 5:3.3
32 BuildRequires:  mftrace >= 1.1.9
33 BuildRequires:  pango-devel >= 1.6.0
34 BuildRequires:  pkgconfig >= 1:0.9.0
35 BuildRequires:  python-devel >= 2.1
36 BuildRequires:  tetex-dvips
37 BuildRequires:  tetex-fonts-cm
38 BuildRequires:  tetex-fonts-cmextra
39 BuildRequires:  tetex-fonts-jknappen
40 BuildRequires:  texinfo >= 4.7
41 BuildConflicts: lilypond < 1.6.0
42 Requires:       ghostscript >= 8.15
43 Requires:       guile >= 5:1.6.5
44 Requires:       python >= 2.1
45 Requires:       tetex-format-latex >= 1.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         texmfdir        /usr/share/texmf
49 %define         texfontsdir     %{texmfdir}/fonts
50
51 %description
52 LilyPond is a music typesetter. It produces beautiful sheet music
53 using a high level description file as input. It excels at typesetting
54 classical music, but you can also print pop-songs. With LilyPond we
55 hope to make music publication software available to anyone on the
56 internet.
57
58 %description -l pl.UTF-8
59 LilyPond jest programem do składu muzycznego. Produkuje piękne
60 partytury używając języka wysokiego poziomu jako wejście. Służy przede
61 wszystkim do składania nut muzyki klasycznej, ale można drukować także
62 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
63 wszystkim oprogramowania do publikacji muzycznych.
64
65 %package -n emacs-lilypond-mode-pkg
66 Summary:        LilyPond mode for Emacs
67 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
68 Group:          Applications/Editors/Emacs
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       emacs
71
72 %description -n emacs-lilypond-mode-pkg
73 LilyPond mode for Emacs.
74
75 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
76 Tryb edycji plików LilyPond dla Emacsa.
77
78 %package -n vim-syntax-lilypond
79 Summary:        LilyPond files support for Vim
80 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
81 Group:          Applications/Editors/Vim
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       vim >= 4:6.4.001-2
84
85 %description -n vim-syntax-lilypond
86 LilyPond files support for Vim.
87
88 %description -n vim-syntax-lilypond -l pl.UTF-8
89 Obsługa plików LilyPonda dla Vima.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96 %patch3 -p1
97
98 %build
99 cp -f /usr/share/automake/config.* stepmake/bin
100 %{__autoconf}
101 %configure \
102         %{?debug:--disable-optimising} \
103         %{?with_gui:--enable-gui}
104 %{__make} -j1
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips/misc,tex},%{texfontsdir}/{source,tfm,type1}}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
114
115 # for dvips
116 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips \
117       $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
118 # ?
119 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
120       $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
121 # for latex and dvips
122 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/tfm \
123       $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
124 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
125       $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
126 # both for lilypond and dvips
127 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
128         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
129 ln -sf %{_datadir}/lilypond/%{version}/ps/music-drawing-routines.ps \
130         $RPM_BUILD_ROOT%{texmfdir}/dvips/misc
131
132 # no need for subdir
133 mv -f $RPM_BUILD_ROOT%{_infodir}/lilypond/*.info* $RPM_BUILD_ROOT%{_infodir}
134
135 # vim syntax/etc. files
136 install -d $RPM_BUILD_ROOT%{_datadir}/vim
137 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
138         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
139
140 # lilypond/stepmake build system - not needed at runtime
141 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
142
143 %find_lang %{name}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
150 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
151 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
152
153 %postun
154 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
155 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
156 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc AUTHORS.txt ChangeLog DEDICATION NEWS.txt README.txt THANKS
161 %attr(755,root,root) %{_bindir}/*
162 %dir %{_libdir}/lilypond
163 %dir %{_libdir}/lilypond/%{version}
164 %dir %{_libdir}/lilypond/%{version}/python
165 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
166 %dir %{_datadir}/lilypond
167 %dir %{_datadir}/lilypond/%{version}
168 %{_datadir}/lilypond/%{version}/fonts
169 %{_datadir}/lilypond/%{version}/ly
170 %{_datadir}/lilypond/%{version}/ps
171 %dir %{_datadir}/lilypond/%{version}/python
172 %{_datadir}/lilypond/%{version}/python/*.py
173 %{_datadir}/lilypond/%{version}/python/*.pyc
174 %{_datadir}/lilypond/%{version}/scm
175 %{_infodir}/*.info*
176 %{_mandir}/man1/*
177
178 %{texfontsdir}/source/lilypond
179 %{texfontsdir}/tfm/lilypond
180 %{texfontsdir}/type1/lilypond
181 %{texmfdir}/dvips/lilypond
182 %{texmfdir}/dvips/misc/*.ps
183 %{texmfdir}/tex/lilypond
184
185 %{_datadir}/omf/lilypond
186
187 %files -n emacs-lilypond-mode-pkg
188 %defattr(644,root,root,755)
189 %{_datadir}/emacs/site-lisp/*.el
190
191 %files -n vim-syntax-lilypond
192 %defattr(644,root,root,755)
193 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
194 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
195 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
196 %{_datadir}/vim/vimfiles/indent/lilypond.vim
197 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.082591 seconds and 4 git commands to generate.