]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- updated to 2.8.7
[packages/lilypond.git] / lilypond.spec
1 #
2 # Conditional build:
3 %bcond_with     gui     # enable experimental GUI
4 #
5 Summary:        Music typesetter
6 Summary(pl):    Program do sk³adania nut
7 Name:           lilypond
8 Version:        2.8.7
9 Release:        1
10 License:        GPL
11 Group:          Applications/Sound
12 Source0:        http://lilypond.org/download/v2.8/%{name}-%{version}.tar.gz
13 # Source0-md5:  f2513f545adb211a256c21cc6b28ab3a
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-sh.patch
16 Patch2:         %{name}-po.patch
17 Patch3:         %{name}-afm.patch
18 URL:            http://www.lilypond.org/
19 BuildRequires:  automake
20 BuildRequires:  bison >= 1.29
21 BuildRequires:  flex >= 2.5.4a
22 BuildRequires:  fontconfig-devel >= 1:2.2.0
23 BuildRequires:  fontforge >= 20050624
24 BuildRequires:  gettext-devel
25 BuildRequires:  ghostscript >= 8.15
26 BuildRequires:  ghostscript-fonts-std
27 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
28 BuildRequires:  guile-devel >= 5:1.6.5
29 BuildRequires:  kpathsea-devel
30 BuildRequires:  libltdl-devel
31 BuildRequires:  libstdc++-devel >= 5:3.3
32 BuildRequires:  mftrace >= 1.1.9
33 BuildRequires:  pango-devel >= 1.6.0
34 BuildRequires:  pkgconfig >= 1:0.9.0
35 BuildRequires:  python-devel >= 2.1
36 BuildRequires:  tetex-dvips
37 BuildRequires:  tetex-fonts-cm
38 BuildRequires:  tetex-fonts-cmextra
39 BuildRequires:  tetex-fonts-jknappen
40 BuildRequires:  texinfo >= 4.7
41 BuildConflicts: lilypond < 1.6.0
42 Requires:       ghostscript >= 8.15
43 Requires:       guile >= 5:1.6.5
44 Requires:       python >= 2.1
45 Requires:       tetex-format-latex >= 1.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _localedir      %{_prefix}/share/locale
49 %define         texmfdir        /usr/share/texmf
50 %define         texfontsdir     %{texmfdir}/fonts
51
52 %description
53 LilyPond is a music typesetter. It produces beautiful sheet music
54 using a high level description file as input. It excels at typesetting
55 classical music, but you can also print pop-songs. With LilyPond we
56 hope to make music publication software available to anyone on the
57 internet.
58
59 %description -l pl
60 LilyPond jest programem do sk³adu muzycznego. Produkuje piêkne
61 partytury u¿ywaj±c jêzyka wysokiego poziomu jako wej¶cie. S³u¿y przede
62 wszystkim do sk³adania nut muzyki klasycznej, ale mo¿na drukowaæ tak¿e
63 piosenki pop. Autorzy udostêpniaj± LilyPond z nadziej± dostarczenia
64 wszystkim oprogramowania do publikacji muzycznych.
65
66 %package -n emacs-lilypond-mode-pkg
67 Summary:        LilyPond mode for Emacs
68 Summary(pl):    Tryb edycji plików LilyPond dla Emacsa
69 Group:          Applications/Editors/Emacs
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       emacs
72
73 %description -n emacs-lilypond-mode-pkg
74 LilyPond mode for Emacs.
75
76 %description -n emacs-lilypond-mode-pkg -l pl
77 Tryb edycji plików LilyPond dla Emacsa.
78
79 %package -n vim-syntax-lilypond
80 Summary:        LilyPond files support for Vim
81 Summary(pl):    Obs³uga plików LilyPonda dla Vima
82 Group:          Applications/Editors/Vim
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       vim >= 4:6.4.001-2
85
86 %description -n vim-syntax-lilypond
87 LilyPond files support for Vim.
88
89 %description -n vim-syntax-lilypond -l pl
90 Obs³uga plików LilyPonda dla Vima.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98
99 %build
100 cp -f /usr/share/automake/config.* stepmake/bin
101 %{__autoconf}
102 %configure \
103         %{?debug:--disable-optimising} \
104         %{?with_gui:--enable-gui}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips/misc,tex},%{texfontsdir}/{source,tfm,type1}}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
115
116 # for dvips
117 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips \
118       $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
119 # ?
120 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
121       $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
122 # for latex and dvips
123 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/tfm \
124       $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
125 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
126       $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
127 # both for lilypond and dvips
128 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
129         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
130 ln -sf %{_datadir}/lilypond/%{version}/ps/music-drawing-routines.ps \
131         $RPM_BUILD_ROOT%{texmfdir}/dvips/misc
132
133 # no need for subdir
134 mv -f $RPM_BUILD_ROOT%{_infodir}/lilypond/*.info* $RPM_BUILD_ROOT%{_infodir}
135
136 # vim syntax/etc. files
137 install -d $RPM_BUILD_ROOT%{_datadir}/vim
138 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
139         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
140
141 # lilypond/stepmake build system - not needed at runtime
142 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
143
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
151 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
152 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
153
154 %postun
155 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
156 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
157 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS.txt ChangeLog DEDICATION NEWS.txt README.txt THANKS
162 %attr(755,root,root) %{_bindir}/*
163 %dir %{_libdir}/lilypond
164 %dir %{_libdir}/lilypond/%{version}
165 %dir %{_libdir}/lilypond/%{version}/python
166 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
167 %dir %{_datadir}/lilypond
168 %dir %{_datadir}/lilypond/%{version}
169 %{_datadir}/lilypond/%{version}/fonts
170 %{_datadir}/lilypond/%{version}/ly
171 %{_datadir}/lilypond/%{version}/ps
172 %dir %{_datadir}/lilypond/%{version}/python
173 %{_datadir}/lilypond/%{version}/python/*.py
174 %{_datadir}/lilypond/%{version}/python/*.pyc
175 %{_datadir}/lilypond/%{version}/scm
176 %{_infodir}/*.info*
177 %{_mandir}/man1/*
178
179 %{texfontsdir}/source/lilypond
180 %{texfontsdir}/tfm/lilypond
181 %{texfontsdir}/type1/lilypond
182 %{texmfdir}/dvips/lilypond
183 %{texmfdir}/dvips/misc/*.ps
184 %{texmfdir}/tex/lilypond
185
186 %{_datadir}/omf/lilypond
187
188 %files -n emacs-lilypond-mode-pkg
189 %defattr(644,root,root,755)
190 %{_datadir}/emacs/site-lisp/*.el
191
192 %files -n vim-syntax-lilypond
193 %defattr(644,root,root,755)
194 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
195 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
196 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
197 %{_datadir}/vim/vimfiles/indent/lilypond.vim
198 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.075269 seconds and 4 git commands to generate.