]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- vimdatadir is in vim-rt package
[packages/lilypond.git] / lilypond.spec
1 # TODO:
2 #       - probably gui bcond is meaningless
3 #
4 # Conditional build:
5 %bcond_with     gui     # enable experimental GUI
6 %bcond_with     docs    # build docs
7 #
8 Summary:        Music typesetter
9 Summary(pl.UTF-8):      Program do składania nut
10 Name:           lilypond
11 Version:        2.10.33
12 Release:        2
13 License:        GPL
14 Group:          Applications/Sound
15 Source0:        http://lilypond.org/download/v2.10/%{name}-%{version}.tar.gz
16 # Source0-md5:  86a67fcc404e942be723f8a72988b286
17 Patch0:         %{name}-info.patch
18 Patch1:         %{name}-sh.patch
19 Patch2:         %{name}-po.patch
20 Patch3:         %{name}-afm.patch
21 Patch4:         %{name}-gcc3.patch
22 URL:            http://www.lilypond.org/
23 %{?with_docs:BuildRequires:     ImageMagick}
24 %{?with_docs:BuildRequires:     ImageMagick-coder-png}
25 BuildRequires:  automake
26 BuildRequires:  bison >= 1.29
27 BuildRequires:  flex >= 2.5.4a
28 BuildRequires:  fontconfig
29 BuildRequires:  fontconfig-devel >= 1:2.2.0
30 BuildRequires:  fontforge >= 20050624
31 BuildRequires:  gettext-devel
32 BuildRequires:  ghostscript >= 8.15
33 BuildRequires:  ghostscript-fonts-std
34 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
35 BuildRequires:  guile-devel >= 5:1.6.7
36 BuildRequires:  kpathsea-devel
37 BuildRequires:  libltdl-devel
38 BuildRequires:  libstdc++-devel >= 5:3.3
39 BuildRequires:  mftrace >= 1.1.19
40 %{?with_docs:BuildRequires:     netpbm-progs}
41 BuildRequires:  pango-devel >= 1.6.0
42 BuildRequires:  pkgconfig >= 1:0.9.0
43 BuildRequires:  python-devel >= 2.1
44 %{?with_docs:BuildRequires:     rsync}
45 BuildRequires:  tetex-dvips
46 BuildRequires:  tetex-fonts-cm
47 BuildRequires:  tetex-fonts-cmextra
48 BuildRequires:  tetex-fonts-jknappen
49 %{?with_docs:BuildRequires:     tetex-latex-bibtex}
50 BuildRequires:  texinfo >= 4.7
51 %{?with_docs:BuildRequires:     texinfo-texi2dvi}
52 BuildConflicts: lilypond < 1.6.0
53 Requires:       ghostscript >= 8.15
54 Requires:       guile >= 5:1.6.5
55 Requires:       python >= 2.1
56 Requires:       tetex-format-latex >= 1.0
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         texmfdir        /usr/share/texmf
60 %define         texfontsdir     %{texmfdir}/fonts
61
62 %description
63 LilyPond is a music typesetter. It produces beautiful sheet music
64 using a high level description file as input. It excels at typesetting
65 classical music, but you can also print pop-songs. With LilyPond we
66 hope to make music publication software available to anyone on the
67 internet.
68
69 %description -l pl.UTF-8
70 LilyPond jest programem do składu muzycznego. Produkuje piękne
71 partytury używając języka wysokiego poziomu jako wejście. Służy przede
72 wszystkim do składania nut muzyki klasycznej, ale można drukować także
73 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
74 wszystkim oprogramowania do publikacji muzycznych.
75
76 %package -n emacs-lilypond-mode-pkg
77 Summary:        LilyPond mode for Emacs
78 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
79 Group:          Applications/Editors/Emacs
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       emacs
82
83 %description -n emacs-lilypond-mode-pkg
84 LilyPond mode for Emacs.
85
86 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
87 Tryb edycji plików LilyPond dla Emacsa.
88
89 %package -n vim-syntax-lilypond
90 Summary:        LilyPond files support for Vim
91 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
92 Group:          Applications/Editors/Vim
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       vim-rt >= 4:6.4.001-2
95
96 %description -n vim-syntax-lilypond
97 LilyPond files support for Vim.
98
99 %description -n vim-syntax-lilypond -l pl.UTF-8
100 Obsługa plików LilyPonda dla Vima.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108 %patch4 -p0
109
110 %build
111 cp -f /usr/share/automake/config.* stepmake/bin
112 %{__autoconf}
113 %configure \
114         %{?debug:--disable-optimising} \
115         %{?with_gui:--enable-gui}
116 %{__make} -j1
117 %{?with_docs:%{__make} -j1 web}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips/misc,tex},%{texfontsdir}/{source,tfm,type1}}
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125 %if %{with docs}
126 %{__make} -j1 web-install \
127         DESTDIR=$RPM_BUILD_ROOT
128 %endif
129
130 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
131
132 # for dvips
133 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips \
134         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
135 # ?
136 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
137         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
138 # for latex and dvips
139 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
140         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
141 # both for lilypond and dvips
142 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
143         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
144 ln -sf %{_datadir}/lilypond/%{version}/ps/music-drawing-routines.ps \
145         $RPM_BUILD_ROOT%{texmfdir}/dvips/misc
146
147 # no need for subdir
148 mv -f $RPM_BUILD_ROOT%{_infodir}/lilypond/*.info* $RPM_BUILD_ROOT%{_infodir}
149
150 # vim syntax/etc. files
151 install -d $RPM_BUILD_ROOT%{_datadir}/vim
152 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
153         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
154
155 # lilypond/stepmake build system - not needed at runtime
156 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
157
158 %find_lang %{name}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post
164 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
165 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
166 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
167
168 %postun
169 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
170 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
171 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
172
173 %files -f %{name}.lang
174 %defattr(644,root,root,755)
175 %doc AUTHORS.txt ChangeLog DEDICATION NEWS.txt README.txt THANKS
176 %attr(755,root,root) %{_bindir}/abc2ly
177 %attr(755,root,root) %{_bindir}/convert-ly
178 %attr(755,root,root) %{_bindir}/etf2ly
179 %attr(755,root,root) %{_bindir}/lilypond
180 %attr(755,root,root) %{_bindir}/lilypond-book
181 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
182 %attr(755,root,root) %{_bindir}/midi2ly
183 %attr(755,root,root) %{_bindir}/musicxml2ly
184 %dir %{_libdir}/lilypond
185 %dir %{_libdir}/lilypond/%{version}
186 %dir %{_libdir}/lilypond/%{version}/python
187 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
188 %dir %{_datadir}/lilypond
189 %dir %{_datadir}/lilypond/%{version}
190 %{_datadir}/lilypond/%{version}/fonts
191 %{_datadir}/lilypond/%{version}/ly
192 %{_datadir}/lilypond/%{version}/ps
193 %dir %{_datadir}/lilypond/%{version}/python
194 %{_datadir}/lilypond/%{version}/python/*.py
195 %{_datadir}/lilypond/%{version}/python/*.pyc
196 %{_datadir}/lilypond/%{version}/scm
197 %{_infodir}/*.info*
198 %{_mandir}/man1/*
199
200 %{texfontsdir}/source/lilypond
201 %{texfontsdir}/type1/lilypond
202 %{texmfdir}/dvips/lilypond
203 %{texmfdir}/dvips/misc/*.ps
204 %{texmfdir}/tex/lilypond
205
206 %{_datadir}/omf/lilypond
207 %{?with_docs:/usr/share/doc/lilypond}
208
209 %files -n emacs-lilypond-mode-pkg
210 %defattr(644,root,root,755)
211 %{_datadir}/emacs/site-lisp/*.el
212
213 %files -n vim-syntax-lilypond
214 %defattr(644,root,root,755)
215 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
216 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
217 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
218 %{_datadir}/vim/vimfiles/indent/lilypond.vim
219 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.036516 seconds and 3 git commands to generate.