]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- release 3
[packages/lilypond.git] / lilypond.spec
1 # TODO:
2 #       - probably gui bcond is meaningless
3 #
4 # Conditional build:
5 %bcond_with     gui     # enable experimental GUI
6 %bcond_with     doc     # build docs
7 #
8 Summary:        Music typesetter
9 Summary(pl.UTF-8):      Program do składania nut
10 Name:           lilypond
11 Version:        2.12.2
12 Release:        3
13 License:        GPL
14 Group:          Applications/Sound
15 Source0:        http://lilypond.org/download/v2.12/%{name}-%{version}.tar.gz
16 # Source0-md5:  681dfbecf8a3710d1400cf9488be716b
17 Patch0:         %{name}-info.patch
18 Patch1:         %{name}-sh.patch
19 Patch3:         %{name}-afm.patch
20 Patch4:         %{name}-aclocal.patch
21 Patch5:         %{name}-bad_cast.patch
22 URL:            http://www.lilypond.org/
23 %{?with_doc:BuildRequires:      ImageMagick-coder-png}
24 %{?with_doc:BuildRequires:      ImageMagick}
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  bison >= 1.29
28 BuildRequires:  flex >= 2.5.4a
29 BuildRequires:  fontconfig
30 BuildRequires:  fontconfig-devel >= 1:2.2.0
31 BuildRequires:  fontforge >= 20060125
32 BuildRequires:  fonts-Type1-urw
33 BuildRequires:  gettext-devel >= 0.17
34 BuildRequires:  ghostscript >= 8.15
35 %{?with_doc:BuildRequires:      ghostscript >= 8.60}
36 BuildRequires:  ghostscript-fonts-std
37 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
38 BuildRequires:  guile-devel >= 5:1.8.2
39 BuildRequires:  kpathsea-devel
40 BuildRequires:  libltdl-devel
41 BuildRequires:  libstdc++-devel >= 5:3.4
42 #BuildRequires: mftrace >= 1.1.19
43 %{?with_doc:BuildRequires:      netpbm-progs}
44 BuildRequires:  pango-devel >= 1.12.0
45 BuildRequires:  perl-base
46 BuildRequires:  pkgconfig >= 1:0.9.0
47 BuildRequires:  python-devel >= 2.4
48 BuildRequires:  python-modules
49 BuildRequires:  rpm-pythonprov
50 %{?with_doc:BuildRequires:      rsync}
51 BuildRequires:  texinfo >= 4.11
52 %{?with_doc:BuildRequires:      texinfo-texi2dvi}
53 #BuildRequires: texlive-dvips
54 #BuildRequires: texlive-fonts-cm
55 #BuildRequires: texlive-fonts-cmextra
56 #BuildRequires: texlive-fonts-jknappen
57 %{?with_doc:BuildRequires:      texlive-latex-bibtex}
58 BuildRequires:  texlive-metapost
59 BuildConflicts: lilypond < 1.6.0
60 Requires:       ghostscript >= 8.15
61 Requires:       guile >= 5:1.8.2
62 Requires:       python >= 2.4
63 Requires:       texlive-latex
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         texmfdir        %{_datadir}/texmf
67 %define         texmfdistdir    %{texmfdir}-dist
68 %define         texfontsdir     %{texmfdistdir}/fonts
69
70 %description
71 LilyPond is a music typesetter. It produces beautiful sheet music
72 using a high level description file as input. It excels at typesetting
73 classical music, but you can also print pop-songs. With LilyPond we
74 hope to make music publication software available to anyone on the
75 internet.
76
77 %description -l pl.UTF-8
78 LilyPond jest programem do składu muzycznego. Produkuje piękne
79 partytury używając języka wysokiego poziomu jako wejście. Służy przede
80 wszystkim do składania nut muzyki klasycznej, ale można drukować także
81 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
82 wszystkim oprogramowania do publikacji muzycznych.
83
84 %package -n emacs-lilypond-mode-pkg
85 Summary:        LilyPond mode for Emacs
86 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
87 Group:          Applications/Editors/Emacs
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       emacs
90
91 %description -n emacs-lilypond-mode-pkg
92 LilyPond mode for Emacs.
93
94 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
95 Tryb edycji plików LilyPond dla Emacsa.
96
97 %package -n vim-syntax-lilypond
98 Summary:        LilyPond files support for Vim
99 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
100 Group:          Applications/Editors/Vim
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       vim-rt >= 4:6.4.001-2
103
104 %description -n vim-syntax-lilypond
105 LilyPond files support for Vim.
106
107 %description -n vim-syntax-lilypond -l pl.UTF-8
108 Obsługa plików LilyPonda dla Vima.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114 %patch3 -p1
115 %patch4 -p1
116 %patch5 -p1
117
118 %build
119 cp -f /usr/share/automake/config.* stepmake/bin
120 %{__autoconf}
121 %configure \
122         %{?debug:--disable-optimising} \
123         %{?with_gui:--enable-gui}
124 %{__make} -j1
125 %{?with_doc:%{__make} -j1 web}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips,tex},%{texfontsdir}/{source,tfm,type1}}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133 %if %{with doc}
134 %{__make} -j1 web-install \
135         DESTDIR=$RPM_BUILD_ROOT
136 %endif
137 cp -aL out/share/lilypond/current/fonts/tfm \
138         $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
139
140 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
141
142 # ?
143 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
144         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
145 # for latex and dvips
146 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
147         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
148 # both for lilypond and dvips
149 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
150         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
151 ln -sf %{_datadir}/lilypond/%{version}/ps \
152         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
153 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips
154
155 # vim syntax/etc. files
156 install -d $RPM_BUILD_ROOT%{_datadir}/vim
157 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
158         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
159
160 # lilypond/stepmake build system - not needed at runtime
161 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
162
163 %find_lang %{name}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %pre
169 test -h %{texmfdir}/dvips/lilypond || rm -rf %{texmfdir}/dvips/lilypond
170
171 %post
172 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
173 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
174 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
175
176 %postun
177 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
178 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
179 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
180
181 %files -f %{name}.lang
182 %defattr(644,root,root,755)
183 %doc AUTHORS.txt DEDICATION NEWS.txt README.txt THANKS
184 %attr(755,root,root) %{_bindir}/abc2ly
185 %attr(755,root,root) %{_bindir}/convert-ly
186 %attr(755,root,root) %{_bindir}/etf2ly
187 %attr(755,root,root) %{_bindir}/lilymidi
188 %attr(755,root,root) %{_bindir}/lilypond
189 %attr(755,root,root) %{_bindir}/lilypond-book
190 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
191 %attr(755,root,root) %{_bindir}/lilysong
192 %attr(755,root,root) %{_bindir}/midi2ly
193 %attr(755,root,root) %{_bindir}/musicxml2ly
194 %dir %{_libdir}/lilypond
195 %dir %{_libdir}/lilypond/%{version}
196 %dir %{_libdir}/lilypond/%{version}/python
197 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
198 %dir %{_datadir}/lilypond
199 %dir %{_datadir}/lilypond/%{version}
200 %{_datadir}/lilypond/%{version}/fonts
201 %{_datadir}/lilypond/%{version}/ly
202 %{_datadir}/lilypond/%{version}/ps
203 %dir %{_datadir}/lilypond/%{version}/python
204 %{_datadir}/lilypond/%{version}/python/*.py
205 %{_datadir}/lilypond/%{version}/python/*.pyc
206 %{_datadir}/lilypond/%{version}/scm
207 %{_infodir}/*.info*
208 %{_mandir}/man1/*
209
210 %{texfontsdir}/source/lilypond
211 %{texfontsdir}/tfm/lilypond
212 %{texfontsdir}/type1/lilypond
213 %{texmfdir}/dvips/lilypond
214 %{texmfdir}/tex/lilypond
215
216 %{_datadir}/omf/lilypond
217 %{?with_doc:/usr/share/doc/lilypond}
218
219 %files -n emacs-lilypond-mode-pkg
220 %defattr(644,root,root,755)
221 %{_datadir}/emacs/site-lisp/*.el
222
223 %files -n vim-syntax-lilypond
224 %defattr(644,root,root,755)
225 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
226 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
227 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
228 %{_datadir}/vim/vimfiles/indent/lilypond.vim
229 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.060045 seconds and 3 git commands to generate.