]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
20b651f6404b5fa7d8e1ca20acda3dac776609cd
[packages/lilypond.git] / lilypond.spec
1 #
2 # Conditional build:
3 %bcond_with     gui     # enable experimental GUI
4 #
5 Summary:        Music typesetter
6 Summary(pl.UTF-8):      Program do składania nut
7 Name:           lilypond
8 Version:        2.10.33
9 Release:        1
10 License:        GPL
11 Group:          Applications/Sound
12 Source0:        http://lilypond.org/download/v2.10/%{name}-%{version}.tar.gz
13 # Source0-md5:  86a67fcc404e942be723f8a72988b286
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-sh.patch
16 Patch2:         %{name}-po.patch
17 Patch3:         %{name}-afm.patch
18 URL:            http://www.lilypond.org/
19 BuildRequires:  automake
20 BuildRequires:  bison >= 1.29
21 BuildRequires:  flex >= 2.5.4a
22 BuildRequires:  fontconfig
23 BuildRequires:  fontconfig-devel >= 1:2.2.0
24 BuildRequires:  fontforge >= 20050624
25 BuildRequires:  gettext-devel
26 BuildRequires:  ghostscript >= 8.15
27 BuildRequires:  ghostscript-fonts-std
28 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
29 BuildRequires:  guile-devel >= 5:1.6.7
30 BuildRequires:  kpathsea-devel
31 BuildRequires:  libltdl-devel
32 BuildRequires:  libstdc++-devel >= 5:4.0
33 BuildRequires:  mftrace >= 1.1.19
34 BuildRequires:  pango-devel >= 1.6.0
35 BuildRequires:  pkgconfig >= 1:0.9.0
36 BuildRequires:  python-devel >= 2.1
37 BuildRequires:  tetex-dvips
38 BuildRequires:  tetex-fonts-cm
39 BuildRequires:  tetex-fonts-cmextra
40 BuildRequires:  tetex-fonts-jknappen
41 BuildRequires:  texinfo >= 4.7
42 BuildConflicts: lilypond < 1.6.0
43 Requires:       ghostscript >= 8.15
44 Requires:       guile >= 5:1.6.5
45 Requires:       python >= 2.1
46 Requires:       tetex-format-latex >= 1.0
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         texmfdir        /usr/share/texmf
50 %define         texfontsdir     %{texmfdir}/fonts
51
52 %description
53 LilyPond is a music typesetter. It produces beautiful sheet music
54 using a high level description file as input. It excels at typesetting
55 classical music, but you can also print pop-songs. With LilyPond we
56 hope to make music publication software available to anyone on the
57 internet.
58
59 %description -l pl.UTF-8
60 LilyPond jest programem do składu muzycznego. Produkuje piękne
61 partytury używając języka wysokiego poziomu jako wejście. Służy przede
62 wszystkim do składania nut muzyki klasycznej, ale można drukować także
63 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
64 wszystkim oprogramowania do publikacji muzycznych.
65
66 %package -n emacs-lilypond-mode-pkg
67 Summary:        LilyPond mode for Emacs
68 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
69 Group:          Applications/Editors/Emacs
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       emacs
72
73 %description -n emacs-lilypond-mode-pkg
74 LilyPond mode for Emacs.
75
76 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
77 Tryb edycji plików LilyPond dla Emacsa.
78
79 %package -n vim-syntax-lilypond
80 Summary:        LilyPond files support for Vim
81 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
82 Group:          Applications/Editors/Vim
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       vim >= 4:6.4.001-2
85
86 %description -n vim-syntax-lilypond
87 LilyPond files support for Vim.
88
89 %description -n vim-syntax-lilypond -l pl.UTF-8
90 Obsługa plików LilyPonda dla Vima.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98
99 %build
100 cp -f /usr/share/automake/config.* stepmake/bin
101 %{__autoconf}
102 %configure \
103         %{?debug:--disable-optimising} \
104         %{?with_gui:--enable-gui}
105 %{__make} -j1
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips/misc,tex},%{texfontsdir}/{source,tfm,type1}}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
115
116 # for dvips
117 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips \
118         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
119 # ?
120 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
121         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
122 # for latex and dvips
123 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
124         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
125 # both for lilypond and dvips
126 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
127         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
128 ln -sf %{_datadir}/lilypond/%{version}/ps/music-drawing-routines.ps \
129         $RPM_BUILD_ROOT%{texmfdir}/dvips/misc
130
131 # no need for subdir
132 mv -f $RPM_BUILD_ROOT%{_infodir}/lilypond/*.info* $RPM_BUILD_ROOT%{_infodir}
133
134 # vim syntax/etc. files
135 install -d $RPM_BUILD_ROOT%{_datadir}/vim
136 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
137         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
138
139 # lilypond/stepmake build system - not needed at runtime
140 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
149 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
150 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
151
152 %postun
153 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
154 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
155 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
156
157 %files -f %{name}.lang
158 %defattr(644,root,root,755)
159 %doc AUTHORS.txt ChangeLog DEDICATION NEWS.txt README.txt THANKS
160 %attr(755,root,root) %{_bindir}/abc2ly
161 %attr(755,root,root) %{_bindir}/convert-ly
162 %attr(755,root,root) %{_bindir}/etf2ly
163 %attr(755,root,root) %{_bindir}/lilypond
164 %attr(755,root,root) %{_bindir}/lilypond-book
165 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
166 %attr(755,root,root) %{_bindir}/midi2ly
167 %attr(755,root,root) %{_bindir}/musicxml2ly
168 %dir %{_libdir}/lilypond
169 %dir %{_libdir}/lilypond/%{version}
170 %dir %{_libdir}/lilypond/%{version}/python
171 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
172 %dir %{_datadir}/lilypond
173 %dir %{_datadir}/lilypond/%{version}
174 %{_datadir}/lilypond/%{version}/fonts
175 %{_datadir}/lilypond/%{version}/ly
176 %{_datadir}/lilypond/%{version}/ps
177 %dir %{_datadir}/lilypond/%{version}/python
178 %{_datadir}/lilypond/%{version}/python/*.py
179 %{_datadir}/lilypond/%{version}/python/*.pyc
180 %{_datadir}/lilypond/%{version}/scm
181 %{_infodir}/*.info*
182 %{_mandir}/man1/*
183
184 %{texfontsdir}/source/lilypond
185 %{texfontsdir}/type1/lilypond
186 %{texmfdir}/dvips/lilypond
187 %{texmfdir}/dvips/misc/*.ps
188 %{texmfdir}/tex/lilypond
189
190 %{_datadir}/omf/lilypond
191
192 %files -n emacs-lilypond-mode-pkg
193 %defattr(644,root,root,755)
194 %{_datadir}/emacs/site-lisp/*.el
195
196 %files -n vim-syntax-lilypond
197 %defattr(644,root,root,755)
198 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
199 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
200 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
201 %{_datadir}/vim/vimfiles/indent/lilypond.vim
202 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.165938 seconds and 3 git commands to generate.