]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- fix for wrong socket call in HTTP/1.0 redirects
[packages/lighttpd.git] / lighttpd.spec
1 #
2 # TODO
3 # - fix modules:
4 #  mod_localizer   : disabled (liblocalizer missing)
5 #  mod_maps        : disabled (liblocalizer missing)
6 #  mod_chat        : disabled, buy your license :)
7 #  mod_cache       : disabled, buy your license :)
8 # - test ldap and mysql (failed at this time)
9 # - documentroot specified in config doesn't exist
10 #
11 # Conditional build for lighttpd:
12 %bcond_without  xattr   # without support of extended attributes
13 %bcond_with     mysql   # with mysql
14 %bcond_with     ldap    # with ldap
15 %bcond_with     valgrind        # enable valgrind fixes in code.
16 %bcond_without  largefile       # without largefile support,
17 # use it if you have 2.4 kernel to get sendfile() support,
18 # and don't need > 2GB file requests,
19 # see http://article.gmane.org/gmane.comp.web.lighttpd:722
20 #
21
22 # Prerelease snapshot: DATE-TIME
23 #define _snap 20050116-1743
24
25 %if 0%{?_snap}
26 %define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
27 %else
28 %define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
29 %endif
30
31 %define _rel 0.18
32
33 Summary:        Fast and light HTTP server
34 Summary(pl):    Szybki i lekki serwer HTTP
35 Name:           lighttpd
36 Version:        1.3.7
37 Release:        %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
38 Group:          Networking/Daemons
39 License:        BSD
40 Source0:        %{_source}
41 # Source0-md5:  40ac1d07d9efb0366720d081c3e02224
42 Source1:        %{name}.init
43 Source2:        %{name}.conf
44 Source3:        %{name}.user
45 Source4:        %{name}.logrotate
46 Source5:        %{name}.sysconfig
47 Patch0:         %{name}-mod_status.patch
48 Patch1:         %{name}-doublefree.patch
49 Patch2:         %{name}-avg-req.patch
50 Patch3:         %{name}-readpost-timeout.patch
51 Patch4:         %{name}-fcgi-fdevent.patch
52 Patch5:         %{name}-write-EINTR.patch
53 Patch6:         %{name}-getsockname.patch
54 URL:            http://www.lighttpd.net/
55 BuildRequires:  autoconf
56 BuildRequires:  automake
57 BuildRequires:  bzip2-devel
58 BuildRequires:  libtool
59 BuildRequires:  openssl-devel
60 BuildRequires:  pcre-devel
61 BuildRequires:  rpmbuild(macros) >= 1.159
62 BuildRequires:  zlib-devel
63 %if %{with xattr}
64 BuildRequires:  attr-devel
65 %endif
66 %{?with_ldap:BuildRequires:     openldap-devel}
67 %{?with_mysql:BuildRequires:    mysql-devel}
68 %{?with_valgrind:BuildRequires: valgrind}
69 %{!?with_valgrind:BuildConflicts:       valgrind}
70 PreReq:         rc-scripts
71 Requires(pre):  sh-utils
72 Requires(pre):  /bin/id
73 Requires(pre):  /usr/bin/getgid
74 Requires(pre):  /usr/sbin/groupadd
75 Requires(pre):  /usr/sbin/useradd
76 Requires(post,preun):   /sbin/chkconfig
77 Requires(postun):       /usr/sbin/groupdel
78 Requires(postun):       /usr/sbin/userdel
79 Provides:       group(lighttpd)
80 Provides:       httpd
81 Provides:       user(lighttpd)
82 Provides:       webserver
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _libdir         %{_prefix}/%{_lib}/%{name}
86 %define         _lighttpddir    /home/services/%{name}
87 %define         _sysconfdir     /etc/%{name}
88
89 %description
90 lighttpd is a secure, fast, compliant and very flexible web-server
91 which has been optimized for high-performance environments. It has
92 a very low memory footprint compared to other webservers and takes
93 care of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
94 Output-Compression, URL-Rewriting and many more) make lighttpd the
95 perfect webserver-software for every server that is suffering load
96 problems.
97
98 %description -l pl
99 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
100 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
101 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci
102 w porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
103 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
104 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
105 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy
106 z powodu problemów z obci±¿eniem.
107
108 %package -n spawn-fcgi
109 Summary:        Spawn fcgi-process directly
110 Summary(pl):    Bezpo¶rednie uruchamianie procesów fcgi
111 Group:          Applications
112
113 %description -n spawn-fcgi
114 spawn-fcgi is used to spawn fcgi-process directly without the help of
115 a webserver or the programm itself.
116
117 %description -n spawn-fcgi -l pl
118 spawn-fcgi s³u¿y do uruchamiania procesów fcgi bezpo¶rednio, bez
119 pomocy serwera WWW ani samego programu.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124 %patch1 -p1
125 %patch2 -p1
126 %patch3 -p1
127 %patch4 -p1
128 %patch5 -p1
129 %patch6 -p1
130
131 %build
132 %{__libtoolize}
133 %{__aclocal}
134 %{__autoconf}
135 %configure \
136         --enable-mod-chat \
137         --enable-mod-cache \
138         --enable-mod-localizer \
139         %{?with_xattr:--with-attr} \
140         %{?with_mysql:--with-mysql} \
141         %{?with_ldap:--with-ldap} \
142         %{!?with_largefile:--disable-lfs} \
143         --with-openssl
144         
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/cgi-bin,/etc/{logrotate.d,rc.d/init.d,sysconfig},%{_sysconfdir}} \
150         $RPM_BUILD_ROOT/var/log/{%{name},archiv/%{name}}
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
156 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
157 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
158 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
159
160 # could use automake patch, but automake generation fails...
161 mv $RPM_BUILD_ROOT%{_bindir}/spawn-fcgi $RPM_BUILD_ROOT%{_sbindir}/spawn-fcgi
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %pre
167 if [ -n "`/usr/bin/getgid lighttpd`" ]; then
168         if [ "`/usr/bin/getgid lighttpd`" != 109 ]; then
169                 echo "Error: group lighttpd doesn't have gid=109. Correct this before installing %{name}." 1>&2
170                 exit 1
171         fi
172 else
173         /usr/sbin/groupadd -g 109 lighttpd
174 fi
175 if [ -n "`/bin/id -u lighttpd 2>/dev/null`" ]; then
176         if [ "`/bin/id -u lighttpd`" != 116 ]; then
177                 echo "Error: user lighttpd doesn't have uid=116. Correct this before installing %{name}." 1>&2
178                 exit 1
179         fi
180 else
181         /usr/sbin/useradd -u 116 -d %{_lighttpddir} -s /bin/false \
182                 -c "HTTP User" -g lighttpd lighttpd 1>&2
183 fi
184
185 %post
186 /sbin/chkconfig --add %{name}
187 if [ -f /var/lock/subsys/%{name} ]; then
188         /etc/rc.d/init.d/%{name} restart 1>&2
189 else
190         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
191 fi
192
193 %preun
194 if [ "$1" = "0" ]; then
195         if [ -f /var/lock/subsys/%{name} ]; then
196                 /etc/rc.d/init.d/%{name} stop 1>&2
197         fi
198         /sbin/chkconfig --del %{name}
199 fi
200
201 %postun
202 if [ "$1" = "0" ]; then
203         %userremove lighttpd
204         %groupremove lighttpd
205 fi
206
207 %triggerpostun -- %{name} <= 1.3.6-2
208 # upgraded
209 if [ "$1" = "2" ]; then
210 %banner %{name} -e <<EOF
211 spawn-fcgi program is now available separately from spawn-fcgi package.
212
213 EOF
214 fi
215
216
217 %files
218 %defattr(644,root,root,755)
219 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
220 %attr(755,root,root) %{_sbindir}/*
221 %dir %{_libdir}
222 %attr(755,root,root) %{_libdir}/*.so
223 %attr(750,root,root) %dir /var/log/archiv/%{name}
224 %dir %attr(750,lighttpd,root) /var/log/%{name}
225 %attr(755,lighttpd,lighttpd) %{_lighttpddir}
226 %attr(754,root,root) /etc/rc.d/init.d/%{name}
227 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
228 %dir %attr(750,root,lighttpd) %{_sysconfdir}
229 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
230 %attr(640,root,lighttpd) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.user
231 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}
232 %{_mandir}/man?/*
233
234 %files -n spawn-fcgi
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_sbindir}/spawn-fcgi
This page took 0.094653 seconds and 4 git commands to generate.