]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- fix md5, it was okay before
[packages/lighttpd.git] / lighttpd.spec
1 #
2 # TODO
3 # - test ldap and mysql (failed at this time)
4 # - documentroot specified in config doesn't exist
5 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
6 #
7 # Conditional build for lighttpd:
8 %bcond_without  xattr           # without support of extended attributes
9 %bcond_with     mysql           # with mysql
10 %bcond_with     ldap            # with ldap
11 %bcond_with     valgrind        # enable valgrind fixes in code.
12 %bcond_without  ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
13 %bcond_without  largefile       # without largefile support,
14 # use it if you have 2.4 kernel to get sendfile() support,
15 # and don't need > 2GB file requests,
16 # see http://article.gmane.org/gmane.comp.web.lighttpd:722
17 #
18
19 # Prerelease snapshot: DATE-TIME
20 #define _snap 20050116-1743
21
22 %if 0%{?_snap}
23 %define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
24 %else
25 %define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
26 %endif
27
28 %define         _rel 0.23
29
30 Summary:        Fast and light HTTP server
31 Summary(pl):    Szybki i lekki serwer HTTP
32 Name:           lighttpd
33 Version:        1.3.8
34 Release:        %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
35 Group:          Networking/Daemons
36 License:        BSD
37 Source0:        %{_source}
38 # Source0-md5:  4ac341879497064b334e776288ad5e0f
39 Source1:        %{name}.init
40 Source2:        %{name}.conf
41 Source3:        %{name}.user
42 Source4:        %{name}.logrotate
43 Source5:        %{name}.sysconfig
44 Patch0:         %{name}-proto-code.patch
45 URL:            http://www.lighttpd.net/
46 BuildRequires:  autoconf
47 BuildRequires:  automake
48 BuildRequires:  bzip2-devel
49 BuildRequires:  libtool
50 BuildRequires:  openssl-devel
51 BuildRequires:  pcre-devel
52 BuildRequires:  rpmbuild(macros) >= 1.159
53 BuildRequires:  zlib-devel
54 %if %{with xattr}
55 BuildRequires:  attr-devel
56 %endif
57 %{?with_ldap:BuildRequires:     openldap-devel}
58 %{?with_mysql:BuildRequires:    mysql-devel}
59 %{?with_valgrind:BuildRequires: valgrind}
60 %{!?with_valgrind:BuildConflicts:       valgrind}
61 PreReq:         rc-scripts
62 Requires(pre):  sh-utils
63 Requires(pre):  /bin/id
64 Requires(pre):  /usr/bin/getgid
65 Requires(pre):  /usr/sbin/groupadd
66 Requires(pre):  /usr/sbin/useradd
67 Requires(post,preun):   /sbin/chkconfig
68 Requires(postun):       /usr/sbin/groupdel
69 Requires(postun):       /usr/sbin/userdel
70 Provides:       group(lighttpd)
71 Provides:       httpd
72 Provides:       user(lighttpd)
73 Provides:       webserver
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _libdir         %{_prefix}/%{_lib}/%{name}
77 %define         _lighttpddir    /home/services/%{name}
78 %define         _sysconfdir     /etc/%{name}
79
80 %description
81 lighttpd is a secure, fast, compliant and very flexible web-server
82 which has been optimized for high-performance environments. It has
83 a very low memory footprint compared to other webservers and takes
84 care of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
85 Output-Compression, URL-Rewriting and many more) make lighttpd the
86 perfect webserver-software for every server that is suffering load
87 problems.
88
89 %description -l pl
90 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
91 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
92 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci
93 w porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
94 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
95 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
96 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy
97 z powodu problemów z obci±¿eniem.
98
99 %package -n spawn-fcgi
100 Summary:        Spawn fcgi-process directly
101 Summary(pl):    Bezpo¶rednie uruchamianie procesów fcgi
102 Group:          Applications
103
104 %description -n spawn-fcgi
105 spawn-fcgi is used to spawn fcgi-process directly without the help of
106 a webserver or the programm itself.
107
108 %description -n spawn-fcgi -l pl
109 spawn-fcgi s³u¿y do uruchamiania procesów fcgi bezpo¶rednio, bez
110 pomocy serwera WWW ani samego programu.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 %build
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %configure \
121         --enable-mod-chat \
122         --enable-mod-cache \
123         --enable-mod-localizer \
124         %{?with_xattr:--with-attr} \
125         %{?with_mysql:--with-mysql} \
126         %{?with_ldap:--with-ldap} \
127         %{!?with_ipv6:--disable-ipv6} \
128         %{!?with_largefile:--disable-lfs} \
129         --with-openssl
130         
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig},%{_sysconfdir}} \
136         $RPM_BUILD_ROOT/var/log/{%{name},archiv/%{name}}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
142 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
143 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
144 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
145
146 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
147
148 # could use automake patch, but automake generation fails...
149 mv $RPM_BUILD_ROOT%{_bindir}/spawn-fcgi $RPM_BUILD_ROOT%{_sbindir}/spawn-fcgi
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %pre
155 if [ -n "`/usr/bin/getgid lighttpd`" ]; then
156         if [ "`/usr/bin/getgid lighttpd`" != 109 ]; then
157                 echo "Error: group lighttpd doesn't have gid=109. Correct this before installing %{name}." 1>&2
158                 exit 1
159         fi
160 else
161         /usr/sbin/groupadd -g 109 lighttpd
162 fi
163 if [ -n "`/bin/id -u lighttpd 2>/dev/null`" ]; then
164         if [ "`/bin/id -u lighttpd`" != 116 ]; then
165                 echo "Error: user lighttpd doesn't have uid=116. Correct this before installing %{name}." 1>&2
166                 exit 1
167         fi
168 else
169         /usr/sbin/useradd -u 116 -d %{_lighttpddir} -s /bin/false \
170                 -c "HTTP User" -g lighttpd lighttpd 1>&2
171 fi
172
173 %post
174 /sbin/chkconfig --add %{name}
175 if [ -f /var/lock/subsys/%{name} ]; then
176         /etc/rc.d/init.d/%{name} restart 1>&2
177 else
178         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
179 fi
180
181 %preun
182 if [ "$1" = "0" ]; then
183         if [ -f /var/lock/subsys/%{name} ]; then
184                 /etc/rc.d/init.d/%{name} stop 1>&2
185         fi
186         /sbin/chkconfig --del %{name}
187 fi
188
189 %postun
190 if [ "$1" = "0" ]; then
191         %userremove lighttpd
192         %groupremove lighttpd
193 fi
194
195 %triggerpostun -- %{name} <= 1.3.6-2
196 # upgraded
197 if [ "$1" = "2" ]; then
198 %banner %{name} -e <<EOF
199 spawn-fcgi program is now available separately from spawn-fcgi package.
200
201 EOF
202 fi
203
204 %files
205 %defattr(644,root,root,755)
206 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
207 %attr(755,root,root) %{_sbindir}/*
208 %dir %{_libdir}
209 %attr(755,root,root) %{_libdir}/*.so
210 %attr(750,root,root) %dir /var/log/archiv/%{name}
211 %dir %attr(750,lighttpd,root) /var/log/%{name}
212 %attr(755,lighttpd,lighttpd) %{_lighttpddir}
213 %attr(754,root,root) /etc/rc.d/init.d/%{name}
214 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
215 %dir %attr(750,root,lighttpd) %{_sysconfdir}
216 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
217 %attr(640,root,lighttpd) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.user
218 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}
219 %{_mandir}/man?/*
220
221 %files -n spawn-fcgi
222 %defattr(644,root,root,755)
223 %doc doc/spawn-php.sh
224 %attr(755,root,root) %{_sbindir}/spawn-fcgi
This page took 0.11429 seconds and 4 git commands to generate.