]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- remove mistaken experimental patch
[packages/lighttpd.git] / lighttpd.spec
1 #
2 # Conditional build for lighttpd:
3 %bcond_without  xattr   # without support of extended attributes
4 #
5 Summary:        Fast and light HTTP server
6 Summary(pl):    Szybki i lekki serwer HTTP
7 Name:           lighttpd
8 Version:        1.3.7
9 Release:        0.2
10 Group:          Networking/Daemons
11 License:        BSD
12 ## do not remove next two lines because atomic revisions are common in lighttpd
13 #%define                _rel    20041102-1041
14 #Source0:       http://jan.kneschke.de/projects/lighttpd/download/%{name}-%{version}-%{_rel}.tar.gz
15 Source0:        http://jan.kneschke.de/projects/lighttpd/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  40ac1d07d9efb0366720d081c3e02224
17 Source1:        %{name}.init
18 Source2:        %{name}.conf
19 Source3:        %{name}.user
20 Source4:        %{name}.logrotate
21 #Patch0:                %{name}-fcgi-err.patch
22 URL:            http://jan.kneschke.de/projects/lighttpd/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  bzip2-devel
26 BuildRequires:  libtool
27 BuildRequires:  openssl-devel
28 BuildRequires:  pcre-devel
29 BuildRequires:  rpmbuild(macros) >= 1.159
30 BuildRequires:  zlib-devel
31 %if %{with xattr}
32 BuildRequires:  attr-devel
33 %endif
34 PreReq:         rc-scripts
35 Requires(pre):  sh-utils
36 Requires(pre):  /bin/id
37 Requires(pre):  /usr/bin/getgid
38 Requires(pre):  /usr/sbin/groupadd
39 Requires(pre):  /usr/sbin/useradd
40 Requires(post,preun):   /sbin/chkconfig
41 Requires(postun):       /usr/sbin/groupdel
42 Requires(postun):       /usr/sbin/userdel
43 Provides:       group(lighttpd)
44 Provides:       httpd
45 Provides:       user(lighttpd)
46 Provides:       webserver
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _libdir         %{_prefix}/%{_lib}/%{name}
50 %define         _lighttpddir    /home/services/%{name}
51 %define         _sysconfdir     /etc/%{name}
52
53 %description
54 lighttpd is a secure, fast, compliant and very flexible web-server
55 which has been optimized for high-performance environments. It has
56 a very low memory footprint compared to other webservers and takes
57 care of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
58 Output-Compression, URL-Rewriting and many more) make lighttpd the
59 perfect webserver-software for every server that is suffering load
60 problems.
61
62 %description -l pl
63 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
64 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
65 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci
66 w porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
67 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
68 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
69 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy
70 z powodu problemów z obci±¿eniem.
71
72 %prep
73 %setup -q
74 #%patch0 -p1
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 #%{__automake}
81 %configure \
82         --enable-mod-chat \
83         --enable-mod-cache \
84         --enable-mod-localizer \
85         %{?with_xattr:--with-attr} \
86         --with-openssl
87         
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/cgi-bin,/etc/{logrotate.d,rc.d/init.d},%{_sysconfdir}} \
93         $RPM_BUILD_ROOT/var/log/{%{name},archiv/%{name}}
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
99 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
100 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %pre
106 if [ -n "`/usr/bin/getgid lighttpd`" ]; then
107         if [ "`/usr/bin/getgid lighttpd`" != 109 ]; then
108                 echo "Error: group lighttpd doesn't have gid=109. Correct this before installing %{name}." 1>&2
109                 exit 1
110         fi
111 else
112         /usr/sbin/groupadd -g 109 lighttpd
113 fi
114 if [ -n "`/bin/id -u lighttpd 2>/dev/null`" ]; then
115         if [ "`/bin/id -u lighttpd`" != 116 ]; then
116                 echo "Error: user lighhttpd doesn't have uid=116. Correct this before installing %{name}." 1>&2
117                 exit 1
118         fi
119 else
120         /usr/sbin/useradd -u 116 -d %{_lighttpddir} -s /bin/false \
121                 -c "HTTP User" -g lighttpd lighttpd 1>&2
122 fi
123
124 %post
125 /sbin/chkconfig --add %{name}
126 if [ -f /var/lock/subsys/%{name} ]; then
127         /etc/rc.d/init.d/%{name} restart 1>&2
128 else
129         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
130 fi
131
132 %preun
133 if [ "$1" = "0" ]; then
134         if [ -f /var/lock/subsys/%{name} ]; then
135                 /etc/rc.d/init.d/%{name} stop 1>&2
136         fi
137         /sbin/chkconfig --del %{name}
138 fi
139
140 %postun
141 if [ "$1" = "0" ]; then
142         %userremove lighttpd
143         %groupremove lighttpd
144 fi
145
146 %files
147 %defattr(644,root,root,755)
148 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
149 %attr(755,root,root) %{_sbindir}/*
150 %attr(755,root,root) %{_bindir}/*
151 %dir %{_libdir}
152 %attr(755,root,root) %{_libdir}/*.so
153 %attr(750,root,root) %dir /var/log/archiv/%{name}
154 %dir %attr(750,lighttpd,root) /var/log/%{name}
155 %attr(755,lighttpd,lighttpd) %{_lighttpddir}
156 %attr(754,root,root) /etc/rc.d/init.d/%{name}
157 %dir %attr(750,root,lighttpd) %{_sysconfdir}
158 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.*
159 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}
160 %{_mandir}/man?/*
This page took 0.0431 seconds and 4 git commands to generate.