]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- bcond for ssl
[packages/lighttpd.git] / lighttpd.spec
1 #
2 # TODO
3 # - test ldap and mysql (failed at this time)
4 # - documentroot specified in config doesn't exist
5 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
6 #
7 # Conditional build for lighttpd:
8 %bcond_without  xattr           # without support of extended attributes
9 %bcond_with     mysql           # with mysql
10 %bcond_with     ldap            # with ldap
11 %bcond_with     valgrind        # enable valgrind fixes in code.
12 %bcond_without  ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
13 %bcond_without  largefile       # without largefile support,
14 %bcond_without  ssl             # disable ssl support
15 # use it if you have 2.4 kernel to get sendfile() support,
16 # and don't need > 2GB file requests,
17 # see http://article.gmane.org/gmane.comp.web.lighttpd:722
18 #
19
20 # Prerelease snapshot: DATE-TIME
21 ##define _snap 20050116-1743
22
23 %if 0%{?_snap}
24 %define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
25 %else
26 %define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
27 %endif
28
29 %define         _rel 2
30
31 Summary:        Fast and light HTTP server
32 Summary(pl):    Szybki i lekki serwer HTTP
33 Name:           lighttpd
34 Version:        1.3.8
35 Release:        %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
36 Group:          Networking/Daemons
37 License:        BSD
38 Source0:        %{_source}
39 # Source0-md5:  4ac341879497064b334e776288ad5e0f
40 Source1:        %{name}.init
41 Source2:        %{name}.conf
42 Source3:        %{name}.user
43 Source4:        %{name}.logrotate
44 Source5:        %{name}.sysconfig
45 Patch0:         %{name}-proto-code.patch
46 URL:            http://www.lighttpd.net/
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 BuildRequires:  bzip2-devel
50 BuildRequires:  libtool
51 %{?with_ssl:BuildRequires:      openssl-devel}
52 BuildRequires:  pcre-devel
53 BuildRequires:  rpmbuild(macros) >= 1.159
54 BuildRequires:  zlib-devel
55 %if %{with xattr}
56 BuildRequires:  attr-devel
57 %endif
58 %{?with_ldap:BuildRequires:     openldap-devel}
59 %{?with_mysql:BuildRequires:    mysql-devel}
60 %{?with_valgrind:BuildRequires: valgrind}
61 %{!?with_valgrind:BuildConflicts:       valgrind}
62 PreReq:         rc-scripts
63 Requires(pre):  sh-utils
64 Requires(pre):  /bin/id
65 Requires(pre):  /usr/bin/getgid
66 Requires(pre):  /usr/sbin/groupadd
67 Requires(pre):  /usr/sbin/useradd
68 Requires(post,preun):   /sbin/chkconfig
69 Requires(postun):       /usr/sbin/groupdel
70 Requires(postun):       /usr/sbin/userdel
71 Provides:       group(lighttpd)
72 Provides:       httpd
73 Provides:       user(lighttpd)
74 Provides:       webserver
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _libdir         %{_prefix}/%{_lib}/%{name}
78 %define         _lighttpddir    /home/services/%{name}
79 %define         _sysconfdir     /etc/%{name}
80
81 %description
82 lighttpd is a secure, fast, compliant and very flexible web-server
83 which has been optimized for high-performance environments. It has
84 a very low memory footprint compared to other webservers and takes
85 care of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
86 Output-Compression, URL-Rewriting and many more) make lighttpd the
87 perfect webserver-software for every server that is suffering load
88 problems.
89
90 %description -l pl
91 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
92 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
93 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci
94 w porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
95 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
96 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
97 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy
98 z powodu problemów z obci±¿eniem.
99
100 %package -n spawn-fcgi
101 Summary:        Spawn fcgi-process directly
102 Summary(pl):    Bezpo¶rednie uruchamianie procesów fcgi
103 Group:          Applications
104
105 %description -n spawn-fcgi
106 spawn-fcgi is used to spawn fcgi-process directly without the help of
107 a webserver or the programm itself.
108
109 %description -n spawn-fcgi -l pl
110 spawn-fcgi s³u¿y do uruchamiania procesów fcgi bezpo¶rednio, bez
111 pomocy serwera WWW ani samego programu.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116
117 %build
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %configure \
122         --enable-mod-chat \
123         --enable-mod-cache \
124         --enable-mod-localizer \
125         %{?with_xattr:--with-attr} \
126         %{?with_mysql:--with-mysql} \
127         %{?with_ldap:--with-ldap} \
128         %{!?with_ipv6:--disable-ipv6} \
129         %{!?with_largefile:--disable-lfs} \
130         %{?with_ssl:--with-openssl}
131         
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig},%{_sysconfdir}} \
137         $RPM_BUILD_ROOT/var/log/{%{name},archiv/%{name}}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
143 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
144 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
145 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
146
147 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
148
149 # could use automake patch, but automake generation fails...
150 mv $RPM_BUILD_ROOT%{_bindir}/spawn-fcgi $RPM_BUILD_ROOT%{_sbindir}/spawn-fcgi
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %pre
156 if [ -n "`/usr/bin/getgid lighttpd`" ]; then
157         if [ "`/usr/bin/getgid lighttpd`" != 109 ]; then
158                 echo "Error: group lighttpd doesn't have gid=109. Correct this before installing %{name}." 1>&2
159                 exit 1
160         fi
161 else
162         /usr/sbin/groupadd -g 109 lighttpd
163 fi
164 if [ -n "`/bin/id -u lighttpd 2>/dev/null`" ]; then
165         if [ "`/bin/id -u lighttpd`" != 116 ]; then
166                 echo "Error: user lighttpd doesn't have uid=116. Correct this before installing %{name}." 1>&2
167                 exit 1
168         fi
169 else
170         /usr/sbin/useradd -u 116 -d %{_lighttpddir} -s /bin/false \
171                 -c "HTTP User" -g lighttpd lighttpd 1>&2
172 fi
173
174 %post
175 /sbin/chkconfig --add %{name}
176 if [ -f /var/lock/subsys/%{name} ]; then
177         /etc/rc.d/init.d/%{name} restart 1>&2
178 else
179         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
180 fi
181
182 %preun
183 if [ "$1" = "0" ]; then
184         if [ -f /var/lock/subsys/%{name} ]; then
185                 /etc/rc.d/init.d/%{name} stop 1>&2
186         fi
187         /sbin/chkconfig --del %{name}
188 fi
189
190 %postun
191 if [ "$1" = "0" ]; then
192         %userremove lighttpd
193         %groupremove lighttpd
194 fi
195
196 %triggerpostun -- %{name} <= 1.3.6-2
197 # upgraded
198 if [ "$1" = "2" ]; then
199 %banner %{name} -e <<EOF
200 spawn-fcgi program is now available separately from spawn-fcgi package.
201
202 EOF
203 fi
204
205 %files
206 %defattr(644,root,root,755)
207 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
208 %attr(755,root,root) %{_sbindir}/*
209 %dir %{_libdir}
210 %attr(755,root,root) %{_libdir}/*.so
211 %attr(750,root,root) %dir /var/log/archiv/%{name}
212 %dir %attr(750,lighttpd,root) /var/log/%{name}
213 %attr(755,lighttpd,lighttpd) %{_lighttpddir}
214 %attr(754,root,root) /etc/rc.d/init.d/%{name}
215 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
216 %dir %attr(750,root,lighttpd) %{_sysconfdir}
217 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
218 %attr(640,root,lighttpd) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.user
219 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}
220 %{_mandir}/man?/*
221
222 %files -n spawn-fcgi
223 %defattr(644,root,root,755)
224 %doc doc/spawn-php.sh
225 %attr(755,root,root) %{_sbindir}/spawn-fcgi
This page took 0.04081 seconds and 4 git commands to generate.