]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- added mod_magnet module, dropped 1.5 only modules
[packages/lighttpd.git] / lighttpd.spec
1 # TODO:
2 # - test ldap and mysql (failed at this time)
3 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
4 # - fam over gamin is possible, just configure doesn't check other than gamin
5 # - feature stat-cache-fam (doesn't work)
6 # - lighttpd writes early startup messages to stderr, and if started from
7 #   rc-scripts the stderr is closed which causes lighttpd to abort():
8 #   2006-07-20 21:05:52: (server.c.1233) WARNING: unknown config-key: url.rewrite-final (ignored)
9 #
10 # NOTES:
11 # - fcgi-devel is only used for the test-scripts
12 # - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
13 #   see http://article.gmane.org/gmane.comp.web.lighttpd:722
14 #
15 # Conditional build for lighttpd:
16 %bcond_without  xattr           # support of extended attributes
17 %bcond_without  ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
18 %bcond_without  largefile       # largefile support (see notes above)
19 %bcond_without  ssl             # ssl support
20 %bcond_without  mysql           # mysql support in mod_mysql_vhost
21 %bcond_with     ldap            # ldap support in mod_auth
22 %bcond_without  lua             # LUA support in mod_cml (needs LUA >= 5.1)
23 %bcond_with     memcache        # memcached support in mod_cml / mod_trigger_b4_dl
24 %bcond_with     gamin           # gamin for reducing number of stat() calls.
25                                 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26 %bcond_with     gdbm            # gdbm in mod_trigger_b4_dl
27 %bcond_with     webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
28 %bcond_with     valgrind        # compile code with valgrind support.
29 %bcond_with     deflate         # build deflate module (needs patch update with current svn)
30
31 # SVN snapshot
32 #define         _svn    1277
33 # Prerelease
34 %define _snap r1309
35
36 %define         _rel 0.60
37 Summary:        Fast and light HTTP server
38 Summary(pl):    Szybki i lekki serwer HTTP
39 Name:           lighttpd
40 Version:        1.4.12
41 Release:        %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
42 License:        BSD
43 Group:          Networking/Daemons
44 Source0:        http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
45 # Source0-md5:  a887b075858cb28bf9fd11d86556509e
46 Source1:        %{name}.init
47 Source2:        %{name}.conf
48 Source3:        %{name}.user
49 Source4:        %{name}.logrotate
50 Source5:        %{name}.sysconfig
51 Source6:        %{name}-mime.types.sh
52 Source7:        http://www.lighttpd.net/favicon.ico
53 # Source7-md5:  a358994becabd4060393a5454bde505d
54 Source8:        http://www.lighttpd.net/light_button.png
55 # Source8-md5:  02330e2313fadc29144edfd6000879f8
56 Source9:        http://www.lighttpd.net/light_logo.png
57 # Source9-md5:  ac20784510e420d5cbe5fc1cdb53d7a7
58 Source10:       http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
59 # Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
60 Source11:       %{name}-pld.html
61 Source100:      %{name}-mod_access.conf
62 Source101:      %{name}-mod_accesslog.conf
63 Source102:      %{name}-mod_alias.conf
64 Source103:      %{name}-mod_auth.conf
65 Source104:      %{name}-mod_cgi.conf
66 Source105:      %{name}-mod_cml.conf
67 Source106:      %{name}-mod_compress.conf
68 Source107:      %{name}-mod_deflate.conf
69 Source108:      %{name}-mod_dirlisting.conf
70 Source109:      %{name}-mod_evasive.conf
71 Source110:      %{name}-mod_evhost.conf
72 Source111:      %{name}-mod_expire.conf
73 Source112:      %{name}-mod_fastcgi.conf
74 Source113:      %{name}-mod_flv_streaming.conf
75 Source114:      %{name}-mod_indexfile.conf
76 Source115:      %{name}-mod_proxy.conf
77 Source116:      %{name}-mod_redirect.conf
78 Source117:      %{name}-mod_rewrite.conf
79 Source118:      %{name}-mod_rrdtool.conf
80 Source119:      %{name}-mod_scgi.conf
81 Source120:      %{name}-mod_secdownload.conf
82 Source121:      %{name}-mod_setenv.conf
83 Source122:      %{name}-mod_simple_vhost.conf
84 Source123:      %{name}-mod_ssi.conf
85 Source124:      %{name}-mod_staticfile.conf
86 Source125:      %{name}-mod_status.conf
87 Source126:      %{name}-mod_trigger_b4_dl.conf
88 Source127:      %{name}-mod_userdir.conf
89 Source128:      %{name}-mod_usertrack.conf
90 Source129:      %{name}-mod_webdav.conf
91 Source130:      %{name}-php-spawned.conf
92 Source131:      %{name}-php-external.conf
93 Source132:      %{name}-ssl.conf
94 Source133:      %{name}-mod_mysql_vhost.conf
95 Source134:      %{name}-mod_magnet.conf
96 #Patch100:      %{name}-branch.diff
97 Patch0:         %{name}-mod_deflate.patch
98 Patch1:         %{name}-use_bin_sh.patch
99 Patch2:         %{name}-initgroups.patch
100 Patch3:         http://trac.lighttpd.net/trac/attachment/ticket/444/%{name}-apr1.patch?format=txt
101 Patch4:         %{name}-mod_evasive-status_code.patch
102 Patch5:         %{name}-lua-version.patch
103 URL:            http://www.lighttpd.net/
104 %{?with_xattr:BuildRequires:    attr-devel}
105 BuildRequires:  autoconf
106 BuildRequires:  automake
107 BuildRequires:  bzip2-devel
108 %{?with_gamin:BuildRequires:    gamin-devel}
109 %{?with_gdbm:BuildRequires:     gdbm-devel}
110 %{?with_memcache:BuildRequires: libmemcache-devel}
111 BuildRequires:  libtool
112 BuildRequires:  libuuid-devel
113 %{?with_webdav_props:BuildRequires:     libxml2-devel}
114 %{?with_lua:BuildRequires:      lua50-devel >= 5.0.2-5.1}
115 BuildRequires:  mailcap >= 2.1.14-4.4
116 %{?with_mysql:BuildRequires:    mysql-devel}
117 %{?with_ldap:BuildRequires:     openldap-devel}
118 %{?with_ssl:BuildRequires:      openssl-devel}
119 BuildRequires:  pcre-devel
120 BuildRequires:  pkgconfig
121 BuildRequires:  rpmbuild(macros) >= 1.268
122 %{?with_webdav_props:BuildRequires:     sqlite3-devel}
123 %{?with_valgrind:BuildRequires: valgrind}
124 BuildRequires:  zlib-devel
125 Requires(post,preun):   /sbin/chkconfig
126 Requires(postun):       /usr/sbin/groupdel
127 Requires(postun):       /usr/sbin/userdel
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/lib/rpm/user_group.sh
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(pre):  /usr/sbin/useradd
133 Requires(pre):  /usr/sbin/usermod
134 Requires:       %{name}-mod_dirlisting
135 Requires:       %{name}-mod_indexfile
136 Requires:       %{name}-mod_staticfile
137 Requires:       rc-scripts
138 Provides:       group(http)
139 Provides:       group(lighttpd)
140 Provides:       user(lighttpd)
141 Provides:       webserver
142 # for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
143 Conflicts:      rpm < 4.4.2-0.2
144 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
145
146 %define         _libdir         %{_prefix}/%{_lib}/%{name}
147 %define         _lighttpddir    /home/services/%{name}
148 %define         _sysconfdir     /etc/%{name}
149
150 %description
151 lighttpd is a secure, fast, compliant and very flexible web-server
152 which has been optimized for high-performance environments. It has a
153 very low memory footprint compared to other webservers and takes care
154 of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
155 Output-Compression, URL-Rewriting and many more) make lighttpd the
156 perfect webserver-software for every server that is suffering load
157 problems.
158
159 %description -l pl
160 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
161 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
162 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci w
163 porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
164 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
165 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
166 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy z
167 powodu problemów z obci±¿eniem.
168
169 %package mod_access
170 Summary:        lighttpd module for making access restrictions
171 Group:          Networking/Daemons
172 Requires:       %{name} = %{version}-%{release}
173 Provides:       webserver(access)
174
175 %description mod_access
176 The access module is used to deny access to files with given trailing
177 path names.
178
179 %package mod_accesslog
180 Summary:        lighttpd module to record access logs
181 Group:          Networking/Daemons
182 Requires:       %{name} = %{version}-%{release}
183
184 %description mod_accesslog
185 CLF like by default, flexible like Apache.
186
187 %package mod_alias
188 Summary:        lighttpd module for making url aliasing
189 Group:          Networking/Daemons
190 Requires:       %{name} = %{version}-%{release}
191 Provides:       webserver(alias)
192
193 %description mod_alias
194 The alias module is used to specify a special document-root for a
195 given url-subset.
196
197 %package mod_auth
198 Summary:        lighttpd module for authentication support
199 Group:          Networking/Daemons
200 Requires:       %{name} = %{version}-%{release}
201 Provides:       webserver(auth)
202
203 %description mod_auth
204 lighttpd supportes both authentication method described by RFC 2617:
205 basic and digest.
206
207 %package mod_cgi
208 Summary:        lighttpd module for CGI handling
209 Group:          Networking/Daemons
210 Requires:       %{name} = %{version}-%{release}
211 Provides:       webserver(cgi)
212
213 %description mod_cgi
214 The cgi module provides a CGI-conforming interface.
215
216 CGI programs allow you to enhance the functionality of the server in a
217 very straight and simple way...
218
219 %package mod_cml
220 Summary:        lighttpd module for Cache Meta Language
221 Summary(pl):    Modu³ Cache Meta Language
222 Group:          Networking/Daemons
223 Requires:       %{name} = %{version}-%{release}
224
225 %description mod_cml
226 CML is a Meta language to describe the dependencies of a page at one
227 side and building a page from its fragments on the other side using
228 LUA.
229
230 %description mod_cml -l pl
231 CML to metajêzyk s³u¿±cy z jednej strony do opisu zale¿no¶ci strony i
232 z drugiej strony do budowania strony z fragmentów przy u¿yciu LUA.
233
234 %package mod_compress
235 Summary:        lighttpd module for output compression
236 Summary(pl):    Kompresja wyj¶cia
237 Group:          Networking/Daemons
238 Requires:       %{name} = %{version}-%{release}
239
240 %description mod_compress
241 Output compression reduces the network load and can improve the
242 overall throughput of the webserver.
243
244 Only static content is supported up to now.
245
246 The server negotiates automatically which compression method is used.
247 Supported are gzip, deflate, bzip.
248
249 %description mod_compress -l pl
250 Kompresja wyj¶cia zmniejsza obci±¿enie sieci i mo¿e poprawiæ ca³kowit±
251 przepustowo¶æ serwera WWW.
252
253 Jak na razie obs³ugiwana jest tylko statyczna tre¶æ.
254
255 Serwer automatycznie negocjuje, która metoda kompresji jest u¿ywana.
256 Obs³ugiwane s± gzip, deflate i bzip.
257
258 %package mod_deflate
259 Summary:        lighttpd module for output compression
260 Summary(pl):    Kompresja wyj¶cia
261 Group:          Networking/Daemons
262 URL:            http://trac.lighttpd.net/trac/wiki/Mod_Deflate
263 Requires:       %{name} = %{version}-%{release}
264
265 %description mod_deflate
266 mod_deflate can compress any output from lighttpd static or dynamic.
267 It doesn't support caching compressed output like mod_compress.
268
269 %package mod_dirlisting
270 Summary:        lighttpd module for directory listings
271 Group:          Networking/Daemons
272 Requires:       %{name} = %{version}-%{release}
273
274 %description mod_dirlisting
275 mod_dirlisting generates HTML based directory listings with full CSS
276 control.
277
278 %package mod_evasive
279 Summary:        lighttpd evasive module
280 Group:          Networking/Daemons
281 Requires:       %{name} = %{version}-%{release}
282
283 %description mod_evasive
284
285 %package mod_evhost
286 Summary:        lighttpd module for enhanced virtual-hosting
287 Group:          Networking/Daemons
288 Requires:       %{name} = %{version}-%{release}
289
290 %description mod_evhost
291 mod_evhost builds the document-root based on a pattern which contains
292 wildcards. Those wildcards can represent parts of the submitted
293 hostname.
294
295 %package mod_expire
296 Summary:        lighttpd module for controlling the expiration of content in caches
297 Group:          Networking/Daemons
298 Requires:       %{name} = %{version}-%{release}
299
300 %description mod_expire
301 mod_expire controls the setting of the the Expire response header.
302
303 %package mod_fastcgi
304 Summary:        lighttpd module for FastCGI interface
305 Group:          Networking/Daemons
306 Requires:       %{name} = %{version}-%{release}
307
308 %description mod_fastcgi
309 The FastCGI interface is the fastest and most secure way to interface
310 external process-handlers like Perl, PHP and your self-written
311 applications.
312
313 %package mod_flv_streaming
314 Summary:        lighttpd module for flv streaming
315 Group:          Networking/Daemons
316 Requires:       %{name} = %{version}-%{release}
317
318 %description mod_flv_streaming
319 lighttpd module for flv streaming.
320
321 %package mod_indexfile
322 Summary:        lighttpd indexfile module
323 Group:          Networking/Daemons
324 Requires:       %{name} = %{version}-%{release}
325 Provides:       webserver(indexfile)
326
327 %description mod_indexfile
328 indexfile module.
329
330 %package mod_magnet
331 Summary:        lighttpd powermagnet module
332 Group:          Networking/Daemons
333 Requires:       %{name} = %{version}-%{release}
334
335 %description mod_magnet
336 mod_magnet is a module to control the request handling in lighty.
337
338 %package mod_mysql_vhost
339 Summary:        lighttpd module for MySQL based vhosting
340 Summary(pl):    vhosty oparte na MySQL-u
341 Group:          Networking/Daemons
342 Requires:       %{name} = %{version}-%{release}
343 Conflicts:      %{name}-mod_simple_vhost
344
345 %description mod_mysql_vhost
346 This module provides virtual hosts (vhosts) based on a MySQL table.
347
348 %description mod_mysql_vhost -l pl
349 Ten modu³ udostêpnia wirtualne hosty (vhosty) oparte na tabeli MySQL.
350
351 %package mod_proxy
352 Summary:        lighttpd module for proxying requests
353 Group:          Networking/Daemons
354 Requires:       %{name} = %{version}-%{release}
355
356 %description mod_proxy
357 The proxy module a simplest way to connect lighttpd to java servers
358 which have a HTTP-interface.
359
360 %package mod_proxy_core
361 Summary:        lighttpd module for proxying requests
362 Group:          Networking/Daemons
363 URL:            http://blog.lighttpd.net/articles/2006/07/18/mod_proxy_core-commited-to-svn
364 Requires:       %{name} = %{version}-%{release}
365
366 %description mod_proxy_core
367 The proxy module a simplest way to connect lighttpd to java servers
368 which have a HTTP-interface.
369
370 This is the new proxy code.
371
372 %package mod_redirect
373 Summary:        lighttpd module for URL redirects
374 Group:          Networking/Daemons
375 Requires:       %{name} = %{version}-%{release}
376
377 %description mod_redirect
378 With mod_redirect module you can redirects a set of URLs externally.
379
380 %package mod_rewrite
381 Summary:        lighttpd module for internal redirects, URL rewrite
382 Group:          Networking/Daemons
383 Requires:       %{name} = %{version}-%{release}
384
385 %description mod_rewrite
386 This module allows you rewrite a set of URLs interally in the
387 webserver BEFORE they are handled.
388
389 %package mod_rrdtool
390 Summary:        lighttpd module for monitoring traffic and server load
391 Group:          Networking/Daemons
392 Requires:       %{name} = %{version}-%{release}
393 Requires:       rrdtool
394
395 %description mod_rrdtool
396 RRD is a system to store and display time-series data (i.e. network
397 bandwidth, machine-room temperature, server load average).
398
399 With this module you can monitor the traffic and load on the
400 webserver.
401
402 %package mod_scgi
403 Summary:        lighttpd module for SCGI interface
404 Group:          Networking/Daemons
405 Requires:       %{name} = %{version}-%{release}
406
407 %description mod_scgi
408 SCGI is a fast and simplified CGI interface. It is mostly used by
409 Python + WSGI.
410
411 %package mod_secdownload
412 Summary:        lighttpd module for secure and fast downloading
413 Group:          Networking/Daemons
414 Requires:       %{name} = %{version}-%{release}
415
416 %description mod_secdownload
417 With this module you can easily achieve authenticated file requests
418 and a countermeasure against deep-linking.
419
420 %package mod_setenv
421 Summary:        lighttpd module for setting conditional request headers
422 Group:          Networking/Daemons
423 Requires:       %{name} = %{version}-%{release}
424
425 %description mod_setenv
426 mod_setenv is used to add request headers.
427
428 %package mod_simple_vhost
429 Summary:        lighttpd module for simple virtual-hosting
430 Group:          Networking/Daemons
431 Requires:       %{name} = %{version}-%{release}
432 Conflicts:      %{name}-mod_mysql_vhost
433
434 %description mod_simple_vhost
435 lighttpd module for simple virtual-hosting.
436
437 %package mod_ssi
438 Summary:        lighttpd module for server-side includes
439 Group:          Networking/Daemons
440 Requires:       %{name} = %{version}-%{release}
441
442 %description mod_ssi
443 The module for server-side includes provides a compatability layer for
444 NSCA/Apache SSI.
445
446 %package mod_staticfile
447 Summary:        lighttpd module for static file serving
448 Group:          Networking/Daemons
449 Requires:       %{name} = %{version}-%{release}
450
451 %description mod_staticfile
452 lighttpd module for static file serving.
453
454 %package mod_status
455 Summary:        lighttpd module for displaying server status
456 Group:          Networking/Daemons
457 Requires:       %{name} = %{version}-%{release}
458
459 %description mod_status
460 mod_status displays the server's status and configuration.
461
462 %package mod_trigger_b4_dl
463 Summary:        Trigger before Download
464 Summary(pl):    Wyzwalacz przed ¶ci±ganiem
465 Group:          Networking/Daemons
466 Requires:       %{name} = %{version}-%{release}
467
468 %description mod_trigger_b4_dl
469 Another anti hot-linking module.
470
471 %description mod_trigger_b4_dl -l pl
472 Jeszcze jeden modu³ blokuj±cy bezpo¶rednie linkowanie.
473
474 %package mod_userdir
475 Summary:        lighttpd module for user homedirs
476 Group:          Networking/Daemons
477 Requires:       %{name} = %{version}-%{release}
478
479 %description mod_userdir
480 The userdir module provides a simple way to link user-based
481 directories into the global namespace of the webserver.
482
483 %package mod_usertrack
484 Summary:        lighttpd usertrack module
485 Group:          Networking/Daemons
486 Requires:       %{name} = %{version}-%{release}
487
488 %description mod_usertrack
489
490 %package mod_webdav
491 Summary:        WebDAV module for lighttpd
492 Summary(pl):    Modu³ WebDAV dla libghttpd
493 Group:          Networking/Daemons
494 Requires:       %{name} = %{version}-%{release}
495
496 %description mod_webdav
497 The WebDAV module is a very minimalistic implementation of RFC 2518.
498 Minimalistic means that not all operations are implementated yet.
499
500 So far we have
501 - PROPFIND
502 - OPTIONS
503 - MKCOL
504 - DELETE
505 - PUT
506
507 and the usual GET, POST, HEAD from HTTP/1.1.
508
509 So far mounting a webdav resource into Windows XP works and the basic
510 litmus tests are passed.
511
512 %description mod_webdav -l pl
513 Modu³ WebDAV to bardzo minimalistyczna implementacja RFC 2518.
514 Minimalistyczna oznacza, ¿e jeszcze nie wszystkie operacje s±
515 zaimplementowane. Jak na razie s±:
516 - PROPFIND
517 - OPTIONS
518 - MKCOL
519 - DELETE
520 - PUT
521 oraz zwyk³e GET, POST, HEAD z HTTP/1.1.
522
523 Jak na razie montowanie zasobu webdav pod Windows XP dzia³a i
524 podstawowe testy lakmusowe przechodz±.
525
526 %package -n spawn-fcgi
527 Summary:        Spawn fcgi-process directly
528 Summary(pl):    Bezpo¶rednie uruchamianie procesów fcgi
529 Group:          Applications
530
531 %description -n spawn-fcgi
532 spawn-fcgi is used to spawn fcgi-process directly without the help of
533 a webserver or the programm itself.
534
535 %description -n spawn-fcgi -l pl
536 spawn-fcgi s³u¿y do uruchamiania procesów fcgi bezpo¶rednio, bez
537 pomocy serwera WWW ani samego programu.
538
539 %package php-spawned
540 Summary:        PHP support via FastCGI, spawned by lighttpd
541 Group:          Networking/Daemons
542 Requires:       %{name} = %{version}-%{release}
543 Requires:       %{name}-mod_fastcgi = %{version}-%{release}
544 Requires:       php-fcgi
545 Obsoletes:      lighttpd-php-external
546
547 %description php-spawned
548 PHP support via FastCGI, spawned by lighttpd
549
550 %package php-external
551 Summary:        PHP support via FastCGI, spawning controlled externally
552 Group:          Networking/Daemons
553 Requires:       %{name} = %{version}-%{release}
554 Requires:       %{name}-mod_fastcgi = %{version}-%{release}
555 Requires:       php-fcgi-init
556 Obsoletes:      lighttpd-php-spawned
557
558 %description php-external
559 PHP support via FastCGI, spawning controlled externally
560
561 %package ssl
562 Summary:        lighttpd support for SSLv2 and SSLv3
563 Group:          Networking/Daemons
564 Requires:       %{name} = %{version}-%{release}
565
566 %description ssl
567 lighttpd support for SSLv2 and SSLv3.
568
569 %prep
570 %setup -q
571 #%patch100 -p1
572 #%patch0 -p1 # applied already?
573 #%patch1 -p1 # outdated
574 %patch2 -p1
575 #%patch3 -p1
576 %patch4 -p0
577 %patch5 -p1
578
579 # build mime.types.conf
580 sh %{SOURCE6} /etc/mime.types
581
582 %build
583 %{__libtoolize}
584 %{__aclocal}
585 %{__autoconf}
586 %{__automake}
587
588 %configure \
589         %{!?with_ipv6:--disable-ipv6} \
590         %{!?with_largefile:--disable-lfs} \
591         %{?with_valgrind:--with-valgrind} \
592         %{?with_xattr:--with-attr} \
593         %{?with_mysql:--with-mysql} \
594         %{?with_ldap:--with-ldap} \
595         %{?with_ssl:--with-openssl} \
596         %{?with_lua:--with-lua} \
597         %{?with_memcache:--with-memcache} \
598         %{?with_webdav_props:--with-webdav-props} \
599         %{?with_gamin:--with-gamin} \
600         %{?with_gdbm:--with-gdbm}
601
602 %{__make}
603
604 %install
605 rm -rf $RPM_BUILD_ROOT
606 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig}} \
607         $RPM_BUILD_ROOT%{_sysconfdir}/{conf,webapps}.d \
608         $RPM_BUILD_ROOT{/var/log/{%{name},archiv/%{name}},/var/run/%{name}}
609
610 %{__make} install \
611         DESTDIR=$RPM_BUILD_ROOT
612
613 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
614 install %{SOURCE2} %{SOURCE3} mime.types.conf $RPM_BUILD_ROOT%{_sysconfdir}
615 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
616 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
617
618 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
619
620 # could use automake patch, but automake generation fails...
621 mv $RPM_BUILD_ROOT%{_bindir}/spawn-fcgi $RPM_BUILD_ROOT%{_sbindir}/spawn-fcgi
622
623 # Install lighttpd images
624 install %{SOURCE7} %{SOURCE8} %{SOURCE9} $RPM_BUILD_ROOT%{_lighttpddir}/html
625 install %{SOURCE10} $RPM_BUILD_ROOT%{_lighttpddir}/html/pld_button.png
626 install %{SOURCE11} $RPM_BUILD_ROOT%{_lighttpddir}/html/index.html
627
628 # NOTE: the order of the modules is somewhat important as the modules are
629 # handled in the way they are specified. mod_rewrite should always be the first
630 # module, mod_accesslog always the last.
631
632 install %{SOURCE117} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/10_mod_rewrite.conf
633 install %{SOURCE116} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/11_mod_redirect.conf
634
635 install %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_access.conf
636 install %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_alias.conf
637 install %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_auth.conf
638 install %{SOURCE104} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cgi.conf
639 install %{SOURCE105} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_cml.conf
640 install %{SOURCE106} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_compress.conf
641 install %{SOURCE107} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_deflate.conf
642 install %{SOURCE108} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_dirlisting.conf
643 install %{SOURCE109} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evasive.conf
644 install %{SOURCE110} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evhost.conf
645 install %{SOURCE111} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_expire.conf
646 install %{SOURCE112} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_fastcgi.conf
647 install %{SOURCE113} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_flv_streaming.conf
648 install %{SOURCE114} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_indexfile.conf
649 install %{SOURCE134} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_magnet.conf
650 install %{SOURCE115} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_proxy.conf
651 install %{SOURCE118} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_rrdtool.conf
652 install %{SOURCE119} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_scgi.conf
653 install %{SOURCE120} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_secdownload.conf
654 install %{SOURCE121} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_setenv.conf
655 install %{SOURCE122} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_simple_vhost.conf
656 install %{SOURCE123} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_ssi.conf
657 install %{SOURCE124} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_staticfile.conf
658 install %{SOURCE125} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_status.conf
659 install %{SOURCE126} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_trigger_b4_dl.conf
660 install %{SOURCE127} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_userdir.conf
661 install %{SOURCE128} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_usertrack.conf
662 install %{SOURCE129} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_webdav.conf
663 install %{SOURCE133} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_mysql_vhost.conf
664
665 install %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_accesslog.conf
666
667 install %{SOURCE130} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/php-spawned.conf
668 install %{SOURCE131} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/php-external.conf
669 install %{SOURCE132} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/ssl.conf
670
671 %if %{without mysql}
672 # avoid packaging dummy module
673 rm -f $RPM_BUILD_ROOT%{_libdir}/mod_mysql_vhost.so
674 rm -f $RPM_BUILD_ROOT%{_libdir}/mod_sql_vhost_core.so
675 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/*_mod_mysql_vhost.conf
676 %endif
677 %if %{without deflate}
678 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/*_mod_deflate.conf
679 %endif
680
681 %clean
682 rm -rf $RPM_BUILD_ROOT
683
684 %pre
685 %groupadd -g 109 lighttpd
686 %groupadd -g 51 http
687 %useradd -u 116 -d %{_lighttpddir} -c "LigHTTPd User" -g lighttpd lighttpd
688 %addusertogroup lighttpd http
689
690 %post
691 /sbin/chkconfig --add %{name}
692
693 %preun
694 if [ "$1" = "0" ]; then
695         %service %{name} stop
696         /sbin/chkconfig --del %{name}
697 fi
698
699 %postun
700 if [ "$1" = "0" ]; then
701         %userremove lighttpd
702         %groupremove lighttpd
703         %groupremove http
704 fi
705
706 %posttrans
707 # minimizing lighttpd restarts logics. we restart webserver:
708 #
709 # 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
710 # 2. first install of module (post: $1 = 1)
711 # 2. uninstall of module (postun: $1 == 0)
712 #
713 # the strict internal deps between lighttpd modules and
714 # main package are very important for all this to work.
715 %service %{name} restart "LigHTTPd webserver"
716 exit 0
717
718 # macro called at module post scriptlet
719 %define module_post \
720 if [ "$1" = "1" ]; then \
721         %service -q lighttpd restart \
722 fi
723
724 # macro called at module postun scriptlet
725 %define module_postun \
726 if [ "$1" = "0" ]; then \
727         %service -q lighttpd restart \
728 fi
729
730 # it's sooo annoying to write them
731 %define module_scripts() \
732 %post %1 \
733 %module_post \
734 \
735 %postun %1 \
736 %module_postun
737
738 %module_scripts mod_access
739 %module_scripts mod_accesslog
740 %module_scripts mod_alias
741 %module_scripts mod_auth
742 %module_scripts mod_cgi
743 %module_scripts mod_cml
744 %module_scripts mod_compress
745 %module_scripts mod_deflate
746 %module_scripts mod_dirlisting
747 %module_scripts mod_evasive
748 %module_scripts mod_evhost
749 %module_scripts mod_expire
750 %module_scripts mod_fastcgi
751 %module_scripts mod_flv_streaming
752 %module_scripts mod_indexfile
753 %module_scripts mod_magnet
754 %module_scripts mod_mysql_vhost
755 %module_scripts mod_proxy
756 %module_scripts mod_redirect
757 %module_scripts mod_rewrite
758 %module_scripts mod_rrdtool
759 %module_scripts mod_scgi
760 %module_scripts mod_secdownload
761 %module_scripts mod_setenv
762 %module_scripts mod_simple_vhost
763 %module_scripts mod_ssi
764 %module_scripts mod_staticfile
765 %module_scripts mod_status
766 %module_scripts mod_trigger_b4_dl
767 %module_scripts mod_userdir
768 %module_scripts mod_usertrack
769 %module_scripts mod_webdav
770
771 %module_scripts php-spawned
772 %module_scripts php-external
773
774 %triggerpostun -- %{name} <= 1.3.6-2
775 %banner %{name} -e <<EOF
776 spawn-fcgi program is now available separately from spawn-fcgi package.
777
778 EOF
779
780 %files
781 %defattr(644,root,root,755)
782 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
783 %dir %attr(750,root,lighttpd) %{_sysconfdir}
784 %dir %attr(750,root,root) %{_sysconfdir}/webapps.d
785 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
786 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.types.conf
787 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.user
788
789 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
790 %attr(750,root,root) %dir /var/log/archiv/%{name}
791 %dir %attr(770,root,lighttpd) /var/log/%{name}
792 %dir %attr(770,root,lighttpd) /var/run/%{name}
793 %attr(754,root,root) /etc/rc.d/init.d/%{name}
794 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
795 %attr(755,root,root) %{_sbindir}/*
796 %dir %{_libdir}
797 %{_mandir}/man?/*
798 %dir %{_lighttpddir}
799 %dir %{_lighttpddir}/cgi-bin
800 %dir %{_lighttpddir}/html
801 %config(noreplace,missingok) %verify(not md5 mtime size) %{_lighttpddir}/html/*
802
803 %files mod_access
804 %defattr(644,root,root,755)
805 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_access.conf
806 %attr(755,root,root) %{_libdir}/mod_access.so
807
808 %files mod_accesslog
809 %defattr(644,root,root,755)
810 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_accesslog.conf
811 %attr(755,root,root) %{_libdir}/mod_accesslog.so
812
813 %files mod_alias
814 %defattr(644,root,root,755)
815 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_alias.conf
816 %attr(755,root,root) %{_libdir}/mod_alias.so
817
818 %files mod_auth
819 %defattr(644,root,root,755)
820 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_auth.conf
821 %attr(755,root,root) %{_libdir}/mod_auth.so
822
823 %files mod_cgi
824 %defattr(644,root,root,755)
825 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cgi.conf
826 %attr(755,root,root) %{_libdir}/mod_cgi.so
827
828 %files mod_cml
829 %defattr(644,root,root,755)
830 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_cml.conf
831 %attr(755,root,root) %{_libdir}/mod_cml.so
832
833 %files mod_compress
834 %defattr(644,root,root,755)
835 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_compress.conf
836 %attr(755,root,root) %{_libdir}/mod_compress.so
837
838 %if %{with deflate}
839 %files mod_deflate
840 %defattr(644,root,root,755)
841 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_deflate.conf
842 %attr(755,root,root) %{_libdir}/mod_deflate.so
843 %endif
844
845 %files mod_dirlisting
846 %defattr(644,root,root,755)
847 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_dirlisting.conf
848 %attr(755,root,root) %{_libdir}/mod_dirlisting.so
849
850 %files mod_evasive
851 %defattr(644,root,root,755)
852 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_evasive.conf
853 %attr(755,root,root) %{_libdir}/mod_evasive.so
854
855 %files mod_evhost
856 %defattr(644,root,root,755)
857 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_evhost.conf
858 %attr(755,root,root) %{_libdir}/mod_evhost.so
859
860 %files mod_expire
861 %defattr(644,root,root,755)
862 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_expire.conf
863 %attr(755,root,root) %{_libdir}/mod_expire.so
864
865 %files mod_fastcgi
866 %defattr(644,root,root,755)
867 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_fastcgi.conf
868 %attr(755,root,root) %{_libdir}/mod_fastcgi.so
869
870 %files mod_flv_streaming
871 %defattr(644,root,root,755)
872 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_flv_streaming.conf
873 %attr(755,root,root) %{_libdir}/mod_flv_streaming.so
874
875 %files mod_indexfile
876 %defattr(644,root,root,755)
877 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_indexfile.conf
878 %attr(755,root,root) %{_libdir}/mod_indexfile.so
879
880 %files mod_magnet
881 %defattr(644,root,root,755)
882 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_magnet.conf
883 %attr(755,root,root) %{_libdir}/mod_magnet.so
884
885 %if %{with mysql}
886 %files mod_mysql_vhost
887 %defattr(644,root,root,755)
888 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_mysql_vhost.conf
889 %attr(755,root,root) %{_libdir}/mod_mysql_vhost.so
890 %endif
891
892 %files mod_proxy
893 %defattr(644,root,root,755)
894 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_proxy.conf
895 %attr(755,root,root) %{_libdir}/mod_proxy.so
896
897 %files mod_redirect
898 %defattr(644,root,root,755)
899 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_redirect.conf
900 %attr(755,root,root) %{_libdir}/mod_redirect.so
901
902 %files mod_rewrite
903 %defattr(644,root,root,755)
904 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_rewrite.conf
905 %attr(755,root,root) %{_libdir}/mod_rewrite.so
906
907 %files mod_rrdtool
908 %defattr(644,root,root,755)
909 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_rrdtool.conf
910 %attr(755,root,root) %{_libdir}/mod_rrdtool.so
911
912 %files mod_scgi
913 %defattr(644,root,root,755)
914 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_scgi.conf
915 %attr(755,root,root) %{_libdir}/mod_scgi.so
916
917 %files mod_secdownload
918 %defattr(644,root,root,755)
919 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_secdownload.conf
920 %attr(755,root,root) %{_libdir}/mod_secdownload.so
921
922 %files mod_setenv
923 %defattr(644,root,root,755)
924 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_setenv.conf
925 %attr(755,root,root) %{_libdir}/mod_setenv.so
926
927 %files mod_simple_vhost
928 %defattr(644,root,root,755)
929 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_simple_vhost.conf
930 %attr(755,root,root) %{_libdir}/mod_simple_vhost.so
931
932 %files mod_ssi
933 %defattr(644,root,root,755)
934 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_ssi.conf
935 %attr(755,root,root) %{_libdir}/mod_ssi.so
936
937 %files mod_staticfile
938 %defattr(644,root,root,755)
939 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_staticfile.conf
940 %attr(755,root,root) %{_libdir}/mod_staticfile.so
941
942 %files mod_status
943 %defattr(644,root,root,755)
944 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_status.conf
945 %attr(755,root,root) %{_libdir}/mod_status.so
946
947 %files mod_trigger_b4_dl
948 %defattr(644,root,root,755)
949 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_trigger_b4_dl.conf
950 %attr(755,root,root) %{_libdir}/mod_trigger_b4_dl.so
951
952 %files mod_userdir
953 %defattr(644,root,root,755)
954 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_userdir.conf
955 %attr(755,root,root) %{_libdir}/mod_userdir.so
956
957 %files mod_usertrack
958 %defattr(644,root,root,755)
959 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_usertrack.conf
960 %attr(755,root,root) %{_libdir}/mod_usertrack.so
961
962 %files mod_webdav
963 %defattr(644,root,root,755)
964 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_webdav.conf
965 %attr(755,root,root) %{_libdir}/mod_webdav.so
966
967 %files -n spawn-fcgi
968 %defattr(644,root,root,755)
969 %doc doc/spawn-php.sh
970 %attr(755,root,root) %{_sbindir}/spawn-fcgi
971
972 %files php-spawned
973 %defattr(644,root,root,755)
974 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/php-spawned.conf
975
976 %files php-external
977 %defattr(644,root,root,755)
978 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/php-external.conf
979
980 %files ssl
981 %defattr(644,root,root,755)
982 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/ssl.conf
This page took 0.126767 seconds and 4 git commands to generate.