]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- fix for ticket #31 (http://trac.lighttpd.net/trac/ticket/31)
[packages/lighttpd.git] / lighttpd.spec
1 #
2 # TODO
3 # - test ldap and mysql (failed at this time)
4 # - documentroot specified in config doesn't exist
5 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
6 #
7 # Conditional build for lighttpd:
8 %bcond_without  xattr           # without support of extended attributes
9 %bcond_with     mysql           # with mysql
10 %bcond_with     ldap            # with ldap
11 %bcond_with     valgrind        # enable valgrind fixes in code.
12 %bcond_without  ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
13 %bcond_without  largefile       # without largefile support,
14 %bcond_without  ssl             # disable ssl support
15 # use it if you have 2.4 kernel to get sendfile() support,
16 # and don't need > 2GB file requests,
17 # see http://article.gmane.org/gmane.comp.web.lighttpd:722
18 #
19
20 # Prerelease snapshot: DATE-TIME
21 ##define _snap 20050116-1743
22
23 %if 0%{?_snap}
24 %define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
25 %else
26 %define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
27 %endif
28
29 %define         _rel 1
30
31 Summary:        Fast and light HTTP server
32 Summary(pl):    Szybki i lekki serwer HTTP
33 Name:           lighttpd
34 Version:        1.3.11
35 Release:        %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
36 Group:          Networking/Daemons
37 License:        BSD
38 Source0:        %{_source}
39 # Source0-md5:  730c9b9d743360d23e523968ab4fe7c5
40 Source1:        %{name}.init
41 Source2:        %{name}.conf
42 Source3:        %{name}.user
43 Source4:        %{name}.logrotate
44 Source5:        %{name}.sysconfig
45 URL:            http://www.lighttpd.net/
46 Patch0:         %{name}-empty_cgi_handler.patch
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 BuildRequires:  bzip2-devel
50 BuildRequires:  libtool
51 %{?with_ssl:BuildRequires:      openssl-devel}
52 BuildRequires:  pcre-devel
53 BuildRequires:  rpmbuild(macros) >= 1.159
54 BuildRequires:  zlib-devel
55 %if %{with xattr}
56 BuildRequires:  attr-devel
57 %endif
58 %{?with_ldap:BuildRequires:     openldap-devel}
59 %{?with_mysql:BuildRequires:    mysql-devel}
60 %{?with_valgrind:BuildRequires: valgrind}
61 PreReq:         rc-scripts
62 Requires(pre):  sh-utils
63 Requires(pre):  /bin/id
64 Requires(pre):  /usr/bin/getgid
65 Requires(pre):  /usr/sbin/groupadd
66 Requires(pre):  /usr/sbin/useradd
67 Requires(post,preun):   /sbin/chkconfig
68 Requires(postun):       /usr/sbin/groupdel
69 Requires(postun):       /usr/sbin/userdel
70 Provides:       group(lighttpd)
71 Provides:       httpd
72 Provides:       user(lighttpd)
73 Provides:       webserver
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _libdir         %{_prefix}/%{_lib}/%{name}
77 %define         _lighttpddir    /home/services/%{name}
78 %define         _sysconfdir     /etc/%{name}
79
80 %description
81 lighttpd is a secure, fast, compliant and very flexible web-server
82 which has been optimized for high-performance environments. It has a
83 very low memory footprint compared to other webservers and takes care
84 of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
85 Output-Compression, URL-Rewriting and many more) make lighttpd the
86 perfect webserver-software for every server that is suffering load
87 problems.
88
89 %description -l pl
90 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
91 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
92 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci w
93 porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
94 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
95 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
96 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy z
97 powodu problemów z obci±¿eniem.
98
99 %package -n spawn-fcgi
100 Summary:        Spawn fcgi-process directly
101 Summary(pl):    Bezpo¶rednie uruchamianie procesów fcgi
102 Group:          Applications
103
104 %description -n spawn-fcgi
105 spawn-fcgi is used to spawn fcgi-process directly without the help of
106 a webserver or the programm itself.
107
108 %description -n spawn-fcgi -l pl
109 spawn-fcgi s³u¿y do uruchamiania procesów fcgi bezpo¶rednio, bez
110 pomocy serwera WWW ani samego programu.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 %build
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %configure \
121         %{?with_valgrind:--with-valgrind} \
122         %{?with_xattr:--with-attr} \
123         %{?with_mysql:--with-mysql} \
124         %{?with_ldap:--with-ldap} \
125         %{!?with_ipv6:--disable-ipv6} \
126         %{!?with_largefile:--disable-lfs} \
127         %{?with_ssl:--with-openssl}
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig},%{_sysconfdir}} \
134         $RPM_BUILD_ROOT/var/log/{%{name},archiv/%{name}}
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
140 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
141 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
142 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
143
144 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
145
146 # could use automake patch, but automake generation fails...
147 mv $RPM_BUILD_ROOT%{_bindir}/spawn-fcgi $RPM_BUILD_ROOT%{_sbindir}/spawn-fcgi
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %pre
153 if [ -n "`/usr/bin/getgid lighttpd`" ]; then
154         if [ "`/usr/bin/getgid lighttpd`" != 109 ]; then
155                 echo "Error: group lighttpd doesn't have gid=109. Correct this before installing %{name}." 1>&2
156                 exit 1
157         fi
158 else
159         /usr/sbin/groupadd -g 109 lighttpd
160 fi
161 if [ -n "`/bin/id -u lighttpd 2>/dev/null`" ]; then
162         if [ "`/bin/id -u lighttpd`" != 116 ]; then
163                 echo "Error: user lighttpd doesn't have uid=116. Correct this before installing %{name}." 1>&2
164                 exit 1
165         fi
166 else
167         /usr/sbin/useradd -u 116 -d %{_lighttpddir} -s /bin/false \
168                 -c "HTTP User" -g lighttpd lighttpd 1>&2
169 fi
170
171 %post
172 /sbin/chkconfig --add %{name}
173 if [ -f /var/lock/subsys/%{name} ]; then
174         /etc/rc.d/init.d/%{name} restart 1>&2
175 else
176         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
177 fi
178
179 %preun
180 if [ "$1" = "0" ]; then
181         if [ -f /var/lock/subsys/%{name} ]; then
182                 /etc/rc.d/init.d/%{name} stop 1>&2
183         fi
184         /sbin/chkconfig --del %{name}
185 fi
186
187 %postun
188 if [ "$1" = "0" ]; then
189         %userremove lighttpd
190         %groupremove lighttpd
191 fi
192
193 %triggerpostun -- %{name} <= 1.3.6-2
194 # upgraded
195 if [ "$1" = "2" ]; then
196 %banner %{name} -e <<EOF
197 spawn-fcgi program is now available separately from spawn-fcgi package.
198
199 EOF
200 fi
201
202 %files
203 %defattr(644,root,root,755)
204 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
205 %attr(755,root,root) %{_sbindir}/*
206 %dir %{_libdir}
207 %attr(755,root,root) %{_libdir}/*.so
208 %attr(750,root,root) %dir /var/log/archiv/%{name}
209 %dir %attr(750,lighttpd,root) /var/log/%{name}
210 %attr(755,lighttpd,lighttpd) %{_lighttpddir}
211 %attr(754,root,root) /etc/rc.d/init.d/%{name}
212 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
213 %dir %attr(750,root,lighttpd) %{_sysconfdir}
214 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
215 %attr(640,root,lighttpd) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.user
216 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}
217 %{_mandir}/man?/*
218
219 %files -n spawn-fcgi
220 %defattr(644,root,root,755)
221 %doc doc/spawn-php.sh
222 %attr(755,root,root) %{_sbindir}/spawn-fcgi
This page took 0.083891 seconds and 3 git commands to generate.