]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- rel. 1
[packages/liferea.git] / liferea.spec
1 #
2 # Conditional build:
3 %bcond_without  dbus            # without DBUS support
4 %bcond_without  gtkhtml         # without GtkHTML
5 %bcond_without  xulrunner       # without XULRunner backend
6 #
7 %ifarch %{x8664}
8 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
9 %endif
10 Summary:        A RSS feed reader
11 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
12 Name:           liferea
13 Version:        1.2.8
14 Release:        1
15 License:        GPL v2
16 Group:          X11/Applications/Networking
17 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
18 # Source0-md5:  695e1c3bef330faa71a0d41706fbd104
19 Patch0:         %{name}-desktop.patch
20 Patch1:         %{name}-xulrunner.patch
21 URL:            http://liferea.sourceforge.net/
22 BuildRequires:  GConf2-devel >= 2.10.0
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake
25 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
26 BuildRequires:  gtk+2-devel >= 2:2.8.0
27 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
28 BuildRequires:  libnotify-devel >= 0.3.2
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel >= 1:2.6.19
32 BuildRequires:  libxslt-devel >= 1.1.19
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.311
35 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
36 Requires(post,postun):  gtk+2
37 Requires(post,postun):  hicolor-icon-theme
38 Requires(post,preun):   GConf2
39 Requires:       %{name}-backend = %{version}-%{release}
40 %ifarch %{x8664}
41 Obsoletes:      liferea-gtkhtml
42 %endif
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
46
47 %description
48 Liferea is a GTK+ clone of FeedReader.
49
50 %description -l pl.UTF-8
51 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
52 FeedReader.
53
54 %package gtkhtml
55 Summary:        GtkHTML module for Liferea
56 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
57 Group:          X11/Applications/Networking
58 Requires:       %{name} = %{version}-%{release}
59 Provides:       %{name}-backend = %{version}-%{release}
60
61 %description gtkhtml
62 GtkHTML module for Liferea.
63
64 %description gtkhtml -l pl.UTF-8
65 Moduł GtkHTML dla Liferea.
66
67 %package mozilla
68 Summary:        Mozilla HTML browser module for Liferea
69 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
70 Group:          X11/Applications/Networking
71 Requires:       %{name} = %{version}-%{release}
72 %requires_eq_to xulrunner xulrunner-devel
73 Provides:       %{name}-backend = %{version}-%{release}
74
75 %description mozilla
76 Mozilla HTML browser module for Liferea.
77
78 %description mozilla -l pl.UTF-8
79 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85
86 %build
87 #%{__glib_gettextize}
88 %{__aclocal}
89 %{__libtoolize}
90 %{__autoheader}
91 %{__automake}
92 %{__autoconf}
93 %configure \
94         --disable-schemas-install \
95         %{!?with_dbus: --disable-dbus} \
96         %{!?with_gtkhtml: --disable-gtkhtml2} \
97         %{!?with_xulrunner: --disable-xulrunner}
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT \
105         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
106
107 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
108
109 %find_lang %{name}
110
111 %post
112 %gconf_schema_install liferea.schemas
113 %update_icon_cache hicolor
114
115 %preun
116 %gconf_schema_uninstall liferea.schemas
117
118 %postun
119 %update_icon_cache hicolor
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README
127 %attr(755,root,root) %{_bindir}/*
128 %dir %{_libdir}/%{name}
129 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
130 %{_iconsdir}/hicolor/48x48/apps/liferea.png
131 %{_mandir}/pl/man1/liferea.1*
132 %{_sysconfdir}/gconf/schemas/*.schemas
133 %{_datadir}/%{name}
134 %{_desktopdir}/*.desktop
135 %{_mandir}/man1/liferea.1*
136
137 %if %{with gtkhtml}
138 %files gtkhtml
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
141 %endif
142
143 %if %{with xulrunner}
144 %files mozilla
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
147 %endif
This page took 0.04066 seconds and 4 git commands to generate.