]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- rel. 1
[packages/liferea.git] / liferea.spec
1 # TODO: create subpackage -lua (?)
2 #
3 # Conditional build:
4 %bcond_without  dbus            # without DBUS support
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  xulrunner       # without XULRunner backend
7 %bcond_without  lua             # without LUA scripting support
8 #
9 %ifarch %{x8664}
10 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
11 %endif
12 Summary:        A RSS feed reader
13 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
14 Name:           liferea
15 Version:        1.2.9
16 Release:        1
17 License:        GPL v2
18 Group:          X11/Applications/Networking
19 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
20 # Source0-md5:  1a11e0eb92b5167edbb7d5c124410daa
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-xulrunner.patch
23 Patch2:         %{name}-lua51.patch
24 URL:            http://liferea.sourceforge.net/
25 BuildRequires:  GConf2-devel >= 2.10.0
26 BuildRequires:  autoconf >= 2.59
27 BuildRequires:  automake
28 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
29 BuildRequires:  gtk+2-devel >= 2:2.8.0
30 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
31 BuildRequires:  libnotify-devel >= 0.3.2
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool
34 BuildRequires:  libxml2-devel >= 1:2.6.19
35 BuildRequires:  libxslt-devel >= 1.1.19
36 %{?with_lua:BuildRequires:      lua51-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 1.311
39 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
40 Requires(post,postun):  gtk+2
41 Requires(post,postun):  hicolor-icon-theme
42 Requires(post,preun):   GConf2
43 Requires:       %{name}-backend = %{version}-%{release}
44 %ifarch %{x8664}
45 Obsoletes:      liferea-gtkhtml
46 %endif
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
50
51 %description
52 Liferea is a GTK+ clone of FeedReader.
53
54 %description -l pl.UTF-8
55 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
56 FeedReader.
57
58 %package gtkhtml
59 Summary:        GtkHTML module for Liferea
60 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
61 Group:          X11/Applications/Networking
62 Requires:       %{name} = %{version}-%{release}
63 Provides:       %{name}-backend = %{version}-%{release}
64
65 %description gtkhtml
66 GtkHTML module for Liferea.
67
68 %description gtkhtml -l pl.UTF-8
69 Moduł GtkHTML dla Liferea.
70
71 %package mozilla
72 Summary:        Mozilla HTML browser module for Liferea
73 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
74 Group:          X11/Applications/Networking
75 Requires:       %{name} = %{version}-%{release}
76 %requires_eq_to xulrunner xulrunner-devel
77 Provides:       %{name}-backend = %{version}-%{release}
78
79 %description mozilla
80 Mozilla HTML browser module for Liferea.
81
82 %description mozilla -l pl.UTF-8
83 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90
91 %build
92 #%{__glib_gettextize}
93 %{__aclocal}
94 %{__libtoolize}
95 %{__autoheader}
96 %{__automake}
97 %{__autoconf}
98 %configure \
99         --disable-schemas-install \
100         %{!?with_dbus: --disable-dbus} \
101         %{!?with_gtkhtml: --disable-gtkhtml2} \
102         %{!?with_lua: --disable-lua} \
103         %{!?with_xulrunner: --disable-xulrunner}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
112
113 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
114
115 %find_lang %{name}
116
117 %post
118 %gconf_schema_install liferea.schemas
119 %update_icon_cache hicolor
120
121 %preun
122 %gconf_schema_uninstall liferea.schemas
123
124 %postun
125 %update_icon_cache hicolor
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README
133 %attr(755,root,root) %{_bindir}/*
134 %dir %{_libdir}/%{name}
135 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
136 %{_iconsdir}/hicolor/48x48/apps/liferea.png
137 %{_mandir}/pl/man1/liferea.1*
138 %{_sysconfdir}/gconf/schemas/*.schemas
139 %{_datadir}/%{name}
140 %{_desktopdir}/*.desktop
141 %{_mandir}/man1/liferea.1*
142 %if %{with lua}
143 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
144 %endif
145
146 %if %{with gtkhtml}
147 %files gtkhtml
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
150 %endif
151
152 %if %{with xulrunner}
153 %files mozilla
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
156 %endif
This page took 0.048845 seconds and 4 git commands to generate.