]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- 1.2.2
[packages/liferea.git] / liferea.spec
1 #
2 # Conditional build:
3 %bcond_without  dbus            # without DBUS support
4 %bcond_without  mozilla         # without mozilla
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  mozilla_firefox # build with mozilla-firefox-devel
7 #
8 Summary:        A RSS feed reader
9 Summary(pl):    Program do pobierania informacji w formacie RSS
10 Name:           liferea
11 Version:        1.2.2
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Applications/Networking
15 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
16 # Source0-md5:  03864ade3088dfe32743b1f0bca09531
17 Patch0:         %{name}-desktop.patch
18 URL:            http://liferea.sourceforge.net/
19 BuildRequires:  GConf2-devel >= 2.10.0
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
23 BuildRequires:  gtk+2-devel >= 2:2.8.0
24 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
25 BuildRequires:  libnotify-devel >= 0.3.2
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  libxml2-devel >= 1:2.6.19
29 BuildRequires:  libxslt-devel
30 %if %{with mozilla}
31 %if %{with mozilla_firefox}
32 BuildRequires:  mozilla-firefox-devel
33 %else
34 BuildRequires:  mozilla-devel
35 %endif
36 %endif
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 1.197
39 Requires(post,preun):   GConf2
40 Requires(post,postun):  gtk+2
41 Requires(post,postun):  hicolor-icon-theme
42 Requires:       %{name}-backend = %{version}-%{release}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
46
47 %description
48 Liferea is a GTK+ clone of FeedReader.
49
50 %description -l pl
51 Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
52 FeedReader.
53
54 %package gtkhtml
55 Summary:        GtkHTML module for Liferea
56 Summary(pl):    Modu³ GtkHTML dla Liferea
57 Group:          X11/Applications/Networking
58 Requires:       %{name} = %{version}-%{release}
59 Provides:       %{name}-backend = %{version}-%{release}
60
61 %description gtkhtml
62 GtkHTML module for Liferea.
63
64 %description gtkhtml -l pl
65 Modu³ GtkHTML dla Liferea.
66
67 %package mozilla
68 Summary:        Mozilla HTML browser module for Liferea
69 Summary(pl):    Modu³ przegl±darki HTML dla Liferea oparty na Mozilli
70 Group:          X11/Applications/Networking
71 Requires:       %{name} = %{version}-%{release}
72 %if %{with mozilla_firefox}
73 %requires_eq    mozilla-firefox-libs
74 %else
75 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
76 %endif
77 Provides:       %{name}-backend = %{version}-%{release}
78
79 %description mozilla
80 Mozilla HTML browser module for Liferea.
81
82 %description mozilla -l pl
83 Modu³ przegl±darki HTML dla Liferea oparty na Mozilli.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 #%{__glib_gettextize}
91 %{__aclocal}
92 %{__libtoolize}
93 %{__autoheader}
94 %{__automake}
95 %{__autoconf}
96 %configure \
97         --disable-schemas-install \
98         %{!?with_dbus: --disable-dbus} \
99         %{!?with_gtkhtml: --disable-gtkhtml2} \
100         %{!?with_mozilla: --disable-gecko}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
109
110 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
111
112 %find_lang %{name}
113
114 %post
115 %gconf_schema_install liferea.schemas
116 %update_icon_cache hicolor
117
118 %preun
119 %gconf_schema_uninstall liferea.schemas
120
121 %postun
122 %update_icon_cache hicolor
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files -f %{name}.lang
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog NEWS README
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_libdir}/%{name}
132 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
133 %{_iconsdir}/hicolor/48x48/apps/liferea.png
134 %{_mandir}/pl/man1/liferea.1*
135 %{_sysconfdir}/gconf/schemas/*.schemas
136 %{_datadir}/%{name}
137 %{_desktopdir}/*.desktop
138 %{_mandir}/man1/liferea.1*
139
140 %if %{with gtkhtml}
141 %files gtkhtml
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
144 %endif
145
146 %if %{with mozilla}
147 %files mozilla
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
150 %endif
This page took 0.070701 seconds and 4 git commands to generate.