]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- updated to 1.4.3b
[packages/liferea.git] / liferea.spec
1 # TODO: create subpackage -lua (?)
2 #
3 # Conditional build:
4 %bcond_without  dbus            # without DBUS support
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  xulrunner       # without XULRunner backend
7 %bcond_without  lua             # without LUA scripting support
8 %bcond_with     nm              # with NetworkManager support
9 #
10 %ifarch %{x8664}
11 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
12 %endif
13 Summary:        A RSS feed reader
14 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
15 Name:           liferea
16 Version:        1.4.3b
17 Release:        1
18 License:        GPL v2
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
21 # Source0-md5:  ee1c591cd51863c36322da83a45d8b30
22 Patch0:         %{name}-desktop.patch
23 Patch1:         %{name}-xulrunner.patch
24 Patch2:         %{name}-lua51.patch
25 Patch3:         %{name}-free.patch
26 URL:            http://liferea.sourceforge.net/
27 BuildRequires:  GConf2-devel >= 2.10.0
28 BuildRequires:  autoconf >= 2.59
29 BuildRequires:  automake
30 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
31 BuildRequires:  gtk+2-devel >= 2:2.8.0
32 BuildRequires:  intltool >= 0.35.5
33 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
34 BuildRequires:  libnotify-devel >= 0.3.2
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool
37 BuildRequires:  libxml2-devel >= 1:2.6.19
38 BuildRequires:  libxslt-devel >= 1.1.19
39 %{?with_lua:BuildRequires:      lua51-devel}
40 %{?with_nm:BuildRequires:       NetworkManager-devel}
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.311
43 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
44 Requires(post,postun):  gtk+2
45 Requires(post,postun):  hicolor-icon-theme
46 Requires(post,preun):   GConf2
47 Requires:       %{name}-backend = %{version}-%{release}
48 %ifarch %{x8664}
49 Obsoletes:      liferea-gtkhtml
50 %endif
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
54 # we have strict deps for it
55 %define         _noautoreq      libxpcom.so
56
57 %description
58 Liferea is a GTK+ clone of FeedReader.
59
60 %description -l pl.UTF-8
61 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
62 FeedReader.
63
64 %package gtkhtml
65 Summary:        GtkHTML module for Liferea
66 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
67 Group:          X11/Applications/Networking
68 Requires:       %{name} = %{version}-%{release}
69 Provides:       %{name}-backend = %{version}-%{release}
70
71 %description gtkhtml
72 GtkHTML module for Liferea.
73
74 %description gtkhtml -l pl.UTF-8
75 Moduł GtkHTML dla Liferea.
76
77 %package mozilla
78 Summary:        Mozilla HTML browser module for Liferea
79 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
80 Group:          X11/Applications/Networking
81 Requires:       %{name} = %{version}-%{release}
82 %requires_eq_to xulrunner xulrunner-devel
83 Provides:       %{name}-backend = %{version}-%{release}
84
85 %description mozilla
86 Mozilla HTML browser module for Liferea.
87
88 %description mozilla -l pl.UTF-8
89 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96 %patch3 -p1
97
98 %build
99 %{__glib_gettextize}
100 %{__intltoolize}
101 %{__aclocal}
102 %{__libtoolize}
103 %{__autoheader}
104 %{__automake}
105 %{__autoconf}
106 %configure \
107         --disable-schemas-install \
108         %{!?with_dbus: --disable-dbus} \
109         %{!?with_gtkhtml: --disable-gtkhtml2} \
110         %{!?with_lua: --disable-lua} \
111         %{!?with_nm: --disable-nm} \
112         %{!?with_xulrunner: --disable-xulrunner}
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
121
122 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
123
124 %find_lang %{name}
125
126 %post
127 %gconf_schema_install liferea.schemas
128 %update_icon_cache hicolor
129
130 %preun
131 %gconf_schema_uninstall liferea.schemas
132
133 %postun
134 %update_icon_cache hicolor
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README
142 %attr(755,root,root) %{_bindir}/*
143 %dir %{_libdir}/%{name}
144 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
145 %{_iconsdir}/hicolor/48x48/apps/liferea.png
146 %{_mandir}/pl/man1/liferea.1*
147 %{_sysconfdir}/gconf/schemas/liferea.schemas
148 %{_datadir}/%{name}
149 %{_desktopdir}/*.desktop
150 %{_mandir}/man1/liferea.1*
151 %if %{with lua}
152 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
153 %endif
154
155 %if %{with gtkhtml}
156 %files gtkhtml
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
159 %endif
160
161 %if %{with xulrunner}
162 %files mozilla
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
165 %endif
This page took 0.047396 seconds and 4 git commands to generate.