]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- missing Rs in mozilla subpackage
[packages/liferea.git] / liferea.spec
1 # Conditional build:
2 %bcond_without  dbus            # without DBUS support
3 %bcond_without  mozilla         # without mozilla
4 %bcond_with     mozilla_firefox # build with mozilla-firefox-devel
5 #
6 Summary:        A RSS feed reader
7 Summary(pl):    Program do pobierania informacji w formacie RSS
8 Name:           liferea
9 Version:        0.9.2
10 Release:        1
11 License:        GPL
12 Group:          X11/Applications/Networking
13 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
14 # Source0-md5:  08a52274b4ef91f7ac9a01cc45fbad13
15 Patch0:         %{name}-desktop.patch
16 URL:            http://liferea.sourceforge.net/
17 BuildRequires:  GConf2-devel >= 2.10.0
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.23}
21 BuildRequires:  gtk+2-devel >= 2:2.6.4
22 BuildRequires:  libxml2-devel >= 1:2.6.19
23 BuildRequires:  libgtkhtml-devel >= 2.6.3
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool
26 %if %{with mozilla}
27 %if %{with mozilla_firefox}
28 BuildRequires:  mozilla-firefox-devel
29 %else
30 BuildRequires:  mozilla-devel
31 %endif
32 %endif
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.197
35 Requires(post,preun):   GConf2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
39
40 %description
41 Liferea is a GTK+ clone of FeedReader.
42
43 %description -l pl
44 Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
45 FeedReader.
46
47 %package mozilla
48 Summary:        Mozilla HTML browser module for Liferea
49 Summary(pl):    Modu³ przegl±darki HTML dla Liferea oparty na Mozilli
50 Group:          X11/Applications/Networking
51 Requires:       %{name} = %{version}-%{release}
52 %if %{with mozilla_firefox}
53 Requires:       mozilla-firefox = %(rpm -q --qf '%{EPOCH}:%{VERSION}' mozilla-firefox)
54 %else
55 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
56 %endif
57
58 %description mozilla
59 Mozilla HTML browser module for Liferea.
60
61 %description mozilla -l pl
62 Modu³ przegl±darki HTML dla Liferea oparty na Mozilli.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 %{__glib_gettextize}
70 %{__aclocal}
71 %{__libtoolize}
72 %{__autoheader}
73 %{__automake}
74 %{__autoconf}
75 %configure \
76         --disable-schemas-install \
77         %{!?with_mozilla: --without-mozilla} \
78         %{!?with_dbus: --disable-dbus}
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT \
86         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
87
88 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
89
90 %find_lang %{name}
91
92 %post
93 %gconf_schema_install liferea.schemas
94
95 %preun
96 %gconf_schema_uninstall liferea.schemas
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files -f %{name}.lang
102 %defattr(644,root,root,755)
103 %doc AUTHORS ChangeLog NEWS README
104 %attr(755,root,root) %{_bindir}/*
105 %dir %{_libdir}/%{name}
106 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
107 %{_sysconfdir}/gconf/schemas/*.schemas
108 %{_datadir}/%{name}
109 %{_desktopdir}/*
110 %{_pixmapsdir}/*
111 %{_mandir}/man1/liferea.1*
112
113 %if %{with mozilla}
114 %files mozilla
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
117 %endif
This page took 0.04581 seconds and 4 git commands to generate.