]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- added bcond nm
[packages/liferea.git] / liferea.spec
1 # TODO: create subpackage -lua (?)
2 #
3 # Conditional build:
4 %bcond_without  dbus            # without DBUS support
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  xulrunner       # without XULRunner backend
7 %bcond_without  lua             # without LUA scripting support
8 %bcond_with     nm              # with NetworkManager support
9 #
10 %ifarch %{x8664}
11 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
12 %endif
13 Summary:        A RSS feed reader
14 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
15 Name:           liferea
16 Version:        1.2.9
17 Release:        1
18 License:        GPL v2
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
21 # Source0-md5:  1a11e0eb92b5167edbb7d5c124410daa
22 Patch0:         %{name}-desktop.patch
23 Patch1:         %{name}-xulrunner.patch
24 Patch2:         %{name}-lua51.patch
25 URL:            http://liferea.sourceforge.net/
26 BuildRequires:  GConf2-devel >= 2.10.0
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake
29 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
30 BuildRequires:  gtk+2-devel >= 2:2.8.0
31 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
32 BuildRequires:  libnotify-devel >= 0.3.2
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtool
35 BuildRequires:  libxml2-devel >= 1:2.6.19
36 BuildRequires:  libxslt-devel >= 1.1.19
37 %{?with_lua:BuildRequires:      lua51-devel}
38 %{?with_nm:BuildRequires:       NetworkManager-devel}
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpmbuild(macros) >= 1.311
41 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
42 Requires(post,postun):  gtk+2
43 Requires(post,postun):  hicolor-icon-theme
44 Requires(post,preun):   GConf2
45 Requires:       %{name}-backend = %{version}-%{release}
46 %ifarch %{x8664}
47 Obsoletes:      liferea-gtkhtml
48 %endif
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
52
53 %description
54 Liferea is a GTK+ clone of FeedReader.
55
56 %description -l pl.UTF-8
57 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
58 FeedReader.
59
60 %package gtkhtml
61 Summary:        GtkHTML module for Liferea
62 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
63 Group:          X11/Applications/Networking
64 Requires:       %{name} = %{version}-%{release}
65 Provides:       %{name}-backend = %{version}-%{release}
66
67 %description gtkhtml
68 GtkHTML module for Liferea.
69
70 %description gtkhtml -l pl.UTF-8
71 Moduł GtkHTML dla Liferea.
72
73 %package mozilla
74 Summary:        Mozilla HTML browser module for Liferea
75 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
76 Group:          X11/Applications/Networking
77 Requires:       %{name} = %{version}-%{release}
78 %requires_eq_to xulrunner xulrunner-devel
79 Provides:       %{name}-backend = %{version}-%{release}
80
81 %description mozilla
82 Mozilla HTML browser module for Liferea.
83
84 %description mozilla -l pl.UTF-8
85 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 #%{__glib_gettextize}
95 %{__aclocal}
96 %{__libtoolize}
97 %{__autoheader}
98 %{__automake}
99 %{__autoconf}
100 %configure \
101         --disable-schemas-install \
102         %{!?with_dbus: --disable-dbus} \
103         %{!?with_gtkhtml: --disable-gtkhtml2} \
104         %{!?with_lua: --disable-lua} \
105         %{!?with_nm: --disable-nm} \
106         %{!?with_xulrunner: --disable-xulrunner}
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
115
116 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
117
118 %find_lang %{name}
119
120 %post
121 %gconf_schema_install liferea.schemas
122 %update_icon_cache hicolor
123
124 %preun
125 %gconf_schema_uninstall liferea.schemas
126
127 %postun
128 %update_icon_cache hicolor
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README
136 %attr(755,root,root) %{_bindir}/*
137 %dir %{_libdir}/%{name}
138 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
139 %{_iconsdir}/hicolor/48x48/apps/liferea.png
140 %{_mandir}/pl/man1/liferea.1*
141 %{_sysconfdir}/gconf/schemas/*.schemas
142 %{_datadir}/%{name}
143 %{_desktopdir}/*.desktop
144 %{_mandir}/man1/liferea.1*
145 %if %{with lua}
146 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
147 %endif
148
149 %if %{with gtkhtml}
150 %files gtkhtml
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
153 %endif
154
155 %if %{with xulrunner}
156 %files mozilla
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
159 %endif
This page took 0.060784 seconds and 4 git commands to generate.