]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- up to 1.2.1
[packages/liferea.git] / liferea.spec
1 #
2 # Conditional build:
3 %bcond_without  dbus            # without DBUS support
4 %bcond_without  mozilla         # without mozilla
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  mozilla_firefox # build with mozilla-firefox-devel
7 #
8 Summary:        A RSS feed reader
9 Summary(pl):    Program do pobierania informacji w formacie RSS
10 Name:           liferea
11 Version:        1.2.1
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Applications/Networking
15 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
16 # Source0-md5:  28d6ec815209dbcab3dfd656205f9f5e
17 Patch0:         %{name}-desktop.patch
18 URL:            http://liferea.sourceforge.net/
19 BuildRequires:  GConf2-devel >= 2.10.0
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
23 BuildRequires:  gtk+2-devel >= 2:2.8.0
24 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
25 BuildRequires:  libnotify-devel >= 0.3.2
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  libxml2-devel >= 1:2.6.19
29 %if %{with mozilla}
30 %if %{with mozilla_firefox}
31 BuildRequires:  mozilla-firefox-devel
32 %else
33 BuildRequires:  mozilla-devel
34 %endif
35 %endif
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.197
38 Requires(post,preun):   GConf2
39 Requires(post,postun):  gtk+2
40 Requires(post,postun):  hicolor-icon-theme
41 Requires:       %{name}-backend = %{version}-%{release}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
45
46 %description
47 Liferea is a GTK+ clone of FeedReader.
48
49 %description -l pl
50 Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
51 FeedReader.
52
53 %package gtkhtml
54 Summary:        GtkHTML module for Liferea
55 Summary(pl):    Modu³ GtkHTML dla Liferea
56 Group:          X11/Applications/Networking
57 Requires:       %{name} = %{version}-%{release}
58 Provides:       %{name}-backend = %{version}-%{release}
59
60 %description gtkhtml
61 GtkHTML module for Liferea.
62
63 %description gtkhtml -l pl
64 Modu³ GtkHTML dla Liferea.
65
66 %package mozilla
67 Summary:        Mozilla HTML browser module for Liferea
68 Summary(pl):    Modu³ przegl±darki HTML dla Liferea oparty na Mozilli
69 Group:          X11/Applications/Networking
70 Requires:       %{name} = %{version}-%{release}
71 %if %{with mozilla_firefox}
72 %requires_eq    mozilla-firefox-libs
73 %else
74 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
75 %endif
76 Provides:       %{name}-backend = %{version}-%{release}
77
78 %description mozilla
79 Mozilla HTML browser module for Liferea.
80
81 %description mozilla -l pl
82 Modu³ przegl±darki HTML dla Liferea oparty na Mozilli.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 #%{__glib_gettextize}
90 %{__aclocal}
91 %{__libtoolize}
92 %{__autoheader}
93 %{__automake}
94 %{__autoconf}
95 %configure \
96         --disable-schemas-install \
97         %{!?with_dbus: --disable-dbus} \
98         %{!?with_gtkhtml: --disable-gtkhtml2} \
99         %{!?with_mozilla: --disable-gecko}
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
108
109 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
110
111 %find_lang %{name}
112
113 %post
114 %gconf_schema_install liferea.schemas
115 %update_icon_cache hicolor
116
117 %preun
118 %gconf_schema_uninstall liferea.schemas
119
120 %postun
121 %update_icon_cache hicolor
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README
129 %attr(755,root,root) %{_bindir}/*
130 %dir %{_libdir}/%{name}
131 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
132 %{_iconsdir}/hicolor/48x48/apps/liferea.png
133 %{_mandir}/pl/man1/liferea.1*
134 %{_sysconfdir}/gconf/schemas/*.schemas
135 %{_datadir}/%{name}
136 %{_desktopdir}/*.desktop
137 %{_mandir}/man1/liferea.1*
138
139 %if %{with gtkhtml}
140 %files gtkhtml
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
143 %endif
144
145 %if %{with mozilla}
146 %files mozilla
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
149 %endif
This page took 0.075582 seconds and 4 git commands to generate.