]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- fix locale names cz => cs
[packages/liferea.git] / liferea.spec
1 # TODO:
2 # - create subpackage -lua (?)
3 # - webkit support
4 #
5 # Conditional build:
6 %bcond_without  dbus            # without DBUS support
7 %bcond_without  gtkhtml         # without GtkHTML
8 %bcond_without  xulrunner       # without XULRunner backend
9 %bcond_without  lua             # without LUA scripting support
10 %bcond_with     nm              # with NetworkManager support
11 #
12 %ifarch %{x8664}
13 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
14 %endif
15 Summary:        A RSS feed reader
16 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
17 Name:           liferea
18 Version:        1.4.15
19 Release:        3
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23 # Source0-md5:  e4ae96a0d41d94c31271ba791caec922
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-xulrunner.patch
26 Patch2:         %{name}-lua51.patch
27 URL:            http://liferea.sourceforge.net/
28 BuildRequires:  GConf2-devel >= 2.10.0
29 %{?with_nm:BuildRequires:       NetworkManager-devel}
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
33 BuildRequires:  gettext-devel
34 BuildRequires:  gnutls-devel
35 BuildRequires:  gtk+2-devel >= 2:2.8.0
36 BuildRequires:  intltool >= 0.35.5
37 BuildRequires:  libglade2-devel >= 2.0.0
38 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
39 BuildRequires:  libnotify-devel >= 0.3.2
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool
42 BuildRequires:  libxml2-devel >= 1:2.6.27
43 BuildRequires:  libxslt-devel >= 1.1.19
44 %{?with_lua:BuildRequires:      lua51-devel}
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpmbuild(macros) >= 1.311
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  sqlite3-devel
49 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
50 Requires(post,postun):  gtk+2
51 Requires(post,postun):  hicolor-icon-theme
52 Requires(post,preun):   GConf2
53 Requires:       %{name}-backend = %{version}-%{release}
54 %ifarch %{x8664}
55 Obsoletes:      liferea-gtkhtml
56 %endif
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
60 # we have strict deps for it
61 %define         _noautoreq      libxpcom.so
62
63 %description
64 Liferea is a GTK+ clone of FeedReader.
65
66 %description -l pl.UTF-8
67 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
68 FeedReader.
69
70 %package gtkhtml
71 Summary:        GtkHTML module for Liferea
72 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
73 Group:          X11/Applications/Networking
74 Requires:       %{name} = %{version}-%{release}
75 Provides:       %{name}-backend = %{version}-%{release}
76
77 %description gtkhtml
78 GtkHTML module for Liferea.
79
80 %description gtkhtml -l pl.UTF-8
81 Moduł GtkHTML dla Liferea.
82
83 %package mozilla
84 Summary:        Mozilla HTML browser module for Liferea
85 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
86 Group:          X11/Applications/Networking
87 Requires:       %{name} = %{version}-%{release}
88 %requires_eq_to xulrunner xulrunner-devel
89 Provides:       %{name}-backend = %{version}-%{release}
90
91 %description mozilla
92 Mozilla HTML browser module for Liferea.
93
94 %description mozilla -l pl.UTF-8
95 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 %{__sed} -i -e 's,cz,cs,' po/LINGUAS
104 mv po/{cz,cs}.po
105
106 %build
107 %{__glib_gettextize}
108 %{__intltoolize}
109 %{__aclocal}
110 %{__libtoolize}
111 %{__autoheader}
112 %{__automake}
113 %{__autoconf}
114 %configure \
115         --disable-schemas-install \
116         %{!?with_dbus: --disable-dbus} \
117         %{!?with_gtkhtml: --disable-gtkhtml2} \
118         %{!?with_lua: --disable-lua} \
119         %{!?with_nm: --disable-nm} \
120         %{!?with_xulrunner: --disable-xulrunner}
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
129
130 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
131
132 %find_lang %{name}
133
134 %post
135 %gconf_schema_install liferea.schemas
136 %update_icon_cache hicolor
137
138 %preun
139 %gconf_schema_uninstall liferea.schemas
140
141 %postun
142 %update_icon_cache hicolor
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog NEWS README
150 %attr(755,root,root) %{_bindir}/liferea
151 %attr(755,root,root) %{_bindir}/liferea-add-feed
152 %attr(755,root,root) %{_bindir}/liferea-bin
153 %dir %{_libdir}/%{name}
154 %attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
155 %{_iconsdir}/hicolor/48x48/apps/liferea.png
156 %{_sysconfdir}/gconf/schemas/liferea.schemas
157 %{_datadir}/%{name}
158 %{_desktopdir}/*.desktop
159 %{_mandir}/man1/liferea.1*
160 %{_mandir}/pl/man1/liferea.1*
161 %if %{with lua}
162 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
163 %endif
164
165 %if %{with gtkhtml}
166 %files gtkhtml
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
169 %endif
170
171 %if %{with xulrunner}
172 %files mozilla
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
175 %endif
This page took 0.084821 seconds and 4 git commands to generate.