]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- updated to 1.2.11
[packages/liferea.git] / liferea.spec
1 # TODO: create subpackage -lua (?)
2 #
3 # Conditional build:
4 %bcond_without  dbus            # without DBUS support
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  xulrunner       # without XULRunner backend
7 %bcond_without  lua             # without LUA scripting support
8 %bcond_with     nm              # with NetworkManager support
9 #
10 %ifarch %{x8664}
11 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
12 %endif
13 Summary:        A RSS feed reader
14 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
15 Name:           liferea
16 Version:        1.2.11
17 Release:        1
18 License:        GPL v2
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
21 # Source0-md5:  e958a06d73dd7d01e0c7bcfeddf192d1
22 Patch0:         %{name}-desktop.patch
23 Patch1:         %{name}-xulrunner.patch
24 Patch2:         %{name}-lua51.patch
25 URL:            http://liferea.sourceforge.net/
26 BuildRequires:  GConf2-devel >= 2.10.0
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake
29 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
30 BuildRequires:  gtk+2-devel >= 2:2.8.0
31 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
32 BuildRequires:  libnotify-devel >= 0.3.2
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtool
35 BuildRequires:  libxml2-devel >= 1:2.6.19
36 BuildRequires:  libxslt-devel >= 1.1.19
37 %{?with_lua:BuildRequires:      lua51-devel}
38 %{?with_nm:BuildRequires:       NetworkManager-devel}
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpmbuild(macros) >= 1.311
41 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
42 Requires(post,postun):  gtk+2
43 Requires(post,postun):  hicolor-icon-theme
44 Requires(post,preun):   GConf2
45 Requires:       %{name}-backend = %{version}-%{release}
46 %ifarch %{x8664}
47 Obsoletes:      liferea-gtkhtml
48 %endif
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
52 # we have strict deps for it
53 %define         _noautoreq      libxpcom.so
54
55 %description
56 Liferea is a GTK+ clone of FeedReader.
57
58 %description -l pl.UTF-8
59 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
60 FeedReader.
61
62 %package gtkhtml
63 Summary:        GtkHTML module for Liferea
64 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
65 Group:          X11/Applications/Networking
66 Requires:       %{name} = %{version}-%{release}
67 Provides:       %{name}-backend = %{version}-%{release}
68
69 %description gtkhtml
70 GtkHTML module for Liferea.
71
72 %description gtkhtml -l pl.UTF-8
73 Moduł GtkHTML dla Liferea.
74
75 %package mozilla
76 Summary:        Mozilla HTML browser module for Liferea
77 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
78 Group:          X11/Applications/Networking
79 Requires:       %{name} = %{version}-%{release}
80 %requires_eq_to xulrunner xulrunner-devel
81 Provides:       %{name}-backend = %{version}-%{release}
82
83 %description mozilla
84 Mozilla HTML browser module for Liferea.
85
86 %description mozilla -l pl.UTF-8
87 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94
95 %build
96 #%{__glib_gettextize}
97 %{__aclocal}
98 %{__libtoolize}
99 %{__autoheader}
100 %{__automake}
101 %{__autoconf}
102 %configure \
103         --disable-schemas-install \
104         %{!?with_dbus: --disable-dbus} \
105         %{!?with_gtkhtml: --disable-gtkhtml2} \
106         %{!?with_lua: --disable-lua} \
107         %{!?with_nm: --disable-nm} \
108         %{!?with_xulrunner: --disable-xulrunner}
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
117
118 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
119
120 %find_lang %{name}
121
122 %post
123 %gconf_schema_install liferea.schemas
124 %update_icon_cache hicolor
125
126 %preun
127 %gconf_schema_uninstall liferea.schemas
128
129 %postun
130 %update_icon_cache hicolor
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README
138 %attr(755,root,root) %{_bindir}/*
139 %dir %{_libdir}/%{name}
140 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
141 %{_iconsdir}/hicolor/48x48/apps/liferea.png
142 %{_mandir}/pl/man1/liferea.1*
143 %{_sysconfdir}/gconf/schemas/*.schemas
144 %{_datadir}/%{name}
145 %{_desktopdir}/*.desktop
146 %{_mandir}/man1/liferea.1*
147 %if %{with lua}
148 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
149 %endif
150
151 %if %{with gtkhtml}
152 %files gtkhtml
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
155 %endif
156
157 %if %{with xulrunner}
158 %files mozilla
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
161 %endif
This page took 0.099472 seconds and 4 git commands to generate.