]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- package lua-dependent file
[packages/liferea.git] / liferea.spec
1 #
2 # Conditional build:
3 %bcond_without  dbus            # without DBUS support
4 %bcond_without  gtkhtml         # without GtkHTML
5 %bcond_without  xulrunner       # without XULRunner backend
6 %bcond_without  lua             # without LUA scripting support
7 #
8 %ifarch %{x8664}
9 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
10 %endif
11 Summary:        A RSS feed reader
12 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
13 Name:           liferea
14 Version:        1.2.9
15 Release:        0.1
16 License:        GPL v2
17 Group:          X11/Applications/Networking
18 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
19 # Source0-md5:  1a11e0eb92b5167edbb7d5c124410daa
20 Patch0:         %{name}-desktop.patch
21 Patch1:         %{name}-xulrunner.patch
22 Patch2:         %{name}-lua51.patch
23 URL:            http://liferea.sourceforge.net/
24 BuildRequires:  GConf2-devel >= 2.10.0
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake
27 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
28 BuildRequires:  gtk+2-devel >= 2:2.8.0
29 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
30 BuildRequires:  libnotify-devel >= 0.3.2
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool
33 BuildRequires:  libxml2-devel >= 1:2.6.19
34 BuildRequires:  libxslt-devel >= 1.1.19
35 %{?with_lua:BuildRequires:      lua51-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.311
38 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
39 Requires(post,postun):  gtk+2
40 Requires(post,postun):  hicolor-icon-theme
41 Requires(post,preun):   GConf2
42 Requires:       %{name}-backend = %{version}-%{release}
43 %ifarch %{x8664}
44 Obsoletes:      liferea-gtkhtml
45 %endif
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
49
50 %description
51 Liferea is a GTK+ clone of FeedReader.
52
53 %description -l pl.UTF-8
54 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
55 FeedReader.
56
57 %package gtkhtml
58 Summary:        GtkHTML module for Liferea
59 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
60 Group:          X11/Applications/Networking
61 Requires:       %{name} = %{version}-%{release}
62 Provides:       %{name}-backend = %{version}-%{release}
63
64 %description gtkhtml
65 GtkHTML module for Liferea.
66
67 %description gtkhtml -l pl.UTF-8
68 Moduł GtkHTML dla Liferea.
69
70 %package mozilla
71 Summary:        Mozilla HTML browser module for Liferea
72 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
73 Group:          X11/Applications/Networking
74 Requires:       %{name} = %{version}-%{release}
75 %requires_eq_to xulrunner xulrunner-devel
76 Provides:       %{name}-backend = %{version}-%{release}
77
78 %description mozilla
79 Mozilla HTML browser module for Liferea.
80
81 %description mozilla -l pl.UTF-8
82 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 #%{__glib_gettextize}
92 %{__aclocal}
93 %{__libtoolize}
94 %{__autoheader}
95 %{__automake}
96 %{__autoconf}
97 %configure \
98         --disable-schemas-install \
99         %{!?with_dbus: --disable-dbus} \
100         %{!?with_gtkhtml: --disable-gtkhtml2} \
101         %{!?with_lua: --disable-lua} \
102         %{!?with_xulrunner: --disable-xulrunner}
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
111
112 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
113
114 %find_lang %{name}
115
116 %post
117 %gconf_schema_install liferea.schemas
118 %update_icon_cache hicolor
119
120 %preun
121 %gconf_schema_uninstall liferea.schemas
122
123 %postun
124 %update_icon_cache hicolor
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README
132 %attr(755,root,root) %{_bindir}/*
133 %dir %{_libdir}/%{name}
134 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
135 %{_iconsdir}/hicolor/48x48/apps/liferea.png
136 %{_mandir}/pl/man1/liferea.1*
137 %{_sysconfdir}/gconf/schemas/*.schemas
138 %{_datadir}/%{name}
139 %{_desktopdir}/*.desktop
140 %{_mandir}/man1/liferea.1*
141 %if %{with lua}
142 /usr/lib/liferea/libliscrlua.so
143 %endif
144
145 %if %{with gtkhtml}
146 %files gtkhtml
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
149 %endif
150
151 %if %{with xulrunner}
152 %files mozilla
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
155 %endif
This page took 0.31382 seconds and 4 git commands to generate.