]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- 1.4.16b
[packages/liferea.git] / liferea.spec
1 # TODO:
2 # - create subpackage -lua (?)
3 #
4 # Conditional build:
5 %bcond_without  dbus            # without DBUS support
6 %bcond_without  gtkhtml         # without GtkHTML
7 %bcond_without  xulrunner       # without XULRunner backend
8 %bcond_without  lua             # without LUA scripting support
9 %bcond_with     nm              # with NetworkManager support
10 %bcond_without  webkit          # without WebKit backend
11 #
12 %ifarch %{x8664}
13 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
14 %endif
15 Summary:        A RSS feed reader
16 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
17 Name:           liferea
18 Version:        1.4.16b
19 Release:        1
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23 # Source0-md5:  b7d8ef4b5d054a7c57e53789d7259edb
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-xulrunner.patch
26 Patch2:         %{name}-lua51.patch
27 URL:            http://liferea.sourceforge.net/
28 BuildRequires:  GConf2-devel >= 2.10.0
29 %{?with_nm:BuildRequires:       NetworkManager-devel}
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
33 BuildRequires:  gettext-devel
34 BuildRequires:  gnutls-devel
35 BuildRequires:  gtk+2-devel >= 2:2.8.0
36 %{?with_webkit:BuildRequires:   gtk-webkit-devel}
37 BuildRequires:  intltool >= 0.35.5
38 BuildRequires:  libglade2-devel >= 2.0.0
39 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
40 BuildRequires:  libnotify-devel >= 0.3.2
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.27
44 BuildRequires:  libxslt-devel >= 1.1.19
45 %{?with_lua:BuildRequires:      lua51-devel}
46 BuildRequires:  pkgconfig
47 BuildRequires:  rpmbuild(macros) >= 1.311
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  sqlite3-devel
50 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
51 Requires(post,postun):  gtk+2
52 Requires(post,postun):  hicolor-icon-theme
53 Requires(post,preun):   GConf2
54 Requires:       %{name}-backend = %{version}-%{release}
55 %ifarch %{x8664}
56 Obsoletes:      liferea-gtkhtml
57 %endif
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
61 # we have strict deps for it
62 %define         _noautoreq      libxpcom.so
63
64 %description
65 Liferea is a GTK+ clone of FeedReader.
66
67 %description -l pl.UTF-8
68 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
69 FeedReader.
70
71 %package gtkhtml
72 Summary:        GtkHTML module for Liferea
73 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
74 Group:          X11/Applications/Networking
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-backend = %{version}-%{release}
77
78 %description gtkhtml
79 GtkHTML module for Liferea.
80
81 %description gtkhtml -l pl.UTF-8
82 Moduł GtkHTML dla Liferea.
83
84 %package mozilla
85 Summary:        Mozilla HTML browser module for Liferea
86 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
87 Group:          X11/Applications/Networking
88 Requires:       %{name} = %{version}-%{release}
89 %requires_eq_to xulrunner xulrunner-devel
90 Provides:       %{name}-backend = %{version}-%{release}
91
92 %description mozilla
93 Mozilla HTML browser module for Liferea.
94
95 %description mozilla -l pl.UTF-8
96 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
97
98 %package webkit
99 Summary:        WebKit module for Liferea
100 Summary(pl.UTF-8):      Moduł WebKit dla Liferea
101 Group:          X11/Applications/Networking
102 Requires:       %{name} = %{version}-%{release}
103 Provides:       %{name}-backend = %{version}-%{release}
104
105 %description webkit
106 WebKit module for Liferea.
107
108 %description webkit -l pl.UTF-8
109 Moduł WebKit dla Liferea.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %build
118 %{__glib_gettextize}
119 %{__intltoolize}
120 %{__aclocal}
121 %{__libtoolize}
122 %{__autoheader}
123 %{__automake}
124 %{__autoconf}
125 %configure \
126         --disable-schemas-install \
127         %{!?with_dbus: --disable-dbus} \
128         %{!?with_gtkhtml: --disable-gtkhtml2} \
129         %{!?with_lua: --disable-lua} \
130         %{!?with_nm: --disable-nm} \
131         %{!?with_xulrunner: --disable-xulrunner} \
132         %{!?with_webkit: --disable-webkit}
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT \
140         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
141
142 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
143
144 %find_lang %{name}
145
146 %post
147 %gconf_schema_install liferea.schemas
148 %update_icon_cache hicolor
149
150 %preun
151 %gconf_schema_uninstall liferea.schemas
152
153 %postun
154 %update_icon_cache hicolor
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog NEWS README
162 %attr(755,root,root) %{_bindir}/liferea
163 %attr(755,root,root) %{_bindir}/liferea-add-feed
164 %attr(755,root,root) %{_bindir}/liferea-bin
165 %dir %{_libdir}/%{name}
166 %attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
167 %{_iconsdir}/hicolor/48x48/apps/liferea.png
168 %{_sysconfdir}/gconf/schemas/liferea.schemas
169 %{_datadir}/%{name}
170 %{_desktopdir}/*.desktop
171 %{_mandir}/man1/liferea.1*
172 %{_mandir}/pl/man1/liferea.1*
173 %if %{with lua}
174 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
175 %endif
176
177 %if %{with gtkhtml}
178 %files gtkhtml
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
181 %endif
182
183 %if %{with xulrunner}
184 %files mozilla
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
187 %endif
188
189 %if %{with webkit}
190 %files webkit
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlw.so
193 %endif
This page took 0.060828 seconds and 4 git commands to generate.